Jump to content
fantomas

[pre-releases] macOS Sierra

769 posts in this topic

Recommended Posts

Advertisement

But no kext patch !  :shock:

When setting kext patch debug mode, I have message saying "Not allowed for this OS 10.12" or something like this ... :wallbash:

I see we have bad luck  :laser:

Share this post


Link to post
Share on other sites

Different method from r3585 by Slice for 10.12 (16A239j), please compare

 

** add diff

Successful upgrade to macOS Sierra DP2 (16A239j) here.

 

Kext injection working for me with @cecekpawon's Clover r3581 on my legacy desktop rig: GA P55aUD3/Intel i5 750/ ATI HD5770.

 

post-846696-0-97554900-1467800192_thumb.png

 

 

Also audio working with AppleALC.kext 1.0.12 :).

Share this post


Link to post
Share on other sites

Any issues?  I tried to install it and now it hangs up half way through the boot process.   Boot in verbose mode, gets through that and then the white apple/black background and nothing.

When it restarts just reboot in safe mode and allow the installer to finish, then reboot normal. This worked for me.

Share this post


Link to post
Share on other sites

Test, please, Clover 3587.

impossible to make the update of clover

/Users/Fljagd/src/edk2/Clover/rEFIt_UEFI/Platform/Settings.c:1021:8: error: use of undeclared identifier 'MatchOS'
  if (!MatchOS || !OSVersion) {
       ^
1 error generated.
make: *** [/Users/Fljagd/src/edk2/Build/Clover/RELEASE_XCODE5/X64/Clover/rEFIt_UEFI/refit/OUTPUT/Platform/Settings.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/Fljagd/src/edk2/Build/Clover/RELEASE_XCODE5/X64/Clover/rEFIt_UEFI/refit]


build.py...
 : error F002: Failed to build module
	/Users/Fljagd/src/edk2/Clover/rEFIt_UEFI/refit.inf [X64, XCODE5, RELEASE]

- Failed -
Build end time: 12:16:47, Jul.06 2016

I use CloverBuilder.command by Micky 1979

Share this post


Link to post
Share on other sites

r3589 does work on may 5960x, which uses kext injecting from the  EFI partition and config.plist patches

Great ! Can you share this version ?

Share this post


Link to post
Share on other sites

3589 hangs here when trying to apply the kext patch on Sierra. No problem with El Capitan.

 

cecekpawon's 3581 from earlier seems to work fine (apart from the MatchOS logic being broken).

 

Update: Removing the MatchOS flags fixes the hang with 3589. Works fine in Sierra now (putting MatchOS back to test caused it to hang again).

 

Update 2: The hang doesn't happen on the X79 (patching AICPUPM). Only on the laptop (patching IOGraphicsFamily).

post-267996-0-16232900-1467808900_thumb.jpg

Share this post


Link to post
Share on other sites

DP1 to DP2 works with CLOVER 3583 and now with CLOVER 3589  :thumbsup_anim:  :thumbsup_anim:
kexts in S/L/E  :)
had tried kexts in clover , folder 10.12 and others , don't work for me !!! :rofl:
sorry for my mistake 
CLOVER INJECT KEXTS  :drool:  :drool: 
have forgotten to modify my config.plist 
<dict>
<key>InjectKexts</key>
<true/>
THANK YOU SO MUCH  :thumbsup_anim:  :thumbsup_anim:


sans_t12.jpg

 

Share this post


Link to post
Share on other sites

Test, please, Clover3585.

attachicon.gifCLOVERX64.efi-beta.zip

 

Thanks, Slice.

Working together with wardoctor post...

 

BOOTX64.efi.zip http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=188256

 

But I found DP2 slow as a Minardi without the 4 weels  :P

 

EDIT: Kext To Patch is not working...

Share this post


Link to post
Share on other sites

Getting back to the beta itself, I'm still getting wifi velocity spam in my Console every 10 seconds. Is anyone else getting this? I can't find anything online about it. I have a genuine Apple AirPort card (Atheros 9280).

 

"(com.apple.wifivelocityd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds"

 

I wasn't getting this on my laptop (Broadcom card) with DP1 but now I'm getting it there as well.

Share this post


Link to post
Share on other sites

Getting back to the beta itself, I'm still getting wifi velocity spam in my Console every 10 seconds. Is anyone else getting this? I can't find anything online about it. I have a genuine Apple AirPort card (Atheros 9280).

 

"(com.apple.wifivelocityd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds"

 

I wasn't getting this on my laptop (Broadcom card) with DP1 but now I'm getting it there as well.

 

Although I am only able to Boot into my DP2 partition in Safe mode, my Broadcom card works without issue after applying this new patch for Sierra: http://www.insanelymac.com/forum/topic/312759-fix-macos-sierra-dp1-bcm94532z-wifi/.   I'm not certain what exactly is going on with my laptop as kext seem to be injecting (though in my case since my kexts are all located/housed in my Library/Extensions folder (not S/L/E) kext injection itself is mostly likely not even applicable) I know at least one of my patches is working (Broadcom Wi-Fi).   Something remains broken as my Bluetooth functionality is now gone.   

 

No new Clover edition released yet has improved my boot process though I have not yet located/tried Clover r3589.   My DP2 partition gets through the 1st part of boot then stops and reboots itself except as previously mentioned when booting in safe mode.

Share this post


Link to post
Share on other sites

I updated to DP2, but since then I'm not able to boot to Sierra. I don't as other people see kexts injecting and I'm sure this is the problem. I tried fakeSMC In /S/L/E but It still doesn't get loaded. I use Clover 3584 installation and CLOVERX64.efi and BOOTX64.efi from post 315. No joy for now.

Share this post


Link to post
Share on other sites

yes , 3589 is working like a charm  :yes:  :yes:
kexts in folder 10.12 of CLOVER 
APIRE 5733 ACER NOTEBOOK
not full QE/CI at the point !!!!
thank you to the DEV :thumbsup_anim:  :thumbsup_anim:
 


sans_t15.jpg

 

Share this post


Link to post
Share on other sites

Using Clover r3589, I have everything working with all of my custom kexts in Clover.  I actually had problems when I had custom kexts both in Clover and S/L/E.  By removing all custom kexts from S/L/E, everything worked perfectly. 

 

Great job, Clover Team!!!

Share this post


Link to post
Share on other sites

I can't get it to work...

 

Using Clover r3589, kexts in S/L/E or in 10.12 folder... not working...

 

It stops at busy timeout[0], (60s), kextd wait(0): 'AppleACPICPU' (and many others...... )

 

EDIT: Oops... My mistake... I forgot to check "LOAD KEXTS" in Clover Configurator.

Now is working, but I don't know if my Clover has a problem with Kext To Patch, or if something in USB has changed, because my previous Patch it's not working for my USB3...

Share this post


Link to post
Share on other sites

I have a laptop that requires that I manually install update packages by going to Library/Updates and running all of the .pkgs. When I tried this for Sierra DP2, I was only able to run one of the packages; the other two had installation failures stating that the packages requires additional components to be installed. The installation failures occur with the firmware update and the actual update package.

 

Anyone know how to get around this and get all packages to be installed successfully? Is there a more meta solution to allow my laptop to install through the App Store like a normal Mac?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
    • By Sagnik Ganguly
      Hello I'm Sagnik Ganguly, I'm trying to dual boot macOS 10.14 and Windows 10 (already installed) on a PC with Legacy BIOS. I've two hard drives one in where the windows is installed and another which is converted to GPT to install macOS Mojave 10.14 with a partion of Mac OS Extended (Journal) or APFS but when I went to the Install Disk Selection page, I'm selecting the partition but it says "This version of macOS 10.14 cannot be installed on this computer." can you help me please? 
      P. S. My motherboard doesn't support UEFI. 
      I'm attaching some pictures of the screens.


    • By y010204025
      Disclaimer: All files of this article are from itpwd.com and rehabman ’s github.com

       
      After Testing:
       
      Graphics card: NVIDIA K1000M / K2000M / K2100M / K3000M / K3100M / K4000M / M1000M (ordinary TN1600x900 or 1920x1080), AMD W5170M / W7170M (DC2 or 4K), Intel HD4000 (ordinary TN1600x900 or 1920x1080) can be driven normally, but NVIDIA graphics card Brightness adjustment is disabled. AMD W5170m and w7170m are the best choices on 8570W and 8770W. The brightness can be adjusted normally and the graphics performance is very good. For WX7100m and WX4170m, the graphics card fans cannot be controlled, and other methods are required to control the fans. CPU: 3rd generation Intel Core i3, i5 and i7 (Ivy Bridge architecture, including all dual-core and quad-core. Celeron and Pentium are not supported), frequency conversion is normal. In general: If you have 8570W, 8770W, and hope you can get the best Hackintosh experience, it is recommended to replace the CPU with i7-3840QM / i7-3940XM, 8570W is recommended to choose W5170M, 8770W, and it is recommended to choose W7170M. In addition: If you want to have a 4K experience or perfect HIDPI, W5170m / W7170M supports 4K output, you can choose a suitable 4K screen to replace, but because 4K screens are mostly edp interface, and 8570W / 8770W motherboard is lvds interface, This requires a custom screen cable, which seems to be a difficult choice, but you can choose to do it yourself or buy it separately. In China, taobao.com is almighty and may be more suitable for you than eBay.
       
      EFI features:
      out of the box, the relevant hardware can be driven after the OS is installed, and it is easy to use without code operation.
      Supported models: HP EliteBook 8470p, 8570p, 8570w, 8770w (click the model for official specifications)
      Wireless network card: Recommended: BCM94360cd (requires ipex4 to ipex1,3 antenna 1300mbps), BCM94352HMB / DW1550 (2 antennas, 867mbps)
      Wireless characteristics: no white list, wireless network card with Bluetooth does not support the Bluetooth function of the wireless network card (also does not need to shield the pins), but the wireless normal use, you need the Bluetooth function to use this machine comes with Bluetooth:
      Clover version: 5103, keyboard mapping has been added Command key = Alt key, Option key = Win key
      Supported systems: macOS Mojave 10.14.6 (18G103)-macOS Catalina 10.15.x,
       
      Notes on known issues:
      1. The touchpad and the left and right keys under the touchpad are normal, the pointing stick and the left and right keys above the touchpad are temporarily unavailable (recommended to use the second generation of Apple Magic Trackpad)
      2. Indicator display problem (can be ignored, function is normal): Caps light is sometimes not switched in time, mute / wireless key may be yellow
      3.AMD graphics card / Intel nuclear display has supported sleep and 15 levels of brightness adjustment, NVIDIA has no
      4. If the AMD graphics card enters Huaping, refer to editing the Clover startup parameters, and add the Boot parameter radpg = 15 (the EFI file that has been configured with this parameter has been uploaded, refer to the following EFI-guided download link)
      5. Using the above NVIDIA graphics card with a normal TN screen 1600x900 or 1920x1080 can not enter the installation interface, please check whether the VBiOS of the graphics card is exclusively for HP, thank you for your test face K1000M
      6. Due to product design defects, the MSata positions of 8570w and 8770w cannot be used as boot disks, so EFI boot can only be placed on the main hard disk (turn the machine over and open the hard disk in the lower left corner of the cover, which is the main hard disk). Put on msata plate
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Hardware requirements:
      Model: 8470p, 8570p, 8570W, 8770W 1 or more, it is recommended to use another notebook for emergency Hard disk: It is recommended to choose an SSD hard disk of 240g or more. Samsung or Intel SATA hard disk is a good choice. Wireless card: BCM94352HMB, DW1550, BCM94360CD, miniPCIe slot U disk: 1 for 16g and above, another winPE emergency USB disk is recommended If you use a rescue USB flash drive, it means that you read this post carefully
       
      Make and install a USB flash drive:
      Get the mirror: please do it your way Making and installing a USB flash drive: macOS command line production is recommended, whether it is a real macOS model or a virtual machine (although this is not allowed to be discussed in many forums)Or you can choose to use TransMac or ether under Windows. This is not recommended, but it is simple enough for those new to Hackintosh. Make boot U disk: If you know how to put the boot into the installation U disk, unzip the EFI file and put it in the EFI partition, or you can choose a fat32 format U disk to store the EFI file separately Note: EFI is an unzipped folder, not a zip or ISO suffix file.
       
      BIOS settings From RehabMan
      To start, set BIOS to defaults.
      Then insure:
      UEFI boot is enabled (hybrid/with CSM for best result) secure boot is disabled disable fast boot IGPU graphics memory set to 64mb, if available disable the serial port via BIOS option, if available disable "LAN/WLAN switching", if available disable "Extended Idle Power States" if you find it under "Power Management Options" disable "Wake on LAN" and "Wake on USB" disable Firewire/IEEE 1394, if your laptop has it for Skylake and KabyLake laptop, enable "Launch Hotkeys without Fn keypress" Note: If you have a laptop with switchable graphics, leave it enabled. You can still use it on Windows, although the discrete card will be disabled when running OS X by the ACPI patches provided here. If you want to also disable it in Windows (via BIOS option), make sure you read about the DGPU option in your model specific SSDT (source is in SSDT-HACK.dsl), as in the scenario where the DGPU is disabled by BIOS, DGPU should be set to zero.
       
      Install:
      Please modify according to the above BIOS settings: Press F9 after booting, select the boot efi to file option, which is generally the last item. Enter your boot USB disk to find the location of cloverx64.efi, select cloverx64.efi, press Enter, and enter the clover boot interface. Select the location of the install entry and press Enter. Enter the macOS interface, use the disk tool to format the partition you need to install to hfs + or apfs format, do not choose the encryption option, this will make your efforts in vain. Note: The disk must be in gpt format, and the remaining EFI space is greater than 200M, 300mb + is recommended. If it is not, please try to modify it in WindowsPE environment. This may cause you to lose the Windows system boot and disk data. Please prepare for backup.
      After formatting the partition successfully, close the disk tool and select install, you will find the partition you installed, and follow the interface prompts. When the installation reaches a certain progress, it will restart. When restarting, select F9, enter from the boot U disk, select the disk partition where you installed macOS (no longer the U disk installation), the installation will continue, and it may restart 2 ~ 3 times Every time, you need F9 to select the boot. After entering the installation interface, except for the first installation, select the U disk, and then select the disk installation partition. Eventually you will enter the settings interface. After following the interface prompts, you will enter the macOS system interface. Remember the system password and turn off the Find my mac option.  
      Post install:
       
      After the installation is complete, you need to hang the EFI partition of the disk, copy the EFI file of the U disk to the EFI partition of the disk, so that you can directly use the disk to boot, otherwise you need to select the U disk to boot each time. The mount tool can choose cloverconfigurator. If after copying the EFI file to the disk, the computer cannot recognize your clover boot, you can use the custom boot option of bios: set the custom boot path to \efi\clover\cloverx64.efi, and set it as the first boot, Use bootice or easyUEFI to increase the clover boot option under Windows and set it as the first boot. If you do not have a wireless network card available temporarily, you can use the USB binding function of your Android phone to share the network. This may require the HoRndis driver. It is not recommended to use a US wireless network card. If you need Windows or Linux, you can install it normally. Be careful not to let Windows overwrite your boot files.  
      For other uses of macOS and brew, please pay attention to forums and other communities. Hackintosh is just the beginning.
       
      Finally, I would like to thank rehabman, vit9696 and others who contributed to Hackintosh. I also thank Cwen for his efforts to modify files and hardware tests. I hope that Hackintosh will be eternal.
       
      Please comply with the laws and regulations of your country or region. My description may not be clear or professional, but I think it is necessary. I think the existence of Hackintosh is everyone's technical hobby and experience macOS, not as a substitute for macOS cheap hardware.

      EFI_8x70_5103_W7170m_20200116 .zip
    • By rodrinico19
      Hola a todos, primero que nada estoy muy contento de a ver econtrado un foro de español sobre hackintosh.
      Mi problema consesite en que descargue unos drivers de esta pagina: https://github.com/chris1111/Wireless-USB-Adapter-Clover
      Seguí los pasos instale los kets en la carpeta EFI/CLOVER/OTHERS todo tal cual como dice ahi la instalación. luego segui los pasos de configurar la red dentro de configuracion del sistema etc.
      Lo cual el nombre me quedo en en0.
      El driver o kets funciona bien es reconocible por el S.O de hecho conecta la red, pero me dice que no tiene IP AUTO ASIGNADA Y LA OTRA QUE HAY UNA DESCONEXION A CADA RATO(como que desconectaras y conectaras el dispositvo usb a cada rato)
      Me gustaria que me ayuden con eso si es posible, Muchas Gracias!!
×