Jump to content
fantomas1

[pre-releases] macOS Sierra

769 posts in this topic

Recommended Posts

Advertisement

But no kext patch !  :shock:

When setting kext patch debug mode, I have message saying "Not allowed for this OS 10.12" or something like this ... :wallbash:

I see we have bad luck  :laser:

Share this post


Link to post
Share on other sites

Different method from r3585 by Slice for 10.12 (16A239j), please compare

 

** add diff

Successful upgrade to macOS Sierra DP2 (16A239j) here.

 

Kext injection working for me with @cecekpawon's Clover r3581 on my legacy desktop rig: GA P55aUD3/Intel i5 750/ ATI HD5770.

 

post-846696-0-97554900-1467800192_thumb.png

 

 

Also audio working with AppleALC.kext 1.0.12 :).

Share this post


Link to post
Share on other sites

Any issues?  I tried to install it and now it hangs up half way through the boot process.   Boot in verbose mode, gets through that and then the white apple/black background and nothing.

When it restarts just reboot in safe mode and allow the installer to finish, then reboot normal. This worked for me.

Share this post


Link to post
Share on other sites

Test, please, Clover 3587.

impossible to make the update of clover

/Users/Fljagd/src/edk2/Clover/rEFIt_UEFI/Platform/Settings.c:1021:8: error: use of undeclared identifier 'MatchOS'
  if (!MatchOS || !OSVersion) {
       ^
1 error generated.
make: *** [/Users/Fljagd/src/edk2/Build/Clover/RELEASE_XCODE5/X64/Clover/rEFIt_UEFI/refit/OUTPUT/Platform/Settings.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/Fljagd/src/edk2/Build/Clover/RELEASE_XCODE5/X64/Clover/rEFIt_UEFI/refit]


build.py...
 : error F002: Failed to build module
	/Users/Fljagd/src/edk2/Clover/rEFIt_UEFI/refit.inf [X64, XCODE5, RELEASE]

- Failed -
Build end time: 12:16:47, Jul.06 2016

I use CloverBuilder.command by Micky 1979

Share this post


Link to post
Share on other sites

r3589 does work on may 5960x, which uses kext injecting from the  EFI partition and config.plist patches

Great ! Can you share this version ?

Share this post


Link to post
Share on other sites

3589 hangs here when trying to apply the kext patch on Sierra. No problem with El Capitan.

 

cecekpawon's 3581 from earlier seems to work fine (apart from the MatchOS logic being broken).

 

Update: Removing the MatchOS flags fixes the hang with 3589. Works fine in Sierra now (putting MatchOS back to test caused it to hang again).

 

Update 2: The hang doesn't happen on the X79 (patching AICPUPM). Only on the laptop (patching IOGraphicsFamily).

post-267996-0-16232900-1467808900_thumb.jpg

Share this post


Link to post
Share on other sites

DP1 to DP2 works with CLOVER 3583 and now with CLOVER 3589  :thumbsup_anim:  :thumbsup_anim:
kexts in S/L/E  :)
had tried kexts in clover , folder 10.12 and others , don't work for me !!! :rofl:
sorry for my mistake 
CLOVER INJECT KEXTS  :drool:  :drool: 
have forgotten to modify my config.plist 
<dict>
<key>InjectKexts</key>
<true/>
THANK YOU SO MUCH  :thumbsup_anim:  :thumbsup_anim:


sans_t12.jpg

 

Share this post


Link to post
Share on other sites

Test, please, Clover3585.

attachicon.gifCLOVERX64.efi-beta.zip

 

Thanks, Slice.

Working together with wardoctor post...

 

BOOTX64.efi.zip http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=188256

 

But I found DP2 slow as a Minardi without the 4 weels  :P

 

EDIT: Kext To Patch is not working...

Share this post


Link to post
Share on other sites

Getting back to the beta itself, I'm still getting wifi velocity spam in my Console every 10 seconds. Is anyone else getting this? I can't find anything online about it. I have a genuine Apple AirPort card (Atheros 9280).

 

"(com.apple.wifivelocityd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds"

 

I wasn't getting this on my laptop (Broadcom card) with DP1 but now I'm getting it there as well.

Share this post


Link to post
Share on other sites

Getting back to the beta itself, I'm still getting wifi velocity spam in my Console every 10 seconds. Is anyone else getting this? I can't find anything online about it. I have a genuine Apple AirPort card (Atheros 9280).

 

"(com.apple.wifivelocityd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds"

 

I wasn't getting this on my laptop (Broadcom card) with DP1 but now I'm getting it there as well.

 

Although I am only able to Boot into my DP2 partition in Safe mode, my Broadcom card works without issue after applying this new patch for Sierra: http://www.insanelymac.com/forum/topic/312759-fix-macos-sierra-dp1-bcm94532z-wifi/.   I'm not certain what exactly is going on with my laptop as kext seem to be injecting (though in my case since my kexts are all located/housed in my Library/Extensions folder (not S/L/E) kext injection itself is mostly likely not even applicable) I know at least one of my patches is working (Broadcom Wi-Fi).   Something remains broken as my Bluetooth functionality is now gone.   

 

No new Clover edition released yet has improved my boot process though I have not yet located/tried Clover r3589.   My DP2 partition gets through the 1st part of boot then stops and reboots itself except as previously mentioned when booting in safe mode.

Share this post


Link to post
Share on other sites

I updated to DP2, but since then I'm not able to boot to Sierra. I don't as other people see kexts injecting and I'm sure this is the problem. I tried fakeSMC In /S/L/E but It still doesn't get loaded. I use Clover 3584 installation and CLOVERX64.efi and BOOTX64.efi from post 315. No joy for now.

Share this post


Link to post
Share on other sites

yes , 3589 is working like a charm  :yes:  :yes:
kexts in folder 10.12 of CLOVER 
APIRE 5733 ACER NOTEBOOK
not full QE/CI at the point !!!!
thank you to the DEV :thumbsup_anim:  :thumbsup_anim:
 


sans_t15.jpg

 

Share this post


Link to post
Share on other sites

Using Clover r3589, I have everything working with all of my custom kexts in Clover.  I actually had problems when I had custom kexts both in Clover and S/L/E.  By removing all custom kexts from S/L/E, everything worked perfectly. 

 

Great job, Clover Team!!!

Share this post


Link to post
Share on other sites

I can't get it to work...

 

Using Clover r3589, kexts in S/L/E or in 10.12 folder... not working...

 

It stops at busy timeout[0], (60s), kextd wait(0): 'AppleACPICPU' (and many others...... )

 

EDIT: Oops... My mistake... I forgot to check "LOAD KEXTS" in Clover Configurator.

Now is working, but I don't know if my Clover has a problem with Kext To Patch, or if something in USB has changed, because my previous Patch it's not working for my USB3...

Share this post


Link to post
Share on other sites

I have a laptop that requires that I manually install update packages by going to Library/Updates and running all of the .pkgs. When I tried this for Sierra DP2, I was only able to run one of the packages; the other two had installation failures stating that the packages requires additional components to be installed. The installation failures occur with the firmware update and the actual update package.

 

Anyone know how to get around this and get all packages to be installed successfully? Is there a more meta solution to allow my laptop to install through the App Store like a normal Mac?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      The macOS Mojave 10.14.4 update adds support for Apple News+, includes bug fixes and improvements, improves the stability and reliability of your Mac, and is recommended for all users.
       
      Apple News+
      Apple News+ is a new subscription service that extends the Apple News experience with hundreds of magazines and top newspapers
      Our editors handpick top articles and magazine issues, and you also get personalized recommendations on the topics most interesting to you
      Automatic downloads make it easy to read magazine issues offline
      Apple News is now available in Canada, with a free experience that includes handpicked Top Stories, a personalized Today feed, and support for both English and French
      Apple News+ is available in the U.S. and in Canada, with dozens of additional Canadian magazines
       
      Safari
      Adds Dark Mode support for websites that support custom color schemes
      Streamlines website login when filling credentials with Password AutoFill
      Allows push notification prompts only after interacting with a website
      Adds a warning when an insecure webpage is loaded
      Removes support for the expired Do Not Track standard to prevent potential use as a fingerprinting variable; Intelligent Tracking Prevention now protects against cross-site tracking by default
      iTunes
      Shows more editorial highlights on a single page in the Browse tab, making it easier to discover new music, playlists, and more in Apple Music
      AirPods
      Adds support for new AirPods (2nd generation)
       
      More
      Supports Air Quality Index in Maps for US, UK and India
      Improves the quality of audio recordings in Messages
      Supports real-time text (RTT) for phone calls made through a nearby iPhone on Mac
      Provides enhanced support for external GPUs in Activity Monitor
      Fixes an App Store issue that may have prevented adoption of the latest versions of Pages, Keynote, Numbers, iMovie, and GarageBand
      Improves the reliability of USB audio devices when used with MacBook Air, MacBook Pro and Mac mini models introduced in 2018
      Corrects the default screen brightness for MacBook Air (Fall 2018)
      Fixes a graphics compatibility issue that may occur on some external displays connected to Mac mini (2018)
      Resolves Wi-Fi connection issues that may occur after upgrading to macOS Mojave
      Fixes an issue where re-adding an Exchange account may cause it to disappear from Internet Accounts
      Fixes an issue where AOL user passwords may be frequently requested in Mail
       
      Update
      Combo
       
       
      View full article
       
    • By fantomas1
      Apple News+
      Apple News+ is a new subscription service that extends the Apple News experience with hundreds of magazines and top newspapers
      Our editors handpick top articles and magazine issues, and you also get personalized recommendations on the topics most interesting to you
      Automatic downloads make it easy to read magazine issues offline
      Apple News is now available in Canada, with a free experience that includes handpicked Top Stories, a personalized Today feed, and support for both English and French
      Apple News+ is available in the U.S. and in Canada, with dozens of additional Canadian magazines
       
      Safari
      Adds Dark Mode support for websites that support custom color schemes
      Streamlines website login when filling credentials with Password AutoFill
      Allows push notification prompts only after interacting with a website
      Adds a warning when an insecure webpage is loaded
      Removes support for the expired Do Not Track standard to prevent potential use as a fingerprinting variable; Intelligent Tracking Prevention now protects against cross-site tracking by default
      iTunes
      Shows more editorial highlights on a single page in the Browse tab, making it easier to discover new music, playlists, and more in Apple Music
      AirPods
      Adds support for new AirPods (2nd generation)
       
      More
      Supports Air Quality Index in Maps for US, UK and India
      Improves the quality of audio recordings in Messages
      Supports real-time text (RTT) for phone calls made through a nearby iPhone on Mac
      Provides enhanced support for external GPUs in Activity Monitor
      Fixes an App Store issue that may have prevented adoption of the latest versions of Pages, Keynote, Numbers, iMovie, and GarageBand
      Improves the reliability of USB audio devices when used with MacBook Air, MacBook Pro and Mac mini models introduced in 2018
      Corrects the default screen brightness for MacBook Air (Fall 2018)
      Fixes a graphics compatibility issue that may occur on some external displays connected to Mac mini (2018)
      Resolves Wi-Fi connection issues that may occur after upgrading to macOS Mojave
      Fixes an issue where re-adding an Exchange account may cause it to disappear from Internet Accounts
      Fixes an issue where AOL user passwords may be frequently requested in Mail
       
      Update
      Combo
       
    • By fantomas1
      macOS Mojave 10.14.4 (18E226)
       
      Update
      Combo
    • By DiddyKong
      Fully optimizing DSDT & SSDT for OS X Sierra POST INSTALL on a Dell345MT with a i7 - 920(first gen) 
       
      I know how this forum feels about 3rd party software, but that was just a crutch, I'm 100% vanilla now which is why I'm now posting for help because I eliminated the possibility having to do with 3rd party. Anyways, with that said I just have a couple things I want to be sure of.
       
      I used a n---bistro to get a App Store copy of Sierra, as I didn't know there were other ways of getting it now from a windows10 machine. anyways, I was able to build a vanilla usb. I couldn't figure the EFI out on my vanilla Sierra-usb, but the EFI on the usb-ni---bistro I had would boot my pre-install and post-install. so I was able to install Sierra. After a few days of figuring out how to remake a EFI and config, I broke my EFI.
      So back to my windows10 SSD and I found BootDiskUtility, and that made a EFI usb with the newest version of clover(r4895). So then swapped SSDs back to my OS X, plugged in the BDU-usb, after trial and error I got back into my Sierra. Now with the newest version of clover and no traces of ni---bistro anymore. Then copied the BDU-usb to my SSD EFI and was able to boot without a usb again!! YAY.
       
      Then starting working on fixing my web drivers for my gtx 1050 2gb. Installed the os update so i'm at 10.12.6, pulled my hair out figuring out the web drivers, eventually got them installed and the cuda fixed.
       
      Now all 3 of my screens work, yet windows can't sit 'between' screens, I just simply haven't looked for that fix yet as I want the sys itself running like a top first.
      My screen saver works, I don't get stuck in screensaver, I did once before, I believe lilu.kext and whatevergreen.kext fixed that.
      Now with all that I felt it was time to give my config.plist a diet cos it was bloated, I generated a config copied the clover settings check for check instead of coping text cos I'm trying to shrink it.
      Config.plist boots my system with DSDT-1FE7B5D7
       
      So after the above, This is now where I'm stuck
       a 100% correct DSDT and SSDT, from my understanding with a patched DSDT I wouldn't need any options selected in clover on the ACPI page?
       
      So with the patching part that I think I understand how to do it now, but when I extract with F4 every file has RSDT in front of it, I have one that says RSDP.aml and RSDT.aml
      so would I just erase the RSDT from the beginning of each file then go from their, which would then leave me with a DSDT.aml and 17 SSDTs?
      I know I have to decompile and patch them, but with my file names[DSDT table extract] not matching tutorials online I'm having a difficult time understanding which files I need.
      IS the RDST-DSDT.aml my DSDT? it is the biggest file.
      which ones that have SSDT in the filename is the SSDT(s) I need to patch?
       
      also how do I know if everything is patched correctly? like if my CPU is fully working and not just sorta working that way when I start running software like photoshop, unity, 10 chrome tabs, my hackintosh doesn't crash
       
      System details
      i7 920 (first gen) very similar to nehelam
      GeForce 1050 2Gb (3 monitors connected all work, one acer on HD connection, two HP s2031 on HD, using adapters to change all ports on GPU card to HD for screens)
          display port, HDMI, and HD
      4x 1Gg + 2x 8Gb RAM running at 1066 after injecting smbios with ram info macOS sees all my ram correctly
      Samsung SSD 860 EVO 500Gb
       
      Thanks to anyone that can help me out, I've been working on my system for about two weeks and this is basically the wall I finally can't seem to figure out how to pass
      I can post another info also if it helps
       
      Boot.log
      DSDTdump.Log

    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
×