Jump to content
About Just Joined group Read more... ×
fantomas

Apple unveils "macOS Sierra"

406 posts in this topic

Recommended Posts

Advertisement

Hello,

 

I keep the usb header because i use it in Windows i have a dual boot with my Hackintosh so the best option is to disable this specific usb header.

 

Great patch again RehabMan now the kext is no more in EFI/Clover/Kext but in S/L/E :D 

Share this post


Link to post
Share on other sites

Intel 4600 installation stopped at apple logo with a empty non-moving bar under the apple logo..used -v mode. Everything seems to be fine before the logo showed up.

 

I know it's the issue with intel 4600 ..please share how to bypass this and get the install going.thanks.

Share this post


Link to post
Share on other sites

JustAnotherPUser

 

can you attached here IONVMeFamily.kext from 10.11.6 ?

 

 

This is a very strange that work perfect with 11.6 , ( you are a very lucky person  :lol:Apple has no kext for NVME Industry standard.

It has AppleNVME that is not NVME.  PCIClass code is different , They are different devices, and one driver will not work for another because of registers and protocols

 

PS: here of corse work perfect only with yose 10.5 , whyle with El no ( work only with 11.3 without kP) 

 

@ You agree Reahbman???

Share this post


Link to post
Share on other sites

JustAnotherPUser

 

can you attached here IONVMeFamily.kext from 10.11.6 ?

 

 

This is a very strange that work perfect with 11.6 , ( you are a very lucky person  :lol:Apple has no kext for NVME Industry standard.

It has AppleNVME that is not NVME.  PCIClass code is different , They are different devices, and one driver will not work for another because of registers and protocols

 

PS: here of corse work perfect only with yose 10.5 , whyle with El no ( work only with 11.3 without kP) 

 

@ You agree Reahbman???

I think JustAnotherPUser was trying to say that some of the problems in NVMeGeneric.kext are fixed in 10.11.6.

 

Personally, I have my doubts... (I'll test it when 10.11.6 is released).

Share this post


Link to post
Share on other sites

i Dont have Sleep working so i cant now if there still delays.

at the first with 10.11.5 i had KP after every reboot but with 10.11.6 its appear a lot less 

 

USB working on Sierra and BT too know :D 

even HDMI audio 

Only two issue i have some artefact in the high left corner dont know how to fix it 

and also the Onboard audio (ALC1150) is not working

Share this post


Link to post
Share on other sites

i Dont have Sleep working so i cant now if there still delays.

at the first with 10.11.5 i had KP after every reboot but with 10.11.6 its appear a lot less

My doubts are confirmed. "appear a lot less" and "haven't tested it" does not imply "fixed".

Share this post


Link to post
Share on other sites

do you have any idea about the artefact problem ? its a black bar that appear and disepear on the left beside the Apple logo

Not without hardware details (should be in your signature).

Share this post


Link to post
Share on other sites

News for NVME devices (thanx to Pike R. Alpha for his hints on his blog on what to patch):

 

This ist how i make my SAMSUNG SM951 NVMe Devices visible under Systeminformation NVMExpress section

        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>NVMe SSD IONameMatch</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>InfoPlistPatch</key>
                <true/>
                <key>Find</key>
                <data>PHN0cmluZz5wY2kxNDRkLGE4MDQ8L3N0cmluZz4=</data>
                <key>Replace</key>
                <data>PHN0cmluZz5wY2kxNDRkLGE4MDI8L3N0cmluZz4=</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>NVMe Size</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>D7aMiIIAAACD+QwP</data>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>Replace</key>
                <data>D7aMiIIAAACD+QkP</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>NVMe prefered BlockSize</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>AADHg6QAAAAAEAAA</data>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>Replace</key>
                <data>AADHg6QAAAAAAgAA</data>
            </dict>
        </array>

Now the devices are shown as folowing:

e4frbo2b.png

5xhqmlwi.png

only problem so far: partitiontable didn't get recogniced, so system wants to format the drives.

5biy6pvc.png

I will think about how to fix it.

Share this post


Link to post
Share on other sites

News for NVME devices (thanx to Pike R. Alpha for his hints on his blog on what to patch):

 

This ist how i make my SAMSUNG SM951 NVMe Devices visible under Systeminformation NVMExpress section

   	 <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>NVMe SSD IONameMatch</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>InfoPlistPatch</key>
                <true/>
                <key>Find</key>
                <data>PHN0cmluZz5wY2kxNDRkLGE4MDQ8L3N0cmluZz4=</data>
                <key>Replace</key>
                <data>PHN0cmluZz5wY2kxNDRkLGE4MDI8L3N0cmluZz4=</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>NVMe Size</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>D7aMiIIAAACD+QwP</data>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>Replace</key>
                <data>D7aMiIIAAACD+QkP</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>NVMe prefered BlockSize</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>AADHg6QAAAAAEAAA</data>
                <key>Name</key>
                <string>IONVMeFamily</string>
                <key>Replace</key>
                <data>AADHg6QAAAAAAgAA</data>
            </dict>
        </array>
Now the devices are shown as folowing:

e4frbo2b.png

5xhqmlwi.png

only problem so far: partitiontable didn't get recogniced, so system wants to format the drives.

5biy6pvc.png

I will think about how to fix it.

have you try without nvmegeneric.kext i thing or not ?

Share this post


Link to post
Share on other sites

have you try without nvmegeneric.kext i thing or not ?

 

No NVMeGeneric.kext here (neither on EFI drive, nor in /S/L/E), cause my BootSSD is SAMSUNG SM951 AHCI.

the two NVMe SSDs are connected to m.2 slots and contain WINDOWS10 and EL CAPITAN as bootable Systems.

AHCI SSD (from which i boot macOS 10.12 right now) sits on PCI-M.2 card in slot#2.

Share this post


Link to post
Share on other sites

No NVMeGeneric.kext here (neither on EFI drive, nor in /S/L/E), cause my BootSSD is SAMSUNG SM951 AHCI.

the two NVMe SSDs are connected to m.2 slots and contain WINDOWS10 and EL CAPITAN as bootable Systems.

AHCI SSD (from which i boot macOS 10.12 right now) sits on PCI-M.2 card in slot#2.

ok.so...you dont try without kext ?

when have time i"ll try

Share this post


Link to post
Share on other sites

ok.so...you dont try without kext ?

when have time i"ll try

no, missunderstand me: i DON't use the NVMeGeneric.kext here anymore, cause my bootdrive is AHCI-SSD, not an NVMe-SSD.

 

I just try to make IONVMeFamily.kext work correctly - and i can check that it works correctly by getting my NVMe-devices mounted to the desktop. As soon as i can see them mounted to the desktop, i know that Apple IONVMeFamily.kext would work like a charme.

Share this post


Link to post
Share on other sites

no, missunderstand me: i DON't use the NVMeGeneric.kext here anymore, cause my bootdrive is AHCI-SSD, not an NVMe-SSD.

 

I just try to make IONVMeFamily.kext work correctly - and i can check that it works correctly by getting my NVMe-devices mounted to the desktop. As soon as i can see them mounted to the desktop, i know that Apple IONVMeFamily.kext would work like a charme.

Ah ok ok ...now i understand 

Share this post


Link to post
Share on other sites

Done! 

Elan TouchPad and fn-Keys don't work.

It is a known problem. It affects all hack keyboard drivers, and system utilities for keyboard such as Karibiner.

Share this post


Link to post
Share on other sites

some of the users of GeForce GT610, managed to get QE / CI?

 

my PNY GT 610 1GB also does not work, only with nv_disable=1 (with Capitan still OOB)

If you can find a solution, then please join.

Share this post


Link to post
Share on other sites

 

my PNY GT 610 1GB also does not work, only with nv_disable=1 (with Capitan still OOB)

If you can find a solution, then please join.

 

The problem is in Geforce.kext I decompilei your binary and made a diff with the binary of GeForce.kext of 10.11 and were made many changes in GeForce.kext of 10.12 I tried a few more things I missed, still looking for a solution .

Share this post


Link to post
Share on other sites

It seems the accelerator is causing the issue with my GPU

 

GAGYVHd.png

 

after deleting the kext AMDRadeonX4000.kext the desktop loaded without QE/CI

 

GPU: Sapphire Vapor-X R9 290X Tri-X UEFI OC.

Share this post


Link to post
Share on other sites

It seems the accelerator is causing the issue with my GPU

 

GAGYVHd.png

 

after deleting the kext AMDRadeonX4000.kext the desktop loaded without QE/CI

 

GPU: Sapphire Vapor-X R9 290X Tri-X UEFI OC.

I have the same problem 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/y6avuxsv
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By y010204025
      Update: On October 24, 2020, using clover to solve the macOS11 beta10 boot problem, you can now enjoy macOS11beta10, and the compatibility of subsequent versions is not guaranteed.
      HIDPI uses a modified version. You can directly execute the hidpi script to get a better experience. If you lose the repair, it is not within the scope of my support.
      Support upgrades without destroying the integrity of the original image.
      There seems to be a problem with the shortcut keys. If you can help solve it, thank you for your contribution.
       
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro.  
       
    • By gengik84
      First beta... build 20A4299v 
       
      Useful information:
      macOSDeveloperBetaAccessUtility.dmg.zip OpenCore is now able to boot the installer and pre-existing installed macOS 11 Big Sur macOS Big Sur beta 8 build (20A5374i)  New! VMware alternative topic installScript_1016fullapp
    • By chris1111
      Here my theme of OC 

      How to create are own Theme with Icnspack-Builder
       

       
      You can Download the themes with ➤ Themes Downloader
      You can also have the themes on ➤ Github
      You can also have the themes on ➤ HTML Page
       
×