Jump to content
augustopaulo

Finalmente instalação do El Capitan (10.11.5) no 5960X!

2 posts in this topic

Recommended Posts

Olá a todos, 

 

Trago-vos hoje uma instalação fácil do último El Capitan (10.11.5) no CPU 5960X (16 cores) :hyper:instalado na motherboard ASUS X99 Deluxe U3.1 com uma Nvidia GTX 908 Ti!!

(English version here)

 

Depois de instalado, as seguintes funcionalidades encontram-se 100% operacionais:

  • 1 x adaptador Ethernet + adaptador Wlan @ 5Ghz
  • Todas portas USB3.0 disponíveis
  • Nvidia 980ti a funcionar com 3 monitores e com som AppleHDA + HDMI funcional 
  • Gestão energy do CPU em operação desde 1.2Ghz até 4.5Ghz
  • Bluetooth, AirDrop, Facetime, iMessage todos a funcionar e muito mais rápido do que no 10.10.5 (Yosemite) !!
  • Sem o NullCPUPowerManagement.kext, o VoodooTSCSync.kext, o IOPCIFamily.kext (modificado) e com o Kernel original sem modificações - caso do Yosemite em 5960X...

Requerimentos:

  • "Instalar OS X El Capitan.app" descarregado e instalado na pasta de aplicações
  • Obter o aplicativo "El Capitan HD.zip" daqui
  • Possuir um Mac/Hackintosh já com o El Capitan instalado e com o SIP desligado, como descrito aqui
  • Um SSD/Disco duro VAZIO ligado em SATA/USB - Se não estiver vazio, o "El Capitan HD" vai formatá-lo completamente!!
  • Obter o Número de série, ROM e MLB de um mac verdadeiro 

Agradecimentos:

  • Brumbaer, stinga11, chris1111, the Clover team, fullerfun, onmybikedrunk, jamiethemorris, pokenguyen e muitos, muitos mais   :drool: ...

Instalação:

 

1 - Descarregar o ficheiro "Arquivo Comprimido.zip", que contém os Kexts, ferramentas e pasta EFI já pré-configuradas daqui e descomprimir para a pasta de descargas do seu Mac/Hackintosh. Depois configurar BIOS 3101 da ASUS X99 Deluxe como as capturas de imagens daqui

 

2 - Executar o aplicativo "El Capitan HD.app" para instalar a configuração base do El Capitan no SSD/Disco duro VAZIO:

2.1 - introduzir palavra passe a cerca de 4%

2.2 - Esperar pelo fim, como:

post-105782-0-45354900-1464443808_thumb.jpg

 

3 - Utilizar o aplicativo “Clover Configurator.app” para montar a partição EFI.

3.1 - "Mount EFI"

3.2 - "Check Partition"

3.3 - Procurar por identificador tipo “/dev/diskX” do disco que contenha a partição “Macintosh-HD”

3.4 - "Mount EFI partition /diskXs1”

post-105782-0-86988700-1464444217_thumb.jpg

 

4 - Instalar o último CLOVER v2.3:

4.1 - Executar o aplicativo CLOVER v2.3 e instalá-lo no disco “Macintosh-HD” com as seguintes opções:

post-105782-0-49075300-1464444374_thumb.jpgpost-105782-0-67878800-1464444373_thumb.jpg

 

4.2 - Usar o gestor de ficheiros “Finder” para copiar:

4.2.1 - <directório ZIP>/EFI/CLOVER/ACPI/*.* para a pasta EFI/CLOVER/ACPI/

4.2.2 - <directório ZIP>/EFI/CLOVER/config.plist para a pasta EFI/CLOVER/

4.2.3 - <directório ZIP>/EFI/CLOVER/kexts/10.11/FakeSMC.kext para a pasta EFI/CLOVER/kexts/10.11/

4.2.4 - <directório ZIP>/EFI/CLOVER/drivers64UEFI/OsxAptioFix2Drv-free2000.efi para a pasta EFI/CLOVER/drivers64UEFI/

 

5 - Utilizar o aplicativo “KCPM Utility Pro.app” para instalar os Kexts no disco “Macintosh-HD” e depois reparar as permissões do ficheiros e reconstruir a kext Caches:

  • AppleGraphicsControl.kext (já alterado para SMBIOS 6.1)
  • AppleIntelE1000e.kext
  • BrcmFirmwareRepo.kext
  • BrcmPatchRAM2.kext
  • FakeSMC.kext
  • X99_Injector.kext

post-105782-0-17211200-1464445382_thumb.jpgpost-105782-0-34566400-1464445381_thumb.jpg

 

6 - Arrancar o PC com o novo 10.11.5 instalado por UEFI OS (P1:xxxxxx)

6.1 - No menu de arranque do CLOVER, selecionar “Boot Mac OS X from Macintost-HD"

post-105782-0-30051200-1464445880_thumb.jpg

6.2 - Configurar País, e não configurar ainda o AppleID

6.3 - Configurar novo utilizador 

6.4 - Efectuar login depois executar o aplicativo “Kext utility.app” e esperar pelo fim das suas operações, como:

post-105782-0-54883700-1464443669_thumb.jpeg

6.5 Arrastar e largar o “LegacyUSBHub.kext” (para USB3.0) e “AppleHDA.kext” (já alterado para ALC1150) sobre janela do “Kext utility”e esperar pelo fim das suas operações, como:

post-105782-0-96408000-1464443669_thumb.jpeg

6.6 - Re-arrancar o PC

 

9 - Instalar Nvidia Web Driver - http://us.download.nvidia.com/Mac/Quadro_Certified/346.03.10f02/WebDriver-346.03.10f02.pkg

9.1 - Instalar o Nvidia CUDA - http://www.nvidia.com/object/macosx-cuda-7.5.29-driver.html

9.2 - Re-arrancar o PC

 

10 - Para configurara o iMessage/Facetime é necessário extrair vários dados de um Mac verdadeiro:

10.1 - Verificar que a placa rede ethernet está configurado como “en0” ao executar o aplicativo “DPCIManager.app”:

post-105782-0-39691000-1464443668_thumb.jpeg

10.2 - Executar o passo 3 novamente para montar a partição EFI

10.3 - Navegar até https://www.youtube.com/watch?v=hRuT8_3ycXc e seguir os passos para extrair (de um Mac verdadeiro), os seguintes dados:

  • Numero Série, SmUUID e Board Serial Number - usados pelo aplicativo "Clover Configurator.app" no quadro "SMBIOS"
  • identificador ROM & MLB - usados pelo aplicativo "Clover Configurator.app" no quadro "Rt Variables"
  • (Utilizando o "iMessageDebug" numa janela de terminal)

10.4 - Re-arrancar o PC

 

Boa sorte, 

Paulo

 

 

Resultado Final:

 

[post-105782-0-32552400-1464499791_thumb.jpegpost-105782-0-93064000-1464443670_thumb.jpegpost-105782-0-74480300-1464499791_thumb.jpegpost-105782-0-93136600-1464443686_thumb.jpegpost-105782-0-40463500-1464443670_thumb.jpegpost-105782-0-40916300-1464443685_thumb.jpegpost-105782-0-14676000-1464500197_thumb.jpeg

 

Testes:

 

post-105782-0-95261700-1464443668_thumb.jpegpost-105782-0-75480800-1464446926_thumb.jpegpost-105782-0-27636900-1464446926_thumb.jpeg

 

Fontes de informação:

Edited by augustopaulo

Share this post


Link to post
Share on other sites
Advertisement

Boas!

 

Achas que funciona igualmente para um i7-6800k?

 

Estava a tentar instalar mas dá sempre kernel panic por causa do CPU, já não sei literalmente o que fazer... (quer el capitan ou sierra)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r5101 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5101 for VMware.zip". Mount Clover-v2.5k-5101-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By albcc
      Hi,
      I used OpenCore with this configuration:
      -b450i Aorus pro wifi
      - ryzen2700
      - rx5700
      - dw1560
       
       
      I followed the instruction and Catalina 10.5.2 works flawlessly. Usb power, bluetooth patched, iCloud,  airplay. audio, gpu.
       
      The only thinks that aren't working are iMessage, FaceTime and handoff.
       
      iMessage Error: a.cicala@logicsolution.com
      FaceTime Error: This account has not reachable addresses. Please signing to appleid.apple.com in order to add one.
      I think it could be related to ROM configuration in PlatformInfo-> Generic -> Rom 
       
      But even if I tries to change the value it doesn't seems to work.
       
      Steps I've done:
       
      - Change Rom Value
      - Change entirely the Generic settings
      - Used CloverConfigurator to create a new rom value
      - checked that en0 is stetted in Wifi
      - removed  [~/Library/Caches/com.apple, ... , networkPreferences.plist] files
       
      Is anything wrong I'm doing in the rom code creation? I attach my config.plist (without  smUUID) maybe in OpenCore I should use not data but string type?
       
       
       
       
       
      config.plist
×