Jump to content
nguyenlc1993

[GUIDE] Installing macOS on ASUS K501L

92 posts in this topic

Recommended Posts

Advertisement

I'm having a strange problem with 10.12.4 that the laptop can enter sleep mode, but it will show black screen and freeze after wake. However if I change the ig-platform-id to other values (like 0x16160002), then it stills show black screen after wake but the OS is working (I can press Ctrl + Power then R to perform rebooting). This problem doesn't happen on 10.12.3 and earlier, so I'm asking RehabMan for the solution.

 

Does anyone have this problem? If yes, please tell me. If not, then send me your configuration, including:

- EFI/CLOVER folder

- IOReg file (use IORegistryExplorer 2.1)

- List of kexts installed in /Library/Extensions

 

Thank you very much for your help and patience. :)

Share this post


Link to post
Share on other sites

Yeah, I experience this issue too, that's quite annoying...

And for the brightness problem (even if I think that you experienced it by yourself), it looks like the brightness is stuck at 50%, it won't ever change no matter what you try (Fn+F6 or changing it in the settings)

(I've got an Asus K501LX)

Share this post


Link to post
Share on other sites

Yeah, I experience this issue too, that's quite annoying...

And for the brightness problem (even if I think that you experienced it by yourself), it looks like the brightness is stuck at 50%, it won't ever change no matter what you try (Fn+F6 or changing it in the settings)

(I've got an Asus K501LX)

Get backlight work on sierra using this https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/ guide.

 

I'm also getting issues on going to sleep. But my laptop even can't go to sleep. It's just stuck on black screen with keyboard backlight on.

Share this post


Link to post
Share on other sites

Get backlight work on sierra using this https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/ guide.

 

I'm also getting issues on going to sleep. But my laptop even can't go to sleep. It's just stuck on black screen with keyboard backlight on.

 

Just tried to fix that by deleting the IntelBacklight.kext and it worked. The thing is, as said in that post, that the brightness range is quite limited. I'll try the full method but I'm a bit afraid 'cause I'm still "new" in the hackintosh world and I try to understand what I'm doing, still not getting the DSDT patches and all those things...

I'll also try to fix the sleep issue, if I find something I will post it here.

 

Thanks for the help !

Share this post


Link to post
Share on other sites

Just tried to fix that by deleting the IntelBacklight.kext and it worked. The thing is, as said in that post, that the brightness range is quite limited. I'll try the full method but I'm a bit afraid 'cause I'm still "new" in the hackintosh world and I try to understand what I'm doing, still not getting the DSDT patches and all those things...

I'll also try to fix the sleep issue, if I find something I will post it here.

 

Thanks for the help !

You don't need to patch dsdt. This method works even by only deleting intel backlight kext from everywhere L\E, S\L\E, installing AppleBacklightInjector, and moving SSDT-PNLF to clover\acpi\patched folder. And you get ~70 level of brightness.

Share this post


Link to post
Share on other sites

You don't need to patch dsdt. This method works even by only deleting intel backlight kext from everywhere L\E, S\L\E, installing AppleBacklightInjector, and moving SSDT-PNLF to clover\acpi\patched folder. And you get ~70 level of brightness.

Just tried this method today and it didn't worked at all, it just went stuck at 50% like before I delete the IntelBacklight.kext.

Dunno what I did wrong... So I just deleted the SSDT-PNLF and Injector Kext and I'm back to a working brightness (but still quite limited). I'll try to get it working tomorrow

Share this post


Link to post
Share on other sites

My screen brightness is at 100% right now without using IntelBacklight or AppleBacklightInjector kext @@

Try using the pre-patched SSDT in the 1.1, I'm using it right now without any problem :)


And btw, have anyone figured out how to fix the sleep problem yet? I can enter sleep mode (blinking power led) but when I open the laptop, the screen were black but the backlight is on @@

Share this post


Link to post
Share on other sites

Just tried this method today and it didn't worked at all, it just went stuck at 50% like before I delete the IntelBacklight.kext.

Dunno what I did wrong... So I just deleted the SSDT-PNLF and Injector Kext and I'm back to a working brightness (but still quite limited). I'll try to get it working tomorrow

I'm sorry that i confused you. You also need to change a bit config.plist as described at manual.

Share this post


Link to post
Share on other sites

Guys, Now I'm having problem with sleep in 10.12.4 for no reason!? It was doing fine for the past few weeks and poof, sleep doesn't work anymore @@. My lap can enter sleep but when I wake it up(open the lid), all I got is a black screen. 

And I'm also still having the problem with my microphone, it doesn't pick up any sound at all @@

I'm willing to provide anything you need or even testing to sort all of these problems out :D

 

P/S: Using the Hotpatch method right now, working great so far :). Wondering if there're any change on the new hotpatch on the new version?

Share this post


Link to post
Share on other sites

Trackpad is working in 10.12.4?

Trackpad works perfectly in 10.12.4 using the kext in 1.1

#Update: I have just tested the sleep function by plugging in an external screen to the laptop. When I wake the laptop from sleep, the top bar showed up on the second screen but the wallpaper is black. I couldn't do anything on the laptop at that moment so I have to do a restart. Any ideas?

Share this post


Link to post
Share on other sites

Hi guys, I'm trying to solve a little problem and I wonder if you can help me. I mainly use my laptop at home connected to an external monitor (and keyboard / mouse indeed). The problem is that I can't boot into macOS Sierra when the HDMI is plugged in, it get stuck a few seconds at 

"IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0"

 before rebooting, as you can see in the pic I attached.

 

 

I've tried to inject IntelGraphics, disable Nvidia ones, but neither does work actually, the only way to boot is to unplug the HDMI, boot, and then connect the HDMI cable. 

It's a minor issue so it's not that important, but it would be much more comfortable to use my Hackintosh if I could get this working.

 

[EDIT] : Problem solved, the laptop's lid must be closed in order to boot macOS properly with an external screen plugged-in

.

post-1699558-0-53119000-1493634663_thumb.jpg

Share this post


Link to post
Share on other sites

Excellent guide, thank you very much :)

I have a ASUS UX360CA touch version of UX305. I had a hard time in using the track-pad and asked around, so far, still have clues to solve it

 

 the most I wanted is to make the trackpad working, even as a mouse ( to line in an usb mouse is really inconvenient, otherwise,

here I reproduced my issues of the two kexts I tried
Last login: Fri Sep 8 10:42:09 on console
Users-MacBook-Air:~ User$ cd "desktop"
Users-MacBook-Air:desktop User$ sudo chown -R root:wheel VoodooI2C.kext
Password:

Users-MacBook-Air:desktop User$ sudo kextutil -v VoodooI2C.kext
Defaulting to kernel file '/System/Library/Kernels/kernel'
Diagnostics for VoodooI2C.kext:
Code Signing Failure: not code signed
VoodooI2C.kext appears to be loadable (not including linkage for on-disk libraries).
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "VoodooI2C.kext"
kext signature failure override allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Users/User/Desktop/VoodooI2C.kext"
Loading VoodooI2C.kext.
VoodooI2C.kext successfully loaded (or already loaded).

---*But not working, when I use the trackpad---*

Users-MacBook-Air:desktop User$ sudo chown -R root:wheel ApplePS2SmartTouchPad.kext
Users-MacBook-Air:desktop User$ sudo kextutil -v ApplePS2SmartTouchPad.kext
Defaulting to kernel file '/System/Library/Kernels/kernel'
Diagnostics for ApplePS2SmartTouchPad.kext:
Code Signing Failure: not code signed
ApplePS2SmartTouchPad.kext appears to be loadable (not including linkage for on-disk libraries).
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "ApplePS2SmartTouchPad.kext"
kext signature failure override allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Users/User/Desktop/ApplePS2SmartTouchPad.kext/Contents/PlugIns/ApplePS2Controller.kext"
kext signature failure override allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Users/User/Desktop/ApplePS2SmartTouchPad.kext/Contents/PlugIns/ApplePS2Keyboard.kext"
kext signature failure override allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext "/Users/User/Desktop/ApplePS2SmartTouchPad.kext"
Loading ApplePS2SmartTouchPad.kext.
(kernel) OSMetaClass: Kext org.emlydinesh.driver.ApplePS2Controller class ApplePS2MouseDevice is a duplicate;kext org.rehabman.voodoo.driver.PS2Controller already has a class by that name.
(kernel) Kext org.emlydinesh.driver.ApplePS2Controller start failed (result 0xdc00400a).
(kernel) Kext org.emlydinesh.driver.ApplePS2Controller failed to load (0xdc008017).
(kernel) Dependency org.emlydinesh.driver.ApplePS2Controller of kext org.emlydinesh.driver.ApplePS2SmartTouchPad failed to load.
(kernel) Can't remove kext org.emlydinesh.driver.ApplePS2Controller; services failed to terminate - 0xdc008018.
(kernel) Kext org.emlydinesh.driver.ApplePS2SmartTouchPad failed to load (0xdc008015).
(kernel) Failed to load kext org.emlydinesh.driver.ApplePS2SmartTouchPad (error 0xdc008015).
Failed to load ApplePS2SmartTouchPad.kext - (libkern/kext) dependency load failed.
Failed to load ApplePS2SmartTouchPad.kext - (libkern/kext) dependency load failed.

So any suggestions? Thank you in advance!

Share this post


Link to post
Share on other sites

 

 

  • RehabMan for helping me solve the black screen issue after wake and suggesting the methods to deal with some problems such as disabling discrete graphics card and USB 3.0 on El Capitan. His collection of tiny SSDT samples also helped me to implement the 'hotpatch' method in this guide.

 

Can you share how you solved the black screen issue?

My Asus K501LX has black screen after sleep. And I haven't followed your guide 100% because of the newer versions of some patches/packages and I'm on High Sierra.

 

Thank you!

Share this post


Link to post
Share on other sites

Will it be possible for you to install it for an Asus X540 to which I have tried in many ways the installation of the Sierra or High Sierra Mac?

 

- Procesador : Intel Core i3 5005u

- Memoria Ram : 4GB DDR3L
- Disco duro : 1TB 
- Pantalla : 15,6 Pulgadas 1366x768 

- Conectividad : WiFi 802.11bgn
- Puertos USB : USB 3.0, USB 2.0, USB3.1 Type C (Gen 1)
- HDMI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 04/02/2020
      EFI Update - 04/02/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      AG Clover Z390 Master Navi Vega EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      AG Clover Z390 Master Polaris EFI.zip - RX5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (04/02/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (04/02/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 14/02/2020
      Z390 Pro Navi Vega Clover EFI 140220.zip - Use with Bios revision F12d Only (14/02/2020 Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI)
      Z390 Pro Polaris Clover EFI 140220.zip - Use with Bios revision F12d Only (14/02/2020 RX5XX Polaris DSDT EFI)
      HD630 Z390 Pro F12d EFI 140220.zip  Use with Bios revision F12d Only (14/02/2020 IGPU Only EFI) SMBIOS MacMini 8,1 
       
      PLEASE NOTE - Please flash your motherboard bios to revision F11 to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (16/01/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
    • By ricardos7
      Boa tarde a todos, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
      Preciso de ajuda para terminar alguns detalhes que nÃo consegui, alguém poderia ajudar?
       
      bem com a minha pasta EFI que pode ser baixada nesse post vc poderá fazer o seu hack mais facilmente nesse modelo,
      pois quase tudo ja esta configurado e pronto pra uso.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck ALC255

      Dell Wireless 1707 WiFi, chip ar9565
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
       
      O QUE NÃO FUNCIONA?
      BRILHO DA TELA
      BLUETOOTH
      SONO (Hibernação)
      HDMI (audio) video funciona mais a tela do note fica preta ao conectar o cabo HDMI
      GRAFICOS DEDICADOS NVIDEA 930M (DESATIVADO)
       
      O QUE FUNCIONA?
       
      GRAFICOS INTEL
      WI-FI - a intel original foi substituída pela DELL dw1707 ar9565
      AUDIO
      TECLADO
      TRACKPAD (com gestos)
      TOUCHSCREEN (com alguns gestos)
      TECLAS  DE ATALHO
      PLACA DE REDE RJ45
      GERENCIAMENTO DE ENERGIA
       
      OBS. PARA DESATIVAR OS GRÁFICOS FOI USANDO UMA SSDT EM CONJUNTO COM A DSDT-5 E 7, DEPOIS DE APLICADO ALGUNS PACHES.
       
      A DSDT E AS SSDT
      PACHS BASICOS APLICADOS.
      Aparentemente o gerenciamento de energia está funcionando bem, pelo menos o processador parece esta bem estável.
       

       
      PASTA OTHER CLOVER (DEPOIS DESSA IMAGEM FOI ADICIONADO MAIS DUAS KEXT QUE NAO ESTAO PRESENTES NA IMAGEM, PARA FUNCIONAR
      O TOUCH E PARA O WIFI CONSEGUIR ENCONTRAR AS REDES.
       

       
      EFI 
       

       
       
       
       
      ESTAREI DEIXANDO UM LINK PARA DOWNLOAD DA MINHA PASTA EFI, CASO ALGUEM ESTEJA FAZENDO ESSE MESMO HACK ESSA PASTA PODERÁ AJUDAR.
       
      ATENÇÃO
       
      LEMBRANDO QUE OS ARQUIVOS DSDT E SSDT, SSDT DE 5 A 8 SÃO DO MEU NOTEBOOK, QUEM FOR USAR DEVER EXTRAIR E CONSTRUIR SEUS PRÓPRIOS DSDT E SSDT.
      O SSDT-EC E O SSDT-PNLF PODEM SER USADOS POIS SÃO GENERICOS.
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F PARA COLOCAR NO PENDRIVER DE INSTALAÇÃO.
      https://drive.google.com/open?id=1nPM2CNgpr7cwOkjwj7UReziqrh9xjtf1
      SE NAO SUBIR COM A Config.plist INICIAL SELECIONE A Config2.plist
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (EM USO) 14/02/2020
      https://drive.google.com/open?id=1US7j-YlufrFTasLihmUZwElyV4jBfHDg
       
      LINK DE DOWNLOAD EFI DELL 5557-P39F (ANTIGA)
      https://drive.google.com/open?id=1Q2tnoqQZ9K44Bv6k2k1yauaHCAop_ZyW
       
      QUEM PUDER AJUDAR A CORRIGIR OS PROBLEMAS RESTANTE EU AGRADEÇO, OBRIGADO.
       
       

    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.3 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5098): Click here -> ASUS-Z170_catalina.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By Krani93
      Hi guys,
       
      I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).
      After some other issues I'm know stuck at attached screen.
      Im using latest opencore version and have my EFI folder attached.
       
      Can someone help me I've got no clue what to try next :/ 
       
       
      Cheers!

      EFI.7z
×