Jump to content
jalavoui

Atheros wireless driver OS X 10.11/12 for unsupported cards

617 posts in this topic

Recommended Posts

Try this way. Download the v5, copy AirPortAtheros40.kext under Contents\Plugins of IO80211Family.kext (in the S/L/E folder). Apply the KextToPatch of chunnann in your config.plist of clover. Rebuild the cache with this three commands: sudo chown -R root:wheel /System/Library/Extensions/ then sudo chmod -R 755 /System/Library/Extensions/ and finally sudo chown -R root:wheel /System/Library/Extensions/ . Reboot and you will find that your wifi works.

Perfect, NB96, it works :)

 

Glad to see you guys have found a method to get some unsupported WIFI mini PCIe cards to work!! I think this is a great and incredible finding. The way you do that, not faking id (like PCIID method), but creating a new ID that is natively recognised by macOS, is of an invaluable importance.

 

Although instead of using these terminal commands I've used Kext Utility, that does the same than your terminal commands.

 

I also tried other methods yesterday night, like not changing AirPortAtheros40.kext, or, instead of this, just and only changing the chain pci168c,30 to pci168c,34 into AirPortAtheros40.kext as you stated in other post, and these methods doesn't work for me.

 

So, what works is just what you have told me here. Thank you again.

Share this post


Link to post
Share on other sites
Advertisement

One more thing, if possible.

 

Chunnann told you before: "If you want to set locale to ETSI, just enable _ar9300FillCapabilityInfo (Unknown Locale) and change "6A" of "C6831609 00006A" to "37", which is "C6831609 000037" in your case..."

I don't know where 6A is.

 

I'm in Europe (Spain), I think I have to set locale to ETSI, too, but I don't understand Chunnann words.

 

I suppose I have to change from

<string>_ar9300FillCapabilityInfo (Unknown Locale)</string>
<key>Disabled</key>
to

<string>_ar9300FillCapabilityInfo (Unknown Locale)</string>
<key>Enabled</key>

in my config.plist, but I don't know where to change from C6831609 00006A to C6831609 000037.

 

Thank you in advance,

Share this post


Link to post
Share on other sites

Now I have FCC, the truth is that there is no big changes in to change the locale (as long you have compatibile channels and our ETSI(Europe) are compatibile with the FCC (USA) ). If you want, simple change the hex that you find in "Replace* [HEX]" from C6831609 00006A to C6831609 000037 with Clover Configurator under the _ar9300FillCapabilityInfo (Unknown Locale)

Share this post


Link to post
Share on other sites

Ar9462 works on 10.12.4.It's a pity that there is  a very long respond time and low tx/rx rate.

Pair with BTFirmwareUploader,My Combo card(Asus Wi-Fi GO!) both BT and Wireless work.

I put v5 in IO801Family and also clover patch in clover config.

 

Update:I tried only clover patches with origin one, can't detect ar9462. Only with v5 works good.

Share this post


Link to post
Share on other sites

@soto2080 use the v5 and KextToPatch together. I know it doesn't make sense to use modified driver with patches that modifies it but I had the same problem with the vanilla driver + KextToPatch. Using the v5 made the wifi more stable, it is not perfect (after 40 - 60 minutes have some disconnection fro 2 - 3 seconds) but it is something. I hope @chunnann can help us solve this problem.

Share this post


Link to post
Share on other sites

@chunnann I've noticed that if I use your v5 instead of the vanilla driver the wifi is even more stable. With the vanilla sometimes it disconnect itself, with your v5 it seams to maintain the connection. Of corse I've tested the v5 and the vanilla with your KextToPatch otherwise my wifi doesn't work. 

 

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

Can I use it in El Capitan, ar9462? Should I use kext to patch?

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

@soto2080 use the v5 and KextToPatch together. I know it doesn't make sense to use modified driver with patches that modifies it but I had the same problem with the vanilla driver + KextToPatch. Using the v5 made the wifi more stable, it is not perfect (after 40 - 60 minutes have some disconnection fro 2 - 3 seconds) but it is something. I hope @chunnann can help us solve this problem.

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

Now I have FCC, the truth is that there is no big changes in to change the locale (as long you have compatibile channels and our ETSI(Europe) are compatibile with the FCC (USA) ). If you want, simple change the hex that you find in "Replace* [HEX]" from C6831609 00006A to C6831609 000037 with Clover Configurator under the _ar9300FillCapabilityInfo (Unknown Locale)

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

Ar9462 works on 10.12.4.It's a pity that there is  a very long respond time and low tx/rx rate.

Pair with BTFirmwareUploader,My Combo card(Asus Wi-Fi GO!) both BT and Wireless work.

I put v5 in IO801Family and also clover patch in clover config.

 

Update:I tried only clover patches with origin one, can't detect ar9462. Only with v5 works good.

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

Share this post


Link to post
Share on other sites

Now I get it, the country code is setted by the wifi you're connected to.

 

@ovflowd you can get the original kext by mounting the recovery partition and then go to com.apple.recovery.boot and mount the BaseSystem.dmg and then go to the S/L/E of that mounted drive. You need to see hidden file so, before you do what I said, open the terminal and use "defaults write com.apple.finder AppleShowAllFiles YES" then "killall Finder". Oh if you need to know your recovery partition use the command "diskutil list" and then mount your partition with the command "diskutil mount /dev/diskXsX" where X stand for your drive and parition finded with the precedent command

 

I just attach the recovery USB stick and explore the folder /System/Library/Extensions, but the Kext doesn't exists. Can you upload it to me?

Share this post


Link to post
Share on other sites

Hi all, I have placed AirPortAtheros in io80211/contents/plugins, but when I try to rebuild cache, I see this:AirPortAtheros40.kext has incorrect permissions; omitting.

What have I do wrong?

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

How to use it? Only place in io8211 kext or simply install with kext util?

Share this post


Link to post
Share on other sites

I will try the v6. For me either the vanilla with patch or with modified binary are the same thing because I can't inject the wifi id so even with the original one I need to modify the plist so under the system info it will always say "unknown" instead of apple

Share this post


Link to post
Share on other sites

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

Worked for me (ar5bw222) on macOS Sierra (10.12)

Share this post


Link to post
Share on other sites

The v6 works, now I'm trying if it is more or less stable compared to the v5 or the vanilla one. By the way, what you have changed from the v5 and the v6? I'm a programmer so I'm curious :P

Share this post


Link to post
Share on other sites

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

Can I help somehow? I am so far away from the programming, but I can do something to test, if you tell what to do..

Share this post


Link to post
Share on other sites

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

Download speed is seems to be 10x time slower than in the windows..) But upload speed seems to be the same..)

Share this post


Link to post
Share on other sites

What is the MBits/s on the speed test? I will test the speed when I go to university. At my place my connection is limited to an ADSL of 7 mega (but I never go beyond 3 mega) so I can't test the speed

Share this post


Link to post
Share on other sites

It shouldn't make any difference between using the patched AirPortAtheros40 and using the unpatched AirPortAtheros40 along with Clover KextsToPatch...  That is interesting to know...

 

 

 

You need to use KextToPatch method to make it work on El Capitan.  The patched AirPortAtheros40 only works on Sierra...

 

 

 

The patched AirPortAtheros40 is never a perfect solution...  The main purpose (at least for me) is to try to make it work somehow and it does kinda work so far...   :P   

 

Besides, the reason to use KextsToPatch method is to avoid using the patched binary...

 

The value of locale is hardcoded to FCC in the patched AirPortAtheros40.  If you wish to be able to change the locale, you need to use the KextsToPatch Method...

 

 

 

I'm really not sure why the KextsToPatch method didn't work on your system since it is working fine here...

 

-----

Here is the AR946X.v6.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

 

 

I didn't notice big difference between V5 and V6.

Latency and Tx/Rx still are not desirable in comparison with my 94352z connecting to the same Wi-Fi. 

Here is the SpeedTest .

My Plan is 20M/5M.

First picture is normal(94352Z).

E1R7hBN.png

 

Second one is AR9462.

 

HoZaXYH.png

Share this post


Link to post
Share on other sites

The v6 works, now I'm trying if it is more or less stable compared to the v5 or the vanilla one. By the way, what you have changed from the v5 and the v6? I'm a programmer so I'm curious :P

 

v6 & v1 were patched based on AR9380 macRev2 while v3~v5 were patched based on AR9380 macRev0...  With v6, I finally got much more stable 5Ghz connection but speed is still limited...

 

The KextstoPatch format is based on AR9330 and that is why it doesn't support 5Ghz connection...

 

 

@soto2080,

 

If you don't mind having only 2.4Ghz connection, you can try the Clover KextstoPatch method.  If Clover KextstoPatch works on your system, you probably will get much faster speed...

Share this post


Link to post
Share on other sites

v6 & v1 were patched based on AR9380 macRev2 while v3~v5 were patched based on AR9380 macRev0...  With v6, I finally got much more stable 5Ghz connection but speed is still limited...

 

The KextstoPatch format is based on AR9330 and that is why it doesn't support 5Ghz connection...

 

 

@soto2080,

 

If you don't mind having only 2.4Ghz connection, you can try the Clover KextstoPatch method.  If Clover KextstoPatch works on your system, you probably will get much faster speed...

Strange...I have set FAKEID WIFI in CLOVER config..

 

Clover patches pair with origin kext.

com.apple.driver.AirPort.Atheros40 is loaded.

yVN44eu.jpg

Share this post


Link to post
Share on other sites

@soto2080,

 

Once com.apple.driver.AirPort.Atheros40 is loaded, you need to rebuild the cache and reboot again.

 

Try "touch /System/Library/Extensions" on terminal to rebuild the cache...

Share this post


Link to post
Share on other sites

@soto2080,

 

Once com.apple.driver.AirPort.Atheros40 is loaded, you need to rebuild the cache and reboot again.

 

Try "touch /System/Library/Extensions" on terminal to rebuild the cache...

Here is the results, Windows and v6O7WR1H4.jpg

WGaCm2f.png

 

Share this post


Link to post
Share on other sites

v6 is very stable, no disconnection overnight. I also will test the velocity tomorrow. The wifi of my university is 2.4ghz and it go between 20 to 60 mbits/s in download and the something in upload, I will test if there is there difference between v5, v6 and vanilla.

Share this post


Link to post
Share on other sites

Now I have FCC, the truth is that there is no big changes in to change the locale (as long you have compatibile channels and our ETSI(Europe) are compatibile with the FCC (USA) ). If you want, simple change the hex that you find in "Replace* [HEX]" from C6831609 00006A to C6831609 000037 with Clover Configurator under the _ar9300FillCapabilityInfo (Unknown Locale)

Ok, thank you!

Share this post


Link to post
Share on other sites

Here is the AR946X.v7.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

 

Both 2.4Ghz and 5Ghz should work.  Hopefully stability and speed improve too...

Share this post


Link to post
Share on other sites

Here is the AR946X.v7.  (only for macOS Sierra).  It's a patched version so please don't use it with KextsToPatch because it might not work...

 

Both 2.4Ghz and 5Ghz should work.  Hopefully stability and speed improve too...

10+ times faster than v6. Now the speed looks like same as in windows) But it seems to bee less stable, after a 1 minute I've cached drops.. 

By the way, opening a wi-fi menu fixes this problem for a while, will do more tests and report it back

6077092.230956899-6971914.893617021.png

Share this post


Link to post
Share on other sites

After some time a have a speed droops even for 0 mb/s, it may fix itself after 1 min or if I will open the top wi-fi menu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×