Jump to content
jalavoui

Atheros wireless driver OS X 10.11/12 for unsupported cards

617 posts in this topic

Recommended Posts

Advertisement

It shouldn't make differences between the patched kext and the kextstopatch method but you're welcome to try it.

 

That's interesting...  Everything is working fine and more stable on my system (with v16).  I'm not sure what might cause internet problems on your system.  Does your system still encounter the freezing problem with v16?

 

You can downloaded the unpatched AirPortAtheros40.kext from the following link.

 

http://www.insanelymac.com/forum/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?p=2399901

I set the system up all over again. I have not experienced frozen problem and breaking problem with v16 for the time being in short term. I will report back after using it for a long time. Thank you for your support.

Update 1: There is no freezing but it still breaks at regular and it does not improve unless I turn WiFi off and on.

Is there anyone who has used 9462 and has never had a breakup problem? If so, what version is it using?

Share this post


Link to post
Share on other sites

oops...  Did your system freeze before it connected to internet or after it connected to internet?  Not sure about the USB mouse...

 

I don't think you need to do anything with the clover plist while using the patched kext...

 

http://www.insanelymac.com/forum/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?p=2450121

My system freeze few seconds or minutes after I login! after freeze I can hear my processor cooler run more fast like full speed, then I need to reset. Notebook acer v3-371, I5 4210U.

Share this post


Link to post
Share on other sites

You're AMAZING Chunnann :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim: 
 
The AR946X.v16.kext works great for me in 10.12.5 but the internet speed seems so slow (like it's being capped).
 
Looking forward for the 10.13 version  :D  :lol:  :w00t:

post-2038406-0-93245700-1499093472_thumb.png

Share this post


Link to post
Share on other sites

oops...  Did your system freeze before it connected to internet or after it connected to internet?  Not sure about the USB mouse...

 

I don't think you need to do anything with the clover plist while using the patched kext...

 

http://www.insanelymac.com/forum/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?p=2450121

AR946X.v16.kext working very good. The best version of the kext, in my opinion.

 

Checked on a 100/100 MB internet connection.

post-796188-0-30641000-1499202050_thumb.png

 

Note: I've used the kext, but not the plist.

Share this post


Link to post
Share on other sites

because this is a work in progress and needs lots of testing maybe use KextsToPatch only for countrycode ?

 

this will help 4 ppl cause they only need to replace with latest version and report back

Share this post


Link to post
Share on other sites

Here are the AR9485.v16. & AR9565.v16. (only for macOS Sierra). It's a patched version so please don't use it with KextsToPatch because it might not work...

Nice work!

AR9485 is more stable than v14. Have no disconnects.

Some issue: on the low connection (2 or 1 strips of wifi sign) wifi is showing up in the list of available connections but can't connect (on v14 all except full wifi strength won't even showing up), but if it was already connected on full strength - it'll be working on low too (sometimes).

Share this post


Link to post
Share on other sites

Here are the AR9485.v16. & AR9565.v16. (only for macOS Sierra). It's a patched version so please don't use it with KextsToPatch because it might not work...

Thanks a lot! But where do I put the AR9485.v16.plist?

Share this post


Link to post
Share on other sites

Sorry about my noob question but if I use config.plist/kext to patch I don't need to install the kext right? And of course the same about the kext.

Share this post


Link to post
Share on other sites

Add to kext to patch in config.plist.

 

Sent from my Redmi Note 3 using Tapatalk

A BIG THANK YOU, Genxster for the tip!  I thought the AR9485 would NEVER work.

AWESOME! and also a BIG THANK YOU for chunnann.

post-156429-0-28845800-1499607948_thumb.png

Share this post


Link to post
Share on other sites

With V16 AR9462  works pretty well. I have never experienced a breakup problem for over 24 hours. But very rarely, I have a problem with speeding down. Thanks for everything. @chunnann

Share this post


Link to post
Share on other sites

Still working here. Not quite as fast as I'd like on the speed test. Does this see 5Ghz for anyone who has it? Mine doesn't but it's not a big deal. Just curious (like that monkey in the kids books)

Share this post


Link to post
Share on other sites

Can you patch for El Captain please? I can't get it working with Clover Kexttopatch with AR9485 cuz Fix_Airport4000 cause KP

 

I don't have El Capitan installed. You can upload the unpatched AirPortAtheros40.kext from El Capitan and I can try to patch it for you...

Share this post


Link to post
Share on other sites

Hi again, I use  AR9462 with V16 Kext, but there is still a breakdown problem in long usage. Sometimes I do not have internet when I turn on my computer and I need to restart it to come back. If you prefer, I can share my config file and my patched DSDT file. It will be really perfect if it resolves in this problem. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×