Jump to content
jalavoui

Atheros wireless driver OS X 10.11/12 for unsupported cards

617 posts in this topic

Recommended Posts

Advertisement

nope, i've tried it. don't know why. Furthermore on sierra it works without kexttopatch

 

That's odd...  Could you please upload unpatched AirPortAtheros40.kext from El Capitan so that I can help patch it for you?

For AR9565? I didn't find it.

 

only V14 for both AR9485 and AR9565 so far...

Share this post


Link to post
Share on other sites

That's odd...  Could you please upload unpatched AirPortAtheros40.kext from El Capitan so that I can help patch it for you?

 

only V14 for both AR9485 and AR9565 so far...

thanks man, I solved it going back to sierra. 10.12.3 :)

Share this post


Link to post
Share on other sites

@jalves

@Chunnann

 

Do not look at the upper right corner

Aren't you boot from clover with patched kexts in clover to obtain ar9565 .Also can you mention your procedure please to get it work .(ar9565).also what abt Bluetooth turn off,do you use patched kexts.Thanks

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

@jalvesAren't you boot from clover with patched kexts in clover to obtain ar9565 .Also can you mention your procedure please to get it work .(ar9565).also what abt Bluetooth turn off,do you use patched kexts.Thanks

 

Sent from my Redmi Note 3 using Tapatalk

@Genxtster

 

I use these clover patch in KextToPatch  http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=242898

 

more this

			<dict>
				<key>Comment</key>
				<string>Change pci168c,30 to pci168c,36</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				PHN0cmluZz5wY2kxNjhjLDMwPC9zdHJpbmc+
				</data>
				<key>InfoPlistPatch</key>
				<true/>
				<key>MatchOS</key>
				<string>10.12.x</string>
				<key>Name</key>
				<string>com.apple.driver.AirPort.Atheros40</string>
				<key>Replace</key>
				<data>
				PHN0cmluZz5wY2kxNjhjLDM2PC9zdHJpbmc+
				</data>
			</dict>

For Bluetooth  http://forum.osxlatitude.com/index.php?/topic/2925-bluetooth-firmware-uploader/

Share this post


Link to post
Share on other sites

@Genxtster

 

I use these clover patch in KextToPatch http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=242898

 

more this

<dict>				<key>Comment</key>				<string>Change pci168c,30 to pci168c,36</string>				<key>Disabled</key>				<false/>				<key>Find</key>				<data>				PHN0cmluZz5wY2kxNjhjLDMwPC9zdHJpbmc+				</data>				<key>InfoPlistPatch</key>				<true/>				<key>MatchOS</key>				<string>10.12.x</string>				<key>Name</key>				<string>com.apple.driver.AirPort.Atheros40</string>				<key>Replace</key>				<data>				PHN0cmluZz5wY2kxNjhjLDM2PC9zdHJpbmc+				</data>			</dict>
For Bluetooth http://forum.osxlatitude.com/index.php?/topic/2925-bluetooth-firmware-uploader/
OK,My Bluetooth remains always on and switch off icon is grayed.do you have the same problem ? Also, whether the clover kext2patch to airport-atheros40.kext ,Inteliofamily.kext is only needed ,no additional kexts to put in anywhere (No modified kexts ,excepts vanilla that already comes with os)

and what's about speed of WiFi in 2.5 GHZ.Thanks for reply.

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

OK,My Bluetooth remains always on and switch off icon is grayed.do you have the same problem ? Also, whether the clover kext2patch to airport-atheros40.kext ,Inteliofamily.kext is only needed ,no additional kexts to put in anywhere (No modified kexts ,excepts vanilla that already comes with os)

and what's about speed of WiFi in 2.5 GHZ.Thanks for reply.

 

Sent from my Redmi Note 3 using Tapatalk

 

Yes, the behavior of bluetooth is this ( In the developer's publication, this behavior is explained )

You do not need anything else, just KextToPatch

 

If the card was not recognized, manually load the kext, redo the caches and reboot

 

sudo kextload /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches

 

reboot

 

I was not able to test at speeds above 5Mb / s, the limit of my DSL

Edited by jalves

Share this post


Link to post
Share on other sites

Yes, the behavior of bluetooth is this ( In the developer's publication, this behavior is explained )

You do not need anything else, just KextToPatch

 

If the card was not recognized, manually load the kext, redo the caches and reboot

 

sudo kextload /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext

sudo kextcache -system-prelinked-kernel

sudo kextcache -system-caches

 

reboot

 

I was not able to test at speeds above 5Mb / s, the limit of my DSL

Thanks,Anyway to switch off BT ,I am afraid of getting BT firmware Worn ,damaged.

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

Have any chances to run QCA9377([168c:0042]) under 10.12.5 using this drivers?

Share this post


Link to post
Share on other sites

V15 doesn't have disconnect problem but there is speed drop problem. Sometimes happen speed drops and the connection is cut off instantly. After that it comes back. So still V13 is more stable than v15 for me.

Share this post


Link to post
Share on other sites

Try to replace device id in 40 kext(vanilla) plist but after rebuilding a cache have no changes and have auto reboot when used FIX_AIRPORT_4000 ): 

Share this post


Link to post
Share on other sites

V15 doesn't have disconnect problem but there is speed drop problem. Sometimes happen speed drops and the connection is cut off instantly. After that it comes back. So still V13 is more stable than v15 for me.

Agreed, same for me

Share this post


Link to post
Share on other sites

@Genxtster

 

I use these clover patch in KextToPatch  http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=242898

 

more this

			<dict>
				<key>Comment</key>
				<string>Change pci168c,30 to pci168c,36</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				PHN0cmluZz5wY2kxNjhjLDMwPC9zdHJpbmc+
				</data>
				<key>InfoPlistPatch</key>
				<true/>
				<key>MatchOS</key>
				<string>10.12.x</string>
				<key>Name</key>
				<string>com.apple.driver.AirPort.Atheros40</string>
				<key>Replace</key>
				<data>
				PHN0cmluZz5wY2kxNjhjLDM2PC9zdHJpbmc+
				</data>
			</dict>

For Bluetooth  http://forum.osxlatitude.com/index.php?/topic/2925-bluetooth-firmware-uploader/

This is my case. Using V14 with this kexttopatch, uploaded the bluetooth firmware, everything seems to run OK in Sierra 10.12.4.

Thank you!!

Share this post


Link to post
Share on other sites

This is my case. Using V14 with this kexttopatch, uploaded the bluetooth firmware, everything seems to run OK in Sierra 10.12.4.

Thank you!!

You mean ,Bluetooth Turn off Button is clickable ?

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

You mean ,Bluetooth Turn off Button is clickable ?

 

Sent from my Redmi Note 3 using Tapatalk

No, Atheros BT doesn't have "Bluetooth OFF" button on Sierra. But BT works, it's more than nothing.

Share this post


Link to post
Share on other sites

No, Atheros BT doesn't have "Bluetooth OFF" button on Sierra. But BT works, it's more than nothing.

I mean ,is there any issue of worn out of bt adapter ?

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

Hello! How i can use the AR9485(TPlink TL-WN781ND2) PCIE card with mac os 10.10?

Thx in advanced.

P.S.: Sorry for my bad english, bat this language is not my nacional.

 

I don't have 10.10 installed.  You can upload the unpatched AirPortAtheros40.kext from 10.10 and I can try to patch it for you...

Have any chances to run QCA9377([168c:0042]) under 10.12.5 using this drivers?

 

I don't think it would work because the driver is for ath9k, not for ath10k...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×