Jump to content

creating the iso using windows / linux

3 posts in this topic

Recommended Posts


Currently I am running Ubuntu Linux and I already have Install OS X El Capitan.app.zip file. I will use VMWare Workstation 12 to install El Capitan to a VM and read the necessary guides. The only problem I have is creating the ISO on Linux. I found and used dmg2img application but the ISO file won't boot in VMWare. I get unsuccessfull errors after booting the VM and VMWare says No OS found.

How can I fix this?

I currently don't have a Mac.

Share this post

Link to post
Share on other sites

Usually it's an error if you are using a legacy iso on UEFI mode but .app i think that doesn't work as bootable expecially from convert tools in other Os, try to verify your settings on VM. If you find a dmg image you can use burn aware that support dmg files, if you find a .iso for pc is nice..

Using VM on my notebook the .iso boot but fail with VMcrash, the same iso burned on dvdr DL work correctly.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sanjuk
      Dear experts,
      I'm new to the mac world however have been using Mountain Lion in a VM (downloaded online).
      Right now, I want to install El Capitan in a VM on Workstation 11.
      What I have right now,
      Hardware :-
      - Dell Vostro 2420 running Win8.1 64 bit.
      - Intel core i5 3230M
      - 4 GB DDR3 RAM
      - Intel B75 express chipset
      - Intel HD4000 graphics
      - 500 GB WD HDD
      Software :-
      - Working Mountain Lion VM
      - El Capitan dmg/iso file downloaded from Mountain Lion.
      - El Capitan Bootable USB created from Mountain Lion
      - VMware Workstation 11 / 12.
      Could anyone help me on how to install El Capitan on,
      - VMware Workstation
      - On Dell Vostro 2420 laptop
      So far I've tried to search lot many forums, but what is see is that they use the pre-configured vm image in the videos.
      While I tried to use ISO image and boot, it shows a STOP/restricted sign. Tried adding setting like smc.version = "0" and disabling sound but to no avail.
      Greatly appreciate any help on this...
    • By colt2
      With the release of El Capitan, the script to create a Bootable ISO for VMware of Mavericks and Yosemite does not seem to work anymore on the El Capitan official release.
      The ISO simply does not boot.
      Below is what I found that worked. Since I've been looking for this for a couple of days, I figured I'd share it. - Enjoy!
       # Mount the installer image
       hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg -noverify -nobrowse -mountpoint /Volumes/install_app
       # Create the ElCapitan Blank ISO Image of 7316mb with a Single Partition - Apple Partition Map
       hdiutil create -o /tmp/ElCapitan.cdr -size 7316m -layout SPUD -fs HFS+J
       # Mount the ElCapitan Blank ISO Image
       hdiutil attach /tmp/ElCapitan.cdr.dmg -noverify -nobrowse -mountpoint /Volumes/install_build
       # Restore the Base System into the ElCapitan Blank ISO Image
       asr restore -source /Volumes/install_app/BaseSystem.dmg -target /Volumes/install_build -noprompt -noverify -erase
       # Remove Package link and replace with actual files
       rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
       cp -rp /Volumes/install_app/Packages /Volumes/OS\ X\ Base\ System/System/Installation/
       # Copy El Capitan installer dependencies
       cp -rp /Volumes/install_app/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System/BaseSystem.chunklist
       cp -rp /Volumes/install_app/BaseSystem.dmg /Volumes/OS\ X\ Base\ System/BaseSystem.dmg
       # Unmount the installer image
       hdiutil detach /Volumes/install_app
       # Unmount the ElCapitan ISO Image
       hdiutil detach /Volumes/OS\ X\ Base\ System/
       # Convert the ElCapitan ISO Image to ISO/CD master (Optional)
       hdiutil convert /tmp/ElCapitan.cdr.dmg -format UDTO -o /tmp/ElCapitan.iso
       # Rename the ElCapitan ISO Image and move it to the desktop
       mv /tmp/ElCapitan.iso.cdr ~/Desktop/ElCapitan.iso
    • By Chinmaya13666
      I am a newbie and have never owned a mac but am fascinated to use osx.
      I have an iso image of osx mavericks. It works in vmware thanks to an unlocker from this forum. I want to install it into my computer (pc). How do i make a bootable usb out of this iso?
      Are there any preferred applications to do so? I have already tried USBwriter which i use for Linux Systems but it failed. I haven't tried dd yet.
      Also can somebody say whether this configuration will work:
      1. Samsung 850 EVO SSD 120GB
      2. Corsair Vengeance 4x2GB RAM
      3. Gigabyte GA-B85M-D3H motherboard
      4. A PSU by Intex of 450W
      5. My Monitor is a Samsung 22 inch TV whose model i don't know.
      6. Integrated Intel HD 4600 graphics
      7. Intel Core i5 4440 processor
    • By alex89
      Salve a tutti,
      dico subito che ho un NETBOOK ASUS X54H e che,
      sto provando ad installare MAX OS 10.8 ML dalla distro NIRESH.
      La mia installazione procede bene, termina con successo, ma al riavvio, terminata l'installazione, quando mi carica il sistema, ovvero mi chiede le ultime cose (lingua, nome account, password ecc..), il touchpad ed il mouse usb non vanno più, nemmeno la tastiera.
      Devo dire però che la fase precedente, ovvero dove uso l'utility disco ecc..i driver ecc mi funzionano.
      Penso proprio manchino i driver nella niresh, alchè ho scaricato i kexts per il mio pc che, ricordo è un NETBOOK ASUS X54H, ma non so dove inserirli nel dvd iso, cioè vorrei caricarli in fase di installazione e di conseguenza modificare l'ISO.
      PS: lo sto installando su una partizione a sè, nessuna macchina virtuale.
      Qualcuno sa dirmi dove inserirli?
      si accettano consigli su tutto.
    • By joatoche
      Hello, im new to the forums and i have a problem installing Hazard's Snow Leopard on my AMD computer.
      Here are my specs:

      CPU: AMD Phenom II X4 965 (no overclock) Motherboard: Gigabyte GA-880GM-UD2H RAM: Corsair Vengeance 4GB 1333mhz DDR3 x2 (8gb total) Graphic card: Nvidia GTX 550 Ti 1GB (no overclock) HDD: WD 500gb (465gb formatted) SATA3
      I've tried both ##### and ModCD and none of them work, i even tried EmpireEFI. On every bootloader, when i swap the disks and press F5, all of the disk labels get corrupted. I've tried the following commands: -v busratio=18 (and for the ModCD >) rd(0.0)/Extra/ModCD/modbin_kernel (i think).
      What is wrong? I thought it was maybe the ISO I downloaded.
      Please help this Hackintosh noobie!