Jump to content
InsanelyMac Forum
Onestyle

El Capitan - Sierra - High Sierra - Sony Vaio E Series (2012) - SVE1712W1EB - AMD Radeon HD 7650M

Recommended Posts

Advertisement

@Nonta97, as u requested :)


Clover configuration-Graphics : 

set Dual Link : 0 , FB Name : Pondweed , Vram : 1,024 , Video Ports : 3 , Check Load Vbios ,Inject Edid , Inject ATI .
3. Clover configuration- Kernel and Kext Patches : 
Name : AMD6000Controller

use AMDFramebufferUtilty to get best result.

 

 

And @Onestyle y is ur Fake ID : ATI : 0x67411002 instead of 0x68411002

1002_6841.rom.zip

Share this post


Link to post
Share on other sites

@Nonta97, as u requested :)

Clover configuration-Graphics : 

set Dual Link : 0 , FB Name : Pondweed , Vram : 1,024 , Video Ports : 3 , Check Load Vbios ,Inject Edid , Inject ATI .

3. Clover configuration- Kernel and Kext Patches : 

Name : AMD6000Controller

use AMDFramebufferUtilty to get best result.

 

 

And @Onestyle y is ur Fake ID : ATI : 0x67411002 instead of 0x68411002

 

Thanks

Can you upload your entire CLOVER folder (remove themes to reduce the size)?

I have already tried this many times, same results: Black screen.

And it is Nonta72 by the way, hahahahahhhh

Share this post


Link to post
Share on other sites

Make sure u have ur own EDID :)


DualLinke = 1 if ur intel HD 4000 is working, else 0(it make difference, gives black screen)


N also post ur details/procedures, so that one can help u :) 

Archive.zip

Share this post


Link to post
Share on other sites

Make sure u have ur own EDID :)

DualLinke = 1 if ur intel HD 4000 is working, else 0(it make difference, gives black screen)

N also post ur details/procedures, so that one can help u :)

Thank you!!!

I now have Full QE/CI using your files.

For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).

Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.

Share this post


Link to post
Share on other sites

Thank you!!!

I now have Full QE/CI using your files.

For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).

Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.

Graphics works on 10.12

Share this post


Link to post
Share on other sites

Graphics works on 10.12

 

That's good news!

Have you got the graphics to work on 10.11 without the framebuffer patch?

Because I think I have been doing the whole thing very wrong. I just found out that Cattail and Fanwort (probably Kudzu and Lotus too) work without the patch. I just checked InjectEDID, LoadVBIOS, InjectATI and disabled your AMD6000Controller patch. After reboot, I have now QE/CI. LVDS is what matters to me right now, VGA and HDMI can wait.

Share this post


Link to post
Share on other sites

Thank you!!!

I now have Full QE/CI using your files.

For the details, you can find them on my signature (same config as you, except mine ends with FW instead of NB which is just regional difference I guess).

Now I will fix the remaining bugs and will install 10.12 on another partition. Together we can try to figure out why the graphics won't work on 10.12.

Sharing is Caring :)

 

OnsStyle did a gr8 Job by creating this Thread with a gr8 Details :)

Share this post


Link to post
Share on other sites

Sharing is Caring :)

 

OnsStyle did a gr8 Job by creating this Thread with a gr8 Details :)

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.

Share this post


Link to post
Share on other sites

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.

Ive used this DSDT Patches,

1.Audio (layout-id 3)

2.IRQ Fix

3.TNOT Fix

4.Brightness Fix

5.7Series/8Series USB

In MacIasl app, add RehabMan's repo(DSDT Patches).

Share this post


Link to post
Share on other sites

Yeah, indeed!

I'm still struggling to get brightness slider working. I used the patch provided by the OP, the brightness slider appeared but won't change the brightness (brightness keys won't change it either).

Do you mind sharing your DSDT patches?

If I use your patched DSDT, I get it working fine. But I'd like to know how you did it for future uses.

 

Brightness slider shows but doesn't do anything,that's strange cause it works for me. Have you did this part in dsdt

 

2a. Find in your dsdt: 

Device (LID0)

{

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

 

 

 

2b. replace

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

with

 Name (_HID, EisaId ("LCD1234")) // _HID: Hardware ID

Share this post


Link to post
Share on other sites

Ive used this DSDT Patches,

1.Audio (layout-id 3)

2.IRQ Fix

3.TNOT Fix

4.Brightness Fix

5.7Series/8Series USB

In MacIasl app, add RehabMan's repo(DSDT Patches).

 

Alright, I will apply these patches and see.

 

Brightness slider shows but doesn't do anything,that's strange cause it works for me. Have you did this part in dsdt

 

2a. Find in your dsdt: 

Device (LID0)

{

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

 

 

 

2b. replace

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

with

 Name (_HID, EisaId ("LCD1234")) // _HID: Hardware ID

 

Yeah, I did that part. Apparently, siddRamesh did not do that part. I tried both cases i.e changing the EisaId and not changing it. All ended up with the same results.

I noticed something strange. I checked siddRamesh's patched DSDT and the PNLF device isn't under a scope. It's just on the very end of the DSDT.

But whenever I patch mine, it goes under a new _SB scope. Can that be the problem?

This is the end of his patched DSDT:

    Name (_S5, Package (0x04)  // _S5_: S5 System State
    {
        0x07, 
        Zero, 
        Zero, 
        Zero
    })
    Device (PNLF)
    {
        Name (_ADR, Zero)  // _ADR: Address
        Name (_HID, EisaId ("APP0002"))  // _HID: Hardware ID
        Name (_CID, "backlight")  // _CID: Compatible ID
        Name (_UID, 0x0A)  // _UID: Unique ID
        Name (_STA, 0x0B)  // _STA: Status
    }
}

I also checked RehabMan's patches and the brightness patch that you provided, none of them seem to contain the comments that are actually in his DSDT i.e // _ADR: Address for example.

Share this post


Link to post
Share on other sites

Alright, I will apply these patches and see.

 

 

 

Yeah, I did that part. Apparently, siddRamesh did not do that part. I tried both cases i.e changing the EisaId and not changing it. All ended up with the same results.

I noticed something strange. I checked siddRamesh's patched DSDT and the PNLF device isn't under a scope. It's just on the very end of the DSDT.

But whenever I patch mine, it goes under a new _SB scope. Can that be the problem?

This is the end of his patched DSDT:

 

Name (_S5, Package (0x04)  // _S5_: S5 System State
    {
        0x07, 
        Zero, 
        Zero, 
        Zero
    })
    Device (PNLF)
    {
        Name (_ADR, Zero)  // _ADR: Address
        Name (_HID, EisaId ("APP0002"))  // _HID: Hardware ID
        Name (_CID, "backlight")  // _CID: Compatible ID
        Name (_UID, 0x0A)  // _UID: Unique ID
        Name (_STA, 0x0B)  // _STA: Status
    }
}
I also checked RehabMan's patches and the brightness patch that you provided, none of them seem to contain the comments that are actually in his DSDT i.e // _ADR: Address for example.

Quick question,is the brightness changing in system preferences?? If it is,update to the latest voodoo PS2

Share this post


Link to post
Share on other sites

Quick question,is the brightness changing in system preferences?? If it is,update to the latest voodoo PS2

 

I have the latest PS2 driver. And no, brightness doesn't change in system preferences or with the Fn keys (Fn+F5 and Fn+F6)

Share this post


Link to post
Share on other sites

I have the latest PS2 driver. And no, brightness doesn't change in system preferences or with the Fn keys (Fn+F5 and Fn+F6)

 

Okay,PNLF issue then,put your whole clover folder here,without themes,and I'll check it out later on when I have time.

Share this post


Link to post
Share on other sites

Okay,PNLF issue then,put your whole clover folder here,without themes,and I'll check it out later on when I have time.

 

I figured it out. There seemed to be a conflict between the SSDTs. I had SSDT (generated by PikerA's script), SSDT-1, SSDT-2 and SSDT-3 in patched folder. I also had "DropOEM" set to true in my config.plist.

Removing the SSDT-3 from patched folder seems to have fixed the problem.

Share this post


Link to post
Share on other sites

Hey plz update to 10.13(OS X High Sierra) !

Not until it's out officially , so probably in about 20 days or so, It's my work station so can't have it to be buggy. First I'll test it out on my second drive, and when I'm done, it's going on my main drive and then I'll update the first post. 

Share this post


Link to post
Share on other sites

Not until it's out officially , so probably in about 20 days or so, It's my work station so can't have it to be buggy. First I'll test it out on my second drive, and when I'm done, it's going on my main drive and then I'll update the first post. 

Sure Bro :)

waiting for ur 10.13 Detail update........

Share this post


Link to post
Share on other sites

hey can u post how did u make your sound work? i have sve14a15fg model e series..

also when i tried your step to make my radeon 7670M work but no luck. is it because my radeon gpu is dedicated gpu? how can i know if my radeon card is integrated or not? because now i'm using intel hd 3000 and it works with 300mb memory only :( . can you help me please? i should get like up to 1gb with my ati radeon gpu.....

Share this post


Link to post
Share on other sites

Hey plz update to 10.13(OS X High Sierra) !

Updated to High Sierra, so far fixing up a few things,but I've managed to get sleep working, everything else works like in Sierra and El capitan. GPU works fully ;) .After I'm done with the fixes I'll update the first post. No ETA, don't have much time to spend on my laptop.

 

EDIT

 

GPU ends up with colouring artefacts, it can probably be fixed by additionally patching the framebuffer, but at the moment I'm too lazy to get it done so went with an easy solution ( disableMonitor app). Everything else works. Soon there will be an updated tutorial on first post.  ;)

Share this post


Link to post
Share on other sites

Bro how did manage to get HIGH!

 

i did fresh install, no QE/CI :(

 

Can i have ur clover files 

 

N ur profile shows u r using 10.11.4(i also find it stable), r u using 10.13 as daily driver!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By zebity
      Hi Hypervisors,
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan and Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install EL Capitan / Sierra / High Sierra and boot into system! for Sierra/High Sierra you need a Processor with SSE4.1 instruction   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time! -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) and tell me what your hardware! -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    My DSDT GA P35-DS3 DSDT.MaLd0n LGA775.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
×