Jump to content
mrmauricionetto

PC Ware PMH61P1 e GTX 970 Turbo

24 posts in this topic

Recommended Posts

Olá, tudo bem com vocês?

 

Pessoal, estou precisando de ajuda.

Instalei El Capitan normalmente, e está tudo funcionando "perfeitamente".

 

Porém a minha placa de video aparenta não ter sido instalada corretamente.
Sim, está com o Web Driver da Nvidia, CUDA, dou boot com nvda_drv=1, inicio com 3 monitores normalmente, mas não parece que todos os recursos estão funcionando.
Mas pq parece que não está? Vamos às provas:

 

1. O Final Cut Pro X está todo travado, principalmente quando passa o mouse na timeline, ou no preview do video.
Eu montei esse hackintosh com intenção de justamente trabalhar com video e graficos, porém esse problema com o FCPX está me matando por dentro.

2. Premiere Pro CC, e DaVinci Resolve, estão com o preview travado também.
Até as outras alternativas do FCPX não tá rolando pra mim.  :( 

3. Tenho "Counter Strike Global Offensive" instalado pela Steam, e não consigo iniciar pois aparece: 

 

ScreenShot2016-04-07at11.22.58PM.png

 

 

Então galera, não sei mais o que fazer.
Seguem especificações e prints:

 

Bootloader: Clover

Boot flags: dart=0 cpus=1 nvda_drv=1

 

ScreenShot2016-04-07at11.24.49PM.png

 

ScreenShot2016-04-07at11.25.53PM.png

 

ScreenShot2016-04-07at11.26.16PM.png

 

AGRADEÇO DESDE JÁ!  :thumbsup_anim: 

Share this post


Link to post
Share on other sites
Advertisement

olá

 

posta as tuas especificações de hardware ..

 

cpus=1 ?

 

sistema está instalado incorrectamente (está coxo)

 

e macpro3,1 ?

 

i7 ? convém saber o modelo e tudo o mais

 

bom hack

Share this post


Link to post
Share on other sites

Olá Artur.

 

Atualizei minha assinatura com as especificações.
Como assim (está coxo)?

 

Eu não deveria dar boot com cpus=1?

 

Qual a smbios correta pro meu pc?

 

Obrigado pela ajuda!

Share this post


Link to post
Share on other sites

olá

 

está coxo cpus=1 só um dos core está a trabalhar ..

 

se usares clover faz o enable disto

 

https://clover-wiki.zetam.org/Configuration/KernelAndKextPatches#kernelandkextpatches_asusaicpupm

 

se usares chameleon tens de patchear a kext

 

http://olarila.com/forum/viewtopic.php?f=9&t=1003

 

bom hack

Share this post


Link to post
Share on other sites

Opaaa!
Obrigado pessoal, então não preciso usar cpus=1.

 

Essa SMBios eu escolho no Clover Configurator?

 

Esse enabler eu faço no Clover configurator tbm?

 

<key>AsusAICPUPM</key>
<true/>

 

Assim que chegar em casa vou fazer o teste, e ponho resultado aqui!

 

Obrigado gente!

Share this post


Link to post
Share on other sites

Pois é pessoal, primeiro tirei a opção cpus=1 e ele da reboot, depois mudei a smbios pra iMac 12,2 e agora reboota também.

Só consigo entrar em modo de segurança mas não monta a partição efi pra mudar.

Q eu faço?

Share this post


Link to post
Share on other sites

Dá boot em -v para ver onde para.

 

Adicionou o patch AICPM?

 

Dica: Faça essas mudanças em um Pendrive primeiro, dai tente dar boot com ele, se o OS X iniciar ok, mas caso não vamos as modificações.

Isso evita problemas como o que você está tendo agora.  :)

Share this post


Link to post
Share on other sites

Opa!

 

Sim, o  AICPM ja estava ativado na verdade.
 

Então, fiz o backup em um pendrive, e voltei ao estado inicial.
Vou add primeiro a SMBIOS para o imac 13,2.

 

Já volto com resultados.

 

---

 

[Edit_1]


Enfim, mudei a SMBIOS pra imac, e inicia normalmente, porém só funciona 2 usb's traseiras.
Aproveitei a oportunidade, e coloquei "Inject NVidia".
 

O mac inicia apenas com 2 monitores e na descrição aparece ASUS GTX970, mas aparece 0 mb

 

Removi o Inject Nvidia, e reiniciei normal.

Tentarei agora, dar o boot sem cpus=1

 

 

ScreenShot2016-04-10at11.46.27AM.png

 

 

----

 

{edit_2]

 

Não consigo iniciar sem cpus=1.

 

O que devo fazer?


Outra pergunta:

 

Como usar Infect NVidia, NvidiaGeneric NvidiaSingle?

Share this post


Link to post
Share on other sites
sua placa de vídeo não é reconhecido corretamente!

iniciar o seu sistema com a bandeira de inicialização tese: -v GraphicsEnabler=No nv_disable=1

Ou, então, criar um DSDT com injeção de gráficos ou edição no config.plist trevo com identidade falsa e Injection, adicione todo o valor apropriado para a sua placa gráfica.

se então a sua placa gráfica está a funcionar correctamente, então arrancar com: -v GraphicsEnabler=No nvda_drv=1

 

 

your graphics card is not recognized correctly!

start your system with these boot-flag: -v GraphicsEnabler=No nv_disable=1

then either create a DSDT with Graphics injection or edit in clover the config.plist with Fake-ID and Injection, add all value suitable for your graphics card.


 

if then your graphics card is working properly, then boot with: -v GraphicsEnabler=No nvda_drv=1

Share this post


Link to post
Share on other sites

A regra como o @spakk falou acima é:

 

nv_disable=1 > Sem WebDrivers 

nvda_drv=1 > Com WebDrivers

 

Trabalhei recentemente com uma GTX 980, e usava InjectNvidia=Nonvda_drv=1.

Share this post


Link to post
Share on other sites

Certo gente.

Sem WebDrivers, não tem resolução, e a placa nao funciona.
Com WebDrivers está desse jeito aí.

 

Agora, como sou muito noob nessa questão de hackintosh, não faço a minima pra que serve um DSDT, e nem como usá-lo.

Share this post


Link to post
Share on other sites

Posta seu config.plist aqui.

 

DSDT é raro o caso, mas usando ele terá o reconhecimento de alguns drivers praticamente como se fosse nativos.

 

Usando os patches certos claro. Aconselho dar uma lida sobre DSDT, no Forum português tem alguns com excelentes explicações.

Share this post


Link to post
Share on other sites

Galera eu ja estou desesperado, não sei mais o que fazer pra iniciar sem esse CPUS=1.

 

Ja fiz o patch, coloquei as opções de boot... sinceramente estou ficando louco.
 
Segue meu Config.plist  e a pasta do Clover pra ver se vcs conseguem me ajudar.

 

Obrigado gente, de verdade!

 

----

Ah outra coisa, quando tento iniciar com o Chameleon, uso as flags: nvda_drv=1 dart=0 -v, mas sempre depois que carrega, as telas ficam pretas! Nem com o CPUS=1 funciona com o chameleon!

config.plist.zip

CLOVER.zip

Share this post


Link to post
Share on other sites

não é por nada não, mas creio que deveria visitar olarila e reinstalar seu sistema com a imagem limpa. e veja se a bios está configurada direito.

Share this post


Link to post
Share on other sites

Então, eu fiquei encucado com isso e fui atras de todas as opções da BIOS.
Consegui inicializar sem CPUS=1 desativando o speedstep/Turbo Boost Tech na bios.
Essas opções deveriam ser desativadas?

Share this post


Link to post
Share on other sites

Opa, valeu.

Então essa opção não faz diferença no mac, porem eu voltei ao normal e ja reinstalei o mac umas 3 vezes hoje.
Finalmente estou conseguindo inicializar sem o CPUS=1.
Mas ai está outro problema:

ELE INICIA QUANDO QUER.

Tem horas que ele carrega tudinho até o final sem erro, e reinicia, quando reinicia vai do mesmo jeito, carrega e entra.
Tem outras horas que ele não inicia de jeito nenhum, e só inicia com -f.

Eu ja to cansado demais, passei o dia todo pra resolver isso e ainda to nessa.

Sabe me dizer o que pode estar ocorrendo?

 

--

 

EDIT:

Estou iniciando com: -v dart=0 nvda_drv=1
 

Com essas flags, tem horas que entra e tem horas que não.

As vezes ele só entra add -f junto.

Share this post


Link to post
Share on other sites

ola...

 

vc realmente precisa de todas aquelas .kexts que estão na pasta kext/10.11..principalmente as de rede?

 

vc esta dando boot em "legacy"?

 

se sim, por que drivers UEFI..?

 

na RTVariables  talvez tenha que colocar 0x67 em CrsActive config..

c.frio

Share this post


Link to post
Share on other sites

Opa, valeu.

Então essa opção não faz diferença no mac, porem eu voltei ao normal e ja reinstalei o mac umas 3 vezes hoje.

 

Na verdade fazem diferença sim. Pra edições, é extremamente necessário.

Todo o Mac Intel usa essas tecnologias, não são só para o Windows.  :lol:

 

Leia com mais atenção  :P

 

Mas vai usando o que tem, futuramente a gente vai encontrar uma solução pra isso.  ^_^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Update - 26/03/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios
      Clover Z390 Pro Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (05/03/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Current EFIs 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest Clover EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Updated 26/03/20 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      Clover Z390 Master Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Master Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (03/03/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (03/03/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By tlefko
      Description
      This esentially an ultra-simplistic version that is stable without the use of a deploy or complicated file installations and copies. Highly recommend using DW1560 wifi card, killer wifi isn't supported. This does include a copy of Clover, which of course I take no credit for. I am only responsible for minor changes in files and plists, as well as placement and instructions throughout the guide (as well as the work used from previous projects). Many files and ideas are sourced from @maz-1, @syscl, and my previous guides Granted, many files are similar or the same but there is significantly less of them and/or they are predeployed into spots where they will work just as well, even if not as efficient on bootup. Esentially, this guide is designed to provide a perfectly working setup with little knowledge of the topic and without optimization (because often they can break things). Most patches on the main plist use patches implemented by him as well. ****This guide does work excellently however and will provide you with a near perfect setup for Catalina for your XPS 9350, and is currently my daily driver as I struggled using the referenced users files as well.
      Styling
      This guide is designed to be literally as thorough as possible to appeal to those who really don't understand many of the things in @maz-1's guide or some of the other users as they assume you would already understand this information. It does not cover complex topics like undervolting etc etc Notes
      Never tested USB C except for charging, works great no issues with sleep, wakeup. power management is defaulted as I found with @maz-1 it had issues when on battery switching from AC USB devices eject on sleep (not really an issue) Haven't implemented a Bluetooth solution into this yet, as I don't really use it -- will be added ASAP (I believe KILLER WIFI will NOT work, must use one of the supported chipsets (DW1560 is excellent) BIOS Setup
      Set all SATA operation as AHCI Disable Secure Boot, Fast Boot For Coil Whine improvement disable C-States Enable UEFI Booting Recommended: Clean Install (Preinstall steps)
      Format a USB (16GB) as Journaled and then proceed to download the latest Catalina Installer Patcher Application Download the latest Catalina installer from within the Patcher App, and select to download a new copy and install to your USB device Download the clover configurator application and mount the EFI of the USB partition, then copy the contents of the Files linked above to the EFI Folder within the EFI partition. ** This is because the App Store installers will often not download a full installer, just an truncated version that downloads the installer files from the interent while installing. Thus, they're not bootable from a USB as they're not complete. That is why you should use this method to make sure the installer is usable for bootable media.
      Install Steps
      Simply use F12 to boot from the USB device, and select the USB Device and then boot from the Install mac OS partition. I have defaulted the installer to boot into verbose mode so I can easily see the errors you guys are seeing if you encounter them. If everything goes well, you can disable these from the boot arguments selection of Clover Configurator Boot into the USB Device, and follow the steps to format your SSD from the installer to install Mac OS Catalina. NOTE THE TRACKPAD WILL NOT FUNCTION AT THIS POINT, BUT THE TOUCHSCREEN WILL. This is caused by the way the installer handles Kext loading but because the touchscreen is being loaded via usb and the keyboard in a different method (which I can explain in detail if you'd like, the install will be possible. Do not be alarmed if the installer takes a long time to boot into, this is expected Once you have done this step, use F12 to select the USB and boot into the installer from the SSD in the options menu. (you cannot boot natively yet as the EFI isn't copied into the SSD yet. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now we will add this as a native boot option. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now will we add this as a boot entry so you can always boot from this natively without the USB. Boot Entry Setup
      Boot into the BIOS of the computer, then navigate to the Boot setup (or entries (not sure what it is called exactly, but it will be a list of the options your computer selects to boot) Click add new, and make sure the USB isn't plugged in. Select the only option that is avaiable, and in FS0 navigate to Boot/BOOTx64. Add this as an entry, then select this as whatever priority you would like. Credits
      Credit Hackintosher.com for basic patches (although @syscl) covered some Credit to @Rehabman Credit to @syscl Kexts, and his contributers (@maz-1) Messages and Facetime
      Using Clover Configuator generate your own Serials, Board Numbers, MLB There are various guides online to do this and as default they're set to essentially Null (Fakeserial) This is fairly straightforward and there is lots of documentation, just don't open these apps until you've done this properly. Finished!
      Congratulations, there really aren't any more steps that are required. Feel free to contact me with any questions. Files can be downloaded here, and issues and help requests can be said here or opened into the GitHub page. Please @ me for a faster response on this page, as I am not that attentive, also, feel free to PM me.  Github: https://github.com/tlefko/XPS13-9350-Catalina Thanks for reading! Files.zip
    • By Teress
      I built the world’s fastest, most powerful, ultimate Hackintosh in 2020! 2019 Mac Pro cannot compete with my build!  Real 2019 Mac Pro killer! Real Monster. Watch here
      https://youtu.be/A-1aFfToXzk
×