Jump to content
tripudio69

HDMI Audio geforce 8400gs palit VA E VIENE

57 posts in this topic

Recommended Posts

Advertisement

niente ho interrotto l'aggiornamento da app store e ora non me lo fa più fare sono bloccato al 10.10 ci vorrebbe una appleHDA compatibile 10.10


sto cercando nella sezione download

Share this post


Link to post
Share on other sites

stamani ho reinstallato yosemite 10.10 fatto l'aggiornamento al 10.10.5 (2 ore) installato le appleHDA e HDAenabler5 patchate stavolta le carica ma niente suono nonostante il controllo audio sia attivo

Share this post


Link to post
Share on other sites

ciao gengik84 risultava "altoparlanti interni" oppure "uscita ottica digitale" a scelta uno delle due.

SE sceglievo il primo il controllo volume sulla barra di stato si attivav ma non si sentiva niente, mentre per il secondo si disattivava proprio e comunque non c'era audio lo stesso.

Inoltre andando in conf. midi audio gli slider del volume delle due uscite erano grigi (on blu) ossia disattvati

Share this post


Link to post
Share on other sites

ci sono tre jack uno è line out (quelllo verde) gli altri due sono ingressi (mic e line-in)

poi per l'audio analogica funziona bene la voodoohda a me interessava l'hdmi...


Sarebbe meglio usare un appleHDA patchato + hdaenabler e iniettare l'audio HDMI nel dsdt

come si fa ad iniettare l'audio nel dsdt? (visto che io non lo uso su questa scheda madre)

Share this post


Link to post
Share on other sites

Estrai il DSDT, con DPCI manager

Forse in futuro lo farò il problema è che non sembro aver fortuna con le AppleHDA Patchate...

 

Visto che finora avevo provato solo questo metodo senza risultati, anzi con risultati inferiori alla voodoohda, sono tornato a cercare meglio tra le tante vodoohda che ci sono in giro ed oggi ho trovato questa:

 

http://www.insanelymac.com/forum/files/file/534-dell-optiplex-760-780-fix-for-analog-inputs-outputs-and-for-hdmi-audio-output-for-nvidia-geforce-210/

 

da notare che questo link contiene un'Apllehda ed una VoodooHDA patchate, la voodoohda in particolare è patchata per abilitare l'auido hdmi sulla Geforce GT210.

Ora dato che la mia 8400gs e la 210 montano lo stesso chip audio (infatti sono le due schede che danno più problemi con le voodoohda) questa kext ha funzionato per me, infatti ora

nelle proprietà/suono ho 4 uscite hdmi di cui la seconda funziona (di continuo non per un secondo come prima) di converso sono sparite le uscite analogiche, e per questo problema mi prendo una pausa di riflessione...

Penso che bisogna usare una appleHDA patchata per lamia scheda madre, ma non quelle che ho usato finora.

Beh che dire... mi ritengo soddisfatto per ora anche se parzialmente, quindi consiglio a tutti i possessori di geforce 8400gs o 210 di utilizzare questa kext, e mi riservo nuovi sviluppi (speriamo)

 

Ah notate il link sotto: un utente col mio stesso problema

 

http://www.insanelymac.com/forum/topic/310382-nvidia-210-1-second-output-through-hdmi-then-no-audio/

 

lui ha risolto con una flag strana

Share this post


Link to post
Share on other sites

Forse in futuro lo farò il problema è che non sembro aver fortuna con le AppleHDA Patchate...

 

Visto che finora avevo provato solo questo metodo senza risultati, anzi con risultati inferiori alla voodoohda, sono tornato a cercare meglio tra le tante vodoohda che ci sono in giro ed oggi ho trovato questa:

 

http://www.insanelymac.com/forum/files/file/534-dell-optiplex-760-780-fix-for-analog-inputs-outputs-and-for-hdmi-audio-output-for-nvidia-geforce-210/

 

da notare che questo link contiene un'Apllehda ed una VoodooHDA patchate, la voodoohda in particolare è patchata per abilitare l'auido hdmi sulla Geforce GT210.

Ora dato che la mia 8400gs e la 210 montano lo stesso chip audio (infatti sono le due schede che danno più problemi con le voodoohda) questa kext ha funzionato per me, infatti ora

nelle proprietà/suono ho 4 uscite hdmi di cui la seconda funziona (di continuo non per un secondo come prima) di converso sono sparite le uscite analogiche, e per questo problema mi prendo una pausa di riflessione...

Penso che bisogna usare una appleHDA patchata per lamia scheda madre, ma non quelle che ho usato finora.

Beh che dire... mi ritengo soddisfatto per ora anche se parzialmente, quindi consiglio a tutti i possessori di geforce 8400gs o 210 di utilizzare questa kext, e mi riservo nuovi sviluppi (speriamo)

 

Ah notate il link sotto: un utente col mio stesso problema

 

http://www.insanelymac.com/forum/topic/310382-nvidia-210-1-second-output-through-hdmi-then-no-audio/

 

lui ha risolto con una flag strana

 

Ti ho chiesto il DSDT così lo posso modificare per inserire l'audio HDMI lol 

Share this post


Link to post
Share on other sites

Eccolo:

 

Scarica IORegistry explorer, aprilo, poi vai su File, salva con nome. 

Il file che ti genera comprimilo e allegalo qui. 

Share this post


Link to post
Share on other sites

si ho fatto tutto quello che hai detto ma non esce l'audio hdmi.

Ovviamente ho reinstallato la voodoo 2.8.8 che mi dava anche le uscite analogiche.

siamo tornati a capo ho provato anche con enable hdmi audio nel chameleon ma niente

Share this post


Link to post
Share on other sites

Sono sempre dell'idea che sarebbe meglio AppleHDA patchato + hdaenabler5.

Ho avuto la stessa scheda madre tra le mani e funzionava correttamente l'audio....

Come viene rilevata la scheda video in informazioni su questo Mac?

si ho fatto tutto quello che hai detto ma non esce l'audio hdmi.

Ovviamente ho reinstallato la voodoo 2.8.8 che mi dava anche le uscite analogiche.

siamo tornati a capo ho provato anche con enable hdmi audio nel chameleon ma niente

Share this post


Link to post
Share on other sites

Palit Geforce 8400GS

 

con le applehda patchate non ho avuto fortuna....

Ok l'iniezione nel dsdt ha funzionato, rimane solo da installare correttamente AppleHDA e HDAEnabler... Appena arrivo a casa....

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By LarryKu
      Hi everyone,
      I am new, I hope I am posting in the correct forum.
      My specs:
      Processor: Core i5 6500 Skylake 3.2ghz
      Mobo: Gigabyte h170-d3h
      M2SSD: WD Black 256gb PCIe (Mac OSx)
      SSD: Samsung 860 Evo (WIndows 10)
      HDD: WD Blue 1TB
      GPU: Radeon RX 480
      Monitor: BenQ RL2460 24"


      I was able to install High Sierra on a new m2 drive, that I added to the above configuration with windows 10 already installed.
      I had a few issues during install, including the monitor turning off at boot screen.

      Unfortunately, this persists even now. It turns off at about 60% of the progress bar, and to turn it on again I have to unplug/plug back my hdmi.
      Additionally, while all of the usb ports worked during install and while running it out of the clover I had on the usb stick, only the rear ones appear to work now.
      The audio doesn't work either, though I added the correct patch according to my mobo

      Lastly, my other drives are not recognized in the bios anymore. They run fine from boot override but they don't show up in the boot priority (while multiple entries of mac OS do, and they seem to increase in number at every reboot)

      Thanks in advance for the help
    • By ITzTravelInTime
      KX AUDIO DRIVER MOD
       
      Hi guys i am a small developer, i really like to use my sound blaster cards on my machines and i love also coding, so when i find the source code for the kx audio driver on git hub and then Eugene, the creator of kx audio driver decided to no longer maintain the project, i decided to start working on a mod of this driver. 
       
      With my mod, created starting from the sources of the last version of kx audio driver, and also by using apple developer documentation for pci and audio drivers as reference, i am working to achieve 2 things mainly: get all the cards supported by the driver to work with all the recent versions os macOS and add support for other cards that are not officially supported by the driver that works or could, but needs to be more properly supported.
       
      This driver is made to support cards based on the E-mu 10k1, 10k2 and similars (like what is used by audigy rx and audigy 4 cards).
       
      Supported cards are:
       
       - most of the sound blaster live!, live! 5.1 and live! 5.1 digital series
       - sound blaster 512
       - sound blaster 256
       - other creative and e-mu sound cards based on the 10k1 chip (cards with the ES1370/ES1371/ES1372/ES1373 chips are not supported)
       - sound blaster Audigy series (1 st gen)
       - sound blaster Audigy 2  and audigy 2 zs series
       - E-MU cards based on the 10k2 sound chip
       - Some Audigy 4 cards (SB0610 only) and the audigy 4 pro
       - Sound blaster Audigy RX (sb0155)
       - other creative and e-mu cards based on the (10k2, 10k2,5 and CA10300 based cards)
       
      NOT supported cards:
       
       - Any ISA Sound card
       - ES1370/ES1371/ES1372/ES1373 based sound cards
       - CMI8738/CMI8788 based cards
       - Any CA0106 based card and cards with similar architectures (like sound blaster live! 24 bit, sound blaster audigy SE SB0570, audigy LS and similars, but audigy SA is supported)
       - Any sound blaster x-fi (some of them works on macOS using a modified version of voodoo hda)
       - Any sound blaster recon3D
       - Any sound blaster Z/ZS/ZX and similar series
       - Any sound blaster AE5 series
       
      In the time being the things i have modded or added with this mod are:
       
      - increased the simple buffer frames number with different values for emu10k1 based cards and emu10k2 based cards (including recent audigy 4 and rx) to reduce and all the audio cracking issues and possibly fixing all of them on a lot of cards
       
      - added a more proper support for the pci express sound blaster audigy rx (which basically is an audigy 4 with a pcie bridge chip) 
       
      - added more fancy names for the cards in the settings and other menus (so the name will be, for example, SB live! 5.1 SB0060 instead of kx SB0060 [e880] witch was shown in the original driver)
       
      - added support to sample rate chaning and added lots of sample rates (from 8 khz to 176,4 khz) to accomodate any possible usecase (note that 10k1 sound cards are limited up to 48khz sample rate, and 10k2 based cards for now are limited up to 176,4 khz and because of issues getting 192 khz to work, for now the driver goes up to 176,4 khz for supported cards) 
       
      - added boot args to manage the driver:
       
      Boot args to use with the kx audio driver mod: -kx_disable or -kxdisable or -kxoff This will prevent the driver from doing any initialization work, so the driver is basically disabled, use it to boot your ssytem in case the driver is giving you issues and kernel panics while you are trying to boot/using your system, so you are able to remove this driver or replace it with another version of it or to do some truble shooting. -kx_debug or -kxdebug or -kxspec Will show more debug info about the card, mainly the i/o port address and the kind of bus that it uses -kx_exp_deb or -kx_beta or -kxbeta Will enable experimental and probably not working or unstable features like showing inputs for the card or 192 khz sampling rate, use it only for testing and debug purposes, this may likely cause instability and problems in the everyday usage! Use it at your own risk! -kx_original or -kxoriginal This will basically turn off almost all the mods of this mod, so the driver will come to work as it was before modding it, this can be usefoul as a "safe mode" like feture to have a working driver in case of problems with features of the mod, so using this means no crsking issues improvements, only 48 khz sample rate and only features of the non-modded kx audio driver for mac os x  
      - created a script file to use with the driver for debug and also installer replacement, it can be also used to unload and reload, replacement of the driver without rebooting
       
      What i'd like to implement but i don't know how to do:
       
       - I'd like mainly to add a more proper support to the pci bridge chip of the audigy rx,
       
       - have audio inputs working,
       
       - fix the support when using more than one card, to get all the cards shown in the settings and other menus,
       
       - have the gameport/gameport midi port of older cards to be used in mac os as a midi in/out
       
      If other developers would like to join and help me, you can, and also an hand from other people with testing and feedback will be nice.
       
      link for the kext only (if you have clover put it in [your clover efi folder]/clover/kexts/[your macOS version]/ so it will not be deleted when updating macOS):
               - download from the downloads section:          kX Audio Driver Mod by ITzTravelInTime 1.01                                                                                    - external download:                                      https://dl.dropboxus...Driver.kext.zip   link for the installer pack (the best way to install it, but you have to reinstall it when you upgrade macOS, remeber to fix kext permitions and rebuild the kernelcache if you want to remove the kext from it's install directory without using the unistall feature of the provvided script):              - download:                                                   https://dl.dropboxus...aller pack.zip   Source code from Git Hub:          -  github repo:                                               https://github.com/ITzTravelInTime/kx-audio-driver   NOTE: Some system because of some problems with the HPET may need to use FixHPET in clover and to install the kext in /System/Library/Extensions  






    • By ITzTravelInTime
      This driver is a mod of the popular kx audio driver for mac os x, the project goal is to still maintaining it for the future releases of mac os and to include as much cards as possible and to get all the features of the cards to work.
       
      Currently the only features not supported are audio inputs and integrated midi and synth capabilitues of the cards, and some minor things like creative remote controllers or software controlled volume gears on creative external drives and bays)
       
      It supports most the sound blaster live! series cards, the sound blaster PCI 512, most of the audigy (emu 10k2 based) series, audigy 1, audigy 2, audigy 2 zs, audigy 4 (SB0610), audigy 4 pro, audigy 5 and audigy rx (sb1550) and some e-mu edsp audio cards with all the recent versions of mac os, tested to work with mac os yosemite, el capitan, sierra and high sierra on intel based machines from socket 775 to 1151 (including enthusiast platforms like x58, x79, x99, x299) and also confirmed to work on mac pros.
       
      reference topic:
       
      Kx audio driver mod [sound blaster live!, audigy 1/2/4/RX emu edsp]
    • By clickerpw
      hi guys
      can anybody help me.
      i connect display dell 2418D ( 2560x1440@60) to intel hd530 via hdmi.
      after power off first time boot mac os boot in 2560x1440@40.

       
       
      after this i reboot mac os and boot in 2560x1440@60

       
       
       
       
      also i shoot the video.
      https://youtu.be/Mi6O3-ghRs0
      i tried:
      Lilu.kext , CoreDisplayFixup.kext,Pixel Clock Patch
    • By Nancy10
      Hello!
      I installed OSX Highsierra( clean install ) but I can't make my VGA and HDMI ports to work. I am running it on an Asus X556U laptop with intel HD510. 
      Here is attached All my specs made by DxDiag. And my debug_gen output ( has all debug needed files )
      help!
      DxDiag.txt
      debug_8155.zip
×