Jump to content

Drivers alternativi da 10.11 a 10.13 per D-Link DWA-131 USB Wireless N Nano

23 posts in this topic

Recommended Posts

Ciao a tutti. La chiavetta USB in questione




ha qualche problema per El capitan. A me capitano sporadici riavvii. Per chi volesse, allego dei drivers alternativi che sono nativi per OSX 10.11. Funzionano anche con MacOs 10.12 e 10.13.



EDIT: In allegato la nuova versione con le icone del wifi del Mac.


Grazie a dodvip123 per le icone e Micky1979 per la nuova versione dell'installer.






Share this post

Link to post
Share on other sites

Hello! thanks for the driver, it fixed the "frozen sleep"problem I had with El Capitan! Because of that issue, I was stuck with Yosemite (i definitely need the sleep function). I had El capitan installed on a spare hard drive, and tested your driver there. Problem solved, and I just LOVE to have the wireless utility accesible fron the menu bar, instead of an app!


So, i decided to update my Yosemite install on my main drive to El capitan. The driver works ok, but I have experienced several kernel panics (with the corresponding reboot). Apparently, in what I could read, the problem is with the realtek driver. I am running el capitan 10.11.6, on a Macbook Late 08 Unibody aluminum. My airport cable is not functional, and I definitely dont have the money to change the display (that includes the cable), so I'm using a Trendnet TEW-805UB adapter. Thanks in advance for your answer!

Share this post

Link to post
Share on other sites

thanks it also work with myRealtek RTL8192EU, much better intégration than Wireless Network Utility (even if it work well too)

in fact i was look for a other driver cos i regulary had kernel panic with the driver i was using.

i already have KP, but seems to be less regulary I'm on sierra 1012.6

Have a nice day.

Share this post

Link to post
Share on other sites

guys, i have a D-Link DWA-131 REV.E, and i'm running macOS 10.3.3... no matter what kext i install, it works good, no kernel panics etc but the connection is always slow... it does not happens using usb tethering with a android device and the same network, just with the d-link usb adapter. i tried to change my router settings, but nothing .... any tip? thanks in advance

Share this post

Link to post
Share on other sites

Thank you very much for these drivers. You just have saved my life.


My early 2011 macbook pro has not internet connection. I had installed dwa-131 rev b in Gran Capitan and it worked perfectly.


Then i updated to High Sierra (10.13.3) and it stop working until I installed your drivers. I have wifi connection again.


Thanks again.

Share this post

Link to post
Share on other sites

Hi again, marco.pisellonio80.

Please could you upload the drivers again? I had to reinstall MacOs and I lost the file I downloaded last week.

The forum was down this week and now that it is back, the link doesn't work.

Thanks in advance.


PS.- Got them...thank you again.

Edited by tiotulo
Problem solved

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.