Jump to content
vit9696

AppleALC — dynamic AppleHDA patching

4,753 posts in this topic

Recommended Posts

Advertisement

I added controller patching code to trunk with x99/hd4600 examples. HDMI audio should be addible now.

Any other (even non-audio) kext patching can be done as well, the platform allows it, just edit the plists.

 

Rockey12, pretty much no one here will write anything for you, and me in particular. There is a decent instruction, follow it and make the codec supported if it is not already. Why do people think I am the one going to set their audio up after creating a platform and even writing the docs on how to use it.

 

pmcnano, I use nvidia web drivers here, and the system boots at least. No idea what fails for you, be more descriptive if you want to get a decent reply.

thank you for your quick reply i really appreciate it i well do it as you sad

Share this post


Link to post
Share on other sites

Sorry if I wasn't clear enough.

 

My first boot with the kext loaded was after updating to 10.11.3, sound was working but I didn't have GPU acceleration because system was using OSX Stock drivers (have a 970).

 

Updated nvidia web drivers and it booted fine, GPU acceleration but no more audio devices (except for HDMI monitors)

 

Using ALC1150.

 

Thanks

Share this post


Link to post
Share on other sites

JorgeMax, that much I can hint of course.

Installing Xcode is as simple as pressing a Download button in App Store :)

And to build a project in Xcode one needs to press that big play button to the left of the configuration name or use cmd+b (cmd+r) shortcut or go to Product → Build / Product → Run menu.

The compilation will start producing a kext file in seconds in the Products section on the left pane. You can right-click the kext and pick "Show in Finder" option to get to a resulting file.

 

pmcnano, I think you were using a bugged version. Sorry for that :) I have recently fixed a bug with very simlar symptoms. Try the latest version in the repository, if it does not work work for you, we will need a debug log.

Share this post


Link to post
Share on other sites

Same alc892 & log here. Got it working with latest Andrey1970s compiled kext from applelife. Looks like applealc always failed to patch the target binary (only working with clover patch) when i compile it myself. And now receiving error when compiling with latest commit from repo. Could anyone share your "working" full project source here please

 

Thank,

 

Vit9696 debug this morning.

HDAU also works fine.

 

Vit9696, i did not find kext to add in info.plist to make load AppleALC earlier.

So patch USB limit as you see is in, but does not load.

 

Fred

Share this post


Link to post
Share on other sites

JorgeMax, that much I can hint of course.

Installing Xcode is as simple as pressing a Download button in App Store :)

And to build a project in Xcode one needs to press that big play button to the left of the configuration name or use cmd+b (cmd+r) shortcut or go to Product → Build / Product → Run menu.

The compilation will start producing a kext file in seconds in the Products section on the left pane. You can right-click the kext and pick "Show in Finder" option to get to a resulting file.

 

pmcnano, I think you were using a bugged version. Sorry for that :) I have recently fixed a bug with very simlar symptoms. Try the latest version in the repository, if it does not work work for you, we will need a debug log.

 

Friend. I do not know what happens, but it appears these two errors:

 

post-1145065-0-17620800-1457806087_thumb.png              post-1145065-0-93837000-1457806110_thumb.png

Share this post


Link to post
Share on other sites

Working fine with ALC898 and ALC892 on my two Asus boards. Didn't have to make any changes to the project, just compiled and rebooted. It does write an entry into the system log about being unable to find HDAU, but I don't use HDMI so I'm not bothered about that yet.

 

I tried it first on my laptop. Don't know if it's the ALC269 or El Capitan (the desktops are both on Yosemite) but it's not working there. I'll do some more digging later. Just wanted to report the success with the two desktops.

Share this post


Link to post
Share on other sites

Friend. I do not know what happens, but it appears these two errors

These are not errors but warnings caused by Apple's laziness. https://forums.developer.apple.com/thread/20024

I am surprised they are not fixed after half a year, but we have what we have. Result-wise they are harmless.

 

 

This log runs something ancient, probably the release version. Download ZIP Use this big button on github project if you fail to use git/svn to obtain the recent source code.

 

Riley Freeman, nice to hear it works. As for ALC269 and laptops you are likely to need your own configuration.

 

Currently the added ALC269 configurations are:

ALC269 - revision 0x100100, layout 27, layout 3

ALC269VC - revision 0x100202, layout 28

and we are yet to update the wiki page regarding codec compatibility.

Share this post


Link to post
Share on other sites

This log runs something ancient, probably the release version. Download ZIP Use this big button on github project if you fail to use git/svn to obtain the recent source code.

 

Weird, I tried with your last compiled kext and I compiled one myself. I will try again though.

 

edit:

 

Ok here's the new log, I think files get mixed somehow while testing:

 

http://pastebin.com/YnDuvM02

Share this post


Link to post
Share on other sites
ALC269VC - revision 0x100202, layout 28

 

And now it works :)

 

I'd been using layout 3 for my ALC269VC. Changed it to 28 and now it's working on all 3 hacks in my sig.

Share this post


Link to post
Share on other sites

Wow .. it's cool .. Good Job bro

 

I tried with "release" AppleALC (887) toleda = Ok

Change layout+platform+pinconfig with mirone patched & compile = Ok

 

thanks 

Share this post


Link to post
Share on other sites

I love the idea of your project... this will have a major effect for Ozmosis users, while Clover users still can patch their AppleHDAs with their config.plist...

Share this post


Link to post
Share on other sites

I love the idea of your project... this will have a major effect for Ozmosis users, while Clover users still can patch their AppleHDAs with their config.plist...

 

Clover users can use this as well, there is no difference between Oz and Clover in that aspect.

Share this post


Link to post
Share on other sites

Wow .. it's cool .. Good Job bro

 

I tried with "release" AppleALC (887) toleda = Ok

Change layout+platform+pinconfig with mirone patched & compile = Ok

 

thanks 

 

Friend, how did you get? I've been trying to compile with my settings, but the kext compiled does not charge.

Could you do this for me? Thank you very much in advance.
Files: Jorge.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×