Jump to content
vit9696

AppleALC — dynamic AppleHDA patching

4,765 posts in this topic

Recommended Posts

On 5/3/2019 at 7:30 PM, Andres ZeroCross said:

Bonjour @ vit9696  et @ vandroiy2012  je fais commettre ici  https://github.com/acidanthera/AppleALC/pull/404

Je peux installer une configuration de broche pour ALC294, et installer un correctif contrôleur HDA pour Intel WhiskeyLake Notebook, identifiant de périphérique de HDEF dans le catalogue Whiskey Game est 0x9DC8. Je fais un patch pour le contrôleur. Et je le teste et travaille dans le cahier WhiskeyLake. Plus besoin de FakePCIID.kext et FakePCIID_INTEl HDMI.kext:)

ven though it seems like audio is working, there is no sound coming from speaker/headphones because

Capture d’écran 2019-10-27 à 09.46.43.png

Capture d’écran 2019-10-27 à 09.45.42.png

Edited by khalidthami

Share this post


Link to post
Share on other sites
Advertisement

Hey everyone, I was wondering if anyone found a solution for Antipop for the Realtek ALC256 when the codec goes to low power mode? I've tried researching but couldn't find anything. I just keep getting the popping sound after a few seconds of not playing anything or the pop will happen when resuming playing audio. 

 

I currently use CodecCommander with a SSDT-ALC256.aml on Catalina, but this issue has happened on every macOS release since using my Dell laptop.

 

I know when I had an IDT 92HD91BXX codec on my previous laptop, there was a patch incorporated to prevent the codec from going to sleep which hope can be used with this codec or find a way to not have the sound come out when the codec is powered down.

 

Please let me know if you need anything else and hope someone can help?

Share this post


Link to post
Share on other sites

Hey everyone. I installed AppleALC on my hakintosh Mojave and sound is working. But sometimes, when I reboot or cold boot the system, sound stop working (10% of boots). Maybe sometimes AppleHDA is loading before AppleALC, which does not allow applying the audio patch. How can I prevent this?? Thanks!

Share this post


Link to post
Share on other sites

Hi, my PC is quite an old one: Intel DH61AG running with an i3-3225 (HD4000). It's audio chip is AL892. I've installed clean Mojave (with Lilu, WhateverGreen and AppleALC kext) and everything seems fine except the audio. Nothing is there. I've attached the config.plist and info.plist. Could anyone help me? Thanks.

config.plist

Info.plist

Edited by A__C

Share this post


Link to post
Share on other sites

Hi guys, can someone please add this to the AppleALC supported list?

Motherboard:
Gigabyte Aorus X399 Xtreme (AMD)
Coded: ALC1220-VB

I've tried a few configurations using profile id: 16 and 28, they work but only using the "Headphones" output, in which is the front panel output and nothing else.

Since I would like also to use the Mic and Internal Speakers (Rear output) I guess the only way is by patching.

I've tried just in case all other profile id's and none with exception of 16 and 28 works.

Thanks!
 

Gigabyte Aorus X399 Xtreme - ALC1220-VB - codec_dump.txt

Share this post


Link to post
Share on other sites
8 hours ago, devillived666 said:

hey guys, 

Ive got an Asus vivobook x405UA(generic model) with cx 8150. Up until recently, injecting layout 3 has allowed everything audio related to work. Latest catalina Ive got no mic. What am I doing wrong? 

 

Send me Denniss-MacBook-Pro.zip

Not sure it is relevant or not. I have a cx 8200, and with 10.15.1, I have to use Applealc 1.4.2 version, I have problems with 1.4.3. .

Hello guys,

 

I have a thinkpad x1c 5th generation, with a cx8200 codec.

But I have problem with AppleALC 1.4.3, I have no device in pref/sound/output and input in 10.15.1.

So I have to switch to version 1.4.2. 

 

It is a problem of 1.4.3 or 10.15.1 ?

Thanks

Share this post


Link to post
Share on other sites

Hello,

 

Having trouble with onboard audio on Mojave 10.14.6 with ALC892 (physical chip) with 5.1 Audio (5 jacks + Optical)

 

No device appears in Hackintool

 

1898411529_ScreenShot2019-11-13at8_43_35PM.png.2f766e839995777bd485845d275e8e3f.png

 

X99 platform, ALZA -> HDEF rename patch (with or without HDEF still appears)

 

AppleALC debug

Timestamp                       (process)[PID]
2019-11-10 16:12:57.241915-0800  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 16:12:57.253201-0800  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
1999-12-31 19:11:42.703156-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
1999-12-31 19:11:42.712571-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:36:08.468730-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:36:08.477322-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:44:59.443680-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:44:59.452790-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:46:44.029639-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-10 22:46:44.038725-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ alc-layout-id was not provided by controller at HDEF
2019-11-13 20:23:18.397714-0500  localhost kernel[0]: (kernel) Lilu:     api @ (DBG) got load request from AppleALC (143)
2019-11-13 20:23:18.397718-0500  localhost kernel[0]: (kernel) AppleALC:    init @ (DBG) AppleALC bootstrap DBG-143-2019-10-30
2019-11-13 20:23:23.311999-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData vendor-id has 8086 value
2019-11-13 20:23:23.312004-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData device-id has 8D20 value
2019-11-13 20:23:23.312008-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData revision-id has 5 value
2019-11-13 20:23:23.312014-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData alc-layout-id was not found
2019-11-13 20:23:23.312018-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to obtain device info for analog controller (1)
2019-11-13 20:23:23.312023-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) found 1 audio controllers
2019-11-13 20:23:23.312028-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) validating 0 controller 1002:AAF8:0
2019-11-13 20:23:23.312032-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 0 mod 1002:AAC8
2019-11-13 20:23:23.312036-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 1 mod 1002:AAE8
2019-11-13 20:23:23.312040-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 2 mod 1002:AB08
2019-11-13 20:23:23.312043-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 3 mod 1022:1457
2019-11-13 20:23:23.312047-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 4 mod 1022:1487
2019-11-13 20:23:23.312051-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 5 mod 1022:15E3
2019-11-13 20:23:23.312055-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 6 mod 8086:C0C
2019-11-13 20:23:23.312058-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 7 mod 8086:F04
2019-11-13 20:23:23.312062-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 8 mod 8086:8CA0
2019-11-13 20:23:23.312066-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 9 mod 8086:8D20
2019-11-13 20:23:23.312070-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 10 mod 8086:8D21
2019-11-13 20:23:23.312074-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 11 mod 8086:9DC8
2019-11-13 20:23:23.312078-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 12 mod 8086:9D71
2019-11-13 20:23:23.312082-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 13 mod 8086:A171
2019-11-13 20:23:23.312085-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 14 mod 8086:A2F0
2019-11-13 20:23:23.312089-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 15 mod 8086:A348
2019-11-13 20:23:23.312094-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 16 mod 10DE:E0F
2019-11-13 20:23:23.312098-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 17 mod 10DE:FB0
2019-11-13 20:23:23.312102-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 18 mod 10DE:FB8
2019-11-13 20:23:23.312109-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 19 mod 10DE:FB9
2019-11-13 20:23:23.312113-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 20 mod 10DE:FBA
2019-11-13 20:23:23.312117-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 21 mod 10DE:FBB
2019-11-13 20:23:23.312121-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 22 mod 10DE:FBC
2019-11-13 20:23:23.312124-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 23 mod 10DE:10EF
2019-11-13 20:23:23.312128-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 24 mod 10DE:10F0
2019-11-13 20:23:23.312132-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 25 mod 10DE:10F1
2019-11-13 20:23:23.312136-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) missing ControllerModInfo for 0 controller
2019-11-13 20:23:23.312323-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) AppleGFXHDA probe for HDAU
2019-11-13 20:32:11.396611-0500  localhost kernel[0]: (kernel) Lilu:     api @ (DBG) got load request from AppleALC (143)
2019-11-13 20:32:11.396616-0500  localhost kernel[0]: (kernel) AppleALC:    init @ (DBG) AppleALC bootstrap DBG-143-2019-10-30
2019-11-13 20:32:16.338723-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData vendor-id has 8086 value
2019-11-13 20:32:16.338727-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData device-id has 8D20 value
2019-11-13 20:32:16.338732-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData revision-id has 5 value
2019-11-13 20:32:16.338737-0500  localhost kernel[0]: (kernel) AppleALC:   iokit @ (DBG) getOSData alc-layout-id has 2 value
2019-11-13 20:32:16.338744-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) found 2 audio controllers
2019-11-13 20:32:16.338748-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) validating 0 controller 1002:AAF8:0
2019-11-13 20:32:16.338753-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 0 mod 1002:AAC8
2019-11-13 20:32:16.338756-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 1 mod 1002:AAE8
2019-11-13 20:32:16.338760-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 2 mod 1002:AB08
2019-11-13 20:32:16.338764-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 3 mod 1022:1457
2019-11-13 20:32:16.338767-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 4 mod 1022:1487
2019-11-13 20:32:16.338771-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 5 mod 1022:15E3
2019-11-13 20:32:16.338775-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 6 mod 8086:C0C
2019-11-13 20:32:16.338779-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 7 mod 8086:F04
2019-11-13 20:32:16.338783-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 8 mod 8086:8CA0
2019-11-13 20:32:16.338787-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 9 mod 8086:8D20
2019-11-13 20:32:16.338791-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 10 mod 8086:8D21
2019-11-13 20:32:16.338795-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 11 mod 8086:9DC8
2019-11-13 20:32:16.338798-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 12 mod 8086:9D71
2019-11-13 20:32:16.338802-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 13 mod 8086:A171
2019-11-13 20:32:16.338806-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 14 mod 8086:A2F0
2019-11-13 20:32:16.338809-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 15 mod 8086:A348
2019-11-13 20:32:16.338813-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 16 mod 10DE:E0F
2019-11-13 20:32:16.338817-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 17 mod 10DE:FB0
2019-11-13 20:32:16.338820-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 18 mod 10DE:FB8
2019-11-13 20:32:16.338824-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 19 mod 10DE:FB9
2019-11-13 20:32:16.338832-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 20 mod 10DE:FBA
2019-11-13 20:32:16.338836-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 21 mod 10DE:FBB
2019-11-13 20:32:16.338839-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 22 mod 10DE:FBC
2019-11-13 20:32:16.338843-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 23 mod 10DE:10EF
2019-11-13 20:32:16.338847-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 24 mod 10DE:10F0
2019-11-13 20:32:16.338853-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 25 mod 10DE:10F1
2019-11-13 20:32:16.338857-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) validating 1 controller 8086:8D20:5
2019-11-13 20:32:16.338861-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 0 mod 1002:AAC8
2019-11-13 20:32:16.338865-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 1 mod 1002:AAE8
2019-11-13 20:32:16.338869-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 2 mod 1002:AB08
2019-11-13 20:32:16.338872-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 3 mod 1022:1457
2019-11-13 20:32:16.338876-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 4 mod 1022:1487
2019-11-13 20:32:16.338880-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 5 mod 1022:15E3
2019-11-13 20:32:16.338884-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 6 mod 8086:C0C
2019-11-13 20:32:16.338887-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 7 mod 8086:F04
2019-11-13 20:32:16.338891-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 8 mod 8086:8CA0
2019-11-13 20:32:16.338895-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) comparing to 9 mod 8086:8D20
2019-11-13 20:32:16.338899-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) found mod for 1 controller
2019-11-13 20:32:16.338903-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) missing ControllerModInfo for 0 controller
2019-11-13 20:32:16.338908-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) handling 1 controller 8086:8D20 with 4 patches
2019-11-13 20:32:16.338913-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) checking patch 0 for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.338919-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) applying patch 0  for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.339290-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) checking patch 1 for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.339295-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) applying patch 1  for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.339789-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) checking patch 2 for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.339794-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) applying patch 2  for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.340163-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) checking patch 3 for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.340170-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) applying patch 3  for 5 kext (com.apple.driver.AppleHDAController)
2019-11-13 20:32:16.340869-0500  localhost kernel[0]: (kernel) AppleALC:     alc @ (DBG) AppleGFXHDA probe for HDAU

 

Seeing

alc @ alc-layout-id was not provided by controller at HDEF

even if alcid=2 or Inject=2  IoReg shows alc-layout-id=2 but layout-id is always <07 00 00 00>

 

edit: Read this is normal.. not sure why audio device is not showing up in Hackintool when HDEF shows up in IOReg.. will try the rest of the layout-id

 

DCPIManager

 

1203574677_ScreenShot2019-11-14at4_29_16AM.thumb.png.2c69292a3abe03e5a2403fe84aabe9fc.png

 

Audio via HDMI and DisplayPort to monitor works OK (no volume control except through monitor)

 

edit: Fixed! Enable fixes for: HPET, RTC, TMR

 

1437071229_ScreenShot2019-11-14at2_47_44PM.thumb.png.4387725f48bab54b1d78b1aafbca9aa8.png

 

keywords:

Codec ID

Revision

Codec Name

sound

input

output

blank

missing

empty

Edited by e97
solved

Share this post


Link to post
Share on other sites

Hey guys, I've got cx8150 as codec on an Asus vivobook . I'm using a custom compiled alc(not mine) and I'd 3. I've got all audio but no mic even though it's recognised . What can I do to fix this?

Note that alc most recent with Id 21 makes it so that my sound device is recognized but I get no sound out.

Sent from my Pixel 3 using Tapatalk
 

Edit: 

My codec dump is here
https://docs.google.com/document/d/1Cjnsxp87ogelb6RGmT5748pawOs-QWVnuIsioVIa2Dg/edit

Edited by devillived666

Share this post


Link to post
Share on other sites
On 8/28/2019 at 4:24 PM, jaymonkey said:

Hi Guys,

 

I recently read @InsanelyDeepak's guide on patching the combo jack on laptops ...

 

Its a great guide and one of the best I've seen so far on the topic.

 

Towards the end of the guide he states the following:

Quote

latest version of AppleALC has feature to send command to codecs like CodecCommander , you can modify AppleALC info.plist to stop using CodecCommander

 

I've looked at the AppleALC documentation and can find no mention of this feature and can't find any examples of it on-line.

How exactly please does that line in info.plist look like?

Share this post


Link to post
Share on other sites
On 10/14/2019 at 8:37 AM, Andres ZeroCross said:


You need to install CodecCommander.kext to Library/Extensions (not System/Library/Extensions), then rebuild kextcache. Reboot and your audio should work. Just use layout id 22


Install CodecCommander.kext to Library/Extensions (not System/Library/Extensions) and rebuild kextcache. use LayoutID = 22. Reboot and your audio should work

 

Thanks, audio now works on the speakers, but no sound from the headphone jack. Is this expected?

On 10/14/2019 at 8:37 AM, Andres ZeroCross said:


You need to install CodecCommander.kext to Library/Extensions (not System/Library/Extensions), then rebuild kextcache. Reboot and your audio should work. Just use layout id 22


Install CodecCommander.kext to Library/Extensions (not System/Library/Extensions) and rebuild kextcache. use LayoutID = 22. Reboot and your audio should work

 

Thanks, audio now works on the speakers, but no sound from the headphone jack. Is this expected?

Share this post


Link to post
Share on other sites
5 minutes ago, josleueven said:

 

Thanks, audio now works on the speakers, but no sound from the headphone jack. Is this expected?

 

Thanks, audio now works on the speakers, but no sound from the headphone jack. Is this expected?


Upload your codec_dump.txt from linux

Share this post


Link to post
Share on other sites

@Vandroiy2012

 

Can you include this file in the next release?

 

Codec for ALC269 Asus Vivobook S200CE LayoutID 12 (New)
 
Codec for ALC269 Asus Vivobook S300CA LayoutID 19 (Updated)

 

Tested at macOS Catalina 10.15

 

Thanks

 

Resources.zip

Edited by chunnann

Share this post


Link to post
Share on other sites
On 27/10/2019 at 07:19, Andres ZeroCross said:


Vous devez définir Custom Command sur CodecCommander.kext pour ALC294 pour ce modèle de bloc-notes. 

Would you please help?

Share this post


Link to post
Share on other sites
On ‎11‎/‎3‎/‎2019 at 12:07 PM, A__C said:

Hi, my PC is quite an old one: Intel DH61AG running with an i3-3225 (HD4000). It's audio chip is AL892. I've installed clean Mojave (with Lilu, WhateverGreen and AppleALC kext) and everything seems fine except the audio. Nothing is there. I've attached the config.plist and info.plist. Could anyone help me? Thanks.

Just an update for anyone who found this thread. I think it's mainly a hardware problem that no one can fix it easily. So I switched to Intel DQ77KB + i3-3225; updated to the latest BIOS; generated the SSDT; setup the HDMI as the secondary display via BIOS (otherwise the famous 8 apples will be displayed). Bingo! All work! Now it's running Mojave smoothly.

Thanks the community for all their hard works!

Share this post


Link to post
Share on other sites

Is there a tool that can generate the layout.xml and platform.xml files automagically? I ask because I have a codec that I generate the pin configs using https://github.com/headkaze/PinConfigurator tool but I cannot get the layout to load. I get an assertion in the platform.xml. The graph is really simple, its output 2 > node 3 (no inputs at all) but as I don't have the source to AppleHDA.kext I cannot tell what I am doing wrong.

 

Share this post


Link to post
Share on other sites
2 hours ago, DSM2 said:

@vandroiy2012 @vit9696

 

Could you guys add this one? 

 

It's ALC285 but none of the known IDs work. 

 

It's an 10Th Gen HP Envy X360 

codec_dump.zip


Use layout 11, 21 or 31. If it doesn't work, upload IOREG Output for each used layout here.

I need to check your configuration, before try making new resources

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

LOL Sorry but what you expect to see?

Its not worth all your "tests"

It doesn't work and its not an fault from my side.

The nodes are completely different on the ones which are included already etc...

 

 

Edited by DSM2

Share this post


Link to post
Share on other sites
7 hours ago, DSM2 said:

LOL Sorry but what you expect to see?

Its not worth all your "tests"

It doesn't work and its not an fault from my side.

The nodes are completely different on the ones which are included already etc...

 

 


Why did you laugh for??? 

You are asking for help, i need to make sure first,,
I must avoid duplicate resource with same Node Id. I don't know you if you're smart or not. Before made resource i need to check your IOREG Output first.

But if you know how to make resource by yourself, then make it. Good luck

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

I just wanted to make clear that I am not dumb and the sound problem is not related to an issue from my side. 

 

If you would check the other IDs you would see the difference in them so I don't unterstand what you expect to see in ioreg. 

Edited by DSM2

Share this post


Link to post
Share on other sites

Can anyone see what I am doing wrong? I am trying to get native support for this codec, 0x1af40012 The codec changes based on the configuration but this is the simplest one that I could find. I attach the image of the output path and the codec.txt

codec.txt.svg

 

I have tried to patch AppleALC to load this codec but I don't think that my pathes and/or layouts are correct. I generated the pin config using headkaes tool. The logs are in the log.txt file.

 

The changes that I have tried are attached. I don't know how if the patches for the AppleHDA kext are correct as I could not find any explanation for them after some searching.

 

I also modified the vendors with:


+++ Resources/Vendors.plist
@@ -20,6 +20,8 @@
        <integer>32902</integer>
        <key>NVIDIA</key>
        <integer>4318</integer>
+       <key>QEMU</key>
+       <integer>6900</integer>
        <key>Realtek</key>
        <integer>4332</integer>
        <key>SigmaTel</key>

and in Resources/PinConfigs.kext/Contents/Info.plist::


								<dict>
                                       <key>AFGLowPowerState</key>
                                       <data>AwAAAA==</data>
                                       <key>CodecID</key>
                                       <integer>452198418</integer>
                                       <key>Comment</key>
                                       <string>QEMU HDA Output</string>
                                       <key>ConfigData</key>
                                       <data>
                                        ADccEAA3HUAANx4AADcfAA==
                                       </data>
                                       <key>FuncGroup</key>
                                       <integer>1</integer>
                                       <key>LayoutID</key>
                                       <integer>18</integer>
                               </dict>

 

Is anyone able to offer some pointers on how to get this to work?

codec.txt

log.txt

Info.plist

layout18.xml

Platforms18.xml

Share this post


Link to post
Share on other sites

Hi, I am using Apple ALC on my XPS 9570 (Coffee Lake, i7-8750H) with ALC298 (layout-id 72). I am able to get audio working over speakers and the jack, but I am not able to get the audio to work over HDMI or DisplayPort.

 

I have AppleALC and WhateverGreen, and use ComboJack with the VerbStub kext--are there any resources/patches I should look at to get this working? I'm happy to provide any log files.

Share this post


Link to post
Share on other sites
On 12/1/2019 at 10:16 AM, Andres ZeroCross said:


Use layout 11, 21 or 31. If it doesn't work, upload IOREG Output for each used layout here.

I need to check your configuration, before try making new resources

HP Envy 13 i7-10510u here, same problem. I attached the three different IOREG files. Would appreciate some help! May be related to the Envy having 4 speakers?

Archiv.zip

Edited by Killuminati91

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

×