Jump to content
Duran Keeley

HELP TOPIC - [AMD] OS X El Capitan (10.11)

719 posts in this topic

Recommended Posts

I can't seem to get ssse3 support with any of these kernels.  Is it not available for my processor? I have an AMD Phenom xII 965T and I'm using 10112R1 kernel 

Share this post


Link to post
Share on other sites
Advertisement

I can't seem to get ssse3 support with any of these kernels.  Is it not available for my processor? I have an AMD Phenom xII 965T and I'm using 10112R1 kernel

1. Moved your post to the help topic.

2. No your processor does not have ssse3 out of the box, the kernel will emulate where it can but programs with it's own built in check for ssse3 will not work.

 

FYI: You could have looked online about your CPU capabilities instead of me having to google your CPU.

Info about CPU: http://cpuboss.com/cpu/AMD-Phenom-II-X4-965

Share this post


Link to post
Share on other sites

Memory allocation error when try to boot from USB installer

 

Solved memory allocation error....but Always the same {censored} {censored}....usb {censored} errors.....stooooooooooooooooop, this is the last chance, i don't want to go crazy with this :(:(

Share this post


Link to post
Share on other sites

1. Moved your post to the help topic.

2. No your processor does not have ssse3 out of the box, the kernel will emulate where it can but programs with it's own built in check for ssse3 will not work.

 

FYI: You could have looked online about your CPU capabilities instead of me having to google your CPU.

Info about CPU: http://cpuboss.com/cpu/AMD-Phenom-II-X4-965

Sorry for posting in the wrong forum.  

 

I know my processor doesn't have out-of-the-box ssse3 support, but I was under the impression that the flag "-nossse3bit" would give my processor the needed emulation.  Oh well. 

 

Thanks for your reply!

Share this post


Link to post
Share on other sites

Memory allocation error when try to boot from USB installer

 

Solved memory allocation error....but Always the same {censored} {censored}....usb {censored} errors.....stooooooooooooooooop, this is the last chance, i don't want to go crazy with this :(:(

kaya, a small problem caused by bootloader... will not be crazy, we will tomorrow start your system

Share this post


Link to post
Share on other sites

@spakk

 

your USB fix is from the 15A283 beta, correct?

 

if that's the case, can you upload a copy of AppleUSBAudio if you have it?

Share this post


Link to post
Share on other sites

@spakk

 

your USB fix is from the 15A283 beta, correct?

 

if that's the case, can you upload a copy of AppleUSBAudio if you have it?

here the complete folder (on Build14F27), on that the USB-Fix is based, so can each user, if problems with building of prelinkedkernel, help themselves to resolve the issues.
Edited by spakk

Share this post


Link to post
Share on other sites

Solved USB stop/restart error on boot, now i've another problem....i tried to renew kernel cache with temrinal command, but no luck i think...got some errors

 

post my screenshots

post-839034-0-67252800-1457719618_thumb.jpg

post-839034-0-94421500-1457719776_thumb.jpg

Share this post


Link to post
Share on other sites

Guys I cant get my mouse work :( Tried usb fix and tried ahciportinjector.kext, nothing worked for me. 

Actually all my usb ports are working with my keyboard but when I try with different mouses and ports nothing happens. Cant get my mouse work.

Also I realised that when I plug my mouse I got an error which says ionetworkingfamily.kext installed wrong or something.

Any suggestions ?

Share this post


Link to post
Share on other sites

I'm a hardcore Unix user (used to build my own Linux distro from scratch circa 2k) with several Apple computers (Mac Pros, iMacs, etc.), but I want to give a shot at installing OS X onto a couple AMD laptops I have here. What's a good starting thread that will link me to either some handy prebuilt install images or standard steps for building one that's working for others?

 

I'd like to be able to start also testing kernel updates on the dev thread and boot to those as they pop out.

Share this post


Link to post
Share on other sites

Solved USB stop/restart error on boot

Hey Kaya, did you ever solve our little problem here?

 

If so, how?  Thanks!

Share this post


Link to post
Share on other sites

No, unfortunately not solved, i 'm not able to reach the installation screen neither with Enoch and Spakk help....very nervous :D

 

Really would like to solve with Clover, 'cause with Enoch never reached the installer

 

 

Now i'm stuck here, can anyone help me?

https://www.dropbox.com/s/5f6dls54pkl6rob/IMG-20160323-WA0000.jpg?dl=0

Share this post


Link to post
Share on other sites

No, unfortunately not solved, i 'm not able to reach the installation screen neither with Enoch and Spakk help....very nervous :D

 

Really would like to solve with Clover, 'cause with Enoch never reached the installer

 

 

Now i'm stuck here, can anyone help me?

https://www.dropbox.com/s/5f6dls54pkl6rob/IMG-20160323-WA0000.jpg?dl=0

kaya, the problem with ... dsmos .... I wrote to you that you should to find and read this post of mine.

link:

http://www.insanelymac.com/forum/topic/311245-help-topic-amd-os-x-el-capitan-1011/page-12?p=2219933&do=findComment&comment=2219933

Share this post


Link to post
Share on other sites

Same USB errors, no waiting for Dsmos anymore....but stack at the same point with the same errors, no need (i think) to post a screenshot, 'cause errors are the same

Share this post


Link to post
Share on other sites

Which is the latest kernel to use with FX8120 + GA 970A DS3 + HD7850?

Also should I use clover or Enoch ?

Coming back to AMD Hackintosh after a long time. I have a stable i7 Hackintosh running 10.11.4. 

 

Am gonna follow 

till then.

 

Thanks

Share this post


Link to post
Share on other sites

:)

 

Your system Intel works ELC 10.11.4 ?

Yep, on my first machine in signature i've a 100% working intel based PC, recently updated to 10.11.4, and clover as bootloader in legacy...are u using clover with AMD?

Share this post


Link to post
Share on other sites

So apparently I started the help topic? Ok? And nobody even tried to help me.

 

Edit: Nvm Spakk did but that didnt fix my problem. which is this

AlTLoCz.jpg


 

install the DSDT Editor or MacIASL, then export a raw DSDT and upload it here: http://www.insanelymac.com/forum/topic/310293-help-topic-el-capitan-usb-fix-and-dsdt-patch/
 
However, El Capitan should work without USB fix in the DSDT, see here: http://www.insanelymac.com/forum/files/file/521-usb-fix-for-el-capitan/?st=10#commentsStart

 

Well i did the fix and it stopped looping AppleUSBEHCI but now hangs 

Share this post


Link to post
Share on other sites

So apparently I started the help topic? Ok? And nobody even tried to help me.

 

Edit: Nvm Spakk did but that didnt fix my problem. which is this

 

Well i did the fix and it stopped looping AppleUSBEHCI but now hangs 

 

uploaded your complete Extra folder, it seems that the folder is not complete.

Share this post


Link to post
Share on other sites

uploaded your complete Extra folder, it seems that the folder is not complete.

How do i attach files?

Well i cant really get the extra folder right now but i use Shaneees extra folder with the latest version of genericusbxhci.kext

heres pictures of the extra folder if it helpsZSas7R9.jpg7UE8EMN.jpgI dont know how to do show spoilers

Disregard the activate windows message just in case you think im a pirate. I own windows on this computer but its an oem and i upgraded my motherboard so the activation code no longer works

Share this post


Link to post
Share on other sites
perhaps, because of lack of access to upload files on insaneleymac, here use this external server: http://workupload.com

further, write your full hardware specifications in your signature, as we can and will otherwise not help.

Edited by spakk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×