Jump to content
Sign in to follow this  
Followers 0
shoopy

Clover not loading kext from S/L/E and it's loading extra kexts from nowhere

6 posts in this topic

Recommended Posts

The only kext being injected in Clover is FakeSMC.kext yet somehow VoodooPS2Controller.kext is running when I boot with clover and kexts from S/L/E are being disabled. For instance, my battery and hardware sensors kexts are disabled when I load from Clover but work when booting from Chameleon. I have checked every folder, there are no Voodoo kexts, is there a driver or something injecting Voodoo kexts in Clover, the only changes I've made is in the config file?

 

When I boot with Chameleon all of my kexts from S/L/E are working fine and VoodooPS2Controller doesn't load (as it should).

 

Can anyone help me figure out what's wrong? I have an Asus UX303LN and these are my specs along with my config file.

 

  • i5 4210u
  • 1TB HDD
  • Intel HD 4400
  • nVidia 840m [disabled in Clover]
  • FocalTech Touchpad

config.zip

Share this post


Link to post
Share on other sites
Advertisement

 

The only kext being injected in Clover is FakeSMC.kext yet somehow VoodooPS2Controller.kext is running when I boot with clover and kexts from S/L/E are being disabled. For instance, my battery and hardware sensors kexts are disabled when I load from Clover but work when booting from Chameleon. I have checked every folder, there are no Voodoo kexts, is there a driver or something injecting Voodoo kexts in Clover, the only changes I've made is in the config file?

 

When I boot with Chameleon all of my kexts from S/L/E are working fine and VoodooPS2Controller doesn't load (as it should).

 

Can anyone help me figure out what's wrong? I have an Asus UX303LN and these are my specs along with my config file.

 

  • i5 4210u
  • 1TB HDD
  • Intel HD 4400
  • nVidia 840m [disabled in Clover]
  • FocalTech Touchpad

 

If you are using the same OS X partition with two bootloaders, it means you are using the same kext cache. Disable it or try to recreate it if you switch between them.

Share this post


Link to post
Share on other sites

If you are using the same OS X partition with two bootloaders, it means you are using the same kext cache. Disable it or try to recreate it if you switch between them.

I've disabled kextcache in Clover, Ive deleted the cache files in OSX and nothing has changed.

Share this post


Link to post
Share on other sites

I've disabled kextcache in Clover, Ive deleted the cache files in OSX and nothing has changed.

Do following:

 

Type in the terminal:

sudo touch /System/Library/Extensions

 

reboot

And reboot again.

 

Check if the kext you are looking for is loaded :

kextstat | grep Kextname

Share this post


Link to post
Share on other sites

Do following:

 

Type in the terminal:

sudo touch /System/Library/Extensions

 

reboot

And reboot again.

 

Check if the kext you are looking for is loaded :

kextstat | grep Kextname

I've done that and I just did it again.

 

Nothing changed, the voodoo kexts are still being loaded from Clover somehow.

 

I tried reinstalling the OS yesterday and got the same results, Clover just loads different Kexts from Chameleon for some reason and ignores Kexts thats I've installed to the Extensions folder.

Share this post


Link to post
Share on other sites

Do following:

 

Type in the terminal:

sudo touch /System/Library/Extensions

 

reboot

And reboot again.

 

Check if the kext you are looking for is loaded :

kextstat | grep Kextname

Also I can't find the location where clover is loading the kext from.

 

v9Gq68d.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
    • By fusion71au
      Clover r4799 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4799 for VMware.zip". Mount Clover-v2.4k-4799-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By sonicthehedgehog2
      Apologies for the lack of information (and for posting in the wrong place), but I can't even boot into Clover so screenshots of verbose mode aren't even possible. I've been running the beta of 10.14.2 for sometime (-using this excellent guide 
      ) without any issues. When I tried to apply the new update for 10.14.2, my pc downloaded the update, shutdown but applied some updates then rebooted into a blank screen. I've tried several things since then. Specifically:
       
      * Booting from the installation USB created using the above guide - same blank screen
      * Booting from an external HDD - successful launch of OS. From here I have tried different versions of Clover including the one on my HDD r4644 (all have been unsuccessful). I have also tried different memory management options osxaptiofix (1, 2 & 3)
       
      The only other information I can provide is in the screenshots below (including a brief of my drive configuration)
       
      Please let me know if and how I can get more information to help resolve the issue, or if I have to rebuild from scratch.
       
      Many thanks in advance
       
       


    • By Drovosek
      As practice shows with the installation of macOS 10.14 Mojave, official cakes from previous, previous versions of the OS sometimes help. So, I pulled out folders /System/Library/Extensions /Library/Extensions from different versions of MacOSX and uploaded on Yandex.Disk and Mediafire. I hope someone will help.   ► 10.4.11
      https://yadi.sk/d/amCPgnkJ3ZMsA7
      http://www.mediafire.com/file/2eap86ny46gjavj/
      ► 10.5.8
      https://yadi.sk/d/XoY70G8K3ZMsBZ
      http://www.mediafire.com/file/a1z7wgizukcrum4/
      ► 10.6.7
      https://yadi.sk/d/8nY0c0ry3ZMsC7
      http://www.mediafire.com/file/rn5n5wt5mw6fzcm/
      ► 10.7.5
      https://yadi.sk/d/8ew7KMbL3ZMsCt
      http://www.mediafire.com/file/9akne1f446j75d5/
      ► 10.8.5
      https://yadi.sk/d/p49F9lZw3ZMsDd
      http://www.mediafire.com/file/xksxbr4gg5ara86/
      ► 10.9.5
      https://yadi.sk/d/LtwMSo3A3ZMsEG
      http://www.mediafire.com/file/6cl3m1dq7068axh/
      ► 10.10.5
      https://yadi.sk/d/ID8QtILY3ZMsEe
      http://www.mediafire.com/file/aefgwlvx696ixmd/
      ► 10.11.6
      https://yadi.sk/d/_KeYANJP3ZMsFN
      http://www.mediafire.com/file/58snknt7x78iubu/
      ► 10.12.6
      https://yadi.sk/d/Nl2Y257v3ZMsMr
      http://www.mediafire.com/file/35924ldz1bb64iu/
      ► 10.13.6
      https://yadi.sk/d/yvoYgqt73ZMsNo
      http://www.mediafire.com/file/ofpa3skypc9e292/
      ► 10.14.1
      https://yadi.sk/d/O3Up1EUAqkMrpQ
      https://www.mediafire.com/file/q6kp3ha5u7rgakx/
    • By Teress
      To build a Hackintosh never was easier. If you want cheap Hackintosh and have it quickly and 100% working and without any knowledge how to tweak things, this video is right for you.
       
×