Jump to content
simras

kext for Atheros QCa61x4 wifi

10 posts in this topic

Recommended Posts

Hello on my motherboard msi z97a gaming 9 ack, i find with aide64 that my wifi module use the id vendor 0x168c and id product 0x003e ans seems to match with the Atheros QCA61x4, so someone have a link, kexts, tutorials for making the wifi work ?

thank you.

Share this post


Link to post
Share on other sites
Advertisement

me to. I have BCM43ae in Yoga 500 but after servicing it is replaced by QCA61x4

Bluetooth is detected but turn off button is grayed out. Also not visible and not discover

Share this post


Link to post
Share on other sites

Can anyone confirm that the above listed drivers work, for Sierra specifically?

 

I'm also using a Qualcomm Atheros QCA61x4A Wireless Network Adapter that comes with my Asus Hero Alpha motherboard. The bluetooth works, but the wireless adapter is not recognized.

Share this post


Link to post
Share on other sites

Can anyone confirm that the above listed drivers work, for Sierra specifically?

 

I'm also using a Qualcomm Atheros QCA61x4A Wireless Network Adapter that comes with my Asus Hero Alpha motherboard. The bluetooth works, but the wireless adapter is not recognized.

bluetooth? how

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
    • By Bushi93
      Finally Manage to make on of the most powerful and compact Hackintosh available with > the i9-9940X 14 cores + the AsRock X299e motherboard and Vega RX 64 8GB.
      Used for Editing, Motion Design and VFX on Mojave 10.14.3
      Exports time >Four time faster compared to my last i7 6 cores hackintosh.

      Need to add a lot of parameters to get the config.plst to work but once it's right it Works very smoothly!
      Turbo Boost up to 4.2 Ghz all core

      Geekbench scores
      Multi core : 54000 (above the iMacPro 18 cores)
      Single core : 5200
      GPU : 186 800

      Ethernet & Audio work without kext
       
      GPU : The Gygabite VEGA RX 64 required a lowfanspeed.kext otherwise it will always have the fans running in full speed mode (and it can get really noisy).

      Bluetooth & wifi (you can get a blue tooth dongle - the Azus works but you may experience some issue or lag sometime so the best solution is to replace the Bluetooth/Wifi card with the Bcm94360cs2 AC + its adaptor:
      https://www.amazon.fr/gp/product/B07HFQKC2Z/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1
      https://www.amazon.fr/gp/product/B073XHY68N/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1
      With this card you won't need any kext to make it work : you will get native bluetooth and wifi support and even be able to control your bios and clover with your bluetooth magic mouse / keyboard !
       
      USB3 PORTS : need to add some kext
      1 of the 2 USB 3.1 WORK in full speed > USB C  in 3.1 and for some mysterious reson the other USB type A in 3.1 work as USB 2 only
      The other 4 USB3 work fine and the 2 USB3 of my front IO (NCASE M1) work fine too 

      XRP RAM OVERCLOCK : YES
      CPU Overcloking to 4.5GHz may work but did experience some freeze/crash and didn't notice any increase in render time when activated.

      Here is a quick overview of my setup
       
       
       
       
    • By valueimagery
      Hello,

      I've updated via system preference fro 10.14.2 to 10.14.3 successfully. However, I've lost location services for Siri and Maps.

      Anyone else?

      I've tried a little trial and error troubleshooting but no luck...
      SysPref->Privacy->Location Services is enabled with all settings checked. I've tried to disable and enable, but not luck.

      I tested booting from previous backup of 10.14.2 install/uefi (pre update) and Location Services worked.

      Prior to OSX update I also updated to latest clover, WEG, Lilu, AirportBrcmFixup, AppleALC.

      So I tested by downgrading all of the above one at a time to the previous state, and still no Location services on 10.14.3

      I've used kext utility to repair any broken kexts.

      I've also tried forcequiting from activity monitor:
      com.apple.geod

      And I've Try Deleting:
      Library/Preferences/com.apple.GEO.plist
      Library/Containers/com.apple.geod

      I've booted into a guest user and this did not allow location services either.

      My build is using a native Broadcom BCM94352Z Dell DW1560 and BrcmPatchRAM2.kext + BrcmFirmwareRepo.kext

      Any thoughts?
    • By ucif19
      Hi, First of all, sorry for my English.
      I want to buy a WiFi/bt card for my hackintosh. I want a card that have a native support for MacOS because I need to use Handoff and AirDrop. I saw the card in the link below: anyone could tell me if the card have the requirements I mentioned before?
       
      wifi/bt card  Broadcom 94352Z DW1560: https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.it%2Fulk%2Fitm%2F272204993348
       
      my build
      macos Mojave 10.14.3
      mobo: H170N-WiFi 
      cpu: i5-6500
      gpu: gtx 1060 6gb (not work on Mojave)
      Ram: 16Gb ddr4 2133 MHz
×