Jump to content
InsanelyMac Forum
quayman

AMD R9 270X 2G - MacPro4,1

Recommended Posts

Hello all !

 

I got an "official" MacPro4,1 (2x2,26 GHtz Nehalem)

with Mac OS X "El Capitan" 10.11.2

and also Windows 8 on an Bootcamp partition.

 

I just bought a SAPPHIRE AMD VAPOR-X R9 270X 2G D5 graphic card.

which seem to work fine on windows 

 

on Mac it is reconnized as "AMD Radeon HD 7xxx 2048 Mo" but relatively work

exept on System information when I click on PCI I got a message say an error occured gathering PCI devices informations.

 

The main problem is it start up with black screen and go directly to my user desktop without any gray apple logo screen and progress bar.

if it is only this, it is ok for me. but when I try to boot with option (to choose which System to boot to) or any other booting option

( Apple + R = to go to Disk Utilities  or even Apple + S = for single user terminal boot)

it didn't work at all, I got a black screen. nothing can be done or happening.

So I'm stuck with my original boot system (OS X or Windows)

 

I read at little about Clover but I'm not sure it is the solution as I am on a real Mac Pro not a Hackintosh.

 

Sorry cause I am a newbie concerning all these matters...

I thanks you very much in advance for any of your help.

Best

keyman

Share this post


Link to post
Share on other sites
Advertisement

solution:

use clover fake id for gpu ati (injection menu) write FBNAME to AMD and write fakeid to: 0x68101002

note: try disable-enable inject amd and edid if blank screen

 

note: select display fix in dsdt fixes in clover

 

this solution working on my friend's hackintosh pc r9 270x

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)  New!
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By verymilan
      Hi, i recently set up High Sierra on my AMD computer with the help of the amdosx community (i actually used an installer just to confirm that something would work in the first place before i spend hours for nothing, i can and could have downloaded High Sierra the "legal" way).
      However the graphicscard is recognized properly, the 6gig are recognized and i have no artifacts and no screen tearing with the official nvidia webdriver,
      but unfortunally, dark colors have horizontal dark stripes in them and specific bright colors like on left bar of system windows such as settings do flicker like low fps.

      I only used the clover on the flash drive for now and i'd like if it's worth digging deeper of if i should just forget about it as it is a common nvidia problem on macOS.
      Would be amazing to know.
       
      Closer machine infos:
      * High Sierra (misses a recent minor patch as my network is veeeery slow and i got this nvidia issue anyway so i mainly jumped back to linux)
      * AMD fx8350
      * Asus Sabertooth 990fx Ref. 2.0
      * NVIDIA GeForce GTX 1060 6GB
       
    • By hackintosh_builder
      Hello, I am interested in building a Hackintosh using Threadripper. Could you please recommend good motherboard(s)? Is there one that is fully compatible with the Hackintosh?
    • By abhinav
      How to install macOS 10.13 High Sierra in Vmware Workstation 14 Pro on AMD Machine
      Unlocker cmd already installed for vmware workstation 14
      vmx file edited...added smc.version="0"
       
      My System Specs
      AMD FX8120 8 Core
      Corsair Vengeance 32 GB DDR3 RAM
      Asus 990FX Sabertooth Motherboard
      Sandisk Ultra II 480 GB SSD SATA 3
      Asus STRIX 960 GTX 4 GB DCU II Model Pixel Shader 5 DirectX 12 Support
       
      Virtual Machine Specs
      16 GB RAM
      2 processors and 4 cores = 8 core processor
      SATA hard drive
      128 MB video memory

    • By crazybirdy
      Patched OSInstall.mpkg and OSInstaller.framework to allow OS X 10.11 installation on MBR partition.
       
      To use those patched files you must follow HowTo-10.11.x to create an USB installer. You can't just run the app downloaded from Mac App Store.
       
      The patch is made base on 落下爱@pcbeta 10.10.x patch method
       
      How to make 10.11 installer for MBR?
       
      Open /Applications/Install OS X El Capitan.app/Contents/SharedSupport/InstallESD.dmg/BaseSystem.dmg first.
      1. Restore BaseSystem.dmg to HFS partition and rename the partition’s name as OSXMBR as /Volumes/OSXMBR/
      2. Copy InstallESD.dmg/BaseSystem.dmg to /Volumes/OSXMBR/
      3. Copy InstallESD.dmg/BaseSystem.chunklist to /Volumes/OSXMBR/
      4. Copy InstallESD.dmg/AppleDiagnostics.dmg to /Volumes/OSXMBR/
      5. Copy InstallESD.dmg/AppleDiagnostics.chunklist to /Volumes/OSXMBR/
      6. Remove /Volumes/OSXMBR/System/Installation/Packages
      7. Copy InstallESD.dmg/Packages to /Volumes/OSXMBR/System/Installation/Packages
       
      8.
      OSInstall.mpkg replace to
      /Volumes/OSXMBR/System/Installation/Packages/OSInstall.mpkg
       
      OSInstaller replace to
      /Volumes/OSXMBR/System/Library/PrivateFrameworks/OSInstaller.framework/Versions/A/OSInstaller
       
      9. Copy InstallESD.dmg/Packages/Essentials.pkg/System/Library/Kernels/kernel
      to /Volumes/OSXMBR/System/Library/Kernels/kernel
      (use Pacifist v3.2.14 to access the contents of Essentials.pkg, and make directory /System/Library/Kernels first.)
      (Need kernel only if you use Chameleon with -f to boot the installer disk, needn't with Clover.)
       
      10. Boot to /Volumes/OSXMBR/ to install Mac OS X.
       
      Work fine with Clover
       
      Work fine with Enoch
      and /Extra/kernel.plist with
      <key>KernelBooter_kexts</key>
      <string>Yes</string>
       
      10.11.6.15G1011
      10.11.6.15G31
      10.11.5.15F34
      10.11.4.15E65
      10.11.3.15D21
      10.11.2.15C50
      10.11.1.15B42
      10.11.0.15A284
       
      If you want to patch MBR by yourself, here is the patch code, works on 10.11.0 ~ 10.11.6
       
      perl -pi -e 's|\x48\x8B\x78\x28\x48\x85\xFF\x74\x5F\x48\x8B\x85|\x48\x8B\x78\x28\x48\x85\xFF\xEB\x5F\x48\x8B\x85|g' OSInstaller
      codesign -f -s - OSInstaller
×