Jump to content
Andres ZeroCross

Success Hackintosh OS X El Capitan 10.11.4 Beta Build 15E27e at HP Pavilion 15-AC169TX

13 posts in this topic

Recommended Posts

Specification :
Processor : Intel Core i5 5200
RAM : 8GB PC12800 DDR3L (Use 1 Slot)
HDD : 1TB Hitachi
Optical Drive : DVD/RW
VGA : Intel HD Graphics 5500 + AMD RADEON R5 M330 2GB
Display : 15.6" Internal Display LED
Sound : Realtek ALC282

Tools and Softwares
1. USB FlashDrive with 8GB
2. "Install OS X El Capitan.app" from AppStore, i downloaded 10.11.2 version
3. Use CreateInstallMedia method
4. Clover R3330
5. UEFI Mode


Special Problem :
1. We can't unlock DVMT Pre-Allocation memory with Shell Command, there is error notification about "can't change value with EFI" so just use PATCH Binary for "AppleIntelBDWGraphicsFramebuffer" with Clover.

What's working
1. Shutdown, Restart and Good Sleep
2. Close LID for Sleep and Open LID for Wake
3. Working Ethernet
4. Working iMessage (I used "ROM" and "MLB" of Real Mac :hysterical: )
5. FN Brightness Fix, Check this
6. Sound via AppleHDA Patching (All Working,, Input dan output)
7. Battery Indicator
8. Super Speed USB 3.0 (5Gb/s) and all of USB Port
9. HDMI Audio and HDMI Output
10. Webcam Camera

Tutorials
1. Format your USB to HFS+ and GPT Format then open terminal and use this command "sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app —no-interaction"
2. After that Install Clover R3330 and choose
- Install for UEFI booting Only
- Install Clover in the ESP
- Select theme (i choose "Shield" theme")
- For Drivers64UEFI (DataHubDxe-64, EmuVariableUefi-64, OsxAptioFixDrv-64, PartitonDxe-64)
then install
3. Open Config.plist at your EFI Partition of USB Installer (EFI/Clover/) with Clover Configurator and select this
- ACPI (FixHPET, AddDTGP, FixUSB, Fix Darwin, FixIPIC, NewWay, FixRegions, FIX_RTC, FIX_TMR, DeleteUnused, AddPNLF, DropTables for DMAR&Cpu0Ist&CpuPm, Generate PStates, Generate Cstates), don't ask me why i choose this, because it work for my system for installing
- Boot (-v, dart=0 or DropDMAR, XMPDetection=Yes, PBR, NeverHibernate)
- Devices (Inject USB, AddClockID USB, FixOwnerShip USB, AFGLowPowerState and write "3" as LayoutID of Audio/HDEF)
- Graphics (Inject Intel), never write your ig-platform-id or you will face Kernel Panic about "AppleIntelBDWGraphicsFramebuffer.kext", we will write it later
- Kernel and Kext Patches (AppleRTC, Kernel LAPIC, KernelPm). We will set "KextsToPatch" later ;)
- Rt Variables (BooterConfig=0x28, CsrActiveConfig=0x67)
- SMBios, for this one i google it and look for "MacBookPro12,1". You won't found "MacBookPro12,1" with this tool :) or see my Config.plist at my attachment file. Don't forget to change serial
- System Parameters (InjectKexts=Detects, Inject System ID)
4. Just boot from your USB and make instalation like normal. (I make 3 partiton for my Harddrive. Partition1=Macintosh HD, Partition2=Windows, Partitio3=Data). Just install to Macintosh HD
5 After get to desktop screen i realize that there is Active CoreStorage at my Harddrive, so open terminal and use this command "diskutil corestorage revert disk1" then restart
6. Try to Install Clover R3330 to your Harddrive but with some adding at Clover Option Installer Menu
- Install RC scripts on target volume
- Install all RC Scripts on all other bootable volume
- Optional RC Scripts
- Install Clover Preference Pane
7. After that,, mount your EFI partition of USB Installer and Copy Clover Folder then paste it at EFI Folder of your harddrive (same directory as your USB Flashdrive)
8. Now open config.plist at your EFI/CLOVER/ on your harddrive with Clover Configurator and write this "kextToPatch" at "Kernel and Kext Patches"
- Name=AppleIntelBDWGraphicsFramebuffer, Find=4139C4763E, Replace=4139C4EB3E, Comment=Up to you :D
9. Now go to Graphics Section and write this value at "ig-platforms-id" 0x16260006
10. Reboot, and you will get QE/CI for Intel HD 5500 :thumbsup_anim::thumbsup_anim::thumbsup_anim:
11. For Audio, just need to use "AppleHDA Patcher" and select "Realtek ALC282 Ver2". Thanks to Micky1979 and Mirone. With their data i can use it for "Abxite Method" (patch XML to ZML, use info.plist injection, and binary patch for Clover)
12. Now you have good device running Hackintosh

Fix and Patches
1. Extract and edit your DSDT, Use rehabman repo for patch
2. For Full Working USB 2.0 and USB 3.0 (5Gb/s), i use rehabman USB Injection all with some modifications and change "EHC1 to EH01" and "EHC2 to EH02". See my USB Injection kext at "Clover/kexts/10.11". I attach it
3. To activate HDMI Audio then write this to KextToPatch of config.plist
- Name=AppleIntelBDWGraphicsFramebuffer, Find=02000001050B00000400000705000002040B00000400000705, Replace=02000001050B00000800000705000002040B00000400000705, Comment= Up To You ;)
4. To Fix Second Stage Glitch, then write this to KextToPatch at config.plist
- Name=IOGraphicsFamily, Find=0100007517, Replace=0100007417, Comment=Up to You
5. After install Windows with UEFI Mode then you will never boot to Clover GUI. We can't change Boot Entry via Shell Command or Bios Setup. There is no option for this. Solution is
- Boot with your USB Installer, then mount EFI Partition of Your Harddrive and go to "EFI/Microsoft/Boot" and change "bootmgfw.efi" to "bootmgfw-orig.efi".
- Then go to "EFI/CLOVER/" and Copy "CLOVERX64.efi" and paste at "EFI/Microsoft/Boot" then rename it to "bootmgfw.efi"
- Restart and you can boot in to CLOVER GUI again :thumbsup_anim::thumbsup_anim:


Special Note :
Just use my DSDT and all SSDT if you have got to desktop screen. Don't use my files at INSTALLING PART, or you will face "Kernel Panic" about "AppleIntelBDWGraphicsFramebuffer". Because i patch Ig-platform-id at my DSDT. You still can use kexts, SMBIOS Setting. I tick none at DSDT Fix at Config.plist because i have Patched DSDT. Do it with your own risk.


Sorry for my Bad English guys :)

post-1311960-0-41665600-1452882197_thumb.jpg

post-1311960-0-98716700-1452882232_thumb.jpg

post-1311960-0-77265200-1452882243_thumb.jpg

post-1311960-0-63020400-1452882256_thumb.jpg

post-1311960-0-95414300-1452882265_thumb.jpg

post-1311960-0-53019800-1452882283_thumb.jpg

post-1311960-0-78927600-1452882291_thumb.jpg

post-1311960-0-31816700-1452882300_thumb.jpg

post-1311960-0-64390000-1452882308_thumb.jpg

post-1311960-0-61183200-1452882316_thumb.jpg

post-1311960-0-35931400-1452882325_thumb.jpg

 

 

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the share, I can try for point numb for Fn brightness fix so my notebook is wrong key Fn not Fn right or left and i can try to fix second stage patch

Good hacky  :thumbsup_anim: 

Share this post


Link to post
Share on other sites

don't have this device~

but for learning purpose, i'm digging into dsdt.dsl files and finally know how to disable device (GFX0) and replaced with new device (IGPU) following with usual DSM method. 

many thanks  :thumbsup_anim: 

Share this post


Link to post
Share on other sites

don't have this device~

 

but for learning purpose, i'm digging into dsdt.dsl files and finally know how to disable device (GFX0) and replaced with new device (IGPU) following with usual DSM method. 

 

many thanks  :thumbsup_anim:

Coffee Time  :hysterical:

Share this post


Link to post
Share on other sites

hello bro

could yo please explain exactly what did you do to patch the voice because i am trying the way with apple patcher and it did not work and it dosnt load any audio device

thanks

Share this post


Link to post
Share on other sites

hey I used this guide for my hp pavilion 15 ab205tx and it works good. The only difference is I use nv_disable=1 and Kext-dev-mode=1 boot flags and that I haven't used any patches from "kext and patches" section as all of them work fine with voodooHDA and vanilla usb driver.

the problem is I get this kernel panic randomly when using the hackintosh.

Anonymous UUID:       C8C4B26F-8EA4-85ED-3B04-F56870D13B55

Wed Oct 19 04:44:55 2016

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f85221964): assertmsg@/Library/Caches/com.apple.xbs/Sources/GPUDriversIntel/GPUDriversIntel-10.12.13/Common/IONDRV/Intel/BDW/AppleIntelFramebuffer/AppleIntelController.cpp:20484
Backtrace (CPU 0), Frame : Return Address
0xffffff80ad70bd10 : 0xffffff80002df792 
0xffffff80ad70bd90 : 0xffffff7f85221964 
0xffffff80ad70bdf0 : 0xffffff7f8521fa8e 
0xffffff80ad70be80 : 0xffffff8000893d2d 
0xffffff80ad70bec0 : 0xffffff8000893836 
0xffffff80ad70bf30 : 0xffffff800088e4ea 
0xffffff80ad70bf70 : 0xffffff80008944cc 
0xffffff80ad70bfb0 : 0xffffff80003ccf77 
      Kernel Extensions in backtrace:
         com.apple.driver.AppleIntelBDWGraphicsFramebuffer(10.1.2)[43A28CBD-5DDC-3E44-B0A0-4312DBFBA30C]@0xffffff7f85207000->0xffffff7f8525cfff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[F398CE94-0FBD-3E8E-A7AB-55F7F05A81ED]@0xffffff7f80af3000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[5D7574C3-8E90-3873-BAEB-D979FC215A7D]@0xffffff7f80e4e000
            dependency: com.apple.iokit.IOAcceleratorFamily2(205.1)[9B36322F-2685-3BDD-9734-9BCC39A0AF94]@0xffffff7f85196000
            dependency: com.apple.iokit.IOReportFamily(31)[C89107EE-2DF2-3BC3-9F6D-3133D43ED7EF]@0xffffff7f80b57000
            dependency: com.apple.AppleGraphicsDeviceControl(3.12.6)[F211EB28-182A-34BB-A610-87667618F925]@0xffffff7f85201000
            dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[429C688E-8DDA-3D15-9C6E-6F3F4855C424]@0xffffff7f8515c000

BSD process name corresponding to current thread: kernel_task
Boot args: kext-dev-mode=1 dart=0 -v  debug=0x100 slide=0  container-dmg=file:///Install%20OS%20X%20El%20Capitan.app/Contents/SharedSupport/InstallESD.dmg root-dmg=file:///BaseSystem.dmg

Mac OS version:
15D21

Kernel version:
Darwin Kernel Version 15.3.0: Thu Dec 10 18:40:58 PST 2015; root:xnu-3248.30.4~1/RELEASE_X86_64
Kernel UUID: DECC9F02-27D7-31F0-9599-A9EF2873902C
__HIB  text base: 0xffffff8000100000
System model name: MacBookAir6,2 (Mac-7DF21CB3ED6977E5)

System uptime in nanoseconds: 115572870404
last loaded kext at 115568136615: com.apple.iokit.IONDRVSupport	2.4.1 (addr 0xffffff7f853a5000, size 57344)
loaded kexts:
org.rehabman.voodoo.driver.PS2Mouse	1.8.24
org.rehabman.voodoo.driver.PS2Trackpad	1.8.24
org.rehabman.voodoo.driver.PS2Keyboard	1.8.24
org.rehabman.voodoo.driver.PS2Controller	1.8.24
org.netkas.driver.FakeSMC	1723
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.driver.AppleFIVRDriver	4.1.0
com.apple.driver.AppleIntelBDWGraphicsFramebuffer	10.1.2
com.apple.nvidia.NVDAStartup	10.0.8
com.apple.nke.webcontentfilter	5
com.apple.filesystems.msdosfs	1.10
com.apple.filesystems.ntfs	3.13
com.apple.driver.DiskImages.SparseDiskImage	417.2
com.apple.driver.DiskImages.ReadWriteDiskImage	417.2
com.apple.driver.DiskImages.UDIFDiskImage	417.2
com.apple.driver.DiskImages.HTTPBackingStore	417.2
com.apple.driver.DiskImages.FileBackingStore	417.2
com.apple.driver.DiskImages.RAMBackingStore	417.2
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.iokit.SCSITaskUserClient	3.7.7
com.apple.BootCache	38
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.iokit.IOAHCIBlockStorage	2.8.5
com.apple.driver.usb.AppleUSBEHCIPCI	1.0.1
com.apple.driver.AppleAHCIPort	3.1.8
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleACPIButtons	4.0
com.apple.driver.AppleACPIEC	4.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.security.quarantine	3
com.apple.security.TMSafetyNet	8
com.apple.nke.applicationfirewall	163
com.apple.kext.MojoKDP	2.0.1
com.apple.iokit.IONDRVSupport	2.4.1
com.apple.driver.AppleHDAController	272.51.3
com.apple.iokit.IOHDAFamily	272.51.3
com.apple.iokit.IOAudioFamily	204.3
com.apple.vecLib.kext	1.2.0
com.apple.kec.Libm	1
com.apple.driver.AppleSMC	3.1.9
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.IOPlatformPluginFamily	6.0.0d7
com.apple.driver.AppleIntelLpssUART	2.0.59
com.apple.iokit.IOSerialFamily	11
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.AppleGraphicsDeviceControl	3.12.6
com.apple.iokit.IOAcceleratorFamily2	205.1
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.driver.DiskImages.KernelBacked	417.2
com.apple.iokit.IOSCSIBlockCommandsDevice	3.7.7
com.apple.iokit.IOUSBMassStorageDriver	1.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice	1.0.1
com.apple.driver.usb.AppleUSBHub	1.0.1
com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.7.7
com.apple.iokit.IOBDStorageFamily	1.8
com.apple.iokit.IODVDStorageFamily	1.8
com.apple.iokit.IOCDStorageFamily	1.8
com.apple.iokit.IONetworkingFamily	3.2
com.apple.driver.AppleXsanScheme	3
com.apple.iokit.IOAHCISerialATAPI	2.6.2
com.apple.iokit.IOSCSIArchitectureModelFamily	3.7.7
com.apple.driver.AppleEFINVRAM	2.0
com.apple.iokit.IOUSBFamily	900.4.1
com.apple.driver.usb.AppleUSBEHCI	1.0.1
com.apple.iokit.IOAHCIFamily	2.8.1
com.apple.driver.AppleIntelLpssI2C	2.0.59
com.apple.driver.AppleIntelLpssGspi	2.0.59
com.apple.driver.AppleIntelLpssDmac	2.0.59
com.apple.driver.usb.AppleUSBXHCIPCI	1.0.1
com.apple.driver.usb.AppleUSBXHCI	1.0.1
com.apple.iokit.IOUSBHostFamily	1.0.1
com.apple.driver.AppleUSBHostMergeProperties	1.0.1
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.driver.DiskImages	417.2
com.apple.iokit.IOStorageFamily	2.1
com.apple.iokit.IOBluetoothFamily	4.4.3f4
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.iokit.IOReportFamily	31
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.AppleACPIPlatform	4.0
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0
Model: MacBookPro11,1, BootROM MBP111.0138.B16, 2 processors, Intel Core i5, 2.20 GHz, 4 GB, SMC 2.16f58
Graphics: Intel HD Graphics 5500, Intel HD Graphics 5500, Built-In
Graphics: NVIDIA Chip Model, NVIDIA Chip Model, PCIe
Memory Module: BANK0/DIMM0, 4 GB, DDR3, 1600 MHz, Micron Technology, 8KTF51264HZ-1G6N1N1
Serial ATA Device: TOSHIBA MQ01ABD100, 1 TB
Serial ATA Device: hp       DVDRW  GUB0N
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: USB 3.0 Bus
Thunderbolt Bus: 

any help?

Share this post


Link to post
Share on other sites

successfully installed EL Capitan with your guide in my HP 15-AC149TX

thanks buddy :)

but there is a little bug with audio whenever i restart my laptop the audio don't work :(

need to repatch the audio all the time

except audio everything works just perfect :)

Share this post


Link to post
Share on other sites

Hello brothers, for the first time Itry to installed Mac os high serria on a laptop HP Pavilion 15-AC169TX ..But I find the installation problem gives me a prohibitory symbol every time..
Please, I want any Mac version that works on this laptop and the steps please

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Corrin
      Hi all,
       
      so ive been trying to get the wifi working on my hackintoshed laptop for a full week now, but i have little to no experience with macs or hackintoshes.
       
      my wifi card is a BCM43142, and my laptop is a HP pavilion 15 p004na running Mojave 10.14.4
       
      i was told on another forum that this card did work on macos, but im starting to doubt it a little :)
       
      any help would be much appreciated,
      Corrin
    • By brasoel
      hi!!!! I try to install High Sierra 10.13.4 on HP Z400 (Intel Xeon W3520 CPU and Nvidia fx 3800 Graphics) but is unposible for me to boot. I create a vanilla usb and with them i boot normaly to my laptop
      HP DV6 2170 SV Intel I5 Nvidia Gforce Cuda but no to my desktop. The only  way to install hackintosh on HP Z400 for me is with Niresh Zone Installation. When I try  niresh usb on laptop does not work...
      So the vanilla usb is working perfect on laptop but no on desktop and Niresh usb is working perfect on Desktop by no to my laptop.
      My question is; is there someone to help me where is the diference and what is wrong? thank you in advance....
         
    • By sudo_dudo
      Introduction
      This guide should work for all HP Pavilion 15 Broadwell(5th gen) laptops. I used AB205TX. This is my first guide so please use comment section if I missed something.
      I have used Andres Zero Cross' guide and made changes to make it work for us.
       
      My Specifications
      Processor: i5 5200u
      Graphics: HD5500 and GT940m
      Display: 15.6" 1920x1080
      Ram: 8Gb DDR3L
      Dual Booted with Windows 10
       
      What’s not working:
      1. Built-in WiFi (Can't! Obviously, use an external adapter)
      2. GT 940m (MacOSX doesn’t support Nvidia optimus.)
      Prerequisites:
      1.  A Mac/Hackintosh/VM for making the install usb.
      2.  A pendrive 8GB or more.
      3.  Clover Configurator installed on machine you will use for making the install usb.
       
      Getting the Bios ready:
      1. Disable virtualisation.
      2. Disable Secure Boot.
      3. Enable Legacy Mode.
       
      Use clover r3330. Nvram problems have been reported in some of the latest versions. I recommend version r3330 because it worked just fine for me.
       
      Making Install USB:
      RehabMan made a very detailed guide (mentioned below) on how to install clover on usb. While following his(did I just assume his gender? ) guide keep the following things in mind:
      The guide: https://www.tonymacx...-clover.148093/
      1.Follow the UEFI way and 2 partition method (not necessary but    recommended) 
      2.When installing clover on "Clover Efi"partition use the following configuration
      - Install for UEFI booting Only
      - Install Clover in the ESP 
      - For Drivers64UEFI (DataHubDxe-64, EmuVariableUefi-64, OsxAptioFixDrv-64, PartitonDxe-64)
      then click Install.
      Open Config.plist at your EFI Partition of USB Installer (EFI/Clover/) with Clover Configurator and match these


      use nv_disable only if you have a nvidia card with Intel HD using optimus technology.




      Note: In the below snap my MLB is not there. You will have one already filled, let it be and don't delete it.


       
      -Go to Clover EFI > EFI > Clover > Kexts > other > and paste FakeSMC.kext and VoodooPS2controller.kext in attachments. Delete rest of the kexts in the folder.
      Now, just boot from your USB and install.

      Installing Clover on HDD:
      1.Install Clover on your hard disk and check
      - Install RC scripts on target volume
      - Install all RC Scripts on all other bootable volume
      - Optional RC Scripts
      2.Mount EFI partition of USB Installer copy the Clover folder to EFI partition of your hard disk, thus replacing the Clover folder of your hard disk.
       
      I have attached my Post-Install Clover files in case you have hp pavilion 15 ab205tx or you need to see my config.plist
       
      My dsdt and ssdts should work for you if you have the same machine. Just copy the clover folder to your efi partition and update your bios to F.82 Rev.A from HP website. If you are using my clover folder as it is you probably don't need to apply any of these patches below as they are already enabled in my config.plist.
      Fixing Graphics:
      Open config.plist at your EFI/CLOVER/ on your hard drive with Clover Configurator and write these patches in "kextToPatch" at "Kernel and Kext Patches"
      - Name=AppleIntelBDWGraphicsFramebuffer, Find=4139C4763E, Replace=4139C4EB3E, Comment=“Unlocking framebuffer"
      - Name=AppleIntelBDWGraphicsFramebuffer, Find=39CF763C, Replace=39CF773C (Add this with the one above only If the above patch doesn't work alone)
      To activate HDMI Audio:
      - Name=AppleIntelBDWGraphicsFramebuffer, Find=02000001050B00000400000705000002040B00000400000705, Replace=02000001050B00000800000705000002040B00000400000705, Comment=“HDMI audio Fix"
      Now go to Graphics Section and in “ig-platforms-id" type 0x16260006
      In the Boot you can uncheck verbose and kext-dev-mode=1
      Open EFI partition on your HDD go to EFI > Clover > kexts > other > and delete all the kexts in it and replace them by ApplePS2SmartTouchPad.kext and FakeSMC.kext
       
       
      Fixing Audio
      For audio : https://redd.it/4e23w6 for ab205tx it is ALC290. I used Layout ID: 3
      Reboot, now you have QE/CI for Intel HD 5500, Audio and Touchpad with gestures working.  
       
      Fixing Performance:
      1. Open up the config.plist of your HDD and choose a suitable SMBIOS. Generally its the one with similar processor. I used Macbook Pro(12,1). 
      Follow this guide: https://www.tonymacx86.com/threads/guide-how-to-configure-your-systems-smbios-correctly.198155/
      2. You will need to enable Native power management to get the most performance out of your machine.
      Follow this Guide: https://www.tonymacx...laptops.175801/
       
      Fixing Battery:
      1. After you have enabled Native Power Management you can disable Nvidia card for OSX to get more battery backup as the card draws power even though it is not supported on os x.
      Follow this guide: https://www.tonymacx...laptops.163772/
      Note: after disabling Nvidia you can boot without nv_disable=1 and remember to drop oem ssdt after patching your own.
      2. To get a working battery status follow this guide: https://www.tonymacx...-status.116102/
       
      Hotkeys:
      Volume and music hotkeys should work out of the box for us. Brightness hotkeys however don't. You need to do some patching to get them working like volume keys but, that's too much work for something such small. To make them work just go to syetem prefs>keyboard>shortcut and change brightness shortcuts to fn+f2 and fn+f3   depending on your machine.Now you have brightness keys working just press fn and then the keys to change brightness.
       
      Fixing Internet/AppStore/iMessage/Facetime:
      I use External USB adapter to connect to Wifi.
      Note: Use latest wifi driver for the USB adapter(the cd included with the adapter often has outdated drivers). Old drivers caused kernel panics for me. If USB wifi adapters are costly in your country or ones from good brands aren't available you can use Leoxsys usb wifi adapters which were the only ones that worked for me among all the cheap Chinese products I could find.
       
      You might notice that you are unable to sign into you Apple Id in AppStore and iMessage. This is because Apple collects some data while you sign in which we provide using our SMBIOS but that's not enough. We need ethernet set en0 and most importantly it should be shown as builtin, which is not possible for us as our ethernet/Wifi cards aren't supported. RehabMan came up with an excellent way to solve the problem. He faked ethernet device that shows up as onboard ethernet, this is possible by adding a device in DSDT.
      Solution: https://github.com/RehabMan/OS-X-Null-Ethernet
       
      Sync time between windows and mac:
      If you are dual booting like me, you may find that windows or osx shows incorrect time. for that follow this guide: http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/?do=findComment&comment=2020591
       
      Credits:
      Hackintosh community and all those whose guides I linked. Specially RehabMan and Andres.
      HAPPY HACKING!
       
      My Clover Folder : http://jmp.sh/v/GiIDIGWQe7k9IaT3uvnY
      kexts.zip
    • By jack-69
      DISM is your friend!
       
      Part 1: (For all the computers that don't have UEFI)
       
      Prepare two USB keys, one with El Capitan & one with Windows 10.
      First put the Windows USB, during the installation (when it asked the Windows code) press shift + f10 and will open the command prompt:
      diskpart list disk (list of your hdd) select disk 0 (0 is number of your hdd) clean (ATTENTION clean all your hard disk selected) convert gpt create partition efi size=200 (creates EFI partition) format fs=fat32 label=EFI We made a EFI partition.
      In my Hdd I have 3 partitions ( 1 for Mac, 1 for Windows=Ntfs & 1 in exFat for sharing files between the two systems).
      create partition primary size=100000 (1 partition for Mac OS X 100GB) format fs=fat32 quick label=Mac (after we will format in HFS+ with disk utility) create partition msr size=128 (creates Microsoft Reserved) create partition primary size=100000 (1 partition for Windows 10 100GB) format fs=ntfs quick label=Windows (format in Ntfs) create partition primary (creates a partition with the remaining space) format fs=exfat quick label=Hdd (format in exFat) Now the fun part.
      We should insert the letters for the partitions. Check
      select disk 0 list volume (check the assigned letters, REMINDS the letter assigned to the USB "example d") list partition (check the number of partition EFI "example partition 1") select partition 1 assign letter=h list partition (check the number of partition Windows "example partition 3") select partition 3 assign letter=g exit Then we have the letter "D:\" for the USB, "H:\" for the EFI partition & "G:\" for the Windows partition.
      Now we need to copy the installation files from the USB to the Windows partition.
      cd\windows\system32\ dism /apply-image /imagefile:d:\sources\install.wim /index:1 /applydir:g:\ Break....
      Now we need the Windows EFI boot files.
      cd\ g: bcdboot (check the command line) bcdboot g:\windows /1 en-us /s h: /f UEFI (in my case "/1 It-it") Restart the computer with the Mac USB "Clover bootloader", then select Microsoft EFI and start the installation of Windows 10 in FULL GPT. 
      If you don't see the exFat partition in Windows don't worry.
      (Take a program like Partition Wizard, format the partition in NTFS  and assigns the letter D:\. Now open the command prompt administrator and write:
      diskpart select disk 0 list partition (check the partition before-exFat = after-NTFS "example partition 4") select partition 4 format fs=exfat quick label=Hdd Now you must have the partition exfat visible and writable)
       
       
      Part 2:
       
      Important!  
      Don't format or delete the EFI partition.   
      From the Mac USB we need delete AppleIntelHDGraphicsFB.kext. 
       
      Now we go in to the installation of El Capitan, with disk utility format the partition "Mac" in HFS+ mac journaled, then install Mac OS X.
      While starting El Capitan from your hard drive, we must block AppleIntelHDGraphicsFB.kext and AppleIntelHDGraphics.kext. (& add cpus=1 or patch with clover)
      When El Capitan is started:
      Patch AICPM with Clover Configurator Install Clover like this  (of course without installation El Capitan) "Legacy mode" Replace the config.plist in EFI partition and add SMBIOS with clover configurator - macbook pro 6.1 Put the DSDT Put HFSPlus.efi, NTFS.efi in drivers64 folder Insert and replace all kext PS:During the first system start we must go in the system preferences, keyboard, shortcuts and change the key combination of brightness (f2- f3+).
       
       
      Work:  
       
      Intel Core i5 460M
      Intel HD Graphics                                      (Clean graphics without artifacts)
      Wifi & Ethernet                                          (Atheros AR9285 & Realtek 8111)
      Stereo speakers & Microphone                    (IDT92HD81B1X5)
      Keyboard & multi-touch touchpad
      Memory Card Reader
      Camera
      All USB
      Battery
      Sleep & Wake
      Brightness Values
      App Store
       
      Don't work: 
       
      ATI Mobility Radeon HD 5470                      (Blocked by BIOS)
      FaceTime                                                   (With Rom,SN,MLB valid work)
      iMessage                                                   (With Rom,SN,MLB valid work)
      Maps            
       
       
      Thanks : GhostRider - pokenguyen - Mirone & Micky1979 - RehabMan
       
       
      HP El Cpitan.zip
    • By Moinas
      Hello everyone.
      So, im kinda new to this whole hackinstosh, but, i have some experience i know at least the basics.

      Big picture. Tried to install mac, stucks at "System uptime in nanosecods: xxxx", some panic error "Local APIC Error".

      If you want me to take a pic, sure, but i think that is enough considering what i have searched. I've tried to boot with some flags like "cpus=1", "nv_disabler=1", "GraphicsEnabler=NO" and some "nvda_driver".
      Did everything in the main tutorial with the #####...

      AND. I got pass that error once but surprise surprise, "Still Waiting for root device".

      Computer Specs:

      Intel Core i5 520M / 2.4 GHz
      4Gb RAM
      NVIDIA GeForce GT 320M - 1 GB DDR3 SDRAM

      Is it possible? If it is, how to make it possible?

      Big thanks.
×