Jump to content

93 posts in this topic

Recommended Posts

Advertisement

no dsdt.  can't figure out how to patch correctly, but here are some screenshots of system info

delete the driver that I have posted you and install this patched driver for (3483:1106) in to /Extra/Extensions, use Kext wizard, fix the permissions etc ... and report with a picture of SystemInfo.app

SuperVIAATA.kext.zip

Share this post


Link to post
Share on other sites

 I have  Intel  DXR79SR  motherboard with  Renesas Electronics  3.0 USB ports ,and  Intel 2.0 ports. I tried  various methods to get  them all working , but  best solution was to edit SSDT ,which is not recommended and my system will not shutdown,only reboots ,I'm on Yosemite now  with GenericUSB.kext .To get  3.o usb to work but it's buggy you have to hot plug them  a few times to get them to pop onto the desktop any idea if this solution will work on my board ? 

Share this post


Link to post
Share on other sites

I have an interesting information here for Clover users, which may be very helpful... Yesterday I have faced USB problem, which I didn't faced before, I was as usually installing all USB-Fix package (or just IOUSBFamily.kext, IOUSBMAssStorageDriver.kextIOUSBMassStorageClass.kext from the package), then I was repairing permissions, rebuilding cache etc. Everything was perfect with the Enoch bootloader: mouse - working, keyboard - working, actually all USB ports were working, that method also always worked for Clover. With Enoch bootloader I always using USBLegacyOff=Yes boot flag (in Clover you should use FixOwnership), so while I was booting my system with clover and in verbose mode, I noticed that in some reason all USB Ports are injecting, the same happening when you are using USB injection in Clover config file, which you don't actually need. And as the result, all my ports were not working, not mouse, not even keyboard. My BooterConfig was set as "0x28" and my CsrActiveConfig was set as "0x67", so everything was correct. Then I just put all USB-Fix drivers on my EFI partition (EFI/EFI/CLOVER/kexts/10.11) and after that everything worked as I expected. I don't know exactly why it's happening, maybe it has something to do with SIP protection, I don't know, but if you're facing same problems, then you have to add USB-Fix package both in S/L/E and EFI/EFI/CLOVER/kexts/10.11! Also you can add AHCIPortInjector.kext inside clover location (from where kexts are injected). And very important thing, as marius described, in clover config you need to disable all ACPI patches for USB (e.g. USBFix).

p.s. I've uploaded kexts, which I've used for Clover.

package.zip

Share this post


Link to post
Share on other sites

just tried all of this fix and every time I went to boot my install USB up I got a message saying that it was waiting for USB device to speed up or something. Any ideas?

Share this post


Link to post
Share on other sites

upload your extra-folder including raw dsdt and ioreg file, then we check what is the possible cause.

Share this post


Link to post
Share on other sites

Hi,

10.11 is always really painful for me. I'm currently stuck on the installation already.

i tried to get this USB Fix working on my system for more than 4 hours now, i really need a brake.... it solves the EHCI log spamming and the system boot successful, but it kills my whole input(excluding ps2 keyboard, which shall work with ps2 drivers :) )

 

I followed the thread and already see users with my mainboard, but they just don't write anymore here, so i guess they solved it already...

My config:

USB: Logitech Mouse

USB: Dedicated USB Numpad

PS2: Logitech Keyboard

 

Things i tried so far:

- Using u'r v3 fix

- Using the AHCIPortInjector.kext in E/E and S/L/E

- Using Shanee's fix (Basically the same)

- Booting with USBBuxFix=Yes/No same for USBLegacyOff=Yes/No

- Using old known working kexts from yosemite.

- Using different mouses, keyboards...

 

 

My Bootargs are "-v UseKernelCache=No dart=0 npci=0x3000" and my Mainboard is a ASUS M5A97 EVO R2.0. Anything we can do here? Thanks :)

 

Edit: Works now, no future investigations needed, i just used a ps2 keyboard only :) with a proper voodoops2 installation

Share this post


Link to post
Share on other sites
Hi!

I tested Shaneee's USB Fix and Spakk USB Fix

Shaneee's USBEHCI (USB2.0) not work, but there are USB info

Spakk USB is fully working, not working USB audio, and there is no info USB

Tested El Capitan and macOS Sierra

post-1166679-0-41202300-1478711723_thumb.png

post-1166679-0-00055700-1478711725_thumb.png

post-1166679-0-37627700-1478711728_thumb.png

Share this post


Link to post
Share on other sites
Hello!

USBAudio still does not work!

I found a USB Prober application earlier versions of Xcode.

I have attached results generated by the program to see if it will help you find the cause of the problem!

 


 

Thank you in advance for your help!

post-1166679-0-30440300-1481050618_thumb.png

post-1166679-0-06647400-1481050620_thumb.png

USB Bus Probe.txt

Share this post


Link to post
Share on other sites

Hey guys,

 

Help me, my pc is:

 

GA 990 FX-GAMING / AMD Phenom II X4 945 / 8 GB / 2 x NVIDIA GeForce GTX 550 TI 1GB - SLI

 

Thanks,

Share this post


Link to post
Share on other sites

How can I help you? What are your problems?

Share this post


Link to post
Share on other sites

 

Hi folks,
I see it as appropriate, when we talk here about the USB problems that arise when installing El Capitan on intel/AMD Hackintosh, or my approach to use Yosemite kext drivers to fix the USB problems.
 
the first attempt V1, was for me the proof that it is the right way, the packet V2 has ultimately convinced me that it works. I do not need to patch any DSDT and all USB drives/ Ports operate as they have previously worked with Yosemite.
 

 

 

The dowload page seems down.

Share this post


Link to post
Share on other sites

Finish the installation of El Captain without problems, restart automatically; not boot, not in the Enoch menu to choose the hard drive, verify that the files are on the hard disk, help me

Share this post


Link to post
Share on other sites

The dowload page seems down.

first save your S/L/Extensions folder and use an unchanged S/L/Extensions folder.

Then install this content of the USB-Fix package and generate a new prelinked kernel.

If the system should stops after starting with a panic message, with various problimatic

Extensions, so upload a picture with the Panic message.

Finish the installation of El Captain without problems, restart automatically; not boot, not in the Enoch menu to choose the hard drive, verify that the files are on the hard disk, help me

First of all write your hardware in ur signature. Then describe your problem,

If you find it difficult to describe this problem in English, so write it in your language.

if necessary add a pictures or bug reports

USB-Fix.zip

Share this post


Link to post
Share on other sites

Hello,

 

My problem is not to boot after completing the installation of El Capitan, 

 

1. I select the HDD where El Capitan installs, IMG_0700_.jpg

2. Show the message Reboot and Select proper Boot device, IMG_0701_.jpg

3. I select the USB installation, IMG_0702_.jpg

4. Does not show El Capitan HDD, IMG_0703_.jpg

5. Start the installation to repair disk, IMG_0704_.jpg and IMG_0705_.jpg

6. Repair disk OK, but not boot, IMG_0706_.jpg and IMG_0707_.jpg and IMG_0701_.jpg

 

Help me please, 

 

 

GA 990 FX-GAMING / AMD Phenom II X4 945 / 8 GB / 2 x NVIDIA GeForce GTX 550 TI 1GB - SLI

post-2163146-0-06145400-1504358946_thumb.jpg

post-2163146-0-54151900-1504358952_thumb.jpg

post-2163146-0-91292400-1504359177_thumb.jpg

post-2163146-0-42430700-1504359191_thumb.jpg

post-2163146-0-19838600-1504359206_thumb.jpg

post-2163146-0-72613000-1504359215_thumb.jpg

post-2163146-0-83301500-1504359315_thumb.jpg

post-2163146-0-50151400-1504359326_thumb.jpg

Share this post


Link to post
Share on other sites
  1. start from the USB installer and format the hard drive with the Guid partions table, create two partitions with "Mac OS Extended journaled", then install El capitan on the first partition.
  2. install Enoch Bootloader into El Capitan partition and add the amd kernel into /System/Library/Kernels/
  3. Then replace the contents of my Extra folders in yours
  4. Then add the content of the USB-FIX package into S/L/E
  5. and finally restart your system

(all files can be found in Archiv.zip)

Archiv.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      https://tinyurl.com/rkqmpd9
       
      --OpenCore Folder--
      https://tinyurl.com/y75hqg7z
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×