Jump to content

93 posts in this topic

Recommended Posts

Advertisement

no dsdt.  can't figure out how to patch correctly, but here are some screenshots of system info

delete the driver that I have posted you and install this patched driver for (3483:1106) in to /Extra/Extensions, use Kext wizard, fix the permissions etc ... and report with a picture of SystemInfo.app

SuperVIAATA.kext.zip

Share this post


Link to post
Share on other sites

 I have  Intel  DXR79SR  motherboard with  Renesas Electronics  3.0 USB ports ,and  Intel 2.0 ports. I tried  various methods to get  them all working , but  best solution was to edit SSDT ,which is not recommended and my system will not shutdown,only reboots ,I'm on Yosemite now  with GenericUSB.kext .To get  3.o usb to work but it's buggy you have to hot plug them  a few times to get them to pop onto the desktop any idea if this solution will work on my board ? 

Share this post


Link to post
Share on other sites

I have an interesting information here for Clover users, which may be very helpful... Yesterday I have faced USB problem, which I didn't faced before, I was as usually installing all USB-Fix package (or just IOUSBFamily.kext, IOUSBMAssStorageDriver.kextIOUSBMassStorageClass.kext from the package), then I was repairing permissions, rebuilding cache etc. Everything was perfect with the Enoch bootloader: mouse - working, keyboard - working, actually all USB ports were working, that method also always worked for Clover. With Enoch bootloader I always using USBLegacyOff=Yes boot flag (in Clover you should use FixOwnership), so while I was booting my system with clover and in verbose mode, I noticed that in some reason all USB Ports are injecting, the same happening when you are using USB injection in Clover config file, which you don't actually need. And as the result, all my ports were not working, not mouse, not even keyboard. My BooterConfig was set as "0x28" and my CsrActiveConfig was set as "0x67", so everything was correct. Then I just put all USB-Fix drivers on my EFI partition (EFI/EFI/CLOVER/kexts/10.11) and after that everything worked as I expected. I don't know exactly why it's happening, maybe it has something to do with SIP protection, I don't know, but if you're facing same problems, then you have to add USB-Fix package both in S/L/E and EFI/EFI/CLOVER/kexts/10.11! Also you can add AHCIPortInjector.kext inside clover location (from where kexts are injected). And very important thing, as marius described, in clover config you need to disable all ACPI patches for USB (e.g. USBFix).

p.s. I've uploaded kexts, which I've used for Clover.

package.zip

Share this post


Link to post
Share on other sites

just tried all of this fix and every time I went to boot my install USB up I got a message saying that it was waiting for USB device to speed up or something. Any ideas?

Share this post


Link to post
Share on other sites

upload your extra-folder including raw dsdt and ioreg file, then we check what is the possible cause.

Share this post


Link to post
Share on other sites

Hi,

10.11 is always really painful for me. I'm currently stuck on the installation already.

i tried to get this USB Fix working on my system for more than 4 hours now, i really need a brake.... it solves the EHCI log spamming and the system boot successful, but it kills my whole input(excluding ps2 keyboard, which shall work with ps2 drivers :) )

 

I followed the thread and already see users with my mainboard, but they just don't write anymore here, so i guess they solved it already...

My config:

USB: Logitech Mouse

USB: Dedicated USB Numpad

PS2: Logitech Keyboard

 

Things i tried so far:

- Using u'r v3 fix

- Using the AHCIPortInjector.kext in E/E and S/L/E

- Using Shanee's fix (Basically the same)

- Booting with USBBuxFix=Yes/No same for USBLegacyOff=Yes/No

- Using old known working kexts from yosemite.

- Using different mouses, keyboards...

 

 

My Bootargs are "-v UseKernelCache=No dart=0 npci=0x3000" and my Mainboard is a ASUS M5A97 EVO R2.0. Anything we can do here? Thanks :)

 

Edit: Works now, no future investigations needed, i just used a ps2 keyboard only :) with a proper voodoops2 installation

Share this post


Link to post
Share on other sites
Hi!

I tested Shaneee's USB Fix and Spakk USB Fix

Shaneee's USBEHCI (USB2.0) not work, but there are USB info

Spakk USB is fully working, not working USB audio, and there is no info USB

Tested El Capitan and macOS Sierra

post-1166679-0-41202300-1478711723_thumb.png

post-1166679-0-00055700-1478711725_thumb.png

post-1166679-0-37627700-1478711728_thumb.png

Share this post


Link to post
Share on other sites
Hello!

USBAudio still does not work!

I found a USB Prober application earlier versions of Xcode.

I have attached results generated by the program to see if it will help you find the cause of the problem!

 


 

Thank you in advance for your help!

post-1166679-0-30440300-1481050618_thumb.png

post-1166679-0-06647400-1481050620_thumb.png

USB Bus Probe.txt

Share this post


Link to post
Share on other sites

Hey guys,

 

Help me, my pc is:

 

GA 990 FX-GAMING / AMD Phenom II X4 945 / 8 GB / 2 x NVIDIA GeForce GTX 550 TI 1GB - SLI

 

Thanks,

Share this post


Link to post
Share on other sites

How can I help you? What are your problems?

Share this post


Link to post
Share on other sites

 

Hi folks,
I see it as appropriate, when we talk here about the USB problems that arise when installing El Capitan on intel/AMD Hackintosh, or my approach to use Yosemite kext drivers to fix the USB problems.
 
the first attempt V1, was for me the proof that it is the right way, the packet V2 has ultimately convinced me that it works. I do not need to patch any DSDT and all USB drives/ Ports operate as they have previously worked with Yosemite.
 

 

 

The dowload page seems down.

Share this post


Link to post
Share on other sites

Finish the installation of El Captain without problems, restart automatically; not boot, not in the Enoch menu to choose the hard drive, verify that the files are on the hard disk, help me

Share this post


Link to post
Share on other sites

The dowload page seems down.

first save your S/L/Extensions folder and use an unchanged S/L/Extensions folder.

Then install this content of the USB-Fix package and generate a new prelinked kernel.

If the system should stops after starting with a panic message, with various problimatic

Extensions, so upload a picture with the Panic message.

Finish the installation of El Captain without problems, restart automatically; not boot, not in the Enoch menu to choose the hard drive, verify that the files are on the hard disk, help me

First of all write your hardware in ur signature. Then describe your problem,

If you find it difficult to describe this problem in English, so write it in your language.

if necessary add a pictures or bug reports

USB-Fix.zip

Share this post


Link to post
Share on other sites

Hello,

 

My problem is not to boot after completing the installation of El Capitan, 

 

1. I select the HDD where El Capitan installs, IMG_0700_.jpg

2. Show the message Reboot and Select proper Boot device, IMG_0701_.jpg

3. I select the USB installation, IMG_0702_.jpg

4. Does not show El Capitan HDD, IMG_0703_.jpg

5. Start the installation to repair disk, IMG_0704_.jpg and IMG_0705_.jpg

6. Repair disk OK, but not boot, IMG_0706_.jpg and IMG_0707_.jpg and IMG_0701_.jpg

 

Help me please, 

 

 

GA 990 FX-GAMING / AMD Phenom II X4 945 / 8 GB / 2 x NVIDIA GeForce GTX 550 TI 1GB - SLI

post-2163146-0-06145400-1504358946_thumb.jpg

post-2163146-0-54151900-1504358952_thumb.jpg

post-2163146-0-91292400-1504359177_thumb.jpg

post-2163146-0-42430700-1504359191_thumb.jpg

post-2163146-0-19838600-1504359206_thumb.jpg

post-2163146-0-72613000-1504359215_thumb.jpg

post-2163146-0-83301500-1504359315_thumb.jpg

post-2163146-0-50151400-1504359326_thumb.jpg

Share this post


Link to post
Share on other sites
  1. start from the USB installer and format the hard drive with the Guid partions table, create two partitions with "Mac OS Extended journaled", then install El capitan on the first partition.
  2. install Enoch Bootloader into El Capitan partition and add the amd kernel into /System/Library/Kernels/
  3. Then replace the contents of my Extra folders in yours
  4. Then add the content of the USB-FIX package into S/L/E
  5. and finally restart your system

(all files can be found in Archiv.zip)

Archiv.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By Funky frank
      Hi,
       
      I am planning to make my hack ready for post High Sierra macos, finally xD  So I was looking for a proper AMD GPU, but it is not that easy to find a proper, recent guide for that. So compared a bunch of AMD GPUs, and this one seems to suit my needs the most: XFX RX 5500 XT Thicc II Pro 8GB
       
      Will this graphics card work properly in macos? And what macos version is the minimum here? I read so many contradictory statements, some older said that the RX5xxx support in macos still sucks and is much slower than in Windows. Is this still true? I currently have a nvidia GT1050, I guess it still will beat that nvidia card?
       
      Would this work with old but gold clover (recent version) + lilu and whatevergreen, or should I switch to OpenCore then?
       
      Thanks for info!
       
    • By sapnupuas69
      hello everyone, so my Intel HD 530 is not getting recognised by macOS. In the about my mac section, it shows as 'Display 7mb'
      Im using HDMI connected to motherboard. I can only boot into os with 0x12345678 or 0x193b0005 as Fake Id and 0x19120000 as platform id with Mac17,1 as smbios. I do have the latest version of Lilu and WhateverGreen installed in boot loader and in L/E too. 
      I have looked through many forum posts, and have not found a solution yet. 
       

      edit: i forgot to change the smbios in the picture, I tried changing to 17,1 and restart, still no luck
      EFI.zip
    • By MaLd0n
      First...
      If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By poisson-myfish
      So I have some less powerful hardware, that's why I'm installing High Sierra in 2020. Anyway, I'm trying to boot from the USB and I get the following errors:
      00:000 00:000 OCB: Missing DMG signature, aborting 00:585 00:585 OCB: LoadImage failed - Unsupported That's it. The logs begin and end there. The rest of the file is zeroes.
       
      Bootloader: OpenCore 0.5.9 Release
      Drivers:
      HfsPlus.efi
      OpenRuntime.efi
       
      Kexts:
      AppleALC.kext
      Lilu.kext
      RealtekRTL8111.kext
      SMCBatteryManager.kext
      SMCLightSensor.kext
      SMCProcessor.kext
      SMCSuperIO.kext
      VirtualSMC.kext
      WhateverGreen.kext
       
      ACPI:
      SSDT-EC.aml
      SSDT-HPET.aml
      SSDT-PLUG.aml
      Note: I used SSDTTime to make the DSDT dumps for this exact computer
       
      Hardware:
      Intel Core i3 (Haswell)
      An Intel VGA-Compatible Haswell iGPU
      An nVidia Geforce 920m GPU (part of the reason for installing High Sierra)
      USB: Intel 8 Series USB xHCI HC
      SATA: Intel 8 series SATA Controller
       
      If you need more details, here's my laptop https://www.asus.com/Laptops/X540LJ/ . I have the 512GB version with 4GB of RAM
       
      I found a lot of forum posts about people having the same error, except nothing solved mine. Also, I haven't found anything online about the error with the Missing DMG Signature.
       
      EDIT: If anybody needs my config.plist, feel free to ask for it and I'll happily post it
    • By ThomasMattOnline
      Hello Everyone,

      Trying to get Hardware Acceleration working on my Hackintosh (HEVC Support) however I am such a noob, OpenCore is very new to me and would love some support.
      I have included screenshots and the EFI that is currently working on my System, I have USB 2 & 3.0 all working, however, the only thing I can fault is my GPU not being hardware acceleration enabled.

      Final Cut Pro X - Recognises GPU
      VideoProc - Doesn't recognise anything.
       
      (I am running the latest version of OpenCore 0.5.9)

      Things I've tried: I tried following the post https://www.tonymacx86.com/threads/catalina-10-15-2-update-lost-hevc-h265-acceleration.288563/ - No Luck
      I have also tried: https://forums.macrumors.com/threads/activate-amd-hardware-acceleration.2180095/page-53?post=28255048#post-28255048 - No luck either!

      My friend online tells me I shouldn't need such Kext as he has the same build as me but when I load his EFI on my system it boots with no USB 2 or 3.0 (I'm keeping his EFI off here as I've uploaded mine.)

      Please note: I appreciate all (any) pieces of advice and please do bear in mind that I am a noob and may need whatever you say simplifying as I can get easily confused.


      config.plist

×