Jump to content

Malformed images (including wallpaper)


9 posts in this topic

Recommended Posts

Hi there,

 

Before everything, my specs:

CPU: AMD Phenom II X4 965 Black Edition

MB: Gigabyte 970A-D3 rev. 1.1

GPU: MSI N550GTX-Ti Cyclone II 1GB GDDR5

RAM: 8GB 1600MHz Kingston HyperX X2 Grey Series

 

I have question. I installed Yosemite Zone (yeah, I know, a distro, but I am newbie on AMD system and for my learning how Hackintosh work...) and sucessfully installed Nvidia Web Drivers. I have FullHD, QE/CI, booting without GE=Yes, functional dual monitor setup, with device-properties i correct VRAM (without this my system show, that I have 1.5GB, but this card have only 1GB), games and videos run smoothly.

But there is three problems:

1. Cannot take screenshot with default Mac screenshot app (with CMD+Shift+3 it take screenshot, save it on desktop, but the file is just white image, nothing in it)
2. Some images are malformed (as can be seen in attached files)

3. Some icons in Launchpad are white (as can be seen in attached files, does not matter if it is in Launchpad root or in folder)

I tried googling, trying, reinstalling, with/without nvidia drivers, with nv_disable=1.

Can someone help me please?

 

PS: Sorry for my english...

post-1213744-0-95579400-1452736870_thumb.png

post-1213744-0-28535200-1452736893_thumb.png

post-1213744-0-12513900-1452736902_thumb.png

Hi there,

 

Before everything, my specs:

CPU: AMD Phenom II X4 965 Black Edition

MB: Gigabyte 970A-D3 rev. 1.1

GPU: MSI N550GTX-Ti Cyclone II 1GB GDDR5

RAM: 8GB 1600MHz Kingston HyperX X2 Grey Series

 

I have question. I installed Yosemite Zone (yeah, I know, a distro, but I am newbie on AMD system and for my learning how Hackintosh work...) and sucessfully installed Nvidia Web Drivers. I have FullHD, QE/CI, booting without GE=Yes, functional dual monitor setup, with device-properties i correct VRAM (without this my system show, that I have 1.5GB, but this card have only 1GB), games and videos run smoothly.

 

But there is three problems:

1. Cannot take screenshot with default Mac screenshot app (with CMD+Shift+3 it take screenshot, save it on desktop, but the file is just white image, nothing in it)

2. Some images are malformed (as can be seen in attached files)

3. Some icons in Launchpad are white (as can be seen in attached files, does not matter if it is in Launchpad root or in folder)

 

I tried googling, trying, reinstalling, with/without nvidia drivers, with nv_disable=1.

 

Can someone help me please?

 

PS: Sorry for my english...

It is an OpenCL issue with your graphics card or its drivers...

This is why Distros are bad... I assume you'r using the AMD kernel that came packaged with the DMG. Use this one instead,

 

http://www.insanelymac.com/forum/topic/302075-amd-yosemite-kernel-testing-for-help-use-the-help-topic/page-72?do=findComment&comment=2163808

 

Copy it to System/Library/Kernels and replace the current one. 

Yes, I know, now I am trying install El Capitan with vanilla method, for now without luck. Because I have legacy BIOS, without capability to handle EFI, so I am stucked with Chameleon (Enoch) bootloader.

I have 10.10.1 version now on my distro, so I dont think that kernels for 10.10.2 and newer will work.

Oh god, you are genius! That kernel repair screenshots, images and launchpad icons. Only thumbnails in folders are malformed and some wallpapers...


Oh, I think it is just something with chache, because when i copy whole folder with Desktop Pictures to the desktop and set the wallpaper from this folder, it is fine. Well, that is nice! You are my god :) And for my learning, never trust distros and their kernels... Thank god :)

  • Like 2

Well I think I will not update this distro, because as you said, distros are bad and when something happened, I will be pretty screwed. Next time I am going to try clear vanilla method with kernels from here... Thank you for your help, I really appreciate it :)

  • Like 1
×
×
  • Create New...