Jump to content
Sign in to follow this  
Followers 0
markuslagan06

(Need Assistance) El Capitan on Gigabyte Z170X Gaming G1, i7 6700k, 64gb 2400 Geil Dragon, GTX Titan X

10 posts in this topic

Recommended Posts

I have seen successful installation of El Capitan on z170x g7 with skylake but I cannot manage to setup final my hackintosh after fresh installation of El Capitan.

 

My build:

Gigabyte Z170X Gaming G1, Socket 1151 Bios F6

GTX Titan X 12 gb

64gb Geil Dragon Ram (16gbx4)

i7-6700k 4.0 ghz Skylake

3TB Seagate Sata

 

Accomplishments:

Configured the bios to make El Capitan USB Installer bootable from scratch.

Able to create bootable usb using Clover

Patch kext but I don't know which ones are important and/or necessary

Able to boot from the HD with El Capitan with usb

Working Audio

Working USB, 3.0 not checked

Bluetooth works

 

 

Problems:

Display is showing but in lowest resolution (so slow)

Wifi not working

I have no proper DSDT, AML for my mobo.

Don't know which set of kexts would be appropriate and necessary.

 

Anyone, please help. Attachment of their dsdt and kexts for the same would be appreciated.

I'm just an average user of hackintosh. Please give me a guide, thanks.

 

 

Note: I have successfully installed El Capitan in my old build: Gigabyte EP35-DS3R, QuadCore 775 Intel 2.5ghz, 8gb ram, 80gb seagate, msi 9600gt with no problems and all are working.

Share this post


Link to post
Share on other sites
Advertisement
here is everything described in detail along with files for download:


then create your own DSDT, then it should work.

Share this post


Link to post
Share on other sites

 

here is everything described in detail along with files for download:
then create your own DSDT, then it should work.

 

will try now. thank you so much.

Share this post


Link to post
Share on other sites

still didn't went well.

currently unable to boot and messed up everything.

dunno what's the workaround for post installation of GTX Titan X to be functional.

I manage to install El Capitan in EP35-DS3R with ease and flawlessly with Nvidia 9600GT.

 

repeating now all the process from start.

 

Is GTX Titan X compatible? need help badly. thanks.

Share this post


Link to post
Share on other sites

at the first start, boot with: nv_disable=1,  after installation of El Capitan and Nvidia WebDriver / Cuda driver then boot with: nvda_drv=1

Share this post


Link to post
Share on other sites

For  install/get in first with boot with nv-disable=1 but inject the first two nvidia checkboxes in clover boot (hit spacebar).

Share this post


Link to post
Share on other sites

has anyone have dsdt for gigabyte z170x gaming g1?

I'm having trouble how to make own dsdt. i really dunno how.

 

Had finally installed el capitan 10.11.3 but having difficutly with the ga gtx titan x to work.

-had nv_disable=1, then installed the latest nvdia driver.

-boot with nvda_drv=1 will result to black screen.

-edited the applegraphicscontrol and changed appropriate assignment to none.

-when booted, the nvdia control setting returns back to osx default graphic setting.

 

 

nv_disable=1, will have glitches at start and low reso.. Anyone please provide me guide.

thanks.

 

os: el capitan

mobo: gigabyte z170x gaming g1

ram: geil 64gb

vid: gigabyte gtx titan x

sata hd

 

will other (ga z170x g3, g7, g5) config.plist work for my setup/board? is this the same for dsdt?

what does macvidz flashing with their cards mean?

Share this post


Link to post
Share on other sites

Finally! Here's how I resolved the issue without removing the graphic card.

Bec. I knew how close I am to the finish line before getting black screen not without nv_disable=1

 

 

Download the latest El Capitan 10.11.3

Download the latest Nvidia Graphic Driver

Create bootable usb

Boot clover with nv_disable=1

Install the OSX

Install the latest Nvdia graphic driver provided for 10.11.3 El Capitan

Edit the AppleGraphicsControl.kext which is located at

 

/System/Library/Extensions/AppleGraphicsControl.kext

/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist
 

My board-id appears to be iMac17,1 in the config.plist

SMBIOS:

Find these lines and replace it's entry to "none"

 

"Mac-B809C3757DA9BB8D" or

"Mac-65CE76090165799A" or

"Mac-DB15BD556843C820"

 

Rebuild the kext using kextutility tool.

Reboot with nvda_drv=1

Then that's it!

 

Edited by markuslagan06

Share this post


Link to post
Share on other sites

USB 3.1 working well?

and how about thunderbolt?

 

Finally! Here's how I resolved the issue without removing the graphic card.

Bec. I knew how close I am to the finish line before getting black screen not without nv_disable=1

 

 

Download the latest El Capitan 10.11.3

Download the latest Nvidia Graphic Driver

Create bootable usb

Boot clover with nv_disable=1

Install the OSX

Install the latest Nvdia graphic driver provided for 10.11.3 El Capitan

Edit the AppleGraphicsControl.kext which is located at

 

/System/Library/Extensions/AppleGraphicsControl.kext

/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist
 

My board-id appears to be iMac17,1 in the config.plist

SMBIOS:

Find these lines and replace it's entry to "none"

 

"Mac-B809C3757DA9BB8D" or

"Mac-65CE76090165799A" or

"Mac-DB15BD556843C820"

 

Rebuild the kext using kextutility tool.

Reboot with nvda_drv=1

Then that's it!

Share this post


Link to post
Share on other sites

Ok, I've been trying to get an El Capiitan install on my system for months, I have tried several methods to get it done, but no joy.  I'm at the point of giving up entirely, almost.  I even spent about $2000 on i new Skylake based build, only to find out that it's not as easy to do as I was lead to believe.  I will post my system specs below I have El Cap kind of installed using VMWare, it works, but that's not what I want.  I want a fully functional dual boot setup, Win 10 for gaming and other stuff, and OS X for development, vid editing and such.  I used several version of USB creation programs, but none of them has worked to create a working USB installer, they get to a certain point in the installer's boot sequence, then go into a never-ending loop, forcing me to hit the reset button.  Not a good outcome...  Can i get a bit of guidance as to what I'm doing wrong?  Maybe what boot flags i need and installer advice?  I'm a newbie at this, but I am rather competent w/ computers. in general.  I can install any version of Linux or Windows, but OS X has so far eluded me.

 

My specs:

 

CPU: Core i7-6700K Skylake

Motherboard: Gigabyte GA-Z170x-Gaming 7

RAM: 32 GB Corsair Vengeance DDR4 2666

Storage: 1 Samsung 850 EVO M.2 SSD 500 GB, 1 Samsung 850 EVO 2.5" SSD 500 GB and 1 WD BLACK HHD 3 TB

Graphics Card: EVGA NVIDIA GeForce GTX 980

CPU Cooler: Corsair H110i liquid cooler (if that's necessary)

Power Supply: Corsair RM850 850 WATT (if that's necessary)

 

My motherboard has 2 NICs, 1 Intel I219-V and Killer e2400 Gigabit.  I'm connected to the Killer, if that matters.

 

Any advice would help.

Thanks from a disabled computer nerd!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
      GLASGOOD'S
       
      MOJAVE HACKINTOSH GUIDE 
       

       
       
       
      **FOR**  GIGABYTE Z390 AORUS PRO
       
       
       
       
      CREDITS & THANKS
       
      @MaLd0n
      His help with EFI configuration and DSDT
       
      CLOVER  TEAM
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, rehabman, Download-Fritz, Zenit432, cecekpawon Et al
       
      APPLEALC
      Acidanthera, vit9696
       
      VOODOOHDA
      autumnrain, slice2009, zenith432
       
      ESP PRO MOUNTER
      @Micky1979 
       
      HACKINTOOL
      @headkaze
       
      CLOVER CONFIGURATOR
      Mackie100
       
      THEME ENGINE
      Alex Zielenski
       
      INSANELYMAC
      OLARILA
       
      Hackintool Tutorial
      daliansky
       
      Hackintosh Vanilla Desktop Guide
      /r/Hackintosh - corpnewt
       
       
      MONITORCONTROL
      JoniVR & theOneyouseek
       
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
      UPDATES
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      PART LIST
       
      • Intel I7 8700 
      • Gigabyte Z390 AORUS PRO
      • Gigabyte AORUS RADEON RX 580 8GB ( connected to monitor with DisplayPort )
       
      • Corsair Vengeance LPX 16GB ( 2 x 8GB ) 2666MHz – CMK16GX4M2A2666C16  In this build, both memory modules are installed in memory slots DDR4_A1  and DDR4_B1 
       
      • Corsair RM650x 80 Plus Gold Power Supply Unit
      • Corsair H100i V2 AIO Hydro/Water RGB LED CPU Cooler
      • Samsung EVO 500GB SSD (2.5) macOS Mojave
      • Samsung EVO 250 GB SSD (2.5) Windows 10 Pro
      • NZXT H500 Mid Tower ATX Case
       
      • RECOMMENDED WIFI CARD → ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS  
      OR
      • WIFI and Bluetooth with BCM94331CD with PCI-e adapter (but will require AirportBrcmFixup.kext for AirDrop.. )
       
      ** Avoid Samsung EVO 970 PLUS as Hackintosh has problem with that device **
       
       
      WORKING
       
      • Sound 
      • HDMI Port on AMD RX580 / 590 ( Ensure you disable BIOS CSM if using HDMI on RX580 / RX590 )
      • HDMI Port on Aorus Z390 Motherboard ( Ensure you have correct BIOS settings as per this guide for Intel only)
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Handoff
      • Continuity
       

       

       
       
       

       
       
       
       
       
      PREAMBLE - BEFORE YOU START 
       
      Here detailed, is all the  steps towards building a successful and stable Aorus Pro Z390 Hackintosh, if you are a first time Hackintosher, this guide will have you quickly up and running with the Aorus Pro Z390 Hackintosh. To rule out any problems from the go,
      only have the disc that you plan to install macOS Mojave connected to the Aorus Pro, disconnect any other Windows / Linux or data drives, external drives from your Aorus Pro. Windows / Linux and data drives can be connected after successful installation of macOS Mojave
      If you have more than 16 GB of memory, then install macOS Mojave with just 16GB, you can later add any additional memory. Install memory modules in slots DDR4_A1  and DDR4_B1. This build has the Wi-Fi combo PCI-e adapter card installed in slot PCIEX1_3.
      The WiFi/Bluetooth PCI-e Combo card used in this Aorus Pro guide has it's 9 pin USB cable attached to motherboard header F_USB2 and is enabled in SSDT-UIAC.aml ( USB ports fix ). 
       
      Do install macOS Mojave on its own physical drive, so do not try and install macOS Mojave onto a free partition on a disc that contains Windows.
      Remove any Thunderbolt cards, Thunderbolt card can be reinserted after installation.  Double check your BIOS settings are the same as this guide. 
       
      Following are unsupported / problematic
       
      • Intel Optane ( if you have this, remove it before installation of macOS Mojave )
       
      • Samsung EVO Plus drives ( firmware problem with macOS )
       
      • XFX Radeon RX 580
       
      • NVIDIA GTX / RTX not supported in macOS Mojave
       
      • Fenvi T919 Wireless Card, it seems Bluetooth is not working out of box for some users ( Maybe the USB port attached to Fenvi bluetooth is wrongly configured, or the SSDT-UIAC.aml port connector was not configured as Internal, or maybe some other reason )
         Save yourself a headache --->  RECOMMENDED WIFI CARD WORKING OUT OF BOX (OOB)  is ---> ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS 
       
       
       
      Q - WILL THIS GUIDE WORK WITH MY NON AORUS Z390 MOTHERBOARD ?
      A - Possibly may work with other Z390 chipset motherboards, but you will have to remove SSDT-UIAC.aml from Clover / ACPI / patched from the PRE-INSTALL EFI and enable the ports limit patch.
       
      Q - I notice you have the Aorus Pro Z390 version, will this guide work with Aorus Pro Z390 WiFi version ?
      A - Yes, but onboard Intel / Intel CNVi WIFII /Bluetooth will not work with macOS and you will have to disable HS14 for Bluetooth to function properly on BCM943602CS or BCM94331CD WiFi/Bluetooth Combo cards ( more info at bottom of guide) .
       
       
       
       
       
       
      PART 1 - DOWNLOAD 
       
       
      Download the following:
       
      • CLOVER
       
      • PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip
       
      • POST-INSTALL Aorus Pro Z390 EFI - RX580.zip 
       
       
       
       
       
      // INTEL UHD 630 EFI  Aorus Pro Z390 EFI's below. For those who do not have a Graphics Card Installed in PCIe Slot, requires Initial Display Output BIOS setting to be changed to IGFX  spoiler below!
       
      •  PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip
       
      • POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip
       
       
       
       
       
      • ESP MOUNTER PRO v1.9
       
      • macOS MOJAVE 
       
      • CLOVER CONFIGURATOR
       
      • EmuVariableUefi-64.efi  ( Used only to initialise iMessages. It then must be removed from Clover drivers64UEFI folder as will cause intermittent memory allocation errors on boot, explained in guide)
       
       
      OPTIONAL DOWNLOADS
       
      • Native Display Brightness with MonitorControl
       
      • VoodooHDA.kext.zip 

      • ThemeEngine 
       
      • Assets.car 
       
       
      // Not really needed but IF no sound on Wake from Sleep then use SSDT-ALC1220 and CodecCommander
      • SSDT-ALC1220.aml  ( Resolves Audio Sound on Wake, place in Clover / ACPI / Patched )
       
      • CodecCommander.kext.zip ( Resolves Audio Sound on Wake, place in Clover / Kexts / Other )
       
       
       
       
      PART 2 - BIOS SETTINGS (version F9 )
       
       
      Here is a list of the BIOS settings that I have used ( Screenshots in spoiler below )
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Enabled
      • Chipset → Internal Graphics → Enabled
      • Chipset → DVMT Pre-Allocated → 256M
      • Chipset → DVMT Total Gfx Mem → MAX 
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → ErP → Disabled
      • Power → RC6 (Render Standby) → Disabled
       
      // IF USING  CORSAIR H100i V2 AIO CPU WATER COOLER 
      • MIT → Smart Fan 5 Settings → CPU Fan Control mode → PWM 
       
      • Save & Exit → Save & Exit Setup
       
      SCREEN DUMP SPOILERS
       
       
       
       
       
      PART 3 – CREATE A MOJAVE USB FLASH INSTALLER
       
      Prepare USB Installer for Mojave ( Video below )
       
      • Insert USB drive
      • Launch /Applications/Utilities/Disk Utility
      • Disk Utility → View → Show All Devices
      • On Left-hand panel → External →(Identify your USB device in left hand panel)
      • Click and highlight your USB device in the left-hand panel.
      • Click erase button.
      • Name: USB
      • Format: Mac OS Extended (Journaled )
      • Scheme: GUID Partition Map
      • Click Erase button.
       
      • Place the downloaded MacOS Mojave app into Applications folder.
      • Open Terminal copy and paste:
       
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --nointeraction && say Mojave Drive Created  • Enter
       
       
       
       
       
       
       
       
       
       
       
      PART 4 – INSTALL CLOVER ON THE MOJAVE USB INSTALLER 
       
      Make Mojave USB flash drive installer bootable.( Video below )
       
      • Launch Clover application, double click.
      • Click Continue → Continue → Continue 
      • Click Change Install Location button.
      • Click Install macOSMojave USB installer → Continue
      • Click Customise button
      • Choose:
      Clover for UEFI booting only Install Clover in the ESP Themes UEFI Drivers • Click Install button
      • Installation Complete!
       
      Video:
       
       
       
       
       
       
      PART 5 – CUSTOMIZE MOJAVE USB INSTALLER FOR AORUS Z390 PRO
       
      Replace Clover EFI folder with PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip  OR  if NO graphics card installed in PCIe slot, then use PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip( Video below ) 
       
      • Install ESP Mounter Pro v1.9
      • Using ESP Mounter Pro, Mount ESP on disk2s1 ( Your disk name may be different )
       

       

       
       
       
      • Open mounted EFI partition found on desktop
      • Copy all the contents from Aorus 390 Pro EFI folder
      • Replace USB EFI folder with all the contents inside the Aorus 390 Pro EFI folder.
       
       

       
       
       
       
       
       
       
      PART 6 – INSTALL MAC OS MOJAVE ON INTERNAL DRIVE
       
      INSTALL NOTE
       
      ENSURE BIOS: Above 4G Decoding is set to Disabled 
      if Above 4G decoding is set to enabled then macOS Mojave install will freeze at 2 mins remaining and will not shut down properly!!!!
       
      Please be patient during install, so when install gets to 2 or 3 mins remaining then it may take extra time. Be ready to boot from UEFI USB installer by pressing F12 when install initiates restarts. 

      • INSERT USB INSTALLER INTO THE USB 2.0 PORT  
       
       
       Here is a walkthrough of the full process using the macOS Mojave USB Installer on the Aorus Z390 Pro. 
       
       
       
       
      • Power on PC and press F12• Choose bootable USB drive from boot menu.
       
       
       
      • Install macOS Mojave to internal solid state or hard drive.
       
       
       
      When system returns to the Clover boot menu choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      At next restart, press F12 and boot from external UEFI USB device and choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      Proceed with macOS Mojave install
       
       
      macOS Mojave is now installed, but it can only boot at this moment thanks to FakeSMC and Clover on the Mojave USB flash drive installer.
       

       
       
       
       
       
       
      PART 7 – MAKE AORUS Z390 PRO INTERNAL DRIVE BOOTABLE
       
      Make internal drive bootable ( Video below )
       
      So far, the Aorus Pro can only boot the internal system drive with the aid of the Mojave USB Installer.
      To boot from the internal system drive without the installer: 
       
      Download and install Clover with RC Scripts on target volume.  
      If your Aorus Pro Z390 has AMD RX 580 then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - RX580.zip  folder and paste it inside the the System Drive EFI partition.          OR
      If your Aorus Pro Z390 has no graphics card installed in PCIe slot, then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip  folder and paste it inside the the System Drive EFI partition.   
       

       
       
       
      • Remove USB Mojave installer and shut down and restart.
       
      Aorus Hackintosh should now be able to boot to macOS Mojave, Done, well almost ! 
       
       
       
       
       
      PART 8 – ENABLE IMESSAGES & FACETIME 
       
       
      // UPDATE 21st MAY 2019
       
      Past experience suggests Clover Configurator now automatically populates correct values for working iMessages when you select an SMBIOS.  
       

       
      After selecting SMBIOS, example iMac19,1 for Aorus Pro with RX580 ( image above ) then go to Apple and ensure you have the "serial number is not valid " message. Done!
       
      If you still have problems connecting to iMessage, test and ensure that AirDrop is working, then follow instructions inside spoiler. 

       
       
      • Mount internal drive EFI/ESP partition
      • Go to folder CLOVER → drivers64UEFI 
      • Place both EMUVariableUefi-64.efi inside → drivers64UEFI
       
       
      Using Clover Configurator, add the following argument to config.plist using Clover Configurator.
       
      • Slide = 0
       

       
       
      Shutdown and then press power on button on PC.
       
      • You should now be able to Log into iCloud, iMessages and FaceTime
       
       
       
      • NOW delete EMUVariableUefi-64.efi from CLOVER → drivers64UEFI Folder 
      • Shutdown and restart Aorus Pro hackintosh. iMessages etc is now operational without EMUVariableUefi-64.efi ( EMUVariableUefi-64.efi only needed to initialise iMessages )
       
       
      // UPDATE 22nd May 2019 
       
      • It seems that there are no "Couldn't allocate runtime area"  errors when continuing to use EMUVariableUefi-64.efi since updating to macOS Mojave 10.14.5 and using Clover version r4920. 
      • It is important to delete EMUVariableUefi-64.efi, this will avoid very intermittent boot errors such as: “Couldn’t allocate runtime area”  post errors.
       
       
       
       
      PART 9 – ENABLE TRIM for Solid State Flash Drives
       
      Open Terminal and enter the following command:
      sudo trimforce enable  
       
       
       
       
      DEFAULT SSDT –  USB PORTS FIX CONFIGURATION WITH FRONT USB-C - SSDT ALREADY INSIDE AORUS Z390 EFI FOLDER  – Provided by @AudioGod 
       
       

       

       
      If you have USBC on Computer Chassis / Case, then SS01 and SS02 is mapped to that USB C port 
       

       
       
       
       
       
       
      ------------    GUIDE FINISHED YOU SHOULD NOW HAVE WORKING AORUS Z390 PRO HACKINTOSH  WITH SSDT USB FIX   ------------
       
       
       
      OPTIONAL: Set Wi-Fi Country Code
       
       
       
       
       
       
      OPTIONAL: System Information - PCI
       
       
       
       
       
       
       
      OPTIONAL:  Enable HDMI Audio on RX580
       
       
       
       
       
       
       
      OPTIONAL:  Native Display Brightness - with MonitorControl

       
       
       
       
       
       
      OPTIONAL:  Dual Boot macOS Mojave & Windows 10 
       
       
       
       
       
       
       
       
      OPTIONAL:  Replace the default "About This Mac" Apple Logo with RED AORUS APPLE
       
       

       
       
       
       
      OPTIONAL - ALTERNATIVE SSDT 1 –  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 2 -  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 3 – Create your own SSDT
       
       
       
       
       
      FRAMEBUFFER PATCHING  – For working Intel UHD 630 Graphics, working HDMI Port, working HDMI Audio on Aorus Z390 Pro
       


       
       
       
       
       
       
      AORUS PRO Z390 WIFI version with Intel CNVi  – Disable Bluetooth on HS14
       
      Resolve bluetooth issue  reported by @eSaF 
       
       
       
       
       
       
      CLOVER  – Updating / Upgrade Clover boot loader 
       
       
       
       
       
      RECOMMENDED READING  – Excellent Hackintosh Vanilla guide created by CorpNewt with in depth tutorial on Clover.  
       
      https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/config.plist-per-hardware/coffee-lake
       
       
       
       
       
       
       
      FOR MORE HACKINTOSH INFORMATION SUCH AS USB PORTS FIX, CLOVER CONFIGURATOR, HACKINTOSH BACKUP WITH CARBON COPY CLONER .....   THEN SEE MY PREVIOUS GUIDE FOR ASUS Z370-G Strix
       
       
       
       
       
       
       
       
       
       
       

       
       
       
       
       
       
       
       
      SSDT-UIAC.aml.zip
      SSDT-UIAC.dsl.zip
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By Candrahm
      Hi everybody,
       
      I'm new here and French. 
      I success to hack my Asus X751LJ and pass it to High Sierra 10.13.6, not easily, and everything works except the keyboard and the touchpad.
      I tried VoodooPS2Controller, ApplePS2SmartTouchpad, even VoodooI2C, but nothing works...
      Could someone help me? Is there a DSDT problem? Witch kext should I use?
      I post my ACPI and Kexts folders and my IOReg.
      Please... Help me. I'm desperate...
      MacBook Pro de Candrahm.ioreg
      Archive.zip
    • By Ten2Pwr6
      I've read a a bunch of threads from folks with the HP ProBook 470 G5... wanted to ask how things went or are going with their 470 G5.  I've just bought one and was thinking of putting High Sierra on a separate SSD drive... could you share your experience.
      ...24 hours later...
       
      I went ahead and bit the bullet. I had an extra SSD drive with High Sierra already on it... seems like it's the UHD 620 giving folks a lot of headaches.  I read a bunch of threads and spent at least 8 hours or more trying THIS and trying THAT... I really didn't have much success.  Then I found a thread regarding the UHD 630 and it helped a lot... Google " Guide - Native Intel UHD630 Graphics support in macOS 10.13.6"
       
      The SSD was installed with 10.13.1 ... so, I updated it to 10.13.6, and I used the 15,2 profile. NOTE: I wasn't able to install the Supplement Update (10.13.6) #1 or #2 ... probably because the drive doesn't have a recovery partition.  I looked at the pkg and sure enough it has a payload for the Recovery Partition... I'll work on that another time.

      Regardless though, success finally.   I'm able to boot into High Sierra (10.13.6) with laptop's screen. I am still doing some tweaking.   It's says Graphics Display 7 MB, and it's lagging.

      Resolution: 1920 x 1080 (1080p FHD - Full High Definition)
      Framebuffer Depth: 24-Bit Color (ARGB8888)
      Main Display: Yes
      Mirror: Off
      Online: Yes
      Automatically Adjust Brightness: No


      I'll mess around some more and report back when I fix some more stuff.   Oh, apparently I have the Realtek card and not the Intel one... looks like the G5 has 4 different offerings. Who Knew? LoL.

      Cheers.    
       
    • By End3rPower50
      Hi, i've installed on my pc MacOS Mojave but after installation my pc, sometimes, crash giving kernel panic.
      I came to the conclusion that it is a random kernel panic because sometimes it starting up and other times it isn't starting up
       
      My PC:
      CPU: Intel i7 6500U
      LAN: RTL8100
      Wi-Fi & Bluetooth: Dell DW1820A
      USB 3.1
       
      CLOVER.zip
×