Jump to content
spakk

[AMD] OS X El Capitan (10.11) Kernel Testing & Release (for help use the Help Topic)

1,259 posts in this topic

Recommended Posts

Anyone else having trouble with some pkg installers failing and simple apps not opening. Getting this error alot in crash logs,

Crashed Thread:        5  Dispatch queue: com.apple.root.user-interactive-qos

 

Yes. Adobe Flash Player installer for instance crashes everytime I try to launch it :

 

 

 

Process:               Install Adobe Flash Player [764]
Path:                  /Volumes/VOLUME/Install Adobe Flash Player.app/Contents/MacOS/Install Adobe Flash Player
Identifier:            com.adobe.InstallAdobeFlashPlayer
Version:               2.0.0.65s (2.0.0.65s)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Install Adobe Flash Player [764]
User ID:               501
Date/Time:             2015-12-10 23:20:44.558 +0100
OS Version:            Mac OS X 10.11.2 (15C50)
Report Version:        11
Anonymous UUID:        768029B8-C2C7-3E60-AE31-7D51EA7F503C

Time Awake Since Boot: 6300 seconds
System Integrity Protection: enabled
Crashed Thread:        2  Dispatch queue: com.apple.root.user-interactive-qos

 

 

 

[EDIT] Same with TextWrangler :(.

 

 

 

Process:               TextWrangler [806]
Path:                  /Applications/TextWrangler.app/Contents/MacOS/TextWrangler
Identifier:            com.barebones.textwrangler
Version:               5.0.2 (3786)
App Item ID:           404010395
App External ID:       814415319
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           TextWrangler [806]
User ID:               501

Date/Time:             2015-12-10 23:28:32.032 +0100
OS Version:            Mac OS X 10.11.2 (15C50)
Report Version:        11
Anonymous UUID:        768029B8-C2C7-3E60-AE31-7D51EA7F503C


Time Awake Since Boot: 6800 seconds

System Integrity Protection: enabled

Crashed Thread:        5  Dispatch queue: com.apple.root.user-interactive-qos

 

 

Share this post


Link to post
Share on other sites
Advertisement

I can never get the installer to the actual installer, all I get is the stuff Enoch shows pre-booting the actaull installer.

P.S. Thanks for likes.

 

no clover there?

Share this post


Link to post
Share on other sites

 

And you are correct !

 

rootless=whatever you want is useless since El Capitan DP3 (or was it DP4 ? Hum… can't remember).

 

CsrActiveConfig=103 (Chameleon) or CsrActiveConfig=0x3 (Clover in RtVariables) is good and also mandatory for everyone now.

Oh, and I forgot to say that you need kernel.plist file in Extra folder for Enoch (Chameleon is still not compatible with El Capitan) with this setting (minimum) :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>KernelBooter_kexts</key>
<string>Yes</string>
</dict>
</plist>

Guys, if you play with kernel source.... why not modify the relative function in place?? ..you can restore the load of the mkext too: 

 

KLDBootstrap::readPrelinkedExtensions

KLDBootstrap::readBooterExtensions

KLDBootstrap::readStartupExtensions

 

http://www.opensource.apple.com/source/xnu/xnu-3247.1.106/libsa/bootstrap.cpp

..and boot fast  ;)

 

 

I made an install drive with Createinstallmedia and I have the amd kernel in /Extra/Kernels/kernel and I boot with the neccasary bootflags for my machine + /Extra/Kernels/kernel but it doesn't seem to boot the amd kernel and reboots I'm using the latest enoch with csractive.

Yep, "createinstallmedia" load the kernelcache anyway ..no way to boot Vanilla

Edited by Micky1979

Share this post


Link to post
Share on other sites

hi, I'm new to hackintosh. is there any guide to build el capitan usb installer for AMD and using kernel from this topic?

 

found it, will try.

Share this post


Link to post
Share on other sites

The problem is really in the usb, try booting with this stick in the other amd pc - with legasy bios problem was similar until disabled usb2,3. This problem is gone, but the installer will not start for 30 minutes hanging on the <Warning> Endpointed through legasy launch (3) APIs. Please switch to XPC or bootstrap_check_in (): com.apple.bsd.dtrhelper

 
p.s. how to make a picture? jpeg does not accept = (

Share this post


Link to post
Share on other sites

 

The problem is really in the usb, try booting with this stick in the other amd pc - with legasy bios problem was similar until disabled usb2,3. This problem is gone, but the installer will not start for 30 minutes hanging on the <Warning> Endpointed through legasy launch (3) APIs. Please switch to XPC or bootstrap_check_in (): com.apple.bsd.dtrhelper

 
p.s. how to make a picture? jpeg does not accept = (

 

It refear to some Apple Helper Tool (com.apple.bsd.dtrhelper), and is a log that say to swicth to an XPC Server instead to use deprecated SMJobBless APIs.

No AMD related, and not a problem.

Share this post


Link to post
Share on other sites

Hello everyone! Well, I was able to boot installer!))) I have used clover 3326. I didn't used VoodooTSCSyncAMD.kext, only FakeSMC.kext and NullCPUPowerManagement.kext. Flags I've used: -v -f npci=0x3000 kext-dev-mode=1 rootless=0 (I know, someone said, that it is useless but still I have used that flag). Also when I've prepared usb installer with Clover Special Edition - there were already made some settings for El Cap, for example: BooterConfig=0x28 and CsrActiveConfig=0x67. And some kext patch for those USB problems I suppose... Anyway it works and perhaps I will install it today on my test partition. I've used 10110R2 kernel by y2k4u, thank you very much! Very good job!

p.s Now I've red about those BooterConfig and CsrActiveConfig, so it's the default settings to disable whole protection of making some changes to system folders and injecting unsigned kexts, am I correct? And I suppose that today kext-dev-mode and rootless flags are no longer needed?

 

upd. forgot to say, it's 10.11.2 installer...)

post-1484325-0-61690300-1449930869_thumb.jpg

Edited by ImmortalSoulL

Share this post


Link to post
Share on other sites

B)

 

Phenom /HD 6670 / motherboard no UEFI (GA78lmtusb3) works good but problem USBMassstorage and problem AppleRTC , the video is fluid  :rolleyes:

 

commmand terminal repair HDD if you please  :blush: , KP aléatoire  :worried_anim:

 

iCloud works ootb :)

 

flag :

 

<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>Lotus</string>
<key>AtiPorts</key>
<string>3</string>
<key>KernelBooter_kexts</key>
<string>Yes</string>
<key>KernelPm</key>
<string>Yes</string>
<key>KernelLapicError</key>
<string>Yes</string>
<key>KernelLapicVersion</key>
<string>No</string>
<key>KernelHasswell</key>
<string>No</string>
<key>KernelcpuFamily</key>
<string>No</string>
<key>KernelSSE3</key>
<string>No</string>
<key>Kernel Flags</key>

 

<string>npci=0x2000 GraphicsEnabler=Yes USBLegacyOff=Yes</string>
 
thantks polyzargone and Ermac , use Enoch 2795 :)
 
edit : repair but the kernel ? 
 
 
iMac-de-gils:~ gils$ sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /

WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.

Password:
	Permissions differ on "Library/Java", should be drwxr-xr-x , they are drwxrwxr-x .
	Repaired "Library/Java".
	User differs on "System/Library/Kernels/kernel", should be 0, user is 501.
	Unable to set owner & group on "System/Library/Kernels/kernel". Error 1: Operation not permitted
	Unable to set permissions on "System/Library/Kernels/kernel". Error 1: Operation not permitted
	User differs on "private/var/db/displaypolicyd", should be 0, user is 244.
	Group differs on "private/var/db/displaypolicyd", should be 0, group is 244.
	Repaired "private/var/db/displaypolicyd".

post-1093405-0-36727400-1449934819_thumb.png

post-1093405-0-05818100-1449934874_thumb.png

post-1093405-0-05252600-1449935184_thumb.png

post-1093405-0-88044200-1449938837_thumb.png

Share this post


Link to post
Share on other sites

Guys, unfortunately after the reboot I couldn't boot into the installer. Getting this USB problem every time I try to boot:

4ASli88.jpg?2


 
I have red that and that and no result.(( It's because with AMD motherboard is all different:

O42kxxK.png


 
I've tried to remove ports restriction, also I've tried to figure out how to add ports to DSDT, I even tried to use injector kexts, where I've deleted ports restriction and still no result. I've spent whole day to find the solution. Perhaps I'm doing something wrong, I don't know. Oh and by the way if you want to use clover, then you should install it on EFI partition, otherwise it will not boot! At least I couldn't boot, when I've installed clover in the same partition where installer was. I think I'll get same issue even with chameleon, maybe I'll try it later... If someone know how to solve this, please help.)
p.s. It's really strange, I was able to boot once, but then again this thing...

Share this post


Link to post
Share on other sites

repair kernel? :)

 

Yes repair with Extension , look 

 

Password:

    Permissions differ on "Library/Java", should be drwxr-xr-x , they are drwxrwxr-x .

    Repaired "Library/Java".

    User differs on "System/Library/Kernels/kernel", should be 0, user is 501.

    Unable to set owner & group on "System/Library/Kernels/kernel". Error 1: Operation not permitted

    Unable to set permissions on "System/Library/Kernels/kernel". Error 1: Operation not permitted

    User differs on "private/var/db/displaypolicyd", should be 0, user is 244.

    Group differs on "private/var/db/displaypolicyd", should be 0, group is 244.

    Repaired "private/var/db/displaypolicyd".

Share this post


Link to post
Share on other sites

El Capitan is fake !!!  :mad:

 

no repair Extension  , no repair kernel , update iTunes crash , mediaflashplayer crash , many Appli crash , usbmassstorage crash , etc.......... , chiot !!  :thumbsdown_anim:

 

return Yosemite

 

Ahahahah true...))

Share this post


Link to post
Share on other sites

@Gills there is no need to repair the kernel permission because is loaded by the bootloader when root is not existing yet...so no matter :)

 

euh ?? 

 

repair permission of El Capitan , the kernel works but très mal ,  AppleRTC patched no works (clearcmos atfer reboot) , voodooPState no works  (kp)   :( + UEFI motherboard AMD no works  :hysterical:

Share this post


Link to post
Share on other sites

If someone wants to try build a different kernel you can use this patch.

 

AMD Kernel.diff.zip

 

Edit: Also for people who wan't to try but aren't to sure how, http://shantonu.blogspot.co.uk/2015/12/building-xnu-for-os-x-1011-el-capitan.html

Share this post


Link to post
Share on other sites

Calling FX testers,

 

Attached is the AMD 10.11.0 kernel for FX CPUs.  I don't know if the FX kernel works since I don't have access to FX CPU, thus, making the FX kernel work is like shooting in the dark.

 

10110FxR1.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DoZe
      Hi :0)
       
      Hope As usual a perfect matching DSDT for this good Laptop.
       
      Regards, Ray
       
       
      SendMeStudiMac.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By kevin_1351
      tl;dr: VirtualSMC causes me a flood of log messages and correlated cpu spikes. FakeSMC doesn't.
       
      Hi, I have almost finalized my Huawei Matebook X Pro Opencore setup and everything is working very well besides wifi/bt ofc (which is about to change).
       
      However, I noticed how the cpu usage sometimes went up a little and when looking at the Console I could see a never-ending flood of:
      default 14:05:05.983292+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:05.982975+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:05.982996+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985932+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.985949+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:06.986134+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426574+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:39.426729+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:39.426585+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431085+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431097+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:41.431246+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433068+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:42.433227+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:42.433078+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434453+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434465+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:43.434622+0100 loginwindow clamshellStateChanged | Clamshell state changed: closed=0, shouldSleepWhenClosed=2 default 14:05:44.436155+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0 default 14:05:44.436166+0100 kernel PMRD: clamshell closed 0, disabled 0, desktopMode 0, ac 0 sleepDisabled 0  
      As you can see, multiple of these per second. Another guy with the same computer is also having this issue and posted a dsdt change to fix it. This fix didn't solve anything though
      He tried to limit the Notify call by implementing a state change requirement before calling Notify.
       
      Here is the original acpi:
      Scope (_SB) { Device (LID) { Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } ^^PCI0.GFX0.CLID = Local0 Return (Local0) } } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } Notify (LID, 0x80) // Status Change } } Which he changed to: 
      Scope (_SB) { Device (LID) { Name (_OLD, One) // assuming everything else.. the lid should start open? Name (_HID, EisaId ("PNP0C0D") /* Lid Device */) // _HID: Hardware ID Method (_LID, 0, NotSerialized) // _LID: Lid Status { Local0 = One Local0 = ^^PCI0.LPCB.EC0.RPIN (0x05, 0x06) If ((Local0 == 0x55)) { Local0 = Zero } Else { Local0 = One } Return (Local0) } } Device (PNLF) { Name (_HID, EisaId ("APP0002")) // _HID: Hardware ID Name (_CID, "backlight") // _CID: Compatible ID Name (_UID, 0x0A) // _UID: Unique ID Name (_STA, 0x0B) // _STA: Status } Device (PWRB) { Name (_HID, EisaId ("PNP0C0C") /* Power Button Device */) // _HID: Hardware ID Method (_STA, 0, NotSerialized) // _STA: Status { Return (0x0B) } } } Scope (_SB.PCI0.LPCB.EC0) { Method (_Q81, 0, NotSerialized) // _Qxx: EC Query, xx=0x00-0xFF { Local0 = ^^^^LID._LID () If ((Local0 == Zero)) { ADBG ("LID-OFF") SGOV (0x02030009, Zero) SGOV (0x02060000, Zero) } Else { ADBG ("LID-ON") SGOV (0x02030009, One) SGOV (0x02060000, One) Notify (ALSD, 0x80) // Status Change } If ((^^^^LID._OLD != Local0)) { Notify (LID, 0x80) // Status Change ^^^^LID._OLD = Local0 } } } Besides me not seeing any reason to declare _OLD in LID. The idea itself shouldn't be too bad right? Well, as I said, his fix didn't work.
       
      In fact, to prove that Method _Q81 doesn't have anything to do with the issue at all, I created a Clover/Opencore patch to change _Q81 to XQ81. This resulted in my lid not working at all of course, but the log flooding still persisted!
      So _Q81 doesn't have anything to do with the issue afaik.
       
      Now, further Google searches led me to a chinese post where he tied the issue to VirtualSMC. And indeed, by migrating to FakeSMC the issue is no more.
       
      Unfortunately, I'm very fond of VirtualSMC for various reasons. So I would very much like to keep it. If not I'd have to implement the old way of doing Battery monitoring etcetc. Which isn't very elegant and update proof as it requires DSDT patching.
       
      So, I do believe that the issue may very well be in the DSDT code, perhaps in the ambient light part. I'm not very skilled at this and just started studying the ACPI spec 3 days ago.
       
      Could someone please help me out? Thanks a lot in advance
       
       
      origin.zip
      OC.zip
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×