Jump to content

164 posts in this topic

Recommended Posts

Hi Guys, i upgraded my motherboard from Z170-HD3 to Z170X-Gaming 7 :)
 
System Specifications :
 
Processor : Intel Core i7 6700 SkyLake 
Motherboard : Gigabyte Z170X - Gaming 7 (I need more onboard Sata Ports)
VGA : Palit Jetstream GTX960 4GB DDR5
Memory : Dual Channel Team Extreem Dark 8GB (2x4GB) DDR4 3000Mhz OC
Storages : 6 Storages (120GB SSD Natno For Windows 10 Enterprise, 120GB Fujitsu for OS X El Capitan, 2TB For Data Multimedia / Program, 2TB for Master Game Installer, 500GB For Data OS X, 500GB for Game Live Installed)
Optical Drive : Asus DVD-RW Box
LAN : Dual LAN - Killer LAN E2400 dan Intel I219V
Wifi Card : TP-Link TL-WDN4800
Camera : A4Tech PK-920H WebCam
Monitor : 2X Asus VN248H @24" Full HD Supported
Audio Codec : Creative CA0132
Clover version : 3330
OS X Version : El Capitan 10.11.2 Beta Build 15C48a
Boot Mode : UEFI with CSM Disabled
 
Working : 
1. QE/CI Full Support with Nvdia
2. Camera Webcam OOB
3. Sleep, Restart, Shutdown 
4. I use Voodoo HDA version 2.8.8 for my Creative CA0132
5. HDMI Audio from Nvidia Card
6. Power Management, Multiplier dan Turbo Boost with SSDTPrGen from Pike R. Alpha
7. iMessages (Inject MLB and ROM from Real MacBookPro)
8. LAN Killer E2400
9. Etc
 
Not Working : 
1. Can'nt use AppleHDA :( Update : we can use AppleHDA for Creative CA0132. See here http://www.insanelymac.com/forum/topic/309441-new-applehda-patcher/?p=2194865
2. Not supported Ethernet I219V yet Work with new kext see here http://www.insanelymac.com/forum/topic/205771-appleintele1000ekext-for-108107106105/page-38?do=findComment&comment=2195842credit to @alreadystarted
3. Intel HD 7000 Integrated
4. Super Speed USB 3.0 not function at 10.11.2 Beta version. But, with 10.11.1 Public releas it's working nicely. Bug i thought. Update : with 10.11.2 Build 15C50 all USB are Working, use my "Z170X-Gaming-7-USB3.0-Injection.kext" and SMBios 17.1 Credit to Rehabman
 
 
I just need to flash bios into beta version then Go to BIOS Setup and "disable IOAPIC Entry" :) , then dumping your DSDT with Clover and check about all of your XHC device port and make USBInjection.kext from Clover :)

This is my Files

1. This is for Z170X-Gaming 7 + Palit Jetstream Nvidia GTX960 + TL-WDN4800. So if your system build is not same to my sytem then you need to modify DSDT File. Click>>Z170X-Gaming 7 Conifguration Tested by Me<<< to download files

2. Universal Setting Clover. Try to use this one if you have different Graphics Card, Processor and PCI-E Device. If you want to use Integrated Graphics and Discrette Graphics Card then set into BIOS for Primary Graphics from IGFX then just boot and it should active your integrated first and discrette graphics output few later. If you just want to boot with Discrette Graphics then set at bios primary graphics is PCI-E. Click>>>General Setting Without Graphic Injection for Z170X-Gaming 7<< to download files
 
3. AppleHDA Creative CA0132 Work without Volume Control. Click >>AppleHDA Files<< to download files. After extract you will get Creative-CA0132.kext, Layout1.zml.zlib, Platform.zml.zlib and Patch-OTF.plist.

    Tutorial for AppleHDA (First you need to remove VooDooHDA.kext + HDADisabler.kext + HDAEnabler.kext if you used it before)
    3a. LayoutID has been set "1" with DSDT. So you don't need to set it again with HDAEnabler or Clover Injection.
    3b. Extract the files and you will find "Creative-CA0132.kext" copy this to EFI/CLOVER/Kexts/10.11
    3c. Open your config.plist with Clover Configurator and add this to "Kernel and Kext Patches->KextToPatch" section (you can see this patch at "Patch-OTF.plist")

          Name : AppleHDA
          Find : 786d6c2e7a6c
          Replace : 7a6d6c2e7a6c
          Comment : Change Path XML to ZML
        
          Name : AppleHDA
          Find :  0088ec1a
          Replace : 11000211
          Comment : Rename Codec 1
 
          Name :  AppleHDA
          Find : 7419ad15
          Replace : 00000000
          Comment : Reset Codec
 
    3d. Copy your original AppleHDA.kext from System/Library/Extensions to Desktop. Then copy "layout1.zml.zlib" and "Platform.zml.zlib" to this kext with path "AppleHDA.kext/Contents/Resources". And reinstall the kext with Kext Utility.  :thumbsup_anim:  :thumbsup_anim: . Credit to Wern Apfel, Mirone and Abxite for XML to ZML method
 
Special Note : If you have already use my DSDT and Config.plist then you can skip step 3a. 3b and 3c
 

Another Screenshots

post-1311960-0-32276200-1449420845_thumb.png

post-1311960-0-20596600-1449420874_thumb.png

post-1311960-0-31201400-1449420902_thumb.png

post-1311960-0-74991500-1449420932_thumb.png

post-1311960-0-80050600-1449420953_thumb.png

post-1311960-0-92626600-1449420980_thumb.png

post-1311960-0-56767200-1449421008_thumb.png

post-1311960-0-22353300-1449421038_thumb.png

post-1311960-0-07080700-1449421139_thumb.png

post-1311960-0-01418200-1449421208_thumb.png

post-1311960-0-44032300-1449421237_thumb.png

post-1311960-0-24792800-1449421265_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

This is very interesting. I want to keep tabs on how well this works. 

 

Does audio not work from the creative card or is that working well now?

Share this post


Link to post
Share on other sites

I'd considered this board when part shopping for my machine and briefly flirting w/ the prospect of going ATX, but the lack of AppleHDA-compatible onboard audio was a dealbreaker.

 

Awesome you got this up and running though w/o too much difficulty.

Share this post


Link to post
Share on other sites

I'd considered this board when part shopping for my machine and briefly flirting w/ the prospect of going ATX, but the lack of AppleHDA-compatible onboard audio was a dealbreaker.

 

Awesome you got this up and running though w/o too much difficulty.

I have success installing to Z170-HD3 before  :hysterical: see my old thread http://www.insanelymac.com/forum/topic/308707-fresh-install-from-usb-installer-el-capitan-10111-beta-build-15b38b-on-skylake-i7-6700-gigabyte-z170-hd3/

 

So, i can install without much difficulty :thumbsup_anim:  :thumbsup_anim:

Share this post


Link to post
Share on other sites

Nice work Andres. How did you get on with Gigabyte's BETA FW F6g?

Share this post


Link to post
Share on other sites

Nice work Andres. How did you get on with Gigabyte's BETA FW F6g?

I just need to download BIOS file then enter bios, and press "F8" then you go :D

 

What's the difference between SSDTPrGen vs. the Skylake hardware sensors in FakeSMC.kext along with VoodooTSC...?

I don't know, AFAIK I use VooDooTSC for X79 Intel Platforms. I always use FakeSMC with CPUSensor.kext as plugin :D

Share this post


Link to post
Share on other sites

6i for G1... testing...

Share this post


Link to post
Share on other sites

I have the same motherboard and i interesting to install El Capitan, can u make a guide for your instalation ? i have gigabyte ga-z170x gaming 7, i7 6700k, 16gb ddr4 gskill 3200 mhz, 500gb ssd evo samsung, amd r9 280x 3gb 

Share this post


Link to post
Share on other sites

I have them same like you but not allowed me to install el capitan with error: Still waiting for root device.

Cpu: i7-6700

Mainboard: Gaming G7 Z170

How can i fixed ?

You need to set XHCI Handoff enabled at bios,, and don't forget to flash latest BETA BIOS for your board. And check your bios setting and make sure IOAPIC Entry = Disabled. Then see my configuration at uploaded file above

 

I have the same motherboard and i interesting to install El Capitan, can u make a guide for your instalation ? i have gigabyte ga-z170x gaming 7, i7 6700k, 16gb ddr4 gskill 3200 mhz, 500gb ssd evo samsung, amd r9 280x 3gb 

We have different Graphics Card here. I think you need using FB Name "Chutoro" for your Graphics Card :D and Flash Latest Beta Bios for your board and make sure to disable IOAPIC Entry at BIOS Setting

Owh,, i almost forgot. You can use my "Z170X-Gaming-7-USB3.0-Injection.kext" at Uploaded file above. Don't forget to use SMBios 17.1,, see my config.plist otherwise your USB will have problem. We have default "XHC" not "XHCI" at BIOS. That's important thing to run USBINjectionKext  :hysterical: 

 

Sorry for my Bad English

Share this post


Link to post
Share on other sites

SUCCESS Gaming G1 works out of the box!

 

Installed new beta bios F6g (didn't bother with F6i beta yet from the giga forums... Dropped in a pre-installed El Capitain 10.11.1 SSD (set up for an iMac 13,2 setup Z77X UD5 TH) into one of the SATAs without changing anything, used;-

 

XHCI Handoff enabled

disable IOAPIC (which now 'appears' in the choices in this 'safe' beta BIOS F6g)

 

Thought Id boot up just for giggles as the prior mob had basic installs with clover and setup for the 980tiGTX and everything is working.

 

Time to play with 10.11.2

 

Haven't done any other kext patching etc yet...

Share this post


Link to post
Share on other sites

Hi 

I have Creative CA0132 too.

Its worked for me.MIRONE HELP to get this.

But Output volume cuzer not work

show volume in menu bar very light not black

can you upload your ioreg please

I have x99gaminG1

THANK YOU.

 

Credits to CA0132 codec patch: wern apfel

Edited by Allan

Share this post


Link to post
Share on other sites

You need to set XHCI Handoff enabled at bios,, and don't forget to flash latest BETA BIOS for your board. And check your bios setting and make sure IOAPIC Entry = Disabled. Then see my configuration at uploaded file above

 

 

I through out of Waiting for root device and see this error.  System uptime in nanoseconds

What can i do now ???

Share this post


Link to post
Share on other sites

I through out of Waiting for root device and see this error.  System uptime in nanoseconds

What can i do now ???

You need to disable Serial Port at BIOS setting, make sure your Internal Graphics = enable and set VRAM 64MB  :thumbsup_anim:  :thumbsup_anim:

Hi 

I have Creative CA0132 too.

Its worked for me.MIRONE HELP to get this.

But Output volume cuzer not work

show volume in menu bar very light not black

can you upload your ioreg please

I have x99gaminG1

THANK YOU.

Can you send me your Patched AppleHDA???

i will give my IOREG too

Hi 

I have Creative CA0132 too.

Its worked for me.MIRONE HELP to get this.

But Output volume cuzer not work

show volume in menu bar very light not black

can you upload your ioreg please

I have x99gaminG1

THANK YOU.

Me too,, my Sound Slider is not function. No problem with me,, i even don't need it, LoL

Share this post


Link to post
Share on other sites

This is Mirone sent for me .

Thats why I dint upload it Anyway try it.

This file is not a file that you are using right now. I can see the GREY Port is NODE 17 and Speaker is 4. But at your platform that you sent to me there is not the node. You have modified it, haven't you?

Share this post


Link to post
Share on other sites

post-826544-0-44607000-1449702016_thumb.jpg

 

[success] El Cap 10.11.2 on Gigabyte z170 Gaming G1 / i7 6700k \64Gb RAM / NVIDIA GeForce GTX 980 Ti 6143 MB 

 

All pretty cool so far.

Both Killer network nics work with Atheros2200\2400 Meinze's kext.

Most USBs work / switched some off at boot so yet to try all

 

Attempting to see if Killer WIFI AC1535 will work (could've sworn I noticed this was working earlier...)

Attempting to see if I can get the m.2 samsung PCIe x4 NVME 500Gb card working

Will take a look at getting Creative 3D Sound {censored} working too

Share this post


Link to post
Share on other sites

Here there is an error. When creating boot by usb so on El Capitan is okay, but when installed on ssd clover 3330 to launch in El Capitan is in the bios boot options appear more 1 again and so continuously accumulated for the next boot time follow. I can fix it?

post-1633391-0-31634200-1449729183_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Nyggasek
      So. My laptop: Asus k55a I installed Mac OS X on the pendrive and now when I turn on the laptop and clicking esc bios it does not detect it. And now I have a question for you what settings I should set up to make everything good
    • By Teress
      Beginners Hackintosh tutorial how to create a macOS Mojave USB Installation Boot Flash Disk. Also works for High Sierra, Sierra and El Capitan. Make your own macOS Mojave boot disk. You can use it to install macOS Mojave, to repair your current installation or perform maintanace tasks.

      macOS Mojave is available for download at this AppStore link:
      https://itunes.apple.com/gb/app/macos-mojave/id1398502828?mt=12
      Apple Support's How to create a bootable installer for macOS:
      https://support.apple.com/en-us/HT201372
      Clover Bootloader Download:
      https://sourceforge.net/projects/cloverefiboot/
       
       
    • By amin321
      hello everyones 
      I think i have a problem with my power management i feels like temperature is coming so hot and so on 
      lenovo ideapad 500 
      i7 6500U 2.50 gz
      any help please 
      Send me macbook-pro.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Release v2018.10.12 on GitHub Updated to Clover r4703 Updated Kexts SSDT updates for T460 Added Frank's T470p DSDT files Added T470 DSDT
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By Teress
      In 5 minutes you get your sound on Hackintosh up and running. 100% working Vanilla, Easy & Fast Solution. Works with all systems and codecs. Hackintosh sound fix most easiest way.
       
      Supported Codecs:
      https://github.com/acidanthera/AppleALC/wiki/Supported-codecs
       
      Video tutorial:
       
       
×