Jump to content

164 posts in this topic

Recommended Posts

Got it working now. Had to use the Radeon framebuffer driver instead of Baladi. So important lessons for me were:

- make sure to have a UEFI vbios on the graphics card (use the dual bios toggle so you can easily swap between UEFI and Legacy vbios when necessary, the Z170X uefi setup menu doesn't always work with the UEFI vbios)

- disable the networking stack in the UEFI settings, as well as IOAPIC and CSM

- enable XHC Hand Off

- don't use fakeid and use the correct framebuffer

 

Now only problem is that sleep doesn't work; the screen goes black but the computer doesn't go to sleep and just stops responding entirely.

Share this post


Link to post
Share on other sites
Advertisement

I moded your dsdt, deleted wireless adaptor and graphic card information.

 

The audio still does not work.

 

I install the attached AppleHDA.kext into S\L\E, put the Creative-CA0132.kext into EFL\Clover\kexts\10.11\

 

Is there anything I missed?

 

Thanks!

Share this post


Link to post
Share on other sites

I moded your dsdt, deleted wireless adaptor and graphic card information.

 

The audio still does not work.

 

I install the attached AppleHDA.kext into S\L\E, put the Creative-CA0132.kext into EFL\Clover\kexts\10.11\

 

Is there anything I missed?

 

Thanks!

Only DSDT?? Did you use my config.plist too??

Share this post


Link to post
Share on other sites

Only DSDT?? Did you use my config.plist too??

Yes, I use your config.plist as well, but with a few modification.

 

The config.plist is as attached.

config.plist.zip

Share this post


Link to post
Share on other sites

Yes, I use your config.plist as well, but with a few modification.

 

The config.plist is as attached.

Can you upload image of DPCIManager.app. Run it, and take a screenshot :D

Share this post


Link to post
Share on other sites

Can you upload image of DPCIManager.app. Run it, and take a screenshot :D

I will do that on next Monday, the computer is in my office.

Share this post


Link to post
Share on other sites

Were you ever able to get sound working with soft volume control? I'm running the same motherboard with an i5-6600K and have the following issues still:

 

1) no soft-volume control

2) CPU seems to only drop to ~1600 MHz

3) Can't run Intel Power Gadget (crashes when launched)

 

Any help would be greatly appreciated. Your post was instrumental in me getting this running in the first place so THANK YOU!

Share this post


Link to post
Share on other sites

I have a Z170X GAMING 7 motherboard and I wasn't able to make sound work after the 10.11.4 update.

 

I tried a bunch of methods and no success. I was using the original method (posted on page 1) before the update.

 

Anything that I am missing?

 

Thanks.

Share this post


Link to post
Share on other sites

I got audio working after a few tries mixing the ACPI folder from the OP and the config.plist I already had working.. The problem is that randomly I got no sound after a while it was playing.. anyone else had the same issue?

Share this post


Link to post
Share on other sites

I got audio working after a few tries mixing the ACPI folder from the OP and the config.plist I already had working.. The problem is that randomly I got no sound after a while it was playing.. anyone else had the same issue?

Yes, I have the same issue. When my sound is gone randomly, I should boot with windows OS then check sound in Windows. If working in windows, your mac will recognize sound as well,.

 

I have no idea why it is working like that. I am regretting buying gaming7, not 5.

Share this post


Link to post
Share on other sites

Yes, I have the same issue. When my sound is gone randomly, I should boot with windows OS then check sound in Windows. If working in windows, your mac will recognize sound as well,.

 

I have no idea why it is working like that. I am regretting buying gaming7, not 5.

 

I just reboot into osx and it works, but I have to reboot :S

 

UPDATE: I just discovered unplugging and plugging back in the jack makes the sound work again

Share this post


Link to post
Share on other sites

Hello everyone,

 

I have a very similar setup - except I can't my GPU to remain selected with the NVIDIA Webdriver after reboot - also shutdown doesn't work (just reboots to clover bootloader).

 

I've tried various things, but finally got a stable system (after quite a few attempts and re-installations) and thus I have lived with it :)

 

However if any of you would know how I can fix these 2 issues (shutdown issue and webdriver) then I'd be super grateful.

 

Thanks in advance for your help.

 

Cheers

Share this post


Link to post
Share on other sites

Hi people,


 


Just to let you know. I found a new "on the fly patch for the sound card CA0132. It's from the coder vit9696 with the valuable help of vandroiy2012.


 


It's the better driver choice than a patched AppleHDA. Cause even if there is a new system update from apple, the sound will be working without any modification.  


 


You can test it and post results here :


 


http://www.insanelym...hing/?p=2237829


 


Cheers


Share this post


Link to post
Share on other sites

Anyone experience their system being super slow after waking from sleep? I used the general settings zip from the first post.

Yes it works but no volume control. BTW, you should use iasl to modify ssdt-0 ssdt-7 and no error.

Share this post


Link to post
Share on other sites

Modify them how?

download iasl from rehabman, put iasl and dsdt.aml ssdt-0 etc in same directory.  open terminal and cd into that directory and run ./iasl -da -dl *.aml. you can use your own ssdt file, from ssdt-0 to ssdt-6. Then no error in ssdt 

Share this post


Link to post
Share on other sites

Hello everyone,

 

I have a very similar setup - except I can't my GPU to remain selected with the NVIDIA Webdriver after reboot - also shutdown doesn't work (just reboots to clover bootloader).

 

I've tried various things, but finally got a stable system (after quite a few attempts and re-installations) and thus I have lived with it :)

 

However if any of you would know how I can fix these 2 issues (shutdown issue and webdriver) then I'd be super grateful.

 

Thanks in advance for your help.

 

Cheers

 

Anyone know where I should start to solve this?

Share this post


Link to post
Share on other sites

Hello, pretty great guide.

 

Problem is once I get into disk utility through clover on my PC it doesn't display any of my hard drives, just the usb stick and two 'External Apple' drives of 2 and 4 gb.

 

I have three drives in my system

 

1 2tb data drive in GPT with 1 NTFS partition

 

1 250gb SSD in MBR with a NTFS partition for games and exFat partition where I want to install hackintosh

 

1 500gb ssd that is my windows install in MBR.

 

As I said none of these properly show up in disk utility.

 

My system:

Motherboard: Gigabyth z170x Gaming 7 (obv)

CPU: I5 6600k

RAM: G.SKILL 16gb 2400

VGA: GTX980TI

 

As I said I'm able to get into clover no problem at all but once I load install osx and choose disk manager it doesn't show my drives.

Share this post


Link to post
Share on other sites

Hi, We're you able to get iMessage, thunderbolt, USB c and USB superSpeed (red port) working?

 

Please help.

 

Hi Guys, i upgraded my motherboard from Z170-HD3 to Z170X-Gaming 7 :)

 

System Specifications :

 

Processor : Intel Core i7 6700 SkyLake 

Motherboard : Gigabyte Z170X - Gaming 7 (I need more onboard Sata Ports)

VGA : Palit Jetstream GTX960 4GB DDR5

Memory : Dual Channel Team Extreem Dark 8GB (2x4GB) DDR4 3000Mhz OC

Storages : 6 Storages (120GB SSD Natno For Windows 10 Enterprise, 120GB Fujitsu for OS X El Capitan, 2TB For Data Multimedia / Program, 2TB for Master Game Installer, 500GB For Data OS X, 500GB for Game Live Installed)

Optical Drive : Asus DVD-RW Box

LAN : Dual LAN - Killer LAN E2400 dan Intel I219V

Wifi Card : TP-Link TL-WDN4800

Camera : A4Tech PK-920H WebCam

Monitor : 2X Asus VN248H @24" Full HD Supported

Audio Codec : Creative CA0132

Clover version : 3330

OS X Version : El Capitan 10.11.2 Beta Build 15C48a

Boot Mode : UEFI with CSM Disabled

 

Working : 

1. QE/CI Full Support with Nvdia

2. Camera Webcam OOB

3. Sleep, Restart, Shutdown 

4. I use Voodoo HDA version 2.8.8 for my Creative CA0132

5. HDMI Audio from Nvidia Card

6. Power Management, Multiplier dan Turbo Boost with SSDTPrGen from Pike R. Alpha

7. iMessages (Inject MLB and ROM from Real MacBookPro)

8. LAN Killer E2400

9. Etc

 

Not Working : 

1. Can'nt use AppleHDA :( Update : we can use AppleHDA for Creative CA0132. See here http://www.insanelymac.com/forum/topic/309441-new-applehda-patcher/?p=2194865

2. Not supported Ethernet I219V yet Work with new kext see here http://www.insanelymac.com/forum/topic/205771-appleintele1000ekext-for-108107106105/page-38?do=findComment&comment=2195842credit to @alreadystarted

3. Intel HD 7000 Integrated

4. Super Speed USB 3.0 not function at 10.11.2 Beta version. But, with 10.11.1 Public releas it's working nicely. Bug i thought. Update : with 10.11.2 Build 15C50 all USB are Working, use my "Z170X-Gaming-7-USB3.0-Injection.kext" and SMBios 17.1 Credit to Rehabman

 

 

I just need to flash bios into beta version then Go to BIOS Setup and "disable IOAPIC Entry" :) , then dumping your DSDT with Clover and check about all of your XHC device port and make USBInjection.kext from Clover :)

This is my Files

1. This is for Z170X-Gaming 7 + Palit Jetstream Nvidia GTX960 + TL-WDN4800. So if your system build is not same to my sytem then you need to modify DSDT File. Click>>Z170X-Gaming 7 Conifguration Tested by Me<<< to download files

 

2. Universal Setting Clover. Try to use this one if you have different Graphics Card, Processor and PCI-E Device. If you want to use Integrated Graphics and Discrette Graphics Card then set into BIOS for Primary Graphics from IGFX then just boot and it should active your integrated first and discrette graphics output few later. If you just want to boot with Discrette Graphics then set at bios primary graphics is PCI-E. Click>>>General Setting Without Graphic Injection for Z170X-Gaming 7<< to download files

 

3. AppleHDA Creative CA0132 Work without Volume Control. Click >>AppleHDA Files<< to download files. After extract you will get Creative-CA0132.kext, Layout1.zml.zlib, Platform.zml.zlib and Patch-OTF.plist.

 

    Tutorial for AppleHDA (First you need to remove VooDooHDA.kext + HDADisabler.kext + HDAEnabler.kext if you used it before)

    3a. LayoutID has been set "1" with DSDT. So you don't need to set it again with HDAEnabler or Clover Injection.

    3b. Extract the files and you will find "Creative-CA0132.kext" copy this to EFI/CLOVER/Kexts/10.11

    3c. Open your config.plist with Clover Configurator and add this to "Kernel and Kext Patches->KextToPatch" section (you can see this patch at "Patch-OTF.plist")

 

          Name : AppleHDA

          Find : 786d6c2e7a6c

          Replace : 7a6d6c2e7a6c

          Comment : Change Path XML to ZML

        

          Name : AppleHDA

          Find :  0088ec1a

          Replace : 11000211

          Comment : Rename Codec 1

 

          Name :  AppleHDA

          Find : 7419ad15

          Replace : 00000000

          Comment : Reset Codec

 

    3d. Copy your original AppleHDA.kext from System/Library/Extensions to Desktop. Then copy "layout1.zml.zlib" and "Platform.zml.zlib" to this kext with path "AppleHDA.kext/Contents/Resources". And reinstall the kext with Kext Utility.  :thumbsup_anim:  :thumbsup_anim: . Credit to Wern Apfel, Mirone and Abxite for XML to ZML method

 

Special Note : If you have already use my DSDT and Config.plist then you can skip step 3a. 3b and 3c

 

Another Screenshots

Share this post


Link to post
Share on other sites

hi

thx for this post

but i follow the tuto

and control volume dosen't work

how to reactive control volume please,,,,,

smbios actually is iMac 17.1

 

thx by advance

Share this post


Link to post
Share on other sites

hi

thx for this post

but i follow the tuto

and control volume dosen't work

how to reactive control volume please,,,,,

smbios actually is iMac 17.1

 

thx by advance

 

check this out: http://www.insanelymac.com/forum/topic/311293-applealc-—-dynamic-applehda-patching/?p=2221652

 

I'm running a Gigabyte Z179X-Gaming 7 with AppleALC, Layout-ID 4 and it works almost perfectly (with volume control)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By ltooz_audis
      This is how I would create my first hackintosh MacBookPro 13,2 on HP EliteBook 820 G3. I selected this one as an example because it has Ethernet and it. can be made as a perfect MacBookPro 13,2. This procedure will actually work with all Laptops and Desktops too. Watch the videos carefully.
      1. Gather all information about the hardware, download solftware, create flash drive installer with Catalina using Clover and OpenCore boot loaders.
       
       
      2. Understand the files inside boot loader and create the config files for both Clover and OpenCore boot loader.
       
       
      3. Actual installation and post installation.
       
       
       
      Install macOS Catalina to External USB Hard Drive.
       
       
      Patch DSDT and SSDTs for perfect Sleep/Wake and USB ports power.
       
      Use External USB Wifi
       
      Install DW1820A instead of DW1560 for BT4.0 and Wifi.
      Patch AppleALC For Audio Codecs
       
      Cheers,
      Louis
    • By ngochoaic3
      Hi everyone, 
      I hava a dell precision m4700 with option dgpu amd firepro m4000, The Intel HD4000 Graphic is disable, i can't enable it on to install Hackintosh
      I'd like to enable it on and ask you for setting custom connectors to get the internal display to work, and enable the iGPU in order to get things like AirPlay screen mirroring to work
      Could you help me?
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (July 2020) Updated to Clover r5120 Updated Lilu based kexts - Lilu, ALC, WEG Added AirportBrcmFixup.kext
        Various Tweaks over Last months The main branch in my github repo is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle seems to work on Sierra, HighSierra, Mojave and Catalina. There is an OpenCore branch in the repo as an alternative to Clover. This guide was developed for a Clover implementation. But the thread has evolved to include discussion of both Clover and Opencore for these systems: T460 and T470 family of ThinkPads.
       
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.6 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
       
      EliteDesk800 G4 Mini - Rev 1.0.zip
    • By ISmokeAir
      I am using opencore. I have an asrock z270 și killer and a core i7 7700k. I don't have a dgpu. I am using the integrated igpu(UHD 630). After booting up I get this kernel Panic.
       
×