Jump to content

164 posts in this topic

Recommended Posts

Andros, Ive hit upon a snag with the GIGABYTE Gaming G1. Id been using a PCIe USB 3 card of recent weeks but decided to see if any of the motherboards USB ports would work since developments and take out the PCIe card. Also one of my front side USB3 blue ports has a pin broken so I have to get round to soldering it back together at some stage but wondered if a missing pin would effect other parts of the USB chain. The fronts list as HS04 4 port from 14410000 to 1440000 and the broken pin means port 14420000 doesn't work. So I should be ok Id have thought with one missing port.

 

What I would like to know.

 

Did all your USBs show up from HS01 all the way upto the USR ports when you used USBInjectAll for your board ? Im only getting HS01 to HS10 and since I have a very similar board to yours I wondered why this was occurring. 

 

In System Information > USB I see the non working device listed as USB 3.0 Bus with;-

USB 3.0 Bus:

 

  Host Controller Driver: AppleUSBXHCIPCI

  PCI Device ID: 0x15b6 

  PCI Revision ID: 0x0000 

  PCI Vendor ID: 0x8086

 

Nothing I do can get it working it seems.

 

Could you take a look?

 

Here attached is my ioregistryexplorer file zipped if you need it.

 

Thanks

 

 

 

 

PS   The other device is fine as in;-

 

USB 3.0 Bus:

 

  Capacity: 15.63 GB (15,631,122,432 bytes)

  Removable Media: Yes

  BSD Name: disk8

  Host Controller Driver: AppleUSBXHCISPT

  Partition Map Type: GPT (GUID Partition Table)

  PCI Device ID: 0xa12f 

  PCI Revision ID: 0x0031 

  PCI Vendor ID: 0x8086 

  Volumes:

EFI:

  Capacity: 209.7 MB (209,715,200 bytes)

  BSD Name: disk8s1

  Content: EFI

  Volume UUID: 0E239BC6-F960-3107-89CF-1C97F78BB46B

USB:

  Capacity: 15.29 GB (15,287,148,544 bytes)

  Available: 4.56 GB (4,556,734,464 bytes)

  Writable: Yes

  File System: HFS+

  BSD Name: disk8s2

  Mount Point: /Volumes/USB

  Content: Apple_HFS

  Volume UUID: C313FE0C-6EF5-30EF-A576-FD4268662199

 

USB Optical Mouse:

 

  Product ID: 0x2510

  Vendor ID: 0x093a  (Pixart Imaging, Inc.)

  Version: 1.00

  Speed: Up to 1.5 Mb/sec

  Manufacturer: PixArt

  Location ID: 0x14800000 / 3

  Current Available (mA): 1000

  Current Required (mA): 100

  Extra Operating Current (mA): 0

  Built-In: Yes

 

Corsair K65 RGB Gaming Keyboard:

 

etc...etc....

Sorry for the late reply,,, 

Yes,, i have all port HSx and SSPx show at IOREG

 

Don't forget to use Patch to unlock limit ports, see the screenshot for the patch

post-1311960-0-06919900-1451674292_thumb.png

post-1311960-0-94122900-1451674298_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

hi, i installed everything, but i have some problems

first of all my system:

ga-z170-gaming 7

i7 6700k

ssd samsung evo 250

vga: gigabyte windforce 980ti

 

i didn't test the USB 3, if they are working

the problems

1)i don't have sound.

 

2)i installed nvidia web driver, i restarted, and i boot with nvda_drv=1, but the monitor after the boot goes to sleep mode.

   if i boot with nv_disable=1 it boot "normal" but mac doesn't regonice the graphics card

 

(any step by step guide will be helpful, i am noob at hackintosh)

 

thanks

Share this post


Link to post
Share on other sites

hi, i installed everything, but i have some problems

first of all my system:

ga-z170-gaming 7

i7 6700k

ssd samsung evo 250

vga: gigabyte windforce 980ti

 

i didn't test the USB 3, if they are working

the problems

1)i don't have sound.

 

2)i installed nvidia web driver, i restarted, and i boot with nvda_drv=1, but the monitor after the boot goes to sleep mode.

   if i boot with nv_disable=1 it boot "normal" but mac doesn't regonice the graphics card

 

(any step by step guide will be helpful, i am noob at hackintosh)

 

thanks

Hey, I have the same system with you.

 

You can just go to Download section and download VoodooHDA 2.8.8 v3. And install it. Audio will work fine.

 

I have a different GPU Radeon. But you can find many many thread for your GPU which is common in these days.

 

When you install VoodooHDA, you will have apple audio controller. But mine is not working properly. I mean my audio is working well but the controller can not control the sound strength at all. I should change the sound manually. I just wonder this is only my problem??

 

Please let me know if your's is working fine.

 

GL

 

Joe.

Share this post


Link to post
Share on other sites

after a lot of tries-failed again and again, working via teamviewer with my old laptop.

i installed successfully the nvidia web drivers.

 

also fixed the sound but is crappy.

i have to max the volume of the speakers!! z706

Share this post


Link to post
Share on other sites

Hi, Thanks for creating this tread. I have the same motherboard as you but instead I have the Titan X 12GB . for some reason when I used your  files (I don't modify anything just copy paste)  doesn't work. but when I disable the Titanx and used the internal Video Card (General Setting Files) it Launch OK, Could you please let me know what I need to Change to make my TitanX work?

 

Also I have 64GB of Ram but only showing 32gb

 

Thanks in advance

Share this post


Link to post
Share on other sites

There is General Setting Folder that i have uploaded. Look for another attachment :)

Yes the general settings folder structure boot fine with the internal video card (I change bios for this too)

 

but when i used your Z170X-Gaming 7.zip I get a waiting for root device error. Could please explaing how to used your Z170X-Gaming 7.zip Files, I meant I mount the EFI partition and them Copy the full content of the zip file inside the EFI folder in the EFI partition, Correct?

Share this post


Link to post
Share on other sites

Yes the general settings folder structure boot fine with the internal video card (I change bios for this too)

 

but when i used your Z170X-Gaming 7.zip I get a waiting for root device error. Could please explaing how to used your Z170X-Gaming 7.zip Files, I meant I mount the EFI partition and them Copy the full content of the zip file inside the EFI folder in the EFI partition, Correct?

Don't use my DSDT if you have different Graphics card with me. I use Nvidia GTX960 and you don't. So use general setting configuration,, install with bootflag "-v nv_disable=1" then it should let you to install OS X. :)

 

If you get stucking then take a photo and upload here. Sorry for my bad english

Share this post


Link to post
Share on other sites

Don't use my DSDT if you have different Graphics card with me. I use Nvidia GTX960 and you don't. So use general setting configuration,, install with bootflag "-v nv_disable=1" then it should let you to install OS X. :)

 

If you get stucking then take a photo and upload here. Sorry for my bad english

 

Thanks for you help, sorry for the noob question how do I  "don't use your DSDT?" simply removing the DSDT.aml from the folder? 

Share this post


Link to post
Share on other sites

System Specs: Z170X Gaming 7, Core i7 6700k, GTX 980 Ti and a Intel 750 

 

I currently have El Capitan running fine in VMWare on this system. Today I was looking around and I saw they released a free NVMe Kext and noticed people having success booting with a Intel 750

 

This will be my first Hackintosh, so far I made a bootable flash drive. Disabled and enabled everything needed in the bios. Currently using beta bios F7d

 

When booting to the flash drive I see an Apple logo and the loading bar filling up it stops around 40% than I see a cancel symbol on my screen.  

 

I am sure I am missing a few steps and any help will be greatly appreciated! 

Share this post


Link to post
Share on other sites

Thanks for you help, sorry for the noob question how do I  "don't use your DSDT?" simply removing the DSDT.aml from the folder? 

My General Setting at 1st page not include DSDT. So use it

Share this post


Link to post
Share on other sites

Hi,

thanks for your Guide, i got most of my System working.

 

- Gigabyte Z170X Gaming 7

- Intel i5-6500

- NVIDIA GTX 750 TI

- Samsung 950 Pro NVMe

 

I used parts of you clover config (APIC Patch, 15 Port Limit Patch ...) and your USB Mapping ssdt.

Used your kexts and added NVMeGeneric and AppleIntelCPUPowerManagement. I have the kexts only on EFI Partition and not in /S/L/E or L/E

 

All USB Ports (including 3.1) are working

 

didn't tried sound yet

 

 

Only problem i have that shutdown is not working, system reboots after shutdown. (shutdown did work sometimes after rebuilding kextcache)

Is there any Logfiles from shutdown to have a look at?

 

 

 

Share this post


Link to post
Share on other sites

System Specs: Z170X Gaming 7, Core i7 6700k, GTX 980 Ti and a Intel 750 

 

I currently have El Capitan running fine in VMWare on this system. Today I was looking around and I saw they released a free NVMe Kext and noticed people having success booting with a Intel 750

 

This will be my first Hackintosh, so far I made a bootable flash drive. Disabled and enabled everything needed in the bios. Currently using beta bios F7d

 

When booting to the flash drive I see an Apple logo and the loading bar filling up it stops around 40% than I see a cancel symbol on my screen.  

 

I am sure I am missing a few steps and any help will be greatly appreciated! 

 

 

 

When plugging in my flash drive into a USB 2.0 port the bar starts to load and once it reaches 70% it restarts. I added boot arg "nv disable=1" because I have a GTX 980 Ti but still no luck.

Share this post


Link to post
Share on other sites

HI, I used your "GENERAL SETTING CLOVER" them  installed the Ethernet kext with easy kext

 

I had to changed system definition to MacPro 5,1 in order to make work the Titan_X if I use iMac17 I get a black screen, everything seem working fine, Anything else would you recomend?

 

Thanks

Share this post


Link to post
Share on other sites

NVMe driver works fine, Ethernet works fine along with my SMSL m8 dac. Two issues, when installing FakeSMC I get a Cancel Symbol when restarting. Second after installing the nvidia web driver I can't switch to the nvidia driver only the generic driver. 

Share this post


Link to post
Share on other sites

AndyCorleone : if you have SkyLake Platforms, then you must use iMac17,1 for better CPU and System Power Management. The solution of Black Screen is editing "AppleGraphicsDevicePolicy.kexts's info.plist" inside "AppleGraphicsControl.kext's plugin". Edit "none"according iMac17,1 board-id.

WannabeOCer : you need to use FakeSmC with cpusensor.kext that support SkyLake already. Don't use old FakeSmC, if you have installed Nvidia Web Driver then change "nv_disable=1" to "nvda_drv=1".

 

If you get black screen, check solution above

Share this post


Link to post
Share on other sites

 

Hi Guys, i upgraded my motherboard from Z170-HD3 to Z170X-Gaming 7 :)
 
System Specifications :
 
Processor : Intel Core i7 6700 SkyLake 
Motherboard : Gigabyte Z170X - Gaming 7 (I need more onboard Sata Ports)
VGA : Palit Jetstream GTX960 4GB DDR5
Memory : Dual Channel Team Extreem Dark 8GB (2x4GB) DDR4 3000Mhz OC
Storages : 6 Storages (120GB SSD Natno For Windows 10 Enterprise, 120GB Fujitsu for OS X El Capitan, 2TB For Data Multimedia / Program, 2TB for Master Game Installer, 500GB For Data OS X, 500GB for Game Live Installed)
Optical Drive : Asus DVD-RW Box
LAN : Dual LAN - Killer LAN E2400 dan Intel I219V
Camera : A4Tech PK-920H WebCam
Monitor : 2X Asus VN248H @24" Full HD Supported
Audio Codec : Creative CA0132

Clover version : 3330

OS X Version : El Capitan 10.11.2 Beta Build 15C48a

Boot Mode : UEFI with CSM Disabled

 
Working : 
1. QE/CI Full Support with Nvdia
2. Camera Webcam OOB
3. Sleep, Restart, Shutdown 
4. I use Voodoo HDA version 2.8.8 for my Creative CA0132
5. HDMI Audio from Nvidia Card
6. Power Management, Multiplier dan Turbo Boost with SSDTPrGen from Pike R. Alpha
7. iMessages (Inject MLB and ROM from Real MacBookPro)
8. LAN Killer E2400
9. Etc
 
Not Working : 
1. Can'nt use AppleHDA :( Update : we can use AppleHDA for Creative CA0132. See here http://www.insanelymac.com/forum/topic/309441-new-applehda-patcher/?p=2194865
2. Not supported Ethernet I219V yet Work with new kext see here http://www.insanelymac.com/forum/topic/205771-appleintele1000ekext-for-108107106105/page-38?do=findComment&comment=2195842credit to @alreadystarted
3. Intel HD 7000 Integrated

4. Super Speed USB 3.0 not function at 10.11.2 Beta version. But, with 10.11.1 Public releas it's working nicely. Bug i thought. Update : with 10.11.2 Build 15C50 all USB are Working, use my "Z170X-Gaming-7-USB3.0-Injection.kext" and SMBios 17.1 Credit to Rehabman

 
 
I just need to flash bios into beta version then Go to BIOS Setup and "disable IOAPIC Entry" :) , then dumping your DSDT with Clover and check about all of your XHC device port and make USBInjection.kext from Clover :)

 

This is my Files

 

1. This is for Z170X-Gaming 7 + Palit Jetstream Nvidia GTX960 + TL-WDN4800. So if your system build is not same to my sytem then you need to modify DSDT File

2. Universal Setting Clover. Try to use this one,, if you want to use Integrated Graphics and Discrette Graphics Card then set into BIOS for Primary Graphics from IGFX then just boot and it should active your integrated first and discrette graphics output few later. If you just want to boot with Discrette Graphics then set at bios primary graphics is PCI-E Download

Another Screenshots

 

 

3. Sleep, Restart, Shutdown <== My hackintosh not working correctly. Sleep and not wake up, don't shutdown, it restart forever.

4. Super Speed USB 3.0 not function at 10.11.2 Beta version. But, with 10.11.1 Public releas it's working nicely. Bug i thought. Update : with 10.11.2 Build 15C50 all USB are Working, use my "Z170X-Gaming-7-USB3.0-Injection.kext" and SMBios 17.1 Credit to Rehabman <=== I install with KCMP Utility Pro but not working.

 

I have attach my DSDT and config.plis.

Tks for help.

origin.zip

config.plist.zip

post-1633391-0-87305700-1453358687_thumb.png

post-1633391-0-23025900-1453358696_thumb.png

post-1633391-0-35713600-1453358705_thumb.png

Share this post


Link to post
Share on other sites

Then how about Tick "fix_WAK" ;)

 

Now it shuts down and goes off, but turns on again.

I found the tip to turn off "Wake on Lan" but its shown greyed in UEFI for the Intel Lan so I can't to that

 

Next Thing will be installing Windows on Second Drive to check if its the same so i have to search UEFI Settings.

 

And the 10.11.3 Update seams to break USB 3.1 again

 

Did you have luck with AppleHDA and using all Inputs and Outputs or are you still using VoodooHDA?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.4
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 04/08/2020
       
       
      Clover EFI Update - 04/08/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios
       
      Clover Z390 Pro Navi Vega EFI 040820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 040820.zip - RX500 Polaris Series (RX590, 580, 570 etc) DSDT EFI
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      OpenCore EFI Update - 04/08/2020
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 060 Z390 Pro 19,1 030820.zip - OpenCore v0.6.0, SMBios iMac19,1
      OpenCore 060 Z390 Pro 1,1 030820.zip - OpenCore v0.6.0, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0. Use the new Config.plist instead.
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      For OpenCore Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11c Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current Clover EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d (F12c Pro WIFI) BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's FOR CLOVER ONLY (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Set to Disabled if using SMBios iMacPro1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       

       

       

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT (connected to the monitor via the DisplayPort)
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO Plus 1TB NVMe SSD macOS Catalina 
      • Samsung 970 EVO 1TB NVMe SSD Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11e or Higher to use any of these EFI's, The DSDT is not designed for any other Bios revision
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 04/08/2020
       
       
      Clover EFI Update v5120 - 04/08/2020 - Use with Bios revision F11e or Higher Only or Replace with the older F11c/F10 DSDT if you don't want to update the bios
       
      EFI Clover VEGA Navi 030820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT SMBios 19,1 EFI
      EFI Clover Polaris NVIDIA 030820.zip - RX500 Polaris Series (RX590, 580, 570 etc) SMBios 19,1 EFI
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
       
      OpenCore EFI Update v0.6.0 - 04/08/2020
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 060 Z390 Master 19,1 030820.zip - OpenCore v0.6.0, SMBios iMac19,1
      OpenCore 060 Z390 Master 1,1 030820.zip - OpenCore v0.6.0, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0 so please use the new Config.plist instead.
       
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11e Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      CFG Unlock (MSR) F11e BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11e)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
       
    • By ltooz_audis
      This is how I would create my first hackintosh MacBookPro 13,2 on HP EliteBook 820 G3. I selected this one as an example because it has Ethernet and it. can be made as a perfect MacBookPro 13,2. This procedure will actually work with all Laptops and Desktops too. Watch the videos carefully.
      1. Gather all information about the hardware, download solftware, create flash drive installer with Catalina using Clover and OpenCore boot loaders.
       
       
      2. Understand the files inside boot loader and create the config files for both Clover and OpenCore boot loader.
       
       
      3. Actual installation and post installation.
       
       
       
      Install macOS Catalina to External USB Hard Drive.
       
       
      Patch DSDT and SSDTs for perfect Sleep/Wake and USB ports power.
       
      Use External USB Wifi
       
      Install DW1820A instead of DW1560 for BT4.0 and Wifi.
      Patch AppleALC For Audio Codecs
       
      Cheers,
      Louis
    • By ngochoaic3
      Hi everyone, 
      I hava a dell precision m4700 with option dgpu amd firepro m4000, The Intel HD4000 Graphic is disable, i can't enable it on to install Hackintosh
      I'd like to enable it on and ask you for setting custom connectors to get the internal display to work, and enable the iGPU in order to get things like AirPlay screen mirroring to work
      Could you help me?
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (July 2020) Updated to Clover r5120 Updated Lilu based kexts - Lilu, ALC, WEG Added AirportBrcmFixup.kext
        Various Tweaks over Last months The main branch in my github repo is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle seems to work on Sierra, HighSierra, Mojave and Catalina. There is an OpenCore branch in the repo as an alternative to Clover. This guide was developed for a Clover implementation. But the thread has evolved to include discussion of both Clover and Opencore for these systems: T460 and T470 family of ThinkPads.
       
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
×