Jump to content
Sign in to follow this  
Followers 0
Zenshredder

Trouble Installing AMD Kernel

5 posts in this topic

Recommended Posts

Hello, so since the last time I posted I've had a bit of luck and happened to find an old iMac in the dumpster at my job. I took it home, repaired it and now I have a legitimate means of getting a fresh copy of OS X! With that in mind, I've ditched the Niresh distro because no matter how many different things I tried I could NEVER get my graphics card to work properly. So I'm back at it trying to make a clean installer with the bare minimum to get me through, so far it's been going pretty good except one thing...the kernel. I honestly don't know where or how to install it onto the boot drive. I've looked around on these forums, on other forums(including Reddit >.>), etc. and I can't seem to find the answer that I'm looking for. My first attempt I just dragged/dropped into the USB drive after installing Clover, that obviously didn't work. I also renamed it to "mach_kernel" which didn't do anything either, lastly I tried installing it in a few places that I thought might be more likely such as the EFI drive. Am I missing something? Overthinking it? I'm at a loss. I'll break down my steps for creating the installer, hopefully someone can help me push through to the next step.

 

 

----------------------------------------------------------

 

 

My Specs:

 

AMD FX 8350

 

Asus M5A97 R2.0 Motherboard

 

MSI R9 290 Twin Frozr

 

4X4GB AMD R9 Gaming RAM @ 2133Mhz

 

Corsair 850W Gold Cert. PSU

 

Installing on a 2.5" spare laptop drive

 

 

-----------------------------------------------------------

 

 

Here's my method of creating the installer:

 

Step 1: Download the Install OS X Yosemite.app installer

 

Step 2: Run Terminal, type in this command:

 

"sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction"

 

Step 3: Once it finishes installing, I restart the iMac to complete any necessary changes

 

Step 4: Open and install the latest revision of Clover to the drive

 

Step 5: Restart the iMac again

 

Step 6: Place FakeSMC and NullCPUPowerManagement kexts into the 10.10 folder inside the USB installer

 

Step 7: Place the AMD kernel for 10.10.5 in the USB installer

 

Step 8: Create a config.plist file with Clover configurator on the iMac to match what I've needed to boot previously and place inside the EFI partition of the USB installer

 

Step 9: Remove the drive, attempt install on PC.

 

 

-----------------------------------------------------------

 

 

Some additional notes:

 

- The kernel I'm using is an AMD 10.10.5 kernel by Deepak, not sure if the OS X version I have is 10.10.5 since it won't tell me in the App Store when I load it, not sure if this is an issue or not

 

- The kexts were also provided by Deepak on his website on getting El Capitan to work

 

- I have installed Clover for UEFI boot, which my system is perfectly capable of, however I'm wondering if it might be a part of the problem

 

- When I actually boot the USB drive, it starts up for several seconds in verbose mode and then powers down my computer completely, restoring power a couple of seconds later.

 

 

I've been at this since April trying to get a working install of Mavericks and Yosemite, both unsuccessfully, so thanks in advance for any and all help, it's definitely appreciated!

Share this post


Link to post
Share on other sites
Advertisement
You're make probably a few thoughts error.

1. Here is the link where you can find all runnable AMD kernel for AMD hackintosh:  http://www.insanelymac.com/forum/topic/285580-database-of-current-working-amd-kernels/page-4

 

2. the kernel for Yosemite belongs in to folder /System/Library/kernels/ (if the folder should not exist, so create the folder and add the matching kernel into the folder.

    (for Mavericks must be installed the mach_kernel into the main directory (root))

 

3. To resolve the problem with your graphics card look here: http://www.insanelymac.com/forum/forum/174-ati/

 

4. replaced by this package, the existing drivers in S/L/E http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/   then fix the permissions and renew the cache

 

otherwise look here for running AMD hackintosh, some users have also made a description: http://www.insanelymac.com/forum/topic/285110-amd-working-builds/page-13?do=findComment&comment=2167036

Share this post


Link to post
Share on other sites

 

"sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction"

 

There is you'r problem. El Capitan will not work on AMD with the Yosemite kernel. Wait untill the El Capitan kernel sources are released and a kernel is made.

Share this post


Link to post
Share on other sites

Thanks for both your guys help!

 

@Spakk I knew it was going to be something dumb like that DX I can't believe I didn't think of creating a folder for the kernel...Ill try your suggestions and see if I can get it to boot tonight.

 

@Shaneee I made that mistake when I first tried to make an installer because I'm dumb, thankfully I didn't have an El Capitan installer so the Terminal command didn't go through when I tried it XD I just deleted the parts where it says El\ Capitan.app and replaced it with Yosemite, no El\ of course.

 

I'll post my success...or failure, as soon as I can, thanks for the help!

Share this post


Link to post
Share on other sites

So I tried your recommendations for the kernel as well as the keys and it seems that did not work. I probably should've tried to snap a picture of this before and troubleshoot from there but it was always a little too fast for me to take a snapshot. However, with a little bit of research it seems it could be one of the following: either I need different boot flags to do certain things like PCIRootUID and USBBusFix, or the kernel I am using isn't the right one or is corrupt. I hope is not the case and that I have to keep trying different kernels...I will keep trying different boot flags before I start testing different kernels from the download page Spakk provided.


Some additional notes I've come up with are as follows:

- My graphics card is not natively supported in OS X, not by a long shot. The 290 non-X version seems to be the least supported graphics card in the whole lineup of AMD cards, which could ultimately be a huge road block, and the fact that I got the Niresh distro to even partially work might be nothing short of a miracle. With all that being said, this could be the source of my problem or not even close to it, I have no idea still *scratches head*

- I've been installing the suggested kexts in the Clover EFI partition under the kexts/10.10 folder, am I supposed to be installing them there to boot? In the actual Install OS X Yosemite.app? Or perhaps do I need to make another folder in one of the partitions?


For now I'll be testing the boot flags and such to see if I can get any new results, in the meanwhile if anyone has any suggestions I'm all ears! And thank you in advance as always, any help is appreciated.

 

 

 

EDIT: Sorry my picture didn't post for some reason, here's an imgur link to check it out: http://imgur.com/70sOLLx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bradipi15
      Ciao ragazzi ho un problema strano... 
      Praticamente quando avvio il pc usando il dsdt, appena connetto la tavoletta grafica huion h640p, il pc si riavvia... 
      Se invece tolgo il dsdt, funziona tutto perfettamente... 
    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By karthiksh1989
      can somebody walkthrough with the mojave installation guide?
      i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop
      Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64
      running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram
       
      https://wa.me/919611736534 (whatsapp)
    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
×