Jump to content
Costanegra

Motherboard for Intel Core i7-6700K Skylake?

6 posts in this topic

Recommended Posts

Hello.

 

It's been about 3 or 4 years since I built my first, and so far only hackingtosh. I did so fallowing a guide written by good guy ^Andy^, witch came with hardware recommendations. I now feel it's time for me to upgrade to a faster system to keep up with heavier work loads. I'm strongly considering building a hackingtosh around the new i7-6700K Skylake processor, but I haven't come across guides for  this type of processor. I was wondering if any of you could recommend me a motherboard that's compatible and that won't become a hassle when trying to install OS X. Also, if there's a guide you know of, please let me know.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

It's a bit early for Skylake at the moment, I'd say. Several things are still being worked out, and you should not expect a fully working system from the get go. Many people have workable systems, but built-in ethernet is not really working, for example.

I'm very sure it will get worked out in relatively short order, but it's still early days for the platform, especially in Macs.

Share this post


Link to post
Share on other sites

Hi

Gigabyte Z170 HD3P has working ethernet with Mieze's kext

i7 6700k is a beast.

My advice.. no Haswell. Development is almost complete on Skylake, whats missing is usb3.1 ports and pure NVME, but usb 3.0 are working, so who needs them anyway.

Share this post


Link to post
Share on other sites

Hi

Gigabyte Z170 HD3P has working ethernet with Mieze's kext

i7 6700k is a beast.

My advice.. no Haswell. Development is almost complete on Skylake, whats missing is usb3.1 ports and pure NVME, but usb 3.0 are working, so who needs them anyway.

 

Thanks for your reply, samma7896. Do you know where I can find a guide I can follow step by step to build a new machine? If your configuration is a popular one around here and requires little hassle to make it work, I will provably buy the same hardware you have. But I kinda got my eyes on a Gigabyte board with support for Intel's Thunderbolt:

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16813128839&cm_re=Gigabyte_Z170_UD5-TH-_-13-128-839-_-Product

 

Any thoughts are appreciated. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By HenryV
      HP 250 G5/Skylake/I5/520 graphics/sunrise point   Insyde H20 updated with TPM, virtualizaton and secure boot disabled.  19A546d USB boots -v cpus=1 and begins install ok.  After first reboot installer hangs at 14 minutes remaining with high CPU/fan use and no HDD write activity.   Same after 4-5 hours.  First reboot apparently creates the volume group and writes the installer files to the Data volume ok.  Clover shows preboot/installer  installer and Recovery icons.  It appears that there are no system files being written to the System volume.  The reboot USB verbose output screen indicates 'assertion failed 19A546d'.  Mojave boots/runs ok on its own partition same HDD.   Anyone with similar installer issue on HP notebook and/or Insyde BIOS?  Any help appreciated.
      Essentials.zip
    • By takeawaydave
      Running Mojave 10.14.6 (18G95) on a Dell Precision 7510 and trying to get all framebuffers working properly.
       
      The following CPU is being used: https://ark.intel.com/content/www/us/en/ark/products/89608/intel-xeon-processor-e3-1505m-v5-8m-cache-2-80-ghz.html
       
      The actual Device ID of the iGPU is 0x191D.
       
      There are the following graphical outputs:
       
      mDP
      HDMI
      Thunderbolt
       
      Clover 5058 (update to date at time of writing) is being used and up to date versions of Lilu 1.38, WEG 1.3.1
       
      Till now I've been running with the following config:
       

       
      with Model Name: MacBookPro13,3
       
      When using 191B:
       
      LDVS - Ok
      HDMI (no audio) : 1920x1080
      Thunderbolt (no audio) : 3440 x 1440
      no mDP
       

       
      191B-config-ioreg.zip is attached.
       
      When using 1912:
       
      No LDVS (as expected since this arrangement is targeted for iMac17,1
      HDMI (with audio): 1920 x 1080
      Thunderbolt (with audio) : 3440 x 1440
      no mDP
       
      1912-config-ioreg.zip attached
       
      Question:
       
      How can I get audio working as with 1912 on the 191B laptop config ? 
       
       
    • By kushwavez
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By Tricchi
      Vorrei assemblare un nuovo hackintosh partendo dallo stretto necessario per poi aggiungere altri componenti nel tempo. Dato che la mobo penso sia fondamentale vorrei prenderne una che mi dia la possibilità di future espansioni ma che non costi troppo. Ho visto che su Amazon ci sono delle mobo come ad esempio la Asrock Z370 Taichi usate ad ottimi prezzi. Voi che ne pensate? Vale la pena o è rischioso? Nella descrizione c'è scritto "Come nuovo" o "Ottime condizioni".
      Riguardo alla compatibilità di questa scheda madre con hackintosh che mi dite? Il modulo wi-fi e bluetooth è compatibile?
      Grazie.
       
      Marco
    • By ale003
      Boa noite galera!
       
      já a alguns anos que tenho hackintosh, é um I7 6700K em uma Asus Maximus Hero VIII Z170 com GPU RX480 8gb
      Porém desde sempre tenho congelamentos aleatórios, na maioria das vezes quando coloco um filme pra exportar no final cut. mas já aconteceu enquanto via videos ou escutava musicas no spotify e recentemente até ao ligar o computador, mal ligou congelou. ele congela todo não dá pra mexer em nada, só desligando segurando botão power que ele volta.
       
      Me disseram que era gerenciamento de energia, eu baixei a DSDT do meu processador, segui alguns outros tutoriais e ainda nada. não consigo de jeito nenhum resolver esse problema, já instalei varias versões desde o yosemite até o High sierra, e ainda nada. Só esse pequeno detalhe que me desanima do Hack. 
       
      Alguem pode ajudar?
       
      High Sierra 10.13.6
      Asus Maximus Hero VIII
      RX 480 Nitrous + 8GB
      Trident Z 16GB DDR4 3200MHZ
×