Jump to content
Mirone

New AppleHDA Patcher

306 posts in this topic

Recommended Posts

Better, I am seeing my USB audio devices again. I am including an updated IOreg, config.plist, and my dsdt pulled from Clover if that helps.
 
tnx
 
Update 1:
Ok it is now being detected after a few reboots but something is extremely wrong. What is being detected is in a different language (Hebrew?) and after a few minutes the audio will distort and deteriorate. It seems to be the exact same issue as bronxteck has described before.

MironeAudioZ170.zip

Share this post


Link to post
Share on other sites
Advertisement

I can also confirm that v1.2 is working (again). Used it on my ALC271 and it generates the same Clover config.plist and a working aDummy.kext. Copied over and everything is fine.

 

Good (and fast) work, Micky  :thumbsup_anim:

can u send me files that working on your alc271x? its been 3weeks, nothing working method on my alc271x.

---------------------------------------------------------------------------------------------------------------------------------------------------

 

 

try this:attachicon.gif omdx.10.11.3.zip

install all files repair permissions rebuild caches.

 

 

 

Use mirone Manual method http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/?p=2225109

 

AudioDevice detected. but no audio at all. on boot its not detected. after few minute browsing, audi detected it self in few minutes...

 

jamG8fX.png

 

Here my latest file. Really need help here. Coz with Voodoo my sound always lost sync on few minute. must change midi source or use terminal code "sudo killall coreaudiod" all time to reset sound.   :wallbash:

 

here my latest DSDT+IOReg+CodecDump+AppleHDA-Vanilla

 

 

 

 

DSDT+IOReg+CodecDump+AppleHDAVanilla10.11.3-OMDX.zip

Share this post


Link to post
Share on other sites

My sound device is IDT92HD71B7. I see IDT92HD71B7X in the laptop list. I tried using that and my conflig.plist is patched too. I can't get the dummy kext to load from SLE. Can someone tell me if the "X" at the end means it is a different device? I sorta assumed it does not matter.

 

IOReg shows layout-id getting injected as 3.

I will say the AppleHDA patch in config.plist is Finding / Replacing something I cannot find in AppleHDA info.plist either as-is or after converting to decimal.

 

What can I do? I am using 10.13. I'm unable to attache files here for some reason

 

Share this post


Link to post
Share on other sites

Hello everyone

I tried to apply the guides for AppleHDA patch for my codec
(IDT 92HD99BXX - 0x111d76e5), but till now I only got the
codec show up in system preferences but no devices on input/output.

I use DSDT injection, but it seems that the codec is not
initialized - don't know if this is because of DSDT, MuteGPIO thing
or anything else.

I tried to follow the guide step by step and tried different
Nodes, LayoutIDs (12, 3) and other patches for this codec with no luck
(also AppleALC). The only semi-working thing is VoodooHDA.

I'm posting my DSDT, Clover config, linux dump and the patched files.
Can somebody have a quick look if can spot anything wrong?

Thank you very much!!
 

https://drive.google.com/open?id=1amZrbMgNyMseyRG9LUKi6sD9iQsRqkYI

 

post-1244116-0-94565900-1512581449_thumb.png

codec_dump.txt

layout3.xml

PathMaps.txt

Platforms.xml

verbs.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Wolfield
      I have a receiver with 7.1 channels, in which I transmit the formats Dolby Digital and DTS without problems by Windows, through the HDMI output of HD4000. On that same Laptop, I have the Hackintosh, with the High Sierra 10.13.6, and with audio enabled using AppleALC, but in the audio preferences, I can not enable the Digital audio format. Also did not find players like Mirillis SplashPro (which I have used in Windows) with the option of HDMI output Bitstream. Is it possible to enable this digital output on Hackintosh?
    • By moman2000
      Hi,
       
      Here it is (attached) for anyone who needs it for patching or restoring!
       
      Taken from macOS 10.14 Beta 1 18A293u
       
      Regards,
      Mohamed
      AppleHDA_282.5.kext.zip
    • By rio2
      How to make AppleHDAController load on Ryzen boards?
      Rename(/add) your audio controller to your DSDT/SSDT as HDEF Add a _DSM method to your HDEF device with layout id 1 Patch the AppleHDAController binary, because it has a static table containing the supported PCI Vendor/DeviceID pairs and it also checks the VendorID against known values. As an example I provide a dif file and patched 10.13.3 binary, but if you want to I can patch the binary for other versions.  
      After AppleHDAController loads to actually get sound working you need to patch AppleHDA.kext for the codec on your board. First I tried to use Lilu+AppleALC for this task, but for some reason it refused to work. (I might look into it later why) But for the time being it was easier to use toleda's cloverALC script for that, but to make it work I had to change(/remove) the specified location of the HDEF device from the script. And for some reason it also required me to mount the EFI partition manually.
       
      Change this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF@1") != 0 ]]; then Into this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF") != 0 ]]; then  
      AppleHDAController_Patched10.13.3
      AppleHDAController-10.13.3-AMD.bdiff
    • By fietipaldi
      Hi there,
       
      I had to reinstall El Capitan on my Hackintosh, as it was installed in Clover Legacy Mode before (with everything working just fine).
      Now I installed it again in UEFI mode and since then, Audio (ALC892) is not working anymore (Neither in UEFI or Legacymode).
      I tried to install the same 2 Kexts as before (AppleHDA modified and HDAEnabler1) using Kextutility (wich was working fine before as well).
      It always fails to install AppleHDA, as it cannot Backup or modify the Original AppleHDA in System/Extensions (Can't copy sourcefile).
      I also tried the same, using the root Account, using terminal with kextunload / load and even a script for clover.
      They all fail to modify / delete the Original AppleHDA. Trying to rename / move or delete the Original file with Terminal or Finder is not working as well, I get an Error, saying that the file cannot be modified because OS X requires it.
       
      So how can I install the Kext to get my audio working again? System is El Capitan (10.11.6)...

      Thank You!
    • By vanquybn
      My Laptop is using ALC 292 and it is runnning: AppleALC.kext, CodecCommander.kext. Thoese kexts work fine for me on MacOS 10.31.1/10.12.x
      After update to 10.13.2 my headphone have no sound, The icon switched when jack plug-in but phone have no sound. The internal speaker and HDMI jack work fine for me.
      Would you please help? Thank you in advance
×