Jump to content
Cyberdevs

El Capitan on GA-Z170X-Gaming 5

790 posts in this topic

Recommended Posts

It's OK, I use a spare copy of my config.plist which uses a different serial number that I actually use, so don't worry about that :D

 

I already posted the EFI folder and it's attached to my previous post. you can find it there.

 

BTW I got my FakeSMC with GPU sensor to work with no problem with my new Pascal graphics :)

Share this post


Link to post
Share on other sites
Advertisement

It's OK, I use a spare copy of my config.plist which uses a different serial number that I actually use, so don't worry about that :D

 

I already posted the EFI folder and it's attached to my previous post. you can find it there.

 

BTW I got my FakeSMC with GPU sensor to work with no problem with my new Pascal graphics :)

ohhhh, good

this version

http://www.hwsensors.com/releases

i found problems with pascal, i used only Intel Power Gadget and check only processor now  ;)

 

All is OK now?

 

last two days i have many problem with clover, the last versions is "hard"

Share this post


Link to post
Share on other sites

It's weird!

 

All my sensors are gone even if I boot from my older EFI folder which I was using earlier this morning!!!

 

I found a version of HWMonitor from http://hwsensors.com/public/HWSensors.6.25-12-g23039705.1438.Binaries.dmgand it was working great with all the sensors specially GPU sensor.

 

But now their all gone :D

Share this post


Link to post
Share on other sites

if u put in Clover/Kexts/Others or S/L/E, work, may two days i have many many problems with inject kexts, i try compiled with 4068 Clover and nothing

 

Run it and reboot two times

Olarila.command.zip

Just it

sudo nvram -c
sudo purge
sudo rm -f /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -u /
sudo update_dyld_shared_cache -force

Share this post


Link to post
Share on other sites

Pewwwwwwwh! I restored my EFI folder from two days back and I deleted the caches and now it's back to normal :)

 

Thanks anyway ;)

 

Their back :D

 

as you can see the GPU sensor is working and I'm happy.

 

I usually use /EFI/Clover/Kexts to install all the additional kexts so when I do a system update they will stay untouched.

post-1011040-0-03393500-1493995123_thumb.png

Share this post


Link to post
Share on other sites

Good now it works on you rig too!

:D

 

about the HDMI audio let me see if it does, I need to trash it and reboot. I'll be back.

 

P.S. 

The HDMI Audio does work without the HDMIAudio.kext so I deleted it!

Share this post


Link to post
Share on other sites

Good now it works on you rig too!

:D

 

about the HDMI audio let me see if it does, I need to trash it and reboot. I'll be back.

 

P.S. 

The HDMI Audio does work without the HDMIAudio.kext so I deleted it!

Pascal Web drivers, HDMi audio on HDMI port does not work, HDMI/DP audio does work on DP ports.

 

1.1 version

HDMIAudio.kext.zip

Share this post


Link to post
Share on other sites

Wow, topic is alive now :)

 

Maybe you share you clean config after all of manipulations? 

I see you have USBinjectAll kext< does it need?

 

Hi there, Welcome back :)

 

Yes we're alive and kicking :D

 

I will summarize the conclusion and will give you the end result of all these test as soon as we're done. So as they say stay tuned  ;)

 

But as I mentioned earlier here I recently changed my Graphic Adapter from AMD to nVidia Pascal so I no longer use El Capitan but I will continue to post on this topic.

Pascal Web drivers, HDMi audio on HDMI port does not work, HDMI/DP audio does work on DP ports.

 

1.1 version

attachicon.gifHDMIAudio.kext.zip

Well my HDMI audio started to work when I added the SSDT-HDMI-HD530.aml to ACPI folder.

I have to Samsung displays which have no speaker and they are connected to DP ports of my graphic adapter and I have a TV connected to the HDMI port of my graphic card, the TV audio over HDMI works just fine.

I don't even have the intel graphics enabled in the BIOS though!

Share this post


Link to post
Share on other sites

Hi there, Welcome back :)

 

Yes we're alive and kicking :D

 

I will summarize the conclusion and will give you the end result of all these test as soon as we're done. So as they say stay tuned ;)

 

But as I mentioned earlier here I recently changed my Graphic Adapter from AMD to nVidia Pascal so I no longer use El Capitan but I will continue to post on this topic.

I think we need to collaborate and make a new thread for this motherboard as it seems very popular and is still being tweaked alot.

I'm more than happy to delete my guide thread for Sierra for a collaborated one.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

I think we need to collaborate and make a new thread for this motherboard as it seems very popular and is still being tweaked alot.

I'm more than happy to delete my guide thread for Sierra for a collaborated one.

 

Sent from my SM-G930F using Tapatalk

Well, it's good idea to create a collaborated thread but I think it's better to keep your thread as well because it's already there and you made a great guide and people might need it. So as soon as the tests are done we can create the new topic for GA-Z170X-Gaming 5 ultimate guide for Mac OS 10.11.x, 10.12.x and hopefully the new upcoming 10.13 :D

Share this post


Link to post
Share on other sites

Sounds good to me. As I already said though I'll be updating my guide soon when .5 or .6 is released and I do a clean install.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Well my HDMI audio started to work when I added the SSDT-HDMI-HD530.aml to ACPI folder.

I can apply it into DSDT too, just one file all solution ;)

Share this post


Link to post
Share on other sites

Sounds good to me. As I already said though I'll be updating my guide soon when .5 or .6 is released and I do a clean install.

 

Sent from my SM-G930F using Tapatalk

 

Which guide is this?

I'm currently running El Cap on my Gaming 5, and I'm looking to do a clean install upgrade to Sierra.

Hopefully, before the next release comes out ;-)

Share this post


Link to post
Share on other sites

Which guide is this?

I'm currently running El Cap on my Gaming 5, and I'm looking to do a clean install upgrade to Sierra.

Hopefully, before the next release comes out ;-)

This the guide SavageAUS created to installing macOS Sierra:

http://www.insanelymac.com/forum/topic/317548-guide-macos-sierra-1012x-on-gigabyte-z170x-gaming-5/

Check

attachicon.gifDSDT.DSDT.GA-Z170X-Gaming 5 HDMI.zip

Intel

attachicon.gif01.png

Nvidia

attachicon.gif02.png

Need test, i never test it, same patch in SSDT IntelHD

 

DONT RENAME HECI and GFX0

I will test it and get back to you.

 

P.S

It works!

Share this post


Link to post
Share on other sites

ok guys, after about 5 hours, my system is stable.

 

So I've made some changes and so far so good.

 

Thanks to MaLd0n for his patched DSDT everything works great.

 

I removed all the ACPI patches, I removed all the SSDT files, I only use his DSDT.aml file

 

I also removed NvidiaGraphicsFixup.kext and applied AGDPfix and the reason is I think those kexts made my Graphic adapter run hotter, it's just a speculation which I'm testing.

Share this post


Link to post
Share on other sites

This the guide SavageAUS created to installing macOS Sierra:

http://www.insanelymac.com/forum/topic/317548-guide-macos-sierra-1012x-on-gigabyte-z170x-gaming-5/

I will test it and get back to you.

 

P.S

It works!

 

Hi there. I am trying to follow properly when you both tested today:

 

Can you please confirm for me if this post #684 forwards:

 

http://www.insanelymac.com/forum/topic/309352-el-capitan-on-ga-z170x-gaming-5/page-35?do=findComment&comment=2418114

 

If HDMI audio worked on:

 

* The actual motherboard's Intel IGP HDMI port? Or it did not?

 

* The motherboard's Intel IGP Displayport? Or it did not?

 

* Or the Nvidia Pascal Card Displayport? Or it did not?

 

* Or the Nvidia Pascal Card HDMI? Or it did not?

 

And it would really help me to know which specific .aml patch were responsible for what. (because for Gaming 3). Many thanks.

Share this post


Link to post
Share on other sites

And it would really help me to know which specific .aml patch were responsible for what. (because for Gaming 3). Many thanks.

-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-USBX
-PMCR
-EC
-PNLF
-HDMI NVIDIA / ATI

other mobo, need other DSDT or SSDT, other bios and bios version ;) if u can open a topic in DSDT section, i edit for u

http://www.insanelymac.com/forum/forum/228-dsdt/

Share this post


Link to post
Share on other sites

Hi there. I am trying to follow properly when you both tested today:

 

Can you please confirm for me if this post #684 forwards:

 

http://www.insanelymac.com/forum/topic/309352-el-capitan-on-ga-z170x-gaming-5/page-35?do=findComment&comment=2418114

 

If HDMI audio worked on:

 

* The actual motherboard's Intel IGP HDMI port? Or it did not?

 

* The motherboard's Intel IGP Displayport? Or it did not?

 

* Or the Nvidia Pascal Card Displayport? Or it did not?

 

* Or the Nvidia Pascal Card HDMI? Or it did not?

 

And it would really help me to know which specific .aml patch were responsible for what. (because for Gaming 3). Many thanks.

HDMI Audio works with HDMI cable connected to nVidia graphics adapter not the HDMI port of the mainboard, I don't even have the IGPU enabled in BIOS.

For other ports I cannot confirm that because I didn't test it.

 

I use 2 monitors with DP cables and 1 TV which is connected with HDMI cable and the Audio works on TV speakers.

Share this post


Link to post
Share on other sites

HDMI Audio works with HDMI cable connected to nVidia graphics adapter not the HDMI port of the mainboard, I don't even have the IGPU enabled in BIOS.

For other ports I cannot confirm that because I didn't test it.

 

I use 2 monitors with DP cables and 1 TV which is connected with HDMI cable and the Audio works on TV speakers.

My HDMI audio has always been flaky. Works when it wants.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (April 2019) Updated to Clover r4918 Updated Lilu kexts - ALC, WEG Merged Verleihnix' config.plist - especially to NOT inject GFX Updated BacklightInjector as option to WEG.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×