Jump to content
Cyberdevs

El Capitan on GA-Z170X-Gaming 5

790 posts in this topic

Recommended Posts

Advertisement

Has anyone had success with this board and sierra with on board graphics?

 

Sent from my SM-G930F using Tapatalk

Yes I have. I Used macOS Sierra 10.12.1 installer and the following config.plist

 

I also managed to get my AMD Radeon HD7790 to work with IGFX set as primary with 3 displays one connected to IGFX and the other two connected to my PCIe graphics adapter. But I removed ATI settings from the file just to avoid confusion and conflicts.

config.plist.zip

Share this post


Link to post
Share on other sites

question, what is the differece between the usb installer kext folder? i see some users are putting kext in the folder named "Other" and some are in folder "10.11". why is that?

Share this post


Link to post
Share on other sites

question, what is the differece between the usb installer kext folder? i see some users are putting kext in the folder named "Other" and some are in folder "10.11". why is that?

In general kext folder inside the EFI\Clover\ is a place for adding extra kext files which are not supported by Mac OS X and Apple Computers and for clover bootloader, Mac OS X will load them and make the installation and/or loading of the Mac OS X possible on non apple computers, "10.11" is the kext folder used for El Capitan installer or the partition which is used to boot El Capitan specifically while "Other" folder is used for any other Mac OS X versions you might have installed on your hard disks. For instance if you are using clover boot loader to boot macOS Sierra you can add another folder and call it "10.12" and put all the relative kext files inside it so clover could load them for macOS Sierra or just simply use the "Other" folder. The other folder is used for any previous versions of Mac OS X installation or installed version of Mac OS X. Whether you use a USB installer or load the clover boot loader from internal hard disk you need to put those kext files inside the kext folder which are relative to your installation.

 

For more information about Clover you can see the following website to see what is what:

https://clover-wiki.zetam.org/Contents

Share this post


Link to post
Share on other sites

Question, I am having difficulty with my build.. 
I have a -
Gigabyte Z170X-Gaming 5

Intel Skylake 6700K 

Ballistix Sport LT 32GB Kit (16GBx2) DDR4 

Samsung 500GB SSD
and a GTX 660

Using SSDT-i7-6700K.aml and a pretty vanilla clover base.. I am seeing weird things like the CPU showing "1.99 GHz Intel Core i7", My Wifi doesn't work but my bluetooth does.. I am using 14,2 in my SMBIOS because thats the only one that I could get bluetooth and my video card working.. Any advice on how to clean everything up would be greatly appreciated.  I've attached a copy of my EFI folder if that helps.. 

 

Share this post


Link to post
Share on other sites

Question, I am having difficulty with my build.. 

I have a -

Gigabyte Z170X-Gaming 5

Intel Skylake 6700K 

Ballistix Sport LT 32GB Kit (16GBx2) DDR4 

Samsung 500GB SSD

and a GTX 660

Using SSDT-i7-6700K.aml and a pretty vanilla clover base.. I am seeing weird things like the CPU showing "1.99 GHz Intel Core i7", My Wifi doesn't work but my bluetooth does.. I am using 14,2 in my SMBIOS because thats the only one that I could get bluetooth and my video card working.. Any advice on how to clean everything up would be greatly appreciated.  I've attached a copy of my EFI folder if that helps.. 

 

There is no attachment here!

Share this post


Link to post
Share on other sites

Question, I am having difficulty with my build.. 

I have a -

Gigabyte Z170X-Gaming 5

Intel Skylake 6700K 

Ballistix Sport LT 32GB Kit (16GBx2) DDR4 

Samsung 500GB SSD

and a GTX 660

Using SSDT-i7-6700K.aml and a pretty vanilla clover base.. I am seeing weird things like the CPU showing "1.99 GHz Intel Core i7", My Wifi doesn't work but my bluetooth does.. I am using 14,2 in my SMBIOS because thats the only one that I could get bluetooth and my video card working.. Any advice on how to clean everything up would be greatly appreciated.  I've attached a copy of my EFI folder if that helps.. 

Where does it show the processor speed 1.99 GHz, in About This Mac window or in third party Hardware monitors? and what type of bluetooth and wireless adapter you are using? 

 

In the EFI folder you attached here it shows that you are using iMac 17,1 SMBIOS and you don't use any kind of kexts at all.

Share this post


Link to post
Share on other sites

Hey guys,

 

I recently updated my BIOS to F21 and it solved the annoying UEFI boot entries.

 

I just wanted to tell you guys in case some of you still struggling with that.

 

Cheers

Share this post


Link to post
Share on other sites

I believe it was already resolved with the F20 bios

 

 

Sent from my iPhone using Tapatalk

Oh, I didn't know that because I was still using the old F5 bios :hysterical:

But thanks for the update

Share this post


Link to post
Share on other sites

Hey guys, what's up?

 

I recently found a Patched DSDT for GA-Z170X-Gaming 5 mainboards and it works just fine. I removed all the previous patches from clover and as far as I know everything works fine on macOS Sierra 10.12.4

I cannot confirm it for El Capitan but it should work as well. Feel free to test it out and post your experience here.

 

Here is the link to barijaona's GitHub page and all the credit goes to him.

 

https://github.com/barijaona/CLOVER_GA-Z170X-Gaming5

 

Cheers

Share this post


Link to post
Share on other sites

Hey guys, what's up?

 

I recently found a Patched DSDT for GA-Z170X-Gaming 5 mainboards and it works just fine. I removed all the previous patches from clover and as far as I know everything works fine on macOS Sierra 10.12.4

I cannot confirm it for El Capitan but it should work as well. Feel free to test it out and post your experience here.

 

Here is the link to barijaona's GitHub page and all the credit goes to him.

 

https://github.com/barijaona/CLOVER_GA-Z170X-Gaming5

 

Cheers

Hi

U can test?

http://www.insanelymac.com/forum/topic/317548-guide-macos-sierra-1012x-on-gigabyte-z170x-gaming-5/?p=2417732

Share this post


Link to post
Share on other sites

After using MaLd0n's patched DSDT I can confirm:

 

I removed the following patches from ACPI:

 

change _OSI to XOSI

Change EHC2 to EH02

Rename HDAS to HDEF

Change EHC1 to EH01

and I don't need FixShutdown_0004 anymore

 

and with your AppleALC.kext

I don't need AppleHDA patches 

 

 

I still use the following Kernel and Kext Patches

 

AirPortAtheros40

AppleUSBXHCIPCI

 

Thank you MaLd0n :)

post-1011040-0-48003100-1493969899_thumb.png

post-1011040-0-44170600-1493969909_thumb.png

Share this post


Link to post
Share on other sites

i apply hdmi intel hd, i think dont have problem if u dont use graphics intel with nvidia/amd

u can send me new ioreg , last check

Share this post


Link to post
Share on other sites

I will send you the ioreg soon, but at first let me check some things with you.

 

1. At first attempt system didn't boot at all maybe that's because I didn't remove all the ssdt files from ACPI, after removing all the ssdt files. system booted normally.

 

2. Hardware sensors don't work even with my old FakeSMC.

 

3. My Front Header USB ports doesn't work any more.

Share this post


Link to post
Share on other sites

u dont need ssdt more, like hdmi, etc, only pike ssdt if u use, for usb u use usbinject all?

Post ur full Clover folder here

Is a EL capo or sierra?

 

run kextutility, just run for rebuild, etc

Kext Utility.app.zip

Share this post


Link to post
Share on other sites

it's good.

run kext utility, reboot and test usb, etc

usbinjectall Does the work

 

for sensors, try it, but without GPU Sensors, problems wit Pascal

FakeSMC.kext.zip

 

if u can, post ur full clover here, remove ur serials ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (April 2019) Updated to Clover r4918 Updated Lilu kexts - ALC, WEG Merged Verleihnix' config.plist - especially to NOT inject GFX Updated BacklightInjector as option to WEG.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×