Jump to content
Cyberdevs

El Capitan on GA-Z170X-Gaming 5

790 posts in this topic

Recommended Posts

Gigabyte eSupprt

I have opened another ticket as well stating about the duplicate uefi entries.

Hi guys,

 

So, in early January, thanks to a lot of help from @cyberdevs, I was able to get Hackintosh up and running on my i5 6500 and Gigabyte Z170-Gaming 5 motherboard. Things have been working just fine for me. The only problem is that for some reason, OS X stops booting for me if I overclock my CPU.

 

Since I have a non-K processor, I OC by changing my BCLK frequency from 100 to higher. Gigabyte uses a custom BCLK generation on the Gaming 5 mobo, so this method is totally fine. I make sure to change other relevant voltage and memory related settings as well. I have successfully managed to OC my i5-6500 to 3.7GHz and even tested it for stability and gaming under Windows 10.

 

OS X, however, just refuses to boot if I increase the BCLK frequency to more than 102. As soon as I do that, it gets stuck at this step. https://www.dropbox.com/s/tf1blvpmriqvxmx/IMG_20160223_095117.jpg?dl=0

 

I have tried quite a few things, including generating a new SSDT for my processor with the increased frequency and BCLK clock, playing around with various CPU and RAM settings in BIOS, to no avail.

 

At this point, I am really pulling my hair out. I wish I could simply exchange my 6500 CPU with a 6600K, but that is not possible where I live. I have also been unable to find a buyer for it :(

 

So, I was wondering if anyone else with a non-K Skylake CPU has managed to OC under El Cap successfully? And if you have a K CPU that is OCed, can you actually OC the CPU using the BCLK frequency and not using the multiplier to see how things go? Any help in this matter will be greatly appreciated. Thanks!

Is it really necessary for you to need to over clock?

Maybe instead of work arounds etc you just source a K version cpu?

Share this post


Link to post
Share on other sites
Advertisement
OS X, however, just refuses to boot if I increase the BCLK frequency to more than 102. As soon as I do that, it gets stuck at this step. https://www.dropbox.com/s/tf1blvpmriqvxmx/IMG_20160223_095117.jpg?dl=0

 

dreamcat4 has more information on overclocking the CPU but as I recall he uses a 6600k processor and has a gaming 3 motherboard.

 

If using the kext doesn't solve the problem maybe he can shed some lights on the matter.

 

 

I was under the impression that no *Gigabyte* has been released with such an unlocked BCLK update for BIOS, at least for our boards range... You state that '3.7 ghz' is your best OC? Well how much BCLK is that above the stock 100Mhz speed? I dont understand how you think you are overclocking it because the skylake silicone is all pretty consistent dies and Intel make 'too good quality' low-end chips. They cannot avoid that due to mfr'ing process. And that's precisely why they lock them.

 

So any random sample of them, nearly all should be able to do at least ~4 - 4.4 GHz (or more). Just except the microcode (if locked) / the mobo / and chipsets surrounding it.

 

If you cannot get a 6600K, then my best ATM advice is sell the mobo instead, and get a new mobo (which has unlocked BCLK feature). Should work OK on osx too, but check other threads for ASUS / ASROCK / whatever. To see others. And of course make sure has right firmware.

 

You can then sell your old mobo more easy than the i5-6500 (not that people know intel are coming down on it). It is also CHEAPER to switch mobo, than getting a new i5-6600K (and likely will be just as fast anyhow). Make sure you have discreete card, as no integrated iGP graphics.

 

Another future possiblility *might* be if someone can hack Gigabyte BIOS to unlock the BCLK feature. But that would first require gigabyte publish some BIOS update including it! (and o don't think they have done that). So that sort of CFW - theres no evidence of it out there yet AFAIKT. And would be more likely on an ASUS / other mfr ones anyhow. Like to 'add-back-in', and get a newer BIOS after they changed their minds and removed the BLK feature from the latest OFW. So that slim possibility is unlikely to matter to you or help you.

Share this post


Link to post
Share on other sites

I've read the news about Intel pressuring the companies whom are producing mainboards that they remove the bclk overclocking features but they will do so in future BIOS updates not the previous releases. So as far as we don't update the BIOSes the ones with non-K processors should be able to overclock their systems.

Share this post


Link to post
Share on other sites

@dreamcat4: 3.7GHz was just a number. I don't have better cooling solution at the moment, so I have not tried any further. I just want to make sure OS X plays well with my overclock before I slap a water cooler and OC the CPU to 4GHz+. I really don't think whatever issue I have has anything to do with the motherboard/BCLK, since my PC works completely fine under Windows 10 when OC'd. I have stress tested it for hours to ensure this.

 

Its likely due to the Speed step/C/P state of the CPU being disabled when OC'd which leads to OS X not booting, since when booting normally, verbose mode in OS X shows multiple CPU P/C states, which is missing from the log when OC'd. Log screenshot as posted previously: https://www.dropbox.com/s/tf1blvpmriqvxmx/IMG_20160223_095117.jpg?dl=0

 

@cyberdevs: I think we tried this. I will try it again tomorrow morning and report back.

Share this post


Link to post
Share on other sites

@dreamcat4: 3.7GHz was just a number. I don't have better cooling solution at the moment, so I have not tried any further. I just want to make sure OS X plays well with my overclock before I slap a water cooler and OC the CPU to 4GHz+. I really don't think whatever issue I have has anything to do with the motherboard/BCLK, since my PC works completely fine under Windows 10 when OC'd. I have stress tested it for hours to ensure this.

 

Its likely due to the Speed step/C/P state of the CPU being disabled when OC'd which leads to OS X not booting, since when booting normally, verbose mode in OS X shows multiple CPU P/C states, which is missing from the log when OC'd. Log screenshot as posted previously: https://www.dropbox.com/s/tf1blvpmriqvxmx/IMG_20160223_095117.jpg?dl=0

 

@cyberdevs: I think we tried this. I will try it again tomorrow morning and report back.

The reason that I'm almost sure that we didn't try it is because of the line AICPUMI: CPU P-State [  (32)  ] in your verbose log, if you had it installed it should have shown more like this:

AICPUPMI: CPU P-States [ 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 (40) 41 42 ] these are the SpeedSteps from my CPU

 

It's worth a shot. But not sure if it's gonna help solving the problem.

Share this post


Link to post
Share on other sites

@dreamcat4: 3.7GHz was just a number. I don't have better cooling solution at the moment, so I have not tried any further. I just want to make sure OS X plays well with my overclock before I slap a water cooler and OC the CPU to 4GHz+. I really don't think whatever issue I have has anything to do with the motherboard/BCLK, since my PC works completely fine under Windows 10 when OC'd. I have stress tested it for hours to ensure this.

 

So are you saying we can do unlocked BCLK on gigabyte? I was not aware of that.

Share this post


Link to post
Share on other sites

So are you saying we can do unlocked BCLK on gigabyte? I was not aware of that.

 

Yes, you can. 

 

@cyberdevs: Those CPU P-States show up fine in Verbose log when I don't overclock, but as soon as I overclock, only the 32 P-State shows up in the log. I think this is the change which OS X is not liking that is leading to issues.  

Share this post


Link to post
Share on other sites

Well in that case i guess you can uncheck the Generate P-State and C-State and see how it works.

You can also try checking the Drop OEM.

Share this post


Link to post
Share on other sites

Bummer :(

Can you boot in to Mac OS X Installer after OC'ing or you still get to the same step and it stops?

 

Stops at the exact same step. Can you try BCLK overclock on your CPU and see if it works for you or not? 

Share this post


Link to post
Share on other sites

I changed the BCLK value from 100 to 110 and system gave me few beeps and shut down, but after recovering from the first crash it cam back on, I checked the BIOS settings and the setting were saved and OS X booted normally with a boost and CineBecnch showed me better performance.

I just don't know what happened the first time exactly but I guess because I already activated XMP with 26.6 caused the system to overwhelm the RAM frequency.

post-1011040-0-41713800-1456735910_thumb.jpg

Share this post


Link to post
Share on other sites

Happy Mac background. I really miss those old marvelous machines and Mac OS Classic. I recently revived a first generation iMac which I will post some photos later.

A gift for my friends :)

post-1011040-0-58157500-1456754704_thumb.png

Share this post


Link to post
Share on other sites

I changed the BCLK value from 100 to 110 and system gave me few beeps and shut down, but after recovering from the first crash it cam back on, I checked the BIOS settings and the setting were saved and OS X booted normally with a boost and CineBecnch showed me better performance.

I just don't know what happened the first time exactly but I guess because I already activated XMP with 26.6 caused the system to overwhelm the RAM frequency.

 

Thanks! I don't think there is anything left to try now. Hopefully, this issue will be fixed once Apple releases more Skylake powered Macs

Share this post


Link to post
Share on other sites

You're welcome

 

I afraid so, but you can send me some screenshots of you BIOS so I can see what's what and see if we can get passed this issue.

Share this post


Link to post
Share on other sites

Hi guys,

 

I do not want to be a sucker for views but I would like to share a playlist on how to / info about hackintosh build on this board :)

Hopefully it is ok.

 

Link: ---deleted---

 

The episode of actual El Capitan install, clover config, bios settings etc should be out within next week.

 

And as it will be mentioned in the video... thank you again for sharing all of the info in this thread and special thanks to cyberdevs who endured my stupid quesitons :D

 

Stay awesome everyone.

Share this post


Link to post
Share on other sites

Hi guys,

 

I do not want to be a sucker for views but I would like to share a playlist on how to / info about hackintosh build on this board :)

Hopefully it is ok.

 

Link: https://www.youtube.com/watch?v=cFileoicP7M&list=PLC1SnCh9efltZjI9xkXRsjZJln56eP0Z3

 

The episode of actual El Capitan install, clover config, bios settings etc should be out within next week.

 

And as it will be mentioned in the video... thank you again for sharing all of the info in this thread and special thanks to cyberdevs who endured my stupid quesitons :D

 

Stay awesome everyone.

Nice Job :) 

Share this post


Link to post
Share on other sites

A small news: Gigabyte seem to be looking into the issue of duplicated boot entries. Or at least trying their best with it. They have asked me to check back with them in 1 week time. i.e. to see if any further progess / news about it.

Share this post


Link to post
Share on other sites

A small news: Gigabyte seem to be looking into the issue of duplicated boot entries. Or at least trying their best with it. They have asked me to check back with them in 1 week time. i.e. to see if any further progess / news about it.

 

That' good news dreamcat4 :)

Share this post


Link to post
Share on other sites

A small news: Gigabyte seem to be looking into the issue of duplicated boot entries. Or at least trying their best with it. They have asked me to check back with them in 1 week time. i.e. to see if any further progess / news about it.

 

This is awesome news, kinda tired of removing those entries manually. I heard they can brick the mobo, is there any experience with that? If it happens is there any ways to get clear the brick?

Now that i have been using my system for a while, i'm starting to miss (it was never there, but didn't bother me so much back in the beginning) the ability see rpm of my cpufan and the fans on the gtx970, is there any way to get those reporting in macos? they work fine in windows.

 

Also if anyone else gets this issue: my sound is coming out on the black rear speakers output rather than headphone green, this is no issue except in windows its on headphones, so i had to set a jumper config in regedit to get the sound out of black rear speaker in windows.

 

Going to have to look into why my machine reboots on shutdown (it shuts down but then boots up again) in mac os. but haven't had time.

 

Finally not a motherboard specific thing, but clock in either windows or macos will always deviate a few hours for me, if you get this issue: http://lifehacker.com/5742148/fix-windows-clock-issues-when-dual-booting-with-os-xfixes it.

Share this post


Link to post
Share on other sites

This is awesome news, kinda tired of removing those entries manually. I heard they can brick the mobo, is there any experience with that? If it happens is there any ways to get clear the brick?

Now that i have been using my system for a while, i'm starting to miss (it was never there, but didn't bother me so much back in the beginning) the ability see rpm of my cpufan and the fans on the gtx970, is there any way to get those reporting in macos? they work fine in windows.

 

Also if anyone else gets this issue: my sound is coming out on the black rear speakers output rather than headphone green, this is no issue except in windows its on headphones, so i had to set a jumper config in regedit to get the sound out of black rear speaker in windows.

 

Going to have to look into why my machine reboots on shutdown (it shuts down but then boots up again) in mac os. but haven't had time.

 

Finally not a motherboard specific thing, but clock in either windows or macos will always deviate a few hours for me, if you get this issue: http://lifehacker.com/5742148/fix-windows-clock-issues-when-dual-booting-with-os-xfixes it.

Use FixShutdown under ACPI to fix your shutdown issue.

 

And I found an easier way to remove all the entries from UEFI bios with clover shell, I earlier posted a way to remove the entries with UEFI Shell command prompt and I said you need to remove the entries from the last entry to first. For example if you have 10 entries you could remove them like this:

 

Shell> bcfg boot rm 09

Shell> bcfg boot rm 08

Shell> bcfg boot rm 07

and so forth then you can remove the latest entry like this:

Shell> bcfg boot rm 00

 

BUT in the new way I just remove the from the first value but I repeat the commond until the are no more entries to remove, so it will be like this:

Shell> bcfg boot rm 00

Shell> bcfg boot rm 00

Shell> bcfg boot rm 00

and so forth till there are no more entries to remove.

 

Until we hear a final solution from gigabyte guys which dreamcat4 is in contact with.

Share this post


Link to post
Share on other sites

 

And I found an easier way to remove all the entries from UEFI bios with clover shell, I earlier posted a way to remove the entries with UEFI Shell command prompt and I said you need to remove the entries from the last entry to first. For example if you have 10 entries you could remove them like this:

 

Shell> bcfg boot rm 09

Shell> bcfg boot rm 08

Shell> bcfg boot rm 07

and so forth then you can remove the latest entry like this:

Shell> bcfg boot rm 00

 

BUT in the new way I just remove the from the first value but I repeat the commond until the are no more entries to remove, so it will be like this:

Shell> bcfg boot rm 00

Shell> bcfg boot rm 00

Shell> bcfg boot rm 00

and so forth till there are no more entries to remove.

 

Until we hear a final solution from gigabyte guys which dreamcat4 is in contact with.

 

Will that not mess up my ability to boot to windows? or does clover rediscover the boot partitions? i have always been removing everything except one boot entry on my macos disk and one on my windows disk

Share this post


Link to post
Share on other sites

Will that not mess up my ability to boot to windows? or does clover rediscover the boot partitions? i have always been removing everything except one boot entry on my macos disk and one on my windows disk

 

yeah it might do from easyUEFI tool. Not really sure about from clover console.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (April 2019) Updated to Clover r4918 Updated Lilu kexts - ALC, WEG Merged Verleihnix' config.plist - especially to NOT inject GFX Updated BacklightInjector as option to WEG.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×