Jump to content
Cyberdevs

El Capitan on GA-Z170X-Gaming 5

790 posts in this topic

Recommended Posts

First of all I want to thank all the people in advance who helped make this happen all the credit goes to them, I just gathered what I’ve learned from them.

Pike R Alpha, RehabMan, Majonéz, Yassinex, Toledo, Todeleda, TheRacerMaster, OiCKilL, Andres ZeroCross, bomerr and many other great minds who helped me out. If any name/s is/are left out please let me know so I put it/them right here.

These are my specs:

Gigabyte Z170X-Gaming 5

Intel Skylake 6700K @ 4.0 GHz up to 4.2 GHz

4x8 GB 2666 DDR4 GSKILL RIPJAWS Memory Modules

Kingston HyperX Savage 240 GB 6Gbps SSD

AMD Radeon HD7790 1 GB GDDR5

TP-Link WDN-4800

CoolerMaster Nepton 120XL Cooling Unit

CoolerMaster V750-Gold Power Supply Unit

CoolderMaster Silencio 452 MidTower Case

 

BIOS Settings:

In BIOS from M.I.T. choose Advanced Memory Settings

     I. From Extreme Memory Profile(X.M.P.) I Choose [Profile1] it's crucial to choose this option if you want your memory modules work with their full frequency.

     II. Enter the correct System Memory Multiplier which in my case based on my 2666MHz DDR4 it must be 26.6.

     III. Select [Enhanced Performance] from Memory Enhancement Settings. You can choose any of the options I chose Enhanced Performance.

     IV. From BIOS Features Fast Boot is disabled, Windows 8/10 Features is set to Windows 8/10 WHQL, LAN PXE Boot Option is disabled, CMS Support is Enabled, Storage Boot Option Control is UEFI Only, Other PCI Device RPM Priority is UEFI Only and Network Stack is Disabled and Secure Boot State is Disabled.

     V. From Peripherals: VT-d is disabled, Internal Graphics is set to Auto, Audio Controller is Enabled, Audio DSP is Disabled, PCH LAN Controller,SATA Configuration is set to AHCI, Wake on LAN and High Precision Timer are Enabled. I didn’t patch my BIOS because of a great job that Pike R Alpha did with a kext based patch for Skylake processors and to patch the AppleACPI.kext.

Under Super IO Configuration Serial Port must be disabled as well.

UPDATE: I recently updated my BIOS to f5h and IOAPCIEntries 24-119 Entries is there so if you are using that version of the BIOS or anything prior to original f4 you don't need to use the ACPI patch.

     VI. Save your new settings and reboot.

Here is a copy of my EFI folder which works great with this configurations, Just remember I didn’t inject any Graphic Adapters so you have to configure it with yourself based on the graphic adapter you are using.

https://www.dropbox.com/s/7bthzjmrhex9ivp/GA-Z170X-Gaming%205.zip?dl=0

 

Activating Audio:

Download and install VoodooHDA 2.8.8.V3

Use clover configurator to edit your config.plist

ACPI: "Add the following DSDT Patch"

Comment: Rename HDAS to HDEF

Find* [HEX] :48444153

Replace [HEX] :48444546

Set the following flags under Boot section:

kext-dev-mode=1 and rootless=0

The audio won't work by default, you need to install Toledo's audio driver or install VoodooHDA.

Toledo's commands are available at: https://github.com/t...audio_CloverALC

and

VoodooHDA is available at: http://sourceforge.n...ects/voodoohda/

I personally use VoodooHDA instead of Toledo's script because for some unknown reason with Toledo's audio kexts and script while I was playing musics after a few minutes I could hear a noise which was getting worse so I tried VoodooHDA and now it work perfectly fine.

My audio layout is set to 1.

FYI: If you are going to use VoodooHDA just remember after you installed the VoodooHDA there will be a file in your application folder called "VoodooHdaSettingsLoader" which you need to place it in your login items in system preferences under "Users and groups" ---> "login Items" and adjust the "input Gain" under "VoodooHDA" in system preferences to avoid the hissing sound every time the OS starts. and if you don't every time you restart the system you'll need to adjust your audio settings. By loading this application OS will remember you settings and load them.

 

 

USB 3.0

Under ACPI add this DSDT Patch:

Comment: change _OSI to XOSI

Find* [HEX] : 5F4F5349

Replace [HEX] : 584F5349
 

and
 

Comment: Change EHC1 to EH01

Find* [HEX] : 45484331

Replace [HEX] : 45483031
 

and
 

Comment: Change EHC2 to EH02

Find* [HEX] : 45484332

Replace [HEX] : 45483032
 

Under Kernel and Kext Patches add the following to “KextsToPatch”:

Name*: AppleUSBXHCIPCI

Find* [HEX] : 83BD8CFEFFFF10

Replace [HEX] : 83BD8CFEFFFF15

Comment: Raise USB Port Limit

You also need to add RehabMan’s “USBInjectAll.kext” to the following path under EFI\Clover\kexts\10.11\

which is available for download at RehabMan’s site.

https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads

 

Graphics:

I Use an AMD RadeonHD 7790 Graphic Adapter with these settings:

Under Graphics:

Dual Link is set to 1, FB Name is set to Baladi, VRAM is set to 1024, Video Ports is se to 4, Load VBIOS is checked and finally Inject ATI is checked too.

Under Kernel and Kext Patches:

ATI Connectors Data is set to:

000400000403000000010300120403030004000004030000000101001102010100040000040300000001020021030202000400000403000000010400220504040004000004030000000105001000050500040000040300000001060020010606

and

ATI Connectors Patch is set to:

000800000400000000010300220503030004000004000000000101002103010200040000040000000001020012040201040000000400000000010400010204040400000004000000000105000000050600040000040000000001060020010605

and finally Ati Connectors Controller is set to 8000 

 

Cheers!

post-1011040-0-70386200-1454264918_thumb.jpeg

post-1011040-0-49712200-1454264936_thumb.jpeg

post-1011040-0-59475300-1454264948_thumb.jpeg

post-1011040-0-74813600-1454264975_thumb.png

post-1011040-0-77049700-1454264989_thumb.png

post-1011040-0-83580800-1454265008_thumb.png

post-1011040-0-82768500-1454265033_thumb.png

post-1011040-0-67925300-1454265049_thumb.png

post-1011040-0-05067400-1454266032_thumb.png

Edited by Cyberdevs

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

You sould disable sata ssdt drop in the clover config, and your SATA controller will work.

I installed the El Captain on my new Gigabyte GA-Z170X-Gaming 3 mothermoard two days ago, and everything works, including sleep too.

Share this post


Link to post
Share on other sites

Hi Majonez,

 

Thank you for your advice, I'm new to Clover, I used to install previous OSes with Chameleon, but i had no luck with clover yet.

I will try it as soon as possible and let you know how it went.

 

Cheers

Share this post


Link to post
Share on other sites
I installed the El Captain on my new Gigabyte GA-Z170X-Gaming 3 mothermoard two days ago, and everything works, including sleep too.

 

Hello Majonez!

 

Sorry to be a nuicance here. But I have that exactly same motherboard - Gaming 3. If you have any patience, can you please try to document all of your steps in a new thread? Or on tonymacx86 website?

 

I would really appreciate that a great deal.

 

Something else: Yesterday Gigabyte eSupport team send me an experimental beta build 'F5d' for this mobo with the missing IOAPIC setting un-hided. I've already flashed it - seems to work OK and is otherwise same as the current 'F5b' beta BIOS. Perhaps you don't need it, did the clover patch work for you? Or did you mod the BIOS yourself? Anyway please fully document steps somewhere if you can. As nobody else has done any guide for gaming 3 yet. Many thanks.

Share this post


Link to post
Share on other sites

 

> Can do you upload the BIOS image what you received?
 
 
md5sum: 193001e155ada9348760239c82302595  Z170XGaming3.f5d
 
It seems they have based it on the current 'beta' BIOS F5b. Includes the necessary IOAPIC menu option now visible under Precision Timer.
 
Thanks for 'EFI' folder. It will help very much.
 
Another Question sorry: I only have access to a Mavericks Zone (Niresh) VMWare VM where to make the m/Beast Setup etc. Should I install El Capitan to target disk directly from a running VM, or make USB Key, or make USB Installer on spare SATA HDD? Which of those 3 general method is best?

Share this post


Link to post
Share on other sites

Thanks a lot man,

 

 

I tried SATA SSDT drop but i had no luck so far, I will replace my configurations with yours and let you know how it went. :)

Share this post


Link to post
Share on other sites

 

> Can do you upload the BIOS image what you received?
 

 

It requires a decryption key.

 

If you can install the sys from the vm, do that, but you can boot up from the key on your machine directly too.

You must check my graphics settings in the plist.

 

@cyberdevs

You must replace my DSDT with yours.

Share this post


Link to post
Share on other sites

Hey Majonez,

 

Thankfully I was finally able to install Mac OS X El Capitan on my Skylake computer on a SATA Hard Disk.

Your help is much appreciated.

Share this post


Link to post
Share on other sites

Did you disable IOAPIC in your BIOS? If you don't have this option, you need Pike's kext patch.

As a matter of fact, I did both, first I patched the bios because I had trouble booting into Mac OS installer then i used Pike's patch to see if SATA works. After a lot of  rebooting and changing configuration I was able to install OS on a SATA HDD, but it's a work in progress. I have no audio yet and didn't have time to work on it.

Share this post


Link to post
Share on other sites

Don't have a guide to install ????

I have i7-6700k, z170 gaming g7 but not working to install. anyone guide ?

 

Do you have access to a working hackintosh or a real Macintosh?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By HenryV
      HP 250 G5/Skylake/I5/520 graphics/sunrise point   Insyde H20 updated with TPM, virtualizaton and secure boot disabled.  19A546d USB boots -v cpus=1 and begins install ok.  After first reboot installer hangs at 14 minutes remaining with high CPU/fan use and no HDD write activity.   Same after 4-5 hours.  First reboot apparently creates the volume group and writes the installer files to the Data volume ok.  Clover shows preboot/installer  installer and Recovery icons.  It appears that there are no system files being written to the System volume.  The reboot USB verbose output screen indicates 'assertion failed 19A546d'.  Mojave boots/runs ok on its own partition same HDD.   Anyone with similar installer issue on HP notebook and/or Insyde BIOS?  Any help appreciated.
      Essentials.zip
    • By takeawaydave
      Running Mojave 10.14.6 (18G95) on a Dell Precision 7510 and trying to get all framebuffers working properly.
       
      The following CPU is being used: https://ark.intel.com/content/www/us/en/ark/products/89608/intel-xeon-processor-e3-1505m-v5-8m-cache-2-80-ghz.html
       
      The actual Device ID of the iGPU is 0x191D.
       
      There are the following graphical outputs:
       
      mDP
      HDMI
      Thunderbolt
       
      Clover 5058 (update to date at time of writing) is being used and up to date versions of Lilu 1.38, WEG 1.3.1
       
      Till now I've been running with the following config:
       

       
      with Model Name: MacBookPro13,3
       
      When using 191B:
       
      LDVS - Ok
      HDMI (no audio) : 1920x1080
      Thunderbolt (no audio) : 3440 x 1440
      no mDP
       

       
      191B-config-ioreg.zip is attached.
       
      When using 1912:
       
      No LDVS (as expected since this arrangement is targeted for iMac17,1
      HDMI (with audio): 1920 x 1080
      Thunderbolt (with audio) : 3440 x 1440
      no mDP
       
      1912-config-ioreg.zip attached
       
      Question:
       
      How can I get audio working as with 1912 on the 191B laptop config ? 
       
       
    • By kushwavez
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (April 2019) Updated to Clover r4918 Updated Lilu kexts - ALC, WEG Merged Verleihnix' config.plist - especially to NOT inject GFX Updated BacklightInjector as option to WEG.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

×