Jump to content
Sign in to follow this  
Followers 0
neclovek

How to hackintosh?

14 posts in this topic

Recommended Posts

Hello! Yesterday I decided to throw out windows (hate it so much...) and try out hackintosh. I somehow (probably a miracle) installed Yosemite and it almost works (but with random freezes, no sound, graphic card glitches and so on...) but i want to start from the start because going into something this complicated headlessly is a suicide.

So what do I need? I need to start learning but i dont know where. If someone would help me to get into this i would really appreciate it.

 

Thanks for reading and looking forward for your replies.

Share this post


Link to post
Share on other sites
Advertisement

Thanks! I will deffinitely read that stuff.

My setup:

MB: Asus M5A78L/USB3

CPU: AMD Phenom II X4 965BE

RAM: Kingston 8GB 1600MHz

GPU: Asus Radeon HD 7770 1GB

Few SSDs to play with

3 monitors (sides on DVI and MiniDP, main on HDMI, all three different)

SoundBlaster Audigy PCI Souund card

 

Sorry if i missed something.

Share this post


Link to post
Share on other sites

Okay, i just finished reading the stuff in the link you posted. Man, there is so much stuff one has to do to get this working... I noticed all the tools needed for this are MAC only, are there some windows alternatives? Also about the DSDT stuff - Do i need it before installation or after installation?

Share this post


Link to post
Share on other sites

then export a raw dsdt 

Mac OS X operating system: use MacIASL.app or DSDT Editor.app
Under Windows operating system: use DSDT-Editor or AIDA64

Under Linux operating system: use DSDT-Editor.app

 

  • AMD CPU, should work without problems, use the latest AMD Kernel for Yosemite 10.10.5
  • GPU: Radeon HD 7770, should work without problems, either by using DSDT GPU Inject or by driver patch --> you'll find a good description on the website of rampagedev
  • Sound card, must read with SystemInfo.app, which is built exactly (vendor-ID device-ID)

Share this post


Link to post
Share on other sites

I found a thing called "TransMac", can it be used as an alternative to make install usb? Because in the tutorial there is no way of doing it from windows machine so i guess i have to keep searching....

Share this post


Link to post
Share on other sites

Yes! use youtube, there is shown. it is simple

Share this post


Link to post
Share on other sites

Well..you need osx system install at some point. Where are you going to get that? If you have a mac machine somewhere why not try making an installer there?

Share this post


Link to post
Share on other sites

If i had a mac machine i wouldnt bother to convert a windows one :D

I got myself a Yosemite 10.10.4 DMG file and i restored it to a 8GB USB. Now i guess i need to add the kernels & stuff but from the big tutorial i really dont understand step 5b:

cp "/Volumes/OS X Install ESD/BaseSystem.dmg" /Volumes/Yosemite/
cp -a "/Volumes/OS X Install ESD/BaseSystem.chunklist" /Volumes/Yosemite/
rm /Volumes/Yosemite/System/Installation/Packages
cp -a /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/Yosemite/System/Installation/Packages
mkdir -f /Volumes/Yosemite/System/Library/Kernels

What does it do? Can i somehow do it if i dont have the Mac APP but only the DMG file? What happens if i dont do it?

Also could someone recommend me a tool that makes windows able to read HFS partitions? Otherwise i dont see a way of editing the install (adding kernels)

Thanks.

 

EDIT: Damn, I just noticed you actualy linked a video tutorial - idk why it didnt show until now...looks like i did it wrong so i have to do it again.

Share this post


Link to post
Share on other sites

Spakk left you a great video guide above your post. It has link in the beginning how to do it with one 8gb flash drive. 

Yo need 7zip, Transmac (trial) and Paragon Partition Manager.

 

If you don't copy BaseSystem.* files, Packages folder and kernel, you won't be able to install OS X. That simple!  :)

 

Difference between Yosemite and Mavericks installation is in two BaseSystem.* files, name and place of the kernel (mach_kernel vs kernel)

Look here for differences, green is 10.10 and red is 10.9

post-1517990-0-54684700-1446384151_thumb.png

From this guide .

That guide is for Mac, but you can use it just to compare what are the differences as you follow that YT guide.

 

 

Edit: I just saw your edit! :hysterical:

Share this post


Link to post
Share on other sites

So cool, after 10 minutes of extracting the InstallESD.dmg 7zip cancels it with some weird error mesage (object disconnected from its clients or something like that) and also i cant install paragon partition manager because when i open the setup it says invalid drive M: - I dont even have drive M, wtf?

It almost seems like windows is trying to prevent me from making an OS X installer...

 

EDIT: http://i.imgur.com/ZKO1rfV.png WHYYYYYYYYYY

Am i doing something wrong? Its the 5GB installESD.DMG from the yosemite.app shared content but when i open it with 7zip it only has this 8MB file in it...i am just about to give up

Also i dont have enough data for today left so i cant download another copy of OS X (stupid FUP...)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kujobeans
      Gigabyte Aorus Z390 Ultra
      Intel i7 8700
      Geforce GTX 760
      16Gb Ballistix DDR4
       
      I've built several computers including 7 hackintoshes (since snow leopard) and this build has me stumped.
      Have tried many methods on many boards including BIOS tweaks and kexts but every time I do I get to the bootloader choose the USB drive and then I'll get several lines in verbose mode and then the prohibitory sign and stuck. Thoughts?
      Any help is appreciated.
      Thanks
      Kurt

    • By fighttoby
      I have tried to install clover via no UEFI legacy mode (and with UEFI method) using the method here (http://www.tonymacx86.com/yosemite-desktop-guides/144426-how-install-os-x-yosemite-using-clover.html)
      both times I can get to just past the clover boot screen and it freezes after that.
      I have verbose (-v) selected in boot options: On the non-UEFI install then it hangs on:
      "Waiting on <dict ID="0"><key>IOProviderClass</key>...."
       
      I have had a lot of issues with trying to get the installer working and many different things that had to be disabled but now it just gets to here and stops. Some times it will glitch out on this screen and give me a the circle with the line through it and text garbage around it where the text in the pictures are.
       
      Need help please.
       
      This is the laptop im using the specs are the same nothing has changed.
      https://www.asus.com/Laptops/ASUS_VivoBook_X202E/


      config.plist
    • By viktr
      Hi!
       
      Please help - cannot install mojave on the gb z370n wifi, 8700, 2x samsung 970 nvme, rx570
      Downloaded latest clover and kexts and installation hangs at the beginning.
      Got some errors at boot (during clover boot, before menu appears) then boot "Mojave install" and then it stuck. Please help. Tried to turn off all fixes, tried old apfs.efi instead of apfsdriverloader - all with no success. Maybe it's a known issue and I'm just doing something completely wrong?
       
      ty
       
       


      clover.tar.gz

    • By Fede1132
      Hi guys i have a problem install macOs Mojave on my PC, I have this configuration:

      CPU: Ryzen 7 2700X;
      GPU1: GTX 970 Strix(For game rendering and 144Hz Monitor);
      GPU2: GTX 750ti Strix(For 2nd monitor rendering to get 100% performances from 1st 144Hz Monitor);
      MotherBoard: MSI x470 GAMING PLUS
      Hard Disk 1 (Windows 10): Samsung EVO M.2;
      Hard Disk 2 (For Storage): RAID (1) between two hard disks;
      Hard Disk 3 (For Mojave): Kingston SSD 120GB;

      I have created my USB with this:
       
      Create Bootable USB Code: sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB -- /Applications/Install\ macOS\ Mojave.app -- nointeract && say Done. Clover Settings: Boot: Verbose; dart=0; nv_disable=0; kext-dev-mode=1; GraphicsEnabler=No; XMPDetection = No. Cpu: C6. Devices: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Inject (Full Enabled); Add ClockID (Full Enabled); FixOwnership (Full Enabled); Gui: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Enabled (Full Enabled); Screen Resolution: 1920x1080; Kernel and Kext Patches: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Apple RTC (Full Enabled); KernelPm (Full Enabled); SMBIOS: iMac(18,3); System Parameters: Inject Kexts = Yes; Inject System ID; Used Kexts: FakeSMC FakePCIID NVIDIA WEB LILU BIOS: VT-d = Disabled; XHCI Hand-Off = Enabled; Legacy USB Support: Enabled; Hard Disk: AHCI Mode; Selection Mode: Legacy + EUFI; Clover Install Log:
      Full Error Log:
       
×