Jump to content
retrogamer95

Titan Black Doesn't Work Properly after Installation of Nvidia Web Drivers(Clover/10.11)

18 posts in this topic

Recommended Posts

Installed El Capitan in system (in signature) with two GTX Titan Black GPUs. GPUs not supported natively (Found this odd, as all Keplers are apparently supported natively as of 10.9) Booted with nv_disable=1, installed Nvidia web drivers 346.03.03f02 after installing El Capitan 10.11.1.

 

Rebooted and got black screen after loading. After a couple minutes, the cursor appears. I moved it around to find the password input box (Completely invisible, but cursor changed to text input icon) and then typed my password, after which I get the spinning beach ball loading icon and nothing more. Tried booting with only one GPU installed, same issue.

 

Managed to properly boot into OS with nv_disable=1. (Albeit, at a low 1024x768 resolution with various visual glitches) Not sure why the drivers don't work, searched around and no one seems to have this issue except with Maxwell cards, and the fixes I've found don't work.

 

So, I tried an old AMD card I had on hand to replace one of the Titans.

 

The system booted fine, with the AMD card being seen as a generic card (Working very much like the Titan with "nv_disable=1"). Oddly, the monitor hooked up to the remaining Titan worked as it should with the proper resolution. System profiler shows the Titan as it should, with all the proper specifications.

 

I put the other Titan back into place and the issue occurs once again. Tried with only the one that worked before (In the same secondary slot) and I got nothing, something about having the AMD card installed changed its boot behavior.

 

Booted with the AMD card again, the display hooked up to the Titan no longer showed any display. System Profiler still showed it as hooked up though, so I reconnected it. This caused the monitor to turn on and display as it should, but the entire system froze a few seconds after. After a few minutes, I was given a login prompt again, and after logging in, everything works as it did the first time I had the AMD card connected.

 

Tried to open Safari, it lags a lot, freezing up the system each time it does for 30 - 60 seconds, though I think it may have something to do with the AMD card being the primary card (And only having 5MB VRAM accessible). It would seem acceleration does not work properly with this configuration.

 

 

Boot Arguments: (Clover)

"dart=0 kext-dev-mode=1 nvda_drv=1"

 

Any help is appreciated.

Share this post


Link to post
Share on other sites
Advertisement

MacPro 5,1 Currently, which is closest to the system specs.

I have also tried, MacPro 3,1 and iMac11,3 (Which crashed upon boot, probably due to having two cpus installed).

Share this post


Link to post
Share on other sites

what are the specifications of the CPU


Maybe you need this patch in confi.plist if your MacPro 5.1 SMBIOS is because you do not have ECC memory



<dict>
    <key>Name</key>
    <string>AppleTyMCEDriver</string>
    <key>Find</key>
    <data>cgoATWFjUHJvNCwxAE1hY1BybzUsMQBY</data>
    <key>Replace</key>
    <data>cgoAAAAAAAAAAAAAAAAAAAAAAAAAAABY</data>
</dict>

Look here

Share this post


Link to post
Share on other sites

No, you are correct that the GPUs do not have ECC. I thought you meant the RAM.

For the hell of it, I decided to try a couple Quadro FX580 cards (Which do have ECC) and got the same issue. This means that even older Nvidia cards are affected by it. Before I thought it was just a Kepler GK110 thing.

Share this post


Link to post
Share on other sites

Yes, as are most Quadros. I'm not sure why the Nvidia drivers would require ECC though when using a Mac Pro SMBIOS. Most Mac Pros that came with Nvidia cards came with Geforce cards, which have never had ECC, so the system should be able to work with Geforce cards. (And as I noted above, even Quadros with ECC didn't work)

 

Edit: Tried a FX5600 (Which is officially supported by the Nvidia drivers) and the system hangs at boot at,

"AppleTyMCEDriver::start coreVIDPID = 0x2c708086 Number of packages =1 Number of cpus = 12 memory monitor through MCA" for a while, and then finally booted to the login prompt.

I added what you said to in post #4 to my config.plist and it caused the same thing to appear, but "NVDANV50HAL loaded and registered" appeared after it before the system before the system hung. After about 5 minutes it reached the login prompt. The FX5600 is only recognized as Display (5MB) while the FX580's are fully recognized. It would seem to me that the primary card is always unable to use the drivers for some reason or another. wheras all other cards will work as intended. (But without acceleration, they're kind of useless)

 

Removing the FX580s caused the "NVDANV50HAL loaded and registered" message to go away. Still hangs. The "Architecture couldn't be recognized!" message sticks out to me. Perhaps something needs to be edited in the Nvidia kext? A bit odd considering the driver is made for the FX5600. I'm not sure where to go from here.

Share this post


Link to post
Share on other sites

based on my AMD Hackintosh with GTX 550 TI, work properly with nvidia web driver,  when I remove problematic Extensions from S/L/E ... which is independent of which OS X version are installed..... but no guarantee for Intel Hackintosh.

 

and patch the AppleGraphicsControl.kext as here described:

http://www.insanelymac.com/forum/topic/300375-cant-install-black-screen/

 

Edit:

here it has pikeralpha better described.:

https://pikeralpha.wordpress.com/2014/05/01/os-x-mavericks-10-9-3-build-13d55-seeded/

Edited by spakk

Share this post


Link to post
Share on other sites

Deleting the kext didn't fix anything, I just get a black screen now after it finishes loading.

I went to patch AppleGraphicsControl.kext, only to find my board ID was already there.

Share this post


Link to post
Share on other sites

 IMO, your case seems unique. I would revert back to a fresh 10.11.1 without the nvidia driver. Cant you fake the Titan ID with your Titan Black? The bad thing in general if your card  running as another card it surely will not be performing very well. 

Share this post


Link to post
Share on other sites

I thought I may be able to fake the card's ID, but I'm not sure it is the card, as I tried using the FX5600 (One of only eight cards listed as supported by Nvidia) and it also has trouble. I could still attempt it, but I'm not sure how to go about that.

The other thing I'm thinking may be the issue, is the weird way PCI is setup on the T5500, the GPUs go into what are named slot 2 and slot 4, they don't work in the other PCIe slots, despite being full length (Though at x8) and the system tries to use GPUs in PCI-X or PCI first. Perhaps something there screws it up?

I don't quite get why I have any issues though, as I have found other posts where people have gotten graphics cards working in T5500's and T7500's (The larger version, same series), the only real difference being they all used Lion or older.

 

Edit: I removed the Nvidia drivers. The system with the FX5600 still appears as "Display 5MB" and the Titans show up as "Nvidia Chip Model 128MB" and whether I use the boot argument "nv_disable" or not, the system acts as though the boot argument is in use.

Share this post


Link to post
Share on other sites

 "used Lion or older" Saw that to, in the past you could swap some kexts for older versions and bam the graphics is working again but in these recent 10.10, 10.11 in my case seems to fail. I will google it to try to see if anyone with a 10.11.0 has done it with the Blacks 

Share this post


Link to post
Share on other sites

I've not found a single documentation of anyone running a newer version of OS X on the T*500 systems. I had a similar issue with getting Ethernet to work using the guides I found, no solution worked for modern (10.9+) versions of OS X. I had to buy an Apple USB Ethernet adapter to work around it.

Unlike Ethernet, there is no easy workaround for GPUs. Running without acceleration makes it kind of useless to have such nice cards, so I may be out of luck (And even cards that should be guaranteed to work, don't). I can't run anything older then 10.9 and expect things to work/be supported software-wise; I may have to go the Virtualization route instead.

 

EDIT: I decided to try a GTS 450 that I had on hand, and it managed to work with Nvidia kext injection enabled in Clover. I may try it with the FX5600 as well. Seems that I may be stuck using older cards, but I suppose that is fine. Haven't tried to install the web drivers, but if the card works well enough without them, I shouldn't need them.

 

EDIT2: The GTS 450 is victim to the "fermi freeze" issue that occurs with non GF100/GF110 fermi cards. The FX 5600 works perfectly with inject nvidia set in Clover.

Share this post


Link to post
Share on other sites

I had the same problem. Here's what I did that fix it (I'm using chameleon, don't think it will be much different in clover though)

 

- In my BIOS, I have a menu "Init Display First". The default value is PCI. I changed it to PEG.

- Boot to OSX using nv_disable=1

- Install Nvidia web driver 

- Restart

- Use these boot-args: GraphicsEnabler=Yes kext-dev-mode=1 nvda_drv=1 PCIRoot=1

Share this post


Link to post
Share on other sites

I decided to use a newer GPU, I figured GF110 would be supported, so I bought a cheap GTX 590. I now get a black screen during the middle of Mac OS booting with or without the Nvidia driver. Oddly enough, the card is partially recognized by the system even when using nv_disable=1, though acceleration is disabled. One GPU shows up as "Geforce GTX 590" the other shows up as "NVIDIA Chip Model".

It also worked fine when booting to setup with only Nvidia graphics injection, not sure what is added after setup that could mess with it. Disabling Nvidia graphics injection causes the system to reboot half way through the boot sequence.

 

EDIT: The problem may have to do with a new change made to Apple's graphics control kext in 10.10.3 (Which obviously would effect all future versions) I'll try using a modified kext I found and see what happens.

 

EDIT2: No change

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SAMEH209
      I've successfully installed High Sierra (10.13.0) on my system using Clover:
      2x Intel Xeon E5410
      16GB Ram
      GTX 950
      Everything is running fine except the GPU. I've tried the web driver's latest version and 378.10.10.10.25.106 but both are very laggy/sluggish.
      I've also tried installing Lilu and nVidiaGraphicsFixUp kexts but they didn't change anything.
      Have someone managed to make this card work with High Sierra?
    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By rvxtm
      Hello,
       
      Maybe i am the only one seeing this or maybe i am doing something wrong but my resize animation performance in HS 10.13.5 is terrible.
      I did a clean install of 10.13.5, installed the latest nvidia drivers 387.10.10.10.35.106. 
      My GPU is a GTX1060 connected via DP to a 4k display.
      Now, the issue, when i open an empty TextEdit for example, if i drag the corner of the window to make it larger, it lags more and more as the size increases.
      I also have Adobe Audition CC installed for my work, the interface is very slow compared to the windows version (my 2011 macbook pro is much faster, but it's not 4k).
      Is there a known issue when running 4k on nvidia web drivers ?
      It's very frustrating because i've been using custom machines with 1080p displays and nvidia cards since Snow Leopard, but i was always butter smooth.
       
      Thanks.
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By JohnCenaTheMemeMachine
      I'm not expecting too much help, but if anyone has any suggestions, that would be great.

      I recently got my Hackintosh running on macOS 10.14, and went to install the graphics drivers for my Nvidia GeForce GTX 750 Ti. My setup is a little different, so here it is:

      Screen 1 Screen 2 Screen 3

      Screen 1 and 2 are both connected to my 750 Ti, whereas screen 3 is connected to my iGPU, with is an intel HD 4600. The intel GPU works like a charm, just as it did under High Sierra.

      Now, I got the Nvidia Web drivers to "work" by removing any traces via the "Web Driver Toolkit" that others have recommended. I then patched the installer, installed it, rebooted, patched the installed drivers, and rebooted again, where the drivers are at their current state.

      This is where things get interesting though. All 3 monitors are recognized. My GPU is recognized in my system profiler. However, it is NOT able to be used to run a compute in Geekbench, meaning that GPU acceleration is obviously disabled. The other thing that doesn't work, is, well, the 2 monitors connected to the GPU. They are set to the correct resolution and refresh rates, and are recognized in System Preferences, and I can even drag things between the different desktops.

      But I can only see my cursor. The screens are totally black, and I can't see anything on them except my cursor moving across them. Has this happened to anyone else? Thanks in advance!

      Specs:
      Asrock B85M-Pro4 Motherboard
      Intel Core i5-4690 CPU
      Intel HD 4600 GPU 1
      Nvidia GeForce GTX 750 Ti GPU 2
      iMac 15,1 SMBIOS

      Here is a picture of what happens
      https://imgur.com/gallery/lWTLWlw

      My clover and EFI folders are attached
      EFI.zip
×