Jump to content
Allan

[Guia] - Criar penboot do OS X 10.11 - Clover

151 posts in this topic

Recommended Posts

Opa!

A imagem da App Store mesmo, Versão 10.11.3 , subiu, deixei o hack largado e fui tomar banho, quando voltei estava parado na tela do clover .... desliguei o hack e agora de manhã liguei e funcionou numa boa.

Já vi que a Ethernet não pegou, vou ver os USB's e outros detalhes aqui e venho dar um feedback

------- editado

Deu erro quando fui resetar

 

Na instalação do Clover marquei o OsxAptioFixDrv ou preciso deixar desmarcado?

Versão 10.11.3

d40badf2d69671b3306ce687ef94dc2b.jpg

Share this post


Link to post
Share on other sites
Advertisement

Opa!

 

A imagem da App Store mesmo, Versão 10.11.3 , subiu, deixei o hack largado e fui tomar banho, quando voltei estava parado na tela do clover .... desliguei o hack e agora de manhã liguei e funcionou numa boa.

Já vi que a Ethernet não pegou, vou ver os USB's e outros detalhes aqui e venho dar um feedback

 

------- editado

 

Deu erro quando fui resetar

 

Na instalação do Clover marquei o OsxAptioFixDrv ou preciso deixar desmarcado?

 

Versão 10.11.3

 

d40badf2d69671b3306ce687ef94dc2b.jpg

 

 

Amigo, eu indico você usar 2 pen drivers. Um  com uma instalação do OS x intocável e outra apenas com o Clover. Você Pode tentar a primeira install em UEFI e caso tenha problemas pra subir a install podes tentar o clover em LEGACY.  Podes tentar usar o OsxAptioFixDrv2

Share this post


Link to post
Share on other sites

Opa!

 

Fiz a instalação do Capitão normalmente, foi numa boa.

Fui dar um reset nele, acho que foi para atualizar o itunes, safari e thunderbolt .... resetou, entrou no clover, selecionei o SSD e deu aquela tela.

Share this post


Link to post
Share on other sites

Uma pesquisada + leitura basica te ajuda champs: Como dar upload nos arquivos usando o gerenciador do Forum.

 

 

Portas USBs não estão funcionando muito bem no El Cap por hora, talvez adicionando patches no DSDT possa te ajudar.

 

 

Dependendo do SMBios, pode ficar limitado mesmo, iMacs tem poucos states.

Testa aqui: How to check your states – Using AICPMInfo, MSRDumper or AppleIntelInfo

 

 

Usa a flag: nvda_dvr=1

 

 

Tem 3 opções para habilitar o audio dentro da pasta, você tem que escolher qual o melhor.

 

Usando o Clover vai evitar preocupações com futuros upgrades.

 

 

 

Allan, já consegui encontrar a aba de attach files.  :thumbsup_anim:

 

Eu chequei o meu ssdt e tem apenas 2 states rolando: x12 e x23. Uma observação: Eu já tenho esse ssdt.aml há um bom tempo e sempre usei ele com o chameleon e tinha todos states perfeitamente. :/ do x8 ao x31.

 

Com relação ao driver da Nvidia web já consegui por pra funcionar. Eu mudei uma letra: nvda_drv=1 ao invés de nvda_dvr=1

 

Eu gostaria de habilitar as outras duas portas USB 3 do notebook. Qual seria o melhor guia?

 

Em outro post você diz: citacao.jpg

Eu notei que quando abri o IORegistryExplorer não tem nada referido a kext X86PlatformPlugin e usar o plugin-type 1 na SSDT. O que devo fazer em relação a isso? O meu CPU é Ivy... :

 

IO%20REG%20CPU.jpg

 

Vou deixar em anexo o meu config.plist(atualizado) + Ioreg + DSDT E SSDT. 

Grato com a forçaa!!!

dados.zip

Share this post


Link to post
Share on other sites

Tenta usar esse config.plist:config.plist.zip

 

Mas mantenha os arquivos que ainda usa.

 

Troquei seu SMBios para um mais apropriado para sua maquina, as vezes isso influência.

 

O "plugin-type=1" estava injetado 2x, tanto no config.plist + SSDT.

 

Agora fiquei impressionado, você conseguiu fazer a Nvidia funcionar, vivendo e aprendendo.  ;)

Share this post


Link to post
Share on other sites

Tenta usar esse config.plist:attachicon.gifconfig.plist.zip

 

Mas mantenha os arquivos que ainda usa.

 

Troquei seu SMBios para um mais apropriado para sua maquina, as vezes isso influência.

 

O "plugin-type=1" estava injetado 2x, tanto no config.plist + SSDT.

 

Agora fiquei impressionado, você conseguiu fazer a Nvidia funcionar, vivendo e aprendendo.  ;)

 

Allan, fiz o teste com sua config.plist modificada pra MacbookPro10,1. Mesmo assim ainda continuo tendo duas states apenas. a x12 e a x23. Estou sem ssdt.aml pois quando uso não consigo subir o sistema. Ele fica sem vídeo.

Outra coisa: Você pode me enviar a sua AppleHda.kext do 10.11.4 sem modificações pra eu testar outro patch aqui. Obrigado.

Não sei se gero outro ssdt.aml mas esse é o que sempre funcionou pra mim, menos com o clover. :/

Share this post


Link to post
Share on other sites

Eita cara, eu não uso o El Cap, só o Mavericks por hora.

 

Seria uma excelente ideia você gerar uma nova SSDT, o patch que o Pike disponibiliza é 100% funcional.  :)

Share this post


Link to post
Share on other sites

Eita cara, eu não uso o El Cap, só o Mavericks por hora.

 

Seria uma excelente ideia você gerar uma nova SSDT, o patch que o Pike disponibiliza é 100% funcional.  :)

 

Estou recriando ele. O comando certo para o meu Ivy seria: ./ssdtPRGen.sh -workarounds 3 ? valeu!

Já baixei o script mas estou com dúvida com os parâmetros.

Share this post


Link to post
Share on other sites

Você selecionou errado o destino do SSDT.

 

Sequência correta seria, n/ n/ e /n.

 

Pra coletar o arquivo modificado, vá em: seuusuario/ Library/ ssdtPRGen/ ssdt.aml

Share this post


Link to post
Share on other sites

olá

 

como de costume maior confusão com tuas config.. faz anos que tu faz hackintosh e sempre mesma coisa

 

pelo que vi

 

usa em teu config .. > ssdt

 

dropoem > true

 

Generate p e c-states > true

 

quanto ao bt

 

BrcmPatchRAM2.kext + BrcmFirmwareData.kext

 

em efi/clover/kexts/10.11

 

https://bitbucket.org/RehabMan/os-x-brcmpatchram/downloads

 

melhor que tem em Pernambuco é Ivete ..

 

bom hack

Share this post


Link to post
Share on other sites

 

usa em teu config .. > ssdt

 

dropoem > true

 

Generate p e c-states > true

 

quanto ao bt

 

BrcmPatchRAM2.kext + BrcmFirmwareData.kext

 

em efi/clover/kexts/10.11

 

bom hack

 

Olá, Artur. O Bluetooth funcionou perfeito:

 

bluetooth%20works%2010.11.jpg

 

 

 

Agora com relação ao ssdt, usei a config como voce disse mas ele sobe mas da tela preta quando vai pra tela de login. 

 

 

 

post-177314-0-24355100-1459311109_thumb.jpg

 

Adicionei a config que estou conseguindo subir o sistema. Grato. =)

 

config.plist.zip

 

Eu tenho mais uma dúvida: Como eu instalo o clover em legacy no meu hd? Ele funciona melhor do quem com UEFI. obrigado!!

 

OBS: Já tentei instalar o Clover direto no HD em Legacy mas o boot n reconhece. Será que tenho que formatar meu hd em MBR? Só consigo subir com o boot legacy com o pen driver feito com o boot bootdiskutility.

Share this post


Link to post
Share on other sites

olá

 

essa config está dando erro

 

para instalar em legacy não precisas de tabela mbr

 

tens de instalar o boot correto

 

bootaf

 

ou

 

boot0ss

 

bom hack

Share this post


Link to post
Share on other sites

Ola..
Aqui,apesar de ingles,da para ver a install em legacy...nao esquecer de desativar uefi na bios se for o caso..
http://www.insanelymac.com/forum/topic/305255-making-a-10101011-usb-installer-w-clover-uefi-and-legacy-the-correct-way/

 

EDIT

 

ou alias aqui mesmo claro..http://www.insanelymac.com/forum/topic/309019-guia-criar-penboot-do-os-x-1011-clover/page-1

 

desculpe @allan

A install em uefi a partir do passo #3...legacy logo apos...e antes tem a preparacao

O chato para mim em uefi, eh ficar montando particao efi com frequencia ate acertar a config certa...


C.frio

Share this post


Link to post
Share on other sites

 

tens de instalar o boot correto

 

bootaf

 

ou

 

boot0ss

 

bom hack

 

 

Já tentei os dois métodos acima mas acredito que minha placa-mãe só faça boot em legacy com HD em MBR, pois, a bios é tanto UEFI (GUID) e legacy (MBR) ela boota os dois... vou formatar o HD em MBR e reinstalar o boot em legacy. 

Share this post


Link to post
Share on other sites

Perai, você consegue subir o Pendrive em Legacy certo? Mas isso não é problema.

 

O importante é instalar o OS X em GPT, pois com a EFI você pode instalar o Clover no modo UEFI.

 

Usar o modo Legacy nessa maquina é um desperdício. 1f615.png

Share this post


Link to post
Share on other sites

Já desisti do legado mas a

Perai, você consegue subir o Pendrive em Legacy certo? Mas isso não é problema.

 

O importante é instalar o OS X em GPT, pois com a EFI você pode instalar o Clover no modo UEFI.

 

Usar o modo Legacy nessa maquina é um desperdício. 1f615.png

Já desisti do legacy mas estou precisando da ajuda de vocês, quando chegar falo aqui. Já está instalado o os do zero. Quero organizar esse boot e depois pos installl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×