Jump to content
Sign in to follow this  
Followers 0
bboczeng

Clover with Mac skylake CPU support?

34 posts in this topic

Recommended Posts

I can't personally recall a time in recent memory when Apple has had a custom intel chipset designed for one of their computers. We know the iMac is Skylake and Z170 is the only thing that supports Skylake atm.

Share this post


Link to post
Share on other sites
Advertisement

I can't personally recall a time in recent memory when Apple has had a custom intel chipset designed for one of their computers. We know the iMac is Skylake and Z170 is the only thing that supports Skylake atm.

 

True in the open market, but H170 or something like that is coming soon. It wouldn't be out of the question for Apple to make a deal to get these chipsets (iMac = MILLIONS of computers) before they are released to the general public. Maybe not custom chips, but normal production chipsets before they are available to us.

Share this post


Link to post
Share on other sites

There are many chipsets for skylake, don't assume till you know for sure, could be h170 or something else even.

 

Comming soon? H170 is out, been out for a while, long before iMac came out in fact. Pls show me proof its z170 and i will gladly shut up.

 

Curently available chipsets being used on mobos are Z170, H170, H110 and B150

Just need someone with access to said high-end model for pulling the IDs.

However I doubt it is 110 as it only supports a single pair of memory, high-end imac has two pairs (4 slots). Also the 110 can only drive 2 displays at once. Q/B line could be, but I doubt Apple would be interested in the business stuff they have (extra money on the low end and redundant on the high end). Most likely Z170 or H170 for the top of the line. I would think on the high-end imac they would want the extra pcie lanes coming off of the Z170 and more flexibility in splitting the lanes. Then again Apple didn't go Thunderbolt 3 so there should be plenty of bandwidth to keep the TB 2 ports fed + all I/O without any major constraints. *shrugs* 

Share this post


Link to post
Share on other sites

Played around with the 10.11.2 beta and I can now get past a lot of the issues but the PCH, as stated before, just isn't being autodetected and configured resulting in issues with AHCI SATA. USB system is also throwing errors left and right. Apple must have changed something with how the PCH and some things hanging off of it are detected and configured as PJALM pointed out. Just giving it the Device IDs still gives wonky behavior. Using the board-id: Mac-65CE76090165799A – Model: iMac17,1 [(Retina 5K, 27-inch, Late 2015) / Core i7 4.0GHz] for basis of SMBIOS joy.

Share this post


Link to post
Share on other sites

I, too have been trying to get this working. Also stuck at the "still waiting for root device" with a prohibited/blocked logo, and the rest of the text is jumbled. I'm trying to get this working on an msi laptop however, and this is about as far as i can get. I've tried disabling things in the clover boot menu with no luck. Anyone have any ideas on how to fix this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×