Jump to content
Hashirama

Instalar Snow Leopard em CPU Haswell

52 posts in this topic

Recommended Posts

Olá, eu percebi que o problema de não iniciar, está relacionado o org.chameleon.boot.plist. Toda vez que vou ajustar pelo chameleon wizard ele trava no boot. Como posso fazer o upload do dstd? Não estou conseguindo.

Share this post


Link to post
Share on other sites
Advertisement

Olá, eu percebi que o problema de não iniciar, está relacionado o org.chameleon.boot.plist. Toda vez que vou ajustar pelo chameleon wizard ele trava no boot. Como posso fazer o upload do dstd? Não estou conseguindo.

 

comprima antes.

Share this post


Link to post
Share on other sites

obrigado pessoal. Agora deu certo.

 

A dsdt foi aplicado os patchs de hpet, acl 883, shudown gigabyte, dtpg, ich7. Será que funciona? O audio está funcionando sem a Voodoo, baixei as kerxts apple hda hda enable e instalei pelo kext wizard. :thumbsup_anim:

Placa de video foi atividade pelo nvenable.pkg, não consegui utilizar o chameleon wizard para ativar, selecionava a opção GraphicsEnable mas não funciona.

DSDT.aml.zip

dsdt.dsl.zip

org.chameleon.Boot.plist.zip

Share this post


Link to post
Share on other sites

Se está c/ dúvidas sobre o patch, tenta aplicar este patch que é completo. Como vc não tava conseguindo baixar do olarila eis o bicho. :D

GA G31M-ES2C.txt.zip .

Depois de editar o DSDT, coloca em Extra. E inclui no chameleon.boot.plist :

<key>GeneratePStates</key>

<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

Carrega o sistema e digita no terminal kextstat e verifica se a LPC.kext tá carregando, se estiver, deleta a NullCPUPower.kext. E bom hack.

Share this post


Link to post
Share on other sites

Obrigado pelo Patch. Vou testar e depois vou postar o resultado. Uma coisa que me deixa intrigado é que toda vez que uso o Chameleon Wizard, modificando alguns parâmetros, o sistema não inicia, somente com o cd de boot.

Share this post


Link to post
Share on other sites

Olá, desculpe minha burrice, mas eu não consigo mais iniciar o sistema de  novo :wallbash:. Eu modifiquei umas opções do cadeado (um pequeno) que fica na pasta do sistema e escolhi uma opção que outros usuários não teriam acesso. Também modifique o nome de usuário. Não sei qual é a responsável pela não inicialização dos sistema.

Já tentei criar um novo usuário pelo terminal mas não consigo. Tentei utilizar este comando: sudo dscl . -create /Users/johndoe. Mas o sistema informa: sudo: command not found. Muito estranho.

post-1598972-0-27886200-1446317236_thumb.jpg

Share this post


Link to post
Share on other sites

Olá, não consegui subir o sistema. O jeito foi reinstalar.

 

Se está c/ dúvidas sobre o patch, tenta aplicar este patch que é completo. Como vc não tava conseguindo baixar do olarila eis o bicho. :D

attachicon.gifGA G31M-ES2C.txt.zip .

Depois de editar o DSDT, coloca em Extra. E inclui no chameleon.boot.plist :

<key>GeneratePStates</key>

<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

Carrega o sistema e digita no terminal kextstat e verifica se a LPC.kext tá carregando, se estiver, deleta a NullCPUPower.kext. E bom hack.

Eu editei a dsdt e coloquei na pasta Extra e instalei o Chameleon. O sistema ficou mais rápido. As kext instaladas são: fakesmc.kext e nvenable.kext. Digitei kextstat e não vi listado a LCP.kext, somente com.apple.driver.AppleLPC.

Não consegui adicionar o texto que vc mandou, eu marquei a opção P States e C States no Chameleon wizard, mas o sistema não iniciou. Não instalei NullCPUPowerManager.kext e não deu panico no kernel. Obrigado pelo patch.

 

 

Faça uma comparação com o arquivo .plist do CD Boot com o da sua maquina, as vezes é algo faltando.

Eu reinstalei o Chameleon e voltou a iniciar. Acho que é problema no Chameleon Wizard. A org. que funcioana está anexada.

 

Dá o boot c/ -v pra ver onde tá parando .

Quando o sistema não inicia, ele sempre para em [PCI Configuration begin].

 

Depois de adicionar a dsdt a suspenção funciona, a bios não apaga, o audio foi identificado (Intel High Definition Audio), porém não funcionou. instalei AppleHDA e funcionou. O processador está um pouco mais quente, não sei porque.

org.chameleon.Boot.plist.zip

Share this post


Link to post
Share on other sites

É essa com.apple.driver.Apple.LPC.kext mesmo, sorry mas eu abreviei o nome. Vc tá tendo gerenciamento de energia nativo, depois tem que ver a questão dos States que esse eu não entendo muito bem. Dá pra ver c/ o aplicativo Dpcimanager.  Acho que tem na seção downloads do site. Qto ao pci configuration begin coloca boot.plist (npci=0x2000) e reinicia o hack pra ver se para de travar em pci configuration begin. Se persistir, inclui no boot.plist (PCIRootUID=1) e reinicia. Qto à temperatura, veja se consegue instalar o HWMonitor, acho que tem na seção downloads do site.
Bom hack.
Obs.: Baixa o aplicativo hachintosh vietnam que tem os aplicativos que mencionei, deve estar em tools. <qdo abrir o aplicativo instala somente os aplicativos>

 

Veja se funciona: org.chameleon.Boot.plist.zip :thumbsup_anim:

Share this post


Link to post
Share on other sites

Olá, coloquei o arquivo que vc mandou e resolveu, ele não travou no pci configuration begin. No momento, ele tá parando em ACPI_SMC_PlatformPlugin: :registerLPCDriver - Failed to locate SMC driver. Eu instalei a fakeSMC.kext será que tem haver? Não consegui instalar o HWmonitor. Dcpimanager informa os dispositivos que estão no computador.

Share this post


Link to post
Share on other sites

Olá, eu tirei uma foto de onde ele para. Antes de ACPI_SMC_PlatformPlugin: :registerLPCDriver - Failed to locate SMC driver, aparece Waiting for Dsmos

post-1598972-0-05064100-1446482104_thumb.jpg

Share this post


Link to post
Share on other sites

Olá pessoal, o sistema está subindo agora. Instalei a fakesmc na pasta System/Library/Extensions. Baxei a kext aqui. A dica peguei aqui no fórum e no Tony. Uma versão mais nova compatível com minha configuração? Tentei instalar uns programas mas, a maioria é incompatível.

Agradeço a todos que me ajudaram nessa tarefa difício de instalar e configurar o OS X no PC. Obrigado.

Share this post


Link to post
Share on other sites

FakeSMC atual pode usar a que vem no pack HWMonitor.

Se tiver erros com a LPC, pode seguir o método com DSDT ou usando o Clover.

Olá, o sistema está subindo beleza. Eu não consegui instalar o HWmonitor. Por enquanto não há erros com LPC.

 

Tenho uma dúvida: Por que não há muitos programas compatíveis com Snow Leopard? Fui instalar o Libre Office e não era compatível, o BlueStacks também não. Achei estranho.

Share this post


Link to post
Share on other sites

Não era pra instalar o HWMonitor, mas sim a FakeSMC que vem dentro dele.

 

Bem comparando com o tempo do Snow Leopard, ele é quase um Windows XP né, então... :rolleyes:

Share this post


Link to post
Share on other sites

Não era pra instalar o HWMonitor, mas sim a FakeSMC que vem dentro dele.

 

Bem comparando com o tempo do Snow Leopard, ele é quase um Windows XP né, então... :rolleyes:

Será que é possivel instalar e usar o Yosemite na nessa máquina: Intel Pentium Dual Core E5200, 2x1 Gb DDR II 800, Samsumg 160 Gb Sata II (Snow Leopard 10.6.8), Samsung 80 Gb Ide (Windows 8.1 Pro), Gigabyte GA-G31M-ESC, Zogis Nvidia Geforce 9500 DDR II 512 Mb, ACL 883, RTL 8169? Tenho a .dmg dele. Estou precisando instalar alguns programas.

Share this post


Link to post
Share on other sites

Olá pessoal, instalei o Yosemite, como inicializador instalei o Clover. A instalação foi tranquila, utilizei o método que Allan postou para instalação via pendrive. O sistema está apenas as kexts Fake.sms e nullpowermanager. Ainda não coloquei a dsdt. Em comparação com Snow Leopard, achei mais pesado, sendo que está utilizando muita memoria 1,13 Gb. Não sei se é normal. O video foi reconhecido na instalação, não foi necessário nenhuma kext para ativá-lo.

Share this post


Link to post
Share on other sites

Olá pessoal, estou com algumas dúvidas com relação à configuração do clover: como transferir as configurações do chameleon e colocar a dsdt no clover, já procurei mas não achei?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×