Jump to content
JahStories

[Guide] Surface Pro 1st gen El Capitan clean installation

220 posts in this topic

Recommended Posts

I'm giving this {censored} up, sorry. This topic is a mess, the files are mostly outdated and this whole.. argh. Screw it. 

Ernsthaft, das isn Scheiß. Da steht man soll das neueste Clover benutzen, nutzt man das neueste Clover geht die Config plist nicht mehr damit, die ganzen Kext files, alle unsortiert und ohne plan kommt man da nicht weit. Es sollte echt mal jmd der da noch durchsteigt einfach nen Clover ordner zippen, hochladen und gut ists. Der OSX Stick ist schnell gemacht, auch ohne Windows und Clover ist es scheißegal ob es auf dem Stick ist, oder auf der EFI partition, dass ist das einzige was ich aus der Sache gelernt habe. Echt schade. Hab es mit 10.10,11 und 12 probiert.. Nada, es bootet einfach das Setup nicht weil ich 1. zu dämlich bin, 2. ich keinen Schimmer hab welche kext wo hin müssen und 3. ich da nicht mehr durchblicke. 

Nuja... Ob das nun egal ist mit Clover auf der Disc oder auf dem Stick sei mal dahingestellt... Dein Versuch als "proof-of-concept" lässt mich daran zweifeln ob es sinnvoll ist so zu verfahren, wenn andere es so wie beschrieben gemacht haben... und erfolg hatten. 

Zum Thema neues Clover: schau mal von wann der Thread ist... da war Clover v.... aktuell/neu. An der Clover-Version liegt es eher selten. An den fehlenden Files, liegt es sehr oft.

 

Sieh dir nochmal meine Verzeichnisstruktur an auf den Bildern an. Da ist eigentlich alles ersichtlich.

 

Falls Dein Aufgeben irgendwann mal aufgibt:

 

- Bootstick erstellen, mit Cloverpartition und installiertem Clover. Die Daten einfügen/austauschen (im Clover-Verzeichnis). Wohin steht hier oder im ersten Thread. (oder ersichtlich in meinen Screenshots)

 

und dann wie beschrieben verfahren.

 

Das ganze ist kein "walkthrough" und auch kein "hit-and-run". Dafür kannst Du mit € auch nen Real-Mac kaufen. Und gut. Kein Stress.

 

Dafür gibt es auch keinen tragbaren Touch-Hackintosh aka Surfaxe.

 

Schau dir mal die anderen Threads an (Cintiq, Surface3 und 4) die haben ganz anderen Spaß. 

 

Ein Bisserl Durchhaltevermögen, Frust vertragen und der "Das haben andere geschafft, ich schaffe das auch"-Spirit gehören schon dazu. Außerdem solltest Du dich auskennen... wenn man dann z.B. alles am laufen hat, und SwitchResX (z.B.) haut einem die falsche Bildschirmauflösung rein (OK...ich wars ;) ) - dann sitzt Du da mit einem schwarzen Bildschirm, weißt das das System läuft aber auch das ein Install ansteht, bzw. ein Backup. Das macht spaß.

 

Alles was ich dazu gebraucht habe ... sind dieser Thread, und der erste Thread auch von JahStories und ja, ich habe alles, wirklich alles dort gelesen. Manchmal langweilig, manchmal lustig. Andere lesen HarryPotter. So what.

 

Bis meine Kiste so war wie sie ist, habe ich gefühlt 20 fresh installs gemacht. und die Config-Plist 300 mal bearbeitet... reboot... etc. und die DSDT gesucht, bearbeitet. und den Sound mit der richtigen KEXT (I Dont really want to know how often JahStories did First-Installs in the beginning... i think there must be 200 or more, fresh installs ---- BIG UP Jah!)

 

So what. It is my hobby.

 

Lass es Dir gut gehen, nimms nicht so hart.

 

 

Anmerkung: Wenn man dann checkt wie der Hase läuft, reicht tatsächlich die Information auf der ersten Threadseite um den Surface zum Surfaxe zu machen... is so.

 

SORRY TO ALL READERS... we now stop germaning and go back to englishing ;) before it gets off topics. I guarantee you... you missed nothing serious.

Share this post


Link to post
Share on other sites
Advertisement

Na dann tu mir bitte den einen gefallen, lade mir deinen fertigen Clover ordner vom Stick, und den Fertigen von der EFI Partition hoch und ich versuche es morgen ein letztes mal auf arbeit, mit einem echten Macbook um clover "sauber" zu installieren.

 

Ich würde so vorgehen:

1. Install Stick für 10.12 erstellen (stock)

2. Clover drauf installieren 

3. ..so, da bin ich ratlos welche kext dateien auf den Stick müssen, und welche zu Clover

4. mach_kernel ins root verzeichnis

5. denk kram ENDLICH mal installiert bekommen

 

Nimms mir nicht übel, aber ich hab echt keinen nerv mehr auf dieses Trial & Error, ich verbringe die letzten mit 2 Tage nix anderem und komm trotzdem nichtmal zum setup weil ich zu doof bin mir hier die beeren zurecht zu picken, ich nicht weiß welche files für welches OSX gehen und gottbeware wo sie überhaupt alles hin müssen (Clover/kexts/10.12 oder doch auf den Sierra stick zu /System/schlagmichtot/). Wenn deins funktioniert, dann funktioniert es sicher auch bei mir, schließlich haben wir beide ein Surface Pro. 

Share this post


Link to post
Share on other sites

Na dann tu mir bitte den einen gefallen, lade mir deinen fertigen Clover ordner vom Stick, und den Fertigen von der EFI Partition hoch und ich versuche es morgen ein letztes mal auf arbeit, mit einem echten Macbook um clover "sauber" zu installieren.

 

Ich würde so vorgehen:

1. Install Stick für 10.12 erstellen (stock)

2. Clover drauf installieren 

3. ..so, da bin ich ratlos welche kext dateien auf den Stick müssen, und welche zu Clover

4. mach_kernel ins root verzeichnis

5. denk kram ENDLICH mal installiert bekommen

 

Nimms mir nicht übel, aber ich hab echt keinen nerv mehr auf dieses Trial & Error, ich verbringe die letzten mit 2 Tage nix anderem und komm trotzdem nichtmal zum setup weil ich zu doof bin mir hier die beeren zurecht zu picken, ich nicht weiß welche files für welches OSX gehen und gottbeware wo sie überhaupt alles hin müssen (Clover/kexts/10.12 oder doch auf den Sierra stick zu /System/schlagmichtot/). Wenn deins funktioniert, dann funktioniert es sicher auch bei mir, schließlich haben wir beide ein Surface Pro. 

 

 

DA schauen... und mal die erste Seite durchlesen... hattest Du das schon??? (hier wird die Cloverinstallation etwas genauer beschrieben... die Treiber die du brauchst, kannst in meinem screenshot sehen).

 

 

Zitat:

 

Ich würde so vorgehen:

1. Install Stick für 10.12 erstellen (stock) 

2. Clover drauf installieren 

3. ..so, da bin ich ratlos welche kext dateien auf den Stick müssen, und welche zu Clover ---> DENKFEHLER! Clover ist auf dem Stick. Da müssen die Files hin... 10.12 Ordner für die KEXTs musst du anlegen. Das andere checkst Du wenn Du endlich mal dein Verzeichnissystem von Clover sehen kannst.

4. mach_kernel ins root verzeichnis ---> Hä??? Nie gehört. Brauchen wir nicht: VANILLA!!!

5. denk kram ENDLICH mal installiert bekommen ---> Ja sicher. Wenn Du dann von EINEM stick installierst.

 

 Wir haben es alle hier geschafft. Du auch. 

 

Nochmal: INSTALLIERE CLOVER AUF DEN STICK. NIX HÄNDISCH. NIX WINDOWS. Vorher mit dem aktuellen DiskmakerX? einen Bootstick erstellen. Clover drauf mit den nötigen Treibern. Wenn Du gelesen hast hat es schon einer mit zwei USB-Sticks versucht. FAIL!

BEIDES MUSS AUF EINEN STICK! Manchmal brauchst Du sogar einen anderen USB-Stick... warum auch immer. War bei mir so.

 

Einen Mac/Hacki brauchst Du dazu. Und wenn es nur Stundenweise ist... 

 

Wenn Du es so nicht machen willst... geh Deinen eigenen Weg. Es zwingt hier keiner, niemanden.

 

Ich könnte auch ne komplette ISO von meiner Festplatte ins Netz stellen. So ist das hier aber nicht gedacht. Finde ich auch nicht gut. Danach fragen nur LEECHER. Hier werden Foren-Mitglieder gebraucht.

Share this post


Link to post
Share on other sites

mmmmh... was working before ... didn't test it

... wait...

 

Working as expected... just drop the kexts we talked about a couple of posts before ;)

Share this post


Link to post
Share on other sites

I have decided to try your guide and I can get a functioning installer made and get into the setup.. but it would appear to be in Italian.. any idea how I can change it to english as its throwing an error I can't read after I try to install after partitioning the HD on the surface

Share this post


Link to post
Share on other sites

I have decided to try your guide and I can get a functioning installer made and get into the setup.. but it would appear to be in Italian.. any idea how I can change it to english as its throwing an error I can't read after I try to install after partitioning the HD on the surface

 

Hi. As i remember you got asked for your language. Screen%20Shot%202013-11-22%20at%2010.02.

Share this post


Link to post
Share on other sites

I have decided to try your guide and I can get a functioning installer made and get into the setup.. but it would appear to be in Italian.. any idea how I can change it to english as its throwing an error I can't read after I try to install after partitioning the HD on the surface

If it didn't ask you for language, you may want to look at Clover's config.plist into GUI/Language. (Docs here)

Share this post


Link to post
Share on other sites

If it didn't ask you for language, you may want to look at Clover's config.plist into GUI/Language. (Docs here)

 

Hi. As i remember you got asked for your language. Screen%20Shot%202013-11-22%20at%2010.02.

 

It did not ask for my language nor Do i have a back button to go back and select another language.. thank you I will look at clovers config

 

 

and @caleidoCope... this is the SECOND thread you've posted absolutely useless rubbish that has had no bearing. Please let this be a BLUNT message.. If you have the answer by all means share it.. But since it was fairly obvious you didn't and your out trolling please stop posting. As I didn't get a language selection Or i'd have PICKED one I can read.

Share this post


Link to post
Share on other sites

If it didn't ask you for language, you may want to look at Clover's config.plist into GUI/Language. (Docs here)

 

Thank you the config.plist on the EFI partition was set to italian.. I switched to English with the help of your documents. thank you very much..

I now have 2 new issues. 

 

1) Screen is very white...

2) Says it cannot validate my El Cap installer and it may have been modified during download.. I do not believe its the newest copy of the installer but without internet on the Surface I'm not sure how its comparing that or why it thinks that.. 

post-827588-0-02760500-1491782815_thumb.jpg

post-827588-0-61215100-1491782838_thumb.jpg

Share this post


Link to post
Share on other sites

@Timelord83

1) If I remember correctly, this was caused by original/unpatched DSDT and AppleIntelFramebufferCapri.kext. Try to live with it during the installation – I'm not sure whether this has been fixed. If the white screen still appears after booting the installed OS X, check that you are using the correct DSDT and AppleIntelFramebufferCapri.kext.

2) This may be caused by an expired certificate. Apple signs Installer packages for verification before installation. If the signature is no longer valid (certificates expire after some time), it can trigger this error. Check that your date/time is set correctly (e.g. in Windows, if you still have those installed, or in the installer: Utilites > Terminal, then type date). If it is correct, try changing your date to ~1 week after the release of the version of OS X you are trying to install. See here for more information:

http://apple.stackexchange.com/questions/216730/this-copy-of-the-install-os-x-el-capitan-application-cant-be-verified-it-may-h

Share this post


Link to post
Share on other sites

@Timelord83

1) If I remember correctly, this was caused by original/unpatched DSDT and AppleIntelFramebufferCapri.kext. Try to live with it during the installation – I'm not sure whether this has been fixed. If the white screen still appears after booting the installed OS X, check that you are using the correct DSDT and AppleIntelFramebufferCapri.kext.

2) This may be caused by an expired certificate. Apple signs Installer packages for verification before installation. If the signature is no longer valid (certificates expire after some time), it can trigger this error. Check that your date/time is set correctly (e.g. in Windows, if you still have those installed, or in the installer: Utilites > Terminal, then type date). If it is correct, try changing your date to ~1 week after the release of the version of OS X you are trying to install. See here for more information:

http://apple.stackexchange.com/questions/216730/this-copy-of-the-install-os-x-el-capitan-application-cant-be-verified-it-may-h

thank you very much your assumption on the expired cert was correct after setting my machine date back to 16 it is installing.. thank you very much

Share this post


Link to post
Share on other sites

I'm on Sierra, using the DSDT_w_Pwr in post #172 and the AppleIntelFramebufferCapri.kext in post #176. QE/CI works, but it's white and flickering (as has been seen in previous posts). I saw a bunch of you had solved it, but actually saying how you did it would be nice.

 

Edit: I installed the latest ACPIBatteryManager.kext and cleared the kernel cache, and didn't need the modified AppleIntelFramebufferCapri.kext anymore. Everything seems to work except double tap to drag, sleep, and brightness adjustment (10.12.5). Will be looking into the latter: https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/

Share this post


Link to post
Share on other sites

Use the rehabman Intelbacklight kext.

 

Can somebody post a proper plist and DSDT and SSDT for Surface Pro 2 in Capitan or preferably Sierra 10.12.6 ??

 

Thanks in advance!

 

Honestly would be great if the community comes together to make the final version of each OS version function perfectly on both Surface Pro 1 and 2.

Share this post


Link to post
Share on other sites

Tried the no_pwr DSDT and the SSDT from the first page on a Surface Pro 2 in Sierra and the machine was doing an auto reboot. Said something about Aptiofixdrv and that was about it. 

 

Any recommendations how to get past that? Currently running Sierra on SP2 based on another guide, yet would like to use the DSDT that was posted on this topic because it seems bluetooth works properly with that on SP1. 

 

Thanks in advance for guidance on getting that working with SP2 properly! 

Share this post


Link to post
Share on other sites

Hello, I'm interested in the problem of the work of BT and WIFI, could you solve it and if so, you can get the instruction and files?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×