Jump to content
arsradu

[HOW TO] Fix second stage boot logo and loading bar for some dedicated desktop video cards

389 posts in this topic

Recommended Posts

in the config.plist

 

?

 

Please, remove the sensitive information from your config and upload it here to take a look.

 

This is what you should see in your config. 

post-1303722-0-58155000-1518816089_thumb.png

 

You provided the Graphics section. I'm more interested in the Devices section.

 

If you open the config with a text editor (I suggest Sublime for that), in your Devices section, you should have something similar to this going on.

 

post-1303722-0-23833200-1518816469_thumb.png

 
So I would suggest uploading the config.plist here to take a look.

Share this post


Link to post
Share on other sites
Advertisement

 

Please, remove the sensitive information from your config and upload it here to take a look.

 

This is what you should see in your config. 

attachicon.gifpost-1303722-0-50532800-1444057472.png

 

You provided the Graphics section. I'm more interested in the Devices section.

 

If you open the config with a text editor (I suggest Sublime for that), in your Devices section, you should have something similar to this going on.

 

attachicon.gifScreen Shot 2018-02-16 at 23.26.31.png

 
So I would suggest uploading the config.plist here to take a look.

 

yes yes, I followed the procedure and entered in the config.plist

Share this post


Link to post
Share on other sites

You can see if everything is right

 

2luqrm0.png

 

Please, upload:

 

1. default and edited device-properties.xml

2. default and edited device-properties.hex

3. config.plist (remove sensitive data)

 

What you're showing me doesn't tell me anything about your editing. It just shows that your boot display is located at the first port (A@0). Which is fine. But I can't tell you if everything is fine, based on that. Since you didn't actually show me what you did. The editing itself. That's the important part. Not the ioreg.

 

So, please, upload the files mentioned above if you want me to take a look at it.

Share this post


Link to post
Share on other sites

Please, upload:

 

1. default and edited device-properties.xml

2. default and edited device-properties.hex

3. config.plist (remove sensitive data)

 

What you're showing me doesn't tell me anything about your editing. It just shows that your boot display is located at the first port (A@0). Which is fine. But I can't tell you if everything is fine, based on that. Since you didn't actually show me what you did. The editing itself. That's the important part. Not the ioreg.

 

So, please, upload the files mentioned above if you want me to take a look at it.

 

 

here's to you
 
thanks

aplha22.zip

Share this post


Link to post
Share on other sites

 

here's to you
 
thanks

 

 

You didn't quite follow the tutorial step by step. Did you? :)) Also, you didn't attach the original (unedited) files.

 

Anyway, the editing is probably mostly on point.

 

Just so you know, you don't need to inject EDID. Clover does that automatically.

 

What I would recommend is to make a separate config with your changes (you can call it config_test or something) and one without those changes. So you can have a backup in case the changes you made are not ok.

 

Anyway, did you give it a try? Does it work for you?

Share this post


Link to post
Share on other sites

You didn't quite follow the tutorial step by step. Did you? :)) Also, you didn't attach the original (unedited) files.

 

Anyway, the editing is probably mostly on point.

 

Just so you know, you don't need to inject EDID. Clover does that automatically.

 

What I would recommend is to make a separate config with your changes (you can call it config_test or something) and one without those changes. So you can have a backup in case the changes you made are not ok.

 

Anyway, did you give it a try? Does it work for you?

 

Hi, these are the original files

Alpha22.zip

Share this post


Link to post
Share on other sites

Hi, these are the original files

 

Yeah, I'm pretty sure those are not the original files. :) First, your device-properties should be an xml, not a plist. Second, it shouldn't contain stuff like your Nvidia card ROM version and all that. If you extracted them now, after applying the patch, it doesn't really work.

 

Anyway...let's move on. Did you try these edits? Do they work for you?

Share this post


Link to post
Share on other sites

Yeah, I'm pretty sure those are not the original files. :) First, your device-properties should be an xml, not a plist. Second, it shouldn't contain stuff like your Nvidia card ROM version and all that. If you extracted them now, after applying the patch, it doesn't really work.

 

I was wrong, you're right these are the ones extracted

Alpha22.zip

Share this post


Link to post
Share on other sites

Yes, I tried the modified version

 

Ok. Let's make a deal so we don't spam everyone subscribed to this thread.

 

I try to put everything I need in one post, and you try to read everything and reply. This way, I don't need to repeat my questions a thousand times until I get a reply. Do you think we can do this? :))

 

I asked you if it works for you. And you seem to have read only the first question and ignore the second one. Just like you ignored it in my previous posts.

 

I would like to ask you to stop doing that and try to read the entire post, and then reply.

 

I'd like us to have a productive conversation here, in which you get your issue fixed and I get to keep the rest of my neurones alive. :))

 

So, what is the status right now? Does it work? Do you have the logo in place? Do you have the loading bar in place (in the middle of the screen)? Do you have ANY changes?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By NoEnd
      Hi team,
       
      I'm looking for the best route to achieve this upgrade, so I have been stuck with HS since Nvidia drivers stopped being supported on newer MacOS releases. Now I'm having an AMD 5700 xt on the way and want to plan the upgrade properly. I have added some information below and questions that might help with your recommendation.
       
      Current GPU 1080 ti with Nvidia webdrivers installed. So should I uninstall the webdriver before adding the new GPU? Clover is being used and EFI attached. Any kext must be removed? or parameters adjusted MacOS HS 10.13.6, should I upgrade before using the new GPU? CPU: 9900K Motherboard:ROG MAXIMUS XI HERO (WI-FI) Dual Monitors I have a Time machine backup, Do you recommend a fresh install? and If I did, will I be able to restore my data/apps as-is?  
      Please let yourself free to explore further aspects to considers.
      EFI-20200204.zip
    • By Tushark2
      Hello,
      1st my laptop spec. 
      CPU - 2.53 GHz Intel Core i3 380m
      RAM - 6 GB 1333 MHz DDR3
      GPU -  1st gen Intel HD Graphics 288 MB
      Laptop - Dell Vostro 3500 series
      BT/WIFI - AzureWave BCM94352HMB
       
      I installed Olarila Mojave 10.14.6 and managed to install 1st gen intel HD graphics but it was bit laggy bcos this gnu doest support metal and its a old machine, so I decided to move to Olarila High Sierra.
      I installed it with most of things working fine expect some issues, for that I want to make SSDT and DSDT to make it run without glitches.
       
      I am atteching my sendme.zip , can some take a look to my current settings and suggest me some changes  
      (Olarila down from few days for me )
       
      Send me MacBook-Pro.zip
×