Jump to content
zzz

Workaround for Ricoh card readers on Yosemite (PCI) Laptop

6 posts in this topic

Recommended Posts

Keywords:

Ricoh, PCI, SD, SDXC, VoodooSDXC, HSSDBlockStorage, T61, T61p, R61e.

 

Recently decided to get a T61p running Yosemite: Noticed a heap of people out in the cold with Ricoh based PCI card readers. 

 

I am no programmer, but I can google well and I do like to see how kernel extensions work with a bit of tweaking.

 

Noticed the HSSDBlockStorage.kext for JMicron based PCI cards exposes the PCI to JMB38X.kext

 

So I took a look at both kexts and a working kext for Mavericks for the "Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 21)" (Perfect T61 Hacbook Bundle -Google -HackintoshOSX forums), added values from JMB38X.kext to VoodooSDHC.kext, added values from VoodooSDHC.kext to HSSDBlockStorage.kext and it loaded and read the cards, formatted etc.

 

I dont have source code for HSSDBlockStorage or coding knowledge, however AppleSDXC.kext is out there.  I have noticed Slice and Andy Val and a few over at OSXLattitude have been looking at Ricoh based cards. I am hoping this might shine some light. Who knows.

 

What I will say is I own a T61p from '07. Anyone who knows the backstory of Nvidia GPU's from back then knows that they are volatile - prone to atefacts and dieing. So I have to treat my computer with cotton wool, I have probably spent more time keeping this machine stable and looking at the console than most (no offence to those that do/don't).  If I didnt do GPU intensive tasks on a volatile GPU I would class this "hack" as OK to pass as a 100% working solution, but on this machine (untested on others -note: some bios's dont report IRQ's properly, FSB, etc etc) when I hit hi triangle counts I can get GPU errors with this "solution/hack". I attribute it to the way the PCIe is handing access to the VoodooSDHC kext.

 

I am talking very high stress situations though. I could run this machine with 0 errors with this hack and use cards IF I didnt tax the GPU to the extreme at times. I'd Imagine a more modern card would work just fine (this is a '07 machine with a GPU undervolt and with its core and clock matched to the gt 8600m 256mb DSDT patched to match - originally fx 570m).

 

What I am hoping is this will help the average user to enable Ricoh cards. Swap out the VoodooSDXC for one that works for you and check the values of the kexts to match yours up, or try a previously working other kext alongside HSSDBlockStorage. Maybe HSSDBlockStorage can be patched with a HEX editor to replace the strings to curb one console nag. Maybe sources for HSSDBlockStorage are out there somewhere.... Once again I am no Coder, just an enthusiast Hacker.

 

I have noticed some people out there using a solution using JMB38X.kext, VoodooSDHC.kext, and VoodooSDHC.kext for their systems already, for other cards. Maybe my method is better or worse.

 

I can do 3D modelling with these kexts, I just cannot game or run huge scenes. If you are willing to face a kernel panic and stress test, maybe theres a fix. I am hoping that this might open up a path to using AppleSDXC on its own - as I own the "Advanced 2503 Dock" and adding ricoh dev ven id's to it opens up this ricoh card reader on that piece of hardware.

 

Happy Hacking and I hope I have made some contribution here, if your ricoh reader is not the same be prepared to edit VoodooSDXC.kext, or try other kexts alongside HSSDBlockStorage looking at what i did inside both.

 

ZZZ

 

 

 

Edit:

 

Seems taking content from AppleSDXC.kext and putting them in the zip file attached called "VoodooSDHC.zip" was enough for my Ricoh device.

 

You will need to remove AppleSDXC.kext, fire up the console, use kextutility and observe any messages.

 

In my case it worked just fine, I was able to use 1.1d1 with:

	<key>OSBundleLibraries</key>
	<dict>
		<key>com.apple.iokit.IOPCIFamily</key>
		<string>2.0.0</string>
		<key>com.apple.iokit.IOReportFamily</key>
		<string>1.0</string>
		<key>com.apple.iokit.IOStorageFamily</key>
		<string>1.2.7</string>
		<key>com.apple.kpi.bsd</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.iokit</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.libkern</key>
		<string>9.0.0</string>
		<key>com.apple.kpi.mach</key>
		<string>9.0.0</string>
	</dict>
	<key>OSBundleRequired</key>
	<string>Local-Root</string>

At the end.

 

Archive.zip

VoodooSDHC.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

Thansk ZZZ,

 

It works like a charm on my DELL E6400 running El Capitan 10.11.2.

Perfect !!!!

 

Sorry, but I am a little confused what needs to be done. I'm running 10.10.5 on Latitude e6500. Can you please help me? Am I supposed to just drop in VoodooSDHC.kext in /S/L/E or should I drop it in /Extra/Extensions? And I should just remove AppleSDXC.kext from /S/L/E?

 

So that's just what I did. Card Reader does not show up under System Information. HOWEVER, when I insert card it mounts !!!

Now one issue. If I restart the machine or login / logout, Card mounts TWICE. Why?

 

PS On another note appreciate guide to install El Capitan on Latitude E6500/E6400

Share this post


Link to post
Share on other sites

I have 2 laptop dv9700, dv2700. Both are same sd card reader RicohR5C822(1180,0822) and run Yosemite. Installed kext above dv9700 working perfectly however dv2700 not working. When I inserted the card its not showing. I've check the kext load in IORegistryExplorer though. Anyone know how to fix? Thanks

IORegistryExplorer.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By guitarsimo93
      Buon giorno a tutti ragazzi!
      Vorrei aggiungere un lettore di SD (interno) al mio hack, l'OS attualmente installato è 10.11.6.
      Ho a portata di mano un lettore che dovrebbe essere della acer, connettore usb2 a header direttamente per la scheda madre.
      Ovviamente ho già provato ad attaccarlo con una leggera speranza che funzionasse da solo, ovviamente non va  o meglio, la porta usb funziona (ovviamente visto che è passante) mentre tutti gli slot per le card non vanno.
      Il chip montato sulla scheda che si occupa degli slot delle card è: ALCOR AU9368
      Sapreste darmi un aiuto?
       
      Per quel che vale il pezzo non escludo la possibilità di acquistarne uno nuovo, potreste consigliarmene uno? Se possibile usb2 e non 3 perché ho tutti gli header usb3 sulla mobo occupati
       
      Grazie mille a tutti quanti intanto 
    • By Lilith
      Hi,
      i have a little old mobo with socket 1156 no Sata 3 - biostar tpower i55 and i Was wondering if i had some chance to install a new nvme memory like Intel 760p.
      Due lack of support by my mobo i found a Pci Express card lycom dt-120 to expand my connectivity.
      After some researches i understood that i need a ‘bios support for the boot from nvme disk’. I want some of these nvme memory to install high Sierra and get a killer desktop.
      I think that i haven’t obviously a native bios support cause my mobo is pretty old, so i can’t get an nvme disk and install properly high Sierra hoping that boot?
      Or should i catch anyway? I Guess that same problem is for w10? 
      Thanks, Gabriele.
    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
      AppleIntel8255x.kext.zip
    • By ITzTravelInTime
      I have started this thread to discuss about old and very cheap ethernet cards working in the latest macOS releases, cards who just uses old ethernet controllers or are new and cheap cards with old ethernet controllers, this thread is just to discuss about such cards and also to have a list in the first post with reported working cards with drivers linked.
      To contribute you have to report which card of this kind is working for you and which driver or method you followed to get it wo work and also which issues you have, and then it will be added in the list.
      I start reporting cards which worked for me, yours will be added in the future:
      intel 8255X based cards:
                just works using the AppleIntel8255X kext (look in the attachments) and seems to be stable with no issues
       
      And also there are some cards i am curious to see if can work with mac, so i leave this part at the end of the post, do you know if it's possible to get realtek pci (not pci express) ethernet cards working in the latest mac os? i have a few of them and i have difficulties fining drivers for mac, having a driver for the latest mac wil help me in creating also a youtube video with the cheapest hackintosh compatible ethernet cards
       
      AppleIntel8255x.kext.zip
    • By grujicic
      First I would like to thank you guys for the great community and perfect source of the informations.
       
      After a lot of struggle i've finally manage to turn this server mobo into great and powerful macpro rig. (smbios - MacPro 5,1)
      It runs sierra 10.12.12 with no errors but there is one strange catch.
       
      This mobo has 7 pcie slots, but only first - bottom three actually works !? dpcimanager don't recognise any of the pcie cards inserted into other / upper 4 pcie slots. (pretty sure that bios settings are correct, and these cards works withouth any problem under windows)
       
      I'm using dsdt (there's no way to boot macos installation or the system without one)
       


       
       
      ** quick example - kt4006 usb 3.0 card (which works oob with 10.12.12) works just fine when is inserted into 3rd pcie slot from the bottom, but doesn't work if it is inserted in any of 4 upper - marked with red - pcie ports.... Basically with this I just want to confirm that the problem is not about pcie cards and specific driver / settings related to them.. it is about slots.
       
      Maybe a few of the initial problems i had with this mobo could be a good clue... After successful sierra installation os recognized 12 cpu threads instead of 24, and 16 gb of ECC Ram instead of 32.
      Cpu cores / threads problem is fixed by adding extra cpus in my dsdt file and ram problem by adding proper slot info via clover configurator.
      Now both memory and cpu cores works perfectly.
       
       
      Supermicro X8DTH-6f http://www.supermicro.com/products/motherboard/QPI/5500/X8DTH-6F.cfm 2x Xeon e5645 32gb ecc evga GTX 960 2gb ssc  
      Thank you!
×