Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KrzychuX86
      Hello my friends!
      First, idk if that's proper place for this post, if not, please move it.
      I'm trying to get Mojave working on my laptop. I have all proper kexts. Everything works great on Yosemite and Sierra, because I'm using Enoch bootloader for them. But I can't get Mojave to work with Enoch, so my only option is Clover.
      But I have some troubles with it:
      - I don't have uefi interface in my laptop, so my only option is Clover for BIOS,
      - Niresh Mojave contains only option to install Clover for UEFI. After installing it my system drops to PXE because it doesn't have UEFI so hard disk becomes non-bootable.
      But these problems can be solved, I "just" need to install Sierra first, which can be booted via Enoch and then I install Clover using official pkg installer, which has option to install BIOS version of Clover. Then I connect Niresh Mojave USB, Clover detects it and boots installer. I uncheck "Install bootloader" and I get bootable Mojave. Yay
      But the real problem is:
      Clover on my device is not working as well as Enoch. Why? Because when I'm on Enoch (for example on Sierra) my kexts for PS/2 keyboard and touchpad (Voodoo PS2 Controller kext) and for Wi-Fi are working good. They are installed in S/L/E and just works. But Clover somehow doesn't want to load them... or has something missing. System booted with Clover has not working keyboard, touchpad working as mouse and not working Wi-Fi.
      Guys! What I have to do to make Clover work as good as Enoch? What Enoch has that Clover hasn't? Why Clover can't load any kext EVEN from CLOVER/kexts/other?
      I have tried booting with -v but I don't see any error related to that...
      Can you help me please?
      Both Enoch and Clover configs are default ones without any modifications. 
      Any help is appreciated.
      P.S. I have lost all DMGs so I can't install MacOS right now, I need to redownload them but my Internet connection is very slow, so for any logs we'll need to wait. But maybe my problem is very easy to fix so I don't need to send any logs? Thanks for any answer
    • By viktr
      A few days ago I faced a problem - installed ocquirks and it somehow broke my prelinked kernel. System won't boot then, and I spent more than a day restoring from the netatalk  backup to copy working prelinked kernel directory from the backup to the s/l
      So, my question is - how to relink prelinked kernel without that? I found boot args -f UseKernelCache=No but it didn't work. I was able to boot to the recovery, if that can help.
    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By TimothyF
      My steps so far:
      Set up Catalina install USB exactly according to Plain Vanilla guide. Disconnect my Windows drive in PC, so that only the empty Hard Drive is connected to Motherboard. Boot to USB, select Install Catalina option. BIOS set to UEFI, Safe mode Off. Always get stuck at the same IOconsoleUsers: GIOScreenLockState point. Tried -radvesa, -radoff, nv-disable=0 boot options (separately), and disabling BIOS virtualization (vt-d) -> NO luck. This from the top search result https://www.reddit.com/r/hackintosh/comments/b5a6ry/ioconsoleusersgioscreenlockstate_3_blackscreen/  
      Screen pics attached. Here are the last couple of lines that could be important:
      GTrace synchronization point 4
      Unsupported CPU
      Unsupported PCH
      Adding ADGP mode validate property
      hmm.. mismatch sizes 3100 vs 20
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
      Please give me some ideas what else might work. Thank you.

      Other details of Clover and Desktop PC below:
      Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: config.plist ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)