Jump to content
Sign in to follow this  
Followers 0
Rytz

Some guidance with USB fix please (not working)...

2 posts in this topic

Recommended Posts

Greetings:
 

Running an Acer Aspire E5-771-74E7 laptop.  Intel  Core i7 5th gen with Intel HD5500.  Running Clover MBR/GPT as a MacBookAir6,2.  Attempting Capitan beta 8.

 

I have 4 ports: 2xUSB2 and 2xUSB3.  On Yosemite 10.10.5, both USB2 and USB3 worked vanilla. I have everything working on Capitan beta 8 except USB.  I get no power to any device when they are plugged in.  My main reason for moving to Capitan is because of the random HD5500 freezes (FakeSMC rollback didn't work).

I have read and tried to follow the main guide thread:
http://www.insanelymac.com/forum/topic/306777-guide-usb-fix-el-capitan-1011/

 

From reading through the thread, which is somewhat lengthy now, the general idea is to match up the port numbers based on what the DSDT is presenting.  Then there is the issue of port restrictions. 

 

Questions:

[1] I see suggestions for both having and not having port restrictions.  Clover In MacBookAir6,2 , there are no port restrictions.  Is it "in some cases" that port restrictions are required?  I'm kinda confused here.

[2] The USB2 port names in my DSDT and AppleUSBEHCIPCI match up (EHC1).  Since there are no restrictions, do I still need to change them in the DSDT to something else?

[3] For USB3, I did try changing my DSDT XHC entries to XHC1 but that did not help.  Is there something else I need to do?
[4] In my DSDT, my port numbers are listed as follows:

        Device (SAT0)
        {
            Name (_ADR, 0x001F0002)  // _ADR: Address
            Name (PRBI, Zero)
            Name (PRBD, Zero)
            Name (PCMD, Zero)
            Device (PRT0)
            {
                Name (_ADR, 0xFFFF)  // _ADR: Address
            }

            Device (PRT1)
            {
                Name (_ADR, 0x0001FFFF)  // _ADR: Address
            }

            Device (PRT2)
            {
                Name (_ADR, 0x0002FFFF)  // _ADR: Address
            }

            Device (PRT3)
            {
                Name (_ADR, 0x0003FFFF)  // _ADR: Address
            }

 

 

Do these seem correct?  I tried adding the entries manually to the kext without success.

I've attached informational files and screenshots for anyone who can lend a hand.  Extensions renamed to avoid blocked uploads.

 

Thanks!

 

rytz’s MacBook Pro.ioreg.txt

DSDT.dsl.txt

config.plist.txt

post-858855-0-00021400-1441500079_thumb.png

post-858855-0-30389000-1441500073_thumb.png

post-858855-0-31925200-1441500067_thumb.png

post-858855-0-84481600-1441500062_thumb.png

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By STLVNUB
      No sense re-inventing the wheel.
       
    • By TheAngryYeti
      First, my build:
       
      Asus ROG Strix H370-I mobo
      i5 8400 cpu
      32gb ddr 4 2133
      1tb samsung evo 860 ssd
       
      Ive finally gotten to the point where the installation of HS loads to the language selection screen, but then i lose all usage of every USB port.
       
      Im at a loss of what to do from here.
       
      According to others, i have the proper files in the kexts/other folder as well as the drivers64UEFI folder.
       
      Does anyone have any suggestions as to what i can do? Im getting kinda desperate as ive been at it for a week now and this is as far as ive gotten.
       
      -Sin
       
       
    • By TheAngryYeti
      So I FINALLY got my High Sierra thumb drive to boot and once I got to the language selection screen, I noticed I lost all connectivity to my keyboard and mouse.
       
      i tried plugging in both into all of my USB ports (2.0, 3.0, 3.1) to no avail.
       
      i made sure I had the latest USBInject kext and XHCI-Unsupported kext in the Other folder.
       
      i also noticed whilst troubleshooting, the thumb drive will ONLY boot using Verbose and plugged into one of the 2 3.1 ports.
       
      does anyone have ANY suggestions?? I’ve been struggling for a week now on this!!
       
      thanks in advance
       
      -Sin
       
      Build: Asus ROG Strix H370-I, i5 8400, 32Gb ddr 4 2133, 1Tb Samsung EVO 860 ssd
    • By djamiirr
      Hello Guys. I have macOS High Sierra installed on my Lenovo g50-80 laptop. At the beginning, everything was working fine, but recently, usb ports stops working suddenly sometimes when i replug usb device, wake up from sleep or by himself (no action) and the only solution is to reboot. lsusb shows that device still plugged when i remove it. I have USBInjectAll.kext in /S/L/E. how can i identify the problem? And thanks.
    • By Drovosek
      Hello.
      I extracted .aml files via F2 to Clover, then moved iasl and patchmatic to .../bin and DSDT converted.aml to DSDT.dsl
      Then I patched the DSDT.dsl patch battery_HP-G6-2221ss.txt and clicked "Compile".

      11750, 6126, syntax error, unexpected PARSEOP_ARG1
      19689, 6126, syntax error, unexpected PARSEOP_METHOD
      19735, 6126, syntax error, unexpected PARSEOP_CLOSE_PAREN
      19738, 6126, syntax error, unexpected '}', expecting $end and premature End-Of-File

      The first error disappears if you remove all the "args", the third if you remove the closing parenthesis (but I do not know how this is the correct solution to the errors)
       

      debug_9278.zip
      battery_HP-G6-2221ss.txt
      DSDT after bat patching.dsl
      DSDT primary.dsl
×