Jump to content
Sign in to follow this  
Followers 0
toekimarks

HDMI audio lag with gtx 970

7 posts in this topic

Recommended Posts

Hello,

 

I have got my G5 yosemite hack (If anyone wants pictures of the untouched clean back and front) running great for a few months now. The only problem I still experience is the fact that my HDMI audio starts lagging after a few minutes and eventually ends in freezing the system. To enable the audio I have used several kext just to enable HDA audio, because I don't use the alc892. But it's needed to run HDMI audio in combination with the well known HDMI audio kext.

 

The problem is the graphics card, because when I use the exact same kexts and other components it runs just fine. Anyone got a solution for this maybe? I use clover as the boot loader.

 

Thanks in advance from sunny Holland

 

 

Share this post


Link to post
Share on other sites
Advertisement

Thanks for you reply. I allready tried voodoohda, but the weird thing is that the exact same problem occurs. So it has to be a hardware problem isnt it? I think I will try hdmi audio in windows and see what it does.

Any other suggestions?

Share this post


Link to post
Share on other sites

If using clover try it, it might work:

<AddHDMI_8000000 - Bolean - Yes>

<NewWay_80000000 - Bolean - Yes>

Thanks, I do use clover, but I'm not a hero with it, so I don't know where I have to put those lines. Can you clarify it?

Share this post


Link to post
Share on other sites

I managed to get the lines in clover, but no excactly, just the newway and addhdmi from cloverconfigurator, which doesnt contain the Bolean part. But no result, but whitout the hdmi kext no dp or hdmi sound. So I kept the lines there and installed the hdmi kext again. Trying to copy your lines directly into config.plist screwd up my whole installation, so... Then I thought about the problem and why it didnt occur when still using mavericks. After the problems occuring in yosemite I went back to mavericks but the sound still lagged after a while. In my first mavericks installation I used the freezefix app. Now I installed it again and the problem seems to be solved.

 

So I'm not sure which change solved it and if it totally solved, though I tested it for hours. If anyone is interested I would be glad to find out what fixed it.

 

Thanks to cumpadi anyway and sorry for my english.

Share this post


Link to post
Share on other sites

My previous posts can be regarded as useless.

 

After a week with troubles again, I decided to use Toleda's new SSDT HDMI sound enabling method, but still the same lag in sound, always beginning with this error in console:

Failed to connect (_consoleX) outlet from (NSApplication) to (ConsoleX): missing setter or instance variable

After that troubles begin. Any suggestions? Same error with hdmi kext method, ssdt method and even voodoohda.

 

I hope you know something, because I'm out of ideas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ayeshch
      Me (and many other people) experience eye-ache from new Macbooks (and windows machines).
       
      I have spent two years of trial-and-error and found that installing macOS Mavericks on my MacBook (pro 13 late 2013, Intel Iris 1536 MB) resolves the issue of eye ache completely. (it is believed that newer systems use harsher version of temporal dithering that causes of a certain group of indivisuals eye aches).

      I cannot stay at Mavericks because of software support and security issues, so the only thing is an issue now:

      How can I take drivers from Mavericks and install them on Catalina? (I tried replacing .kext in /System/Library/Extensions with old files but it didn't work).

      It would be so great if possible!

      Thank you
    • By AppleCampus
      My computer was using Intel core i5-4210u ,My computer was using Intel core i5-4210u ,Sound card is cx20751/2,I use applealc inject id=3 successfully drive my onboard soundcard,but I found that HDMI Output is still no sound,how can i deal with it?
    • By agrafuese
      Hello, I hope I am posting in the right place...
       
      I am having issues with VoodooInput. It loads fine, no errors or KPs, but movement is erratic. It seems when I am moving the cursor with my index finger and then try to click with my thumb, the cursor will shoot to the bottom of the screen, causing erroneous clicks and a lot of headaches. Sometimes it shoots to the top instead. Sometimes it performs as expected. It's unpredictable. 
       
      I have used VoodooI2C + VoodooI2CHID instead, and they work perfectly fine, but unfortunately they cause KPs. Plus, I like that VoodooInput is a singular kext. This is why I am trying to see if there's any way to fix this issue.
       
      Please see signature for my specs.
       
      Thank you.
×