Jump to content
Sign in to follow this  
Followers 0
helpme

Qualche problema da risolvere su HP ENVY j100el..

25 posts in this topic

Recommended Posts

Salve a tutti! Quest'estate mi sono messo di buona lena ed ho provveduto ad installare Yosemite sul mio nuovo portatile, un HP ENVY j100el. La release era originariamente la 10.10.2 ma con gli aggiornamenti che ho regolarmente effettuato via Mac App Store ora monto la 10.10.5, lanciata sempre da Clover ed in dual boot con Windows 10. 

 

Fin dove ho potuto ho cercato di fare tutto da solo, ma ora sono dinanzi ad un muro ed ho bisogno dell'aiuto di qualcuno che ne capisca più di me per poter ovviare a dei problemi. Il sistema di per sé funziona abbastanza bene, ho provveduto anche ad installare programmi professionali di grafica vettoriale e 3D come ad esempio Autocad ed Archicad e paiono avviarsi senza notificare alcun tipo di incompatibilità. Ci sono tuttavia degli aspetti o comunque delle periferiche che potrebbero funzionare ma che non lo fanno. Passi per il wifi, il bluetooth e il lettore integrato di schede SD (Ralink) per i quali mi sono già messo l'anima in pace che non funzioneranno mai, credo si possa metter mano a:

 

- Webcam: una HP Truevision HD che a molti funziona ma che a me non viene proprio individuata

 

- Audio: Funziona, ma quanto ad altoparlanti interni funzionano solo i subwoofer, mentre il jack audio si attiva solo se un dispositivo (cuffie o auricolari) è connesso al portatile al boot o al riavvio dopo sleep. Alle volte capita anche che pur disconnettendo le cuffie queste risultino ancora attaccate con il risultato finale che il suono non esce dagli altoparlanti che risultano di fatto inibiti, ciò quasi esclusivamente se il portatile è in modalità batteria o in modalità adattatore ma senza batteria attaccata

 

- USB: Funziona e funziona anche la modalità 3.0, per le memorie flash nessun problema ma in caso di hard disk esterno affinché Yosemite lo riconosca devo procedere in questo modo: connetterlo, disconnetterlo, connetterlo ad un'altra porta ed infine l'icona appare. Inoltre se per caso il sistema va in sleep ed una qualsivoglia memoria (sia flash che disco rigido) è connessa al portatile dopo lo sleep avviene la notifica di errata espulsione. Ho provato anche con un programma chiamato Jettison che dovrebbe disconnettere automaticamente tutte le periferiche prima dello sleep per poi riconnetterle automaticamente alla riattivazione, ma le notifiche di errata espulsione persistono ugualmente. Ne deduco quindi che l'USB non funziona alla perfezione

 

- Messaggi: Ho provveduto ad applicare NullEthernet.kext di RehabMan grazie alla quale ora il mio account iCloud funziona con Mac App Store, iTunes, Mail.. ma non capisco perché l'applicazione Messaggi non effettua l'accesso restituendomi invece quest'errore "Impossibile accedere. Verifica la connessione di network e riprova."

 

A corredo, se può essere utile, allego DSDT, il file spx che contiene le informazioni di sistema tratto da Yosemite, il file readme che contiene le specifiche di sistema generato con Speccy sotto Windows, e il config.plist di Clover. Ovviamente per qualsiasi altro file da postare sono qui..

 

Se qualcuno mi vuol far la cortesia di dargli un'occhiata o comunque suggerirmi soluzioni praticabili gliene sarei molto grato. Ovviamente a cose sistemate è mia intenzione dare un contributo alla community rilasciando una guida come feci a suo tempo col mio vecchio portatile sul quale montavo Leopard. Grazie a tutti sin da ora!

Files.zip

Share this post


Link to post
Share on other sites
Advertisement

Ok, credo di aver fatto qualche passo avanti sul fronte audio ma senza risolvere ancora al 100%.. Ho rimosso il vecchio kext AppleHDA ed installato uno nuovo apposito per la versione dell'injector IDT che utilizzo (IDT 92HD91BXX). L'audio nelle cuffie ora SEMBRA funzionare anche se queste non sono collegate al jack durante il boot o al riavvio e lo switch altoparlanti/cuffie avviene preciso ed immediato. Tuttavia mi è anche capitato di disconnettere le cuffie senza però che queste risultassero disconnesse Preferenze di Sistema/Suono/Uscita, con la conseguenza che il suono non usciva dagli altoparlanti.

 

Per inciso, non si tratta di un evento seriale ma random, tanto che finora avrò provato una trentina di volte a fare lo switch ma il problema è presentato una sola volta, ma tant'è la cosa mi fa pensare che qualcosina che non vada alla fine permanga ancora. Escluderei comunque un problema hardware visto che con Windows 10 fila tutto liscio sotto questo aspetto. Ah dimenticavo, sia col vecchio kext che con il nuovo, a cuffie collegate, dopo che ho finito di sentire un qualsivoglia suono tempo una 15ina di secondi e parte per 4/5 secondi un ticchettìo gracchiante, come se il sistema stesse chiudendo l'audio in cuffia, audio che se poi riattivo viene preceduto da un bip prima che il suono cominci correttamente e fluentemente a scorrere nelle cuffie. Ora, non so se sia normale amministrazione o se possa essere parte del non perfetto funzionamento, certo è che sotto Windows la cosa non si presenta.

 

Quanto agli altri aspetti da sistemare io continuo a cercare, ma certo se qualcuno mi potesse dare una dritta mi faciliterebbe non poco la vita..  :rolleyes:

Share this post


Link to post
Share on other sites

Edit: adesso siamo tornati quasi allo stato pre-sostituzione del kext AppleHDA.

 

- Boot con cuffie inserite -> Audio in uscita dalle cuffie se inserite altrimenti dagli altoparlanti

- Boot con cuffie non inserite -> Audio in uscita dagli altoparlanti sia con le cuffie inserite che non

- Ripristino sessione da sleep sia con cuffie inserite che non -> Audio in uscita dalle cuffie se inserite altrimenti dagli altoparlanti

 

Tra l'altro random c'è sempre il bug dell'audio che non esce dagli altoparlanti a cuffie staccate..

 

Help please, non so più che pesci prendere.. :bye:

Share this post


Link to post
Share on other sites

Questi problemi audio riguardano l'autoswitch e quindi si possono risolvere scegliendo un'altra uscita premendo ALT e cliccando sull'icona volume o non esce proprio l'audio dalle altre uscite?

Share this post


Link to post
Share on other sites

Ciao carbo e grazie per essere intervenuto innanzitutto! Dunque no, quando ad esempio avvio il sistema senza cuffie, e quindi l'audio esce solo dagli altoparlanti, premendo ALT (o meglio nel mio caso command/windows logo) non è possibile selezionare altre uscite. Le cuffie, per spiegarmi meglio, non vengono proprio riconosciute. Cosa che invece come detto il sistema fa in caso di wake up da sleep o in caso di boot con jack inserito nell'uscita audio del portatile.

 

Magari mi sbaglio, ma per quel poco di esperienza base che ho di hackintosh io credo ci sia qualcosa che non va nel DSDT.. Ora per dire siamo proprio tornati allo stato iniziale in cui l'audio nelle cuffie non si sente neanche in caso di riavvio da sleep senza cuffie attaccate. È come se per qualche motivo qualcosa inibisse il segnale di input che normalmente dovrebbe arrivare al sistema operativo in caso di inserimento del jack nell'ingresso del portatile, ma la cosa ancor più strana è che il tutto avviene senza una regola specifica, voglio dire, dopo l'aggiornamento del kext sono passato da una situazione di funzionamento totale sino ad arrivare ad una situazione di funzionamento tra virgolette indotto, nel senso che deve essere forzato a computer spento con l'inserimento del jack. E ancor più strano è che dalla sostituzione del kext, cui ovviamente ha subito fatto seguito riparazione di cache e permessi prima del riavvio, io poi non ho toccato più nulla, né config.plist, né kext vari, né altri file di sistema..

Share this post


Link to post
Share on other sites

Quindi nelle preferenze di sistema alla voce suono ti compare soltanto l'uscita altoparlanti interni o auricolari come conseguenza del metodo di avvio?

Non credo sia un problema di DSDT, ma non è detto, al limite prova ad aggiungere la patch per IRQ (se non l'hai messa).

Altri cambiamenti ci possono essere a seconda se la patch dell'HDEF prevede o meno la presenza della patch DTGP

Share this post


Link to post
Share on other sites

Esatto. O come conseguenza del metodo di avvio o comunque di wake up da sleep, fermo restando che come detto gli auricolari devono essere sempre connessi all'uscita del portatile. Quanto al DSDT la patch IRQ che intendi tu è questa giusto? E di preciso in che punto del DSDT va incollata? No perché io il DSDT l'ho preso su un thread qui su insanelymac e non ci ho messo mai mano.. Ah comunque giusto per avere un quadro ancora più preciso, fino a quando io sono stato sotto la release 10.10.4 questi problemi non si erano verificati. Ora non so se è stato per pura coincidenza, e, vista l'assoluta apparente anarchia con cui l'audio ha progressivamente cambiato modo di funzionare oggi, non lo escluderei a priori, ma tant'è. Nel qual caso però non si tratti di coincidenza magari potrebbe pure essere che la release 10.10.5 abbia magari soprascritta qualche file che ora crea conflitto. Tu che dici?

Share this post


Link to post
Share on other sites

Con MacIASL la patch si può applicare automaticamente, per l'aggiornamento potrebbe darsi che alcuni files fengano sovrascritti, ma se hai reinstallato AppleHDA che avevi prima dell'aggiornamento dovrebbe funzionare bene

Share this post


Link to post
Share on other sites

No no, il kext AppleHDA che ho installato non era quello utilizzato sino alla 10.10.4 (che ad ogni modo ho controllato in Ottieni Informazioni e a giudicare dalla data era addirittura quello della 10.10.2 di installazione), piuttosto quello caricato su questo thread nella versione corrispondente all'injector (IDT92HD91BXXInject.kext) che avevo installato sin dall'inizio. Il DSDT invece, e questo avevo dimenticato di dirlo, l'ho preso da questo altro thread ma non creava alcun problema rispetto a quello originario, anzi faceva andare correttamente in sleep il pc laddove quello precedente faceva andare in sleep il sistema salvo ripristinarlo un attimo dopo senza che io premessi alcun pulsante per il wake up. Per questo motivo anche chiedevo dove incollare la patch, per verificare che non fosse già stata inserita a monte da chi il DSDT l'aveva postato sul forum.

Share this post


Link to post
Share on other sites

Lo dovrei estrarre dall'installer ora, perché quello che si trovava in S/L/E l'ho cancellato senza farne una copia di backup.. Per estrarre kext dall'installer se non ricordo male era buono Pacifist, giusto?

Share this post


Link to post
Share on other sites

Ho dato un occhio al materiale dell'altro thread, è presente la patch nel dsdt e tra i kext c'è l'injector per l'IDT.

Se usi AppleHDA di Mirone devi cambiare il DSM dell'HDEF nel DSDT, secondo quanto riportato dal file readme allegato al kext

Share this post


Link to post
Share on other sites

Ok, quindi come procedo? Intanto reinstallo il vecchio AppleHDA e provo a vedere se il problema si risolve così?

Share this post


Link to post
Share on other sites

Niente da fare.. Reinstallato il vecchio AppleHDA estratto dall'installer di Yosemite addirittura adesso neanche mi dava l'audio connesso (icona grigia), ho dovuto quindi reinstallare il nuovo che al primo avvio (cuffie staccate) switchava correttamente, al secondo invece subito i soliti noti problemi. Chiaramente avevo riparato permessi e cache con Kext Wizard dopo l'installazione dei kext.

 

Devo dire tuttavia che al primo avvio avevo batteria connessa ed alimentatore attaccato, al secondo invece ho voluto provare il verificarsi dei problemi con il solo alimentatore attaccato. Non so se magari i problemi di switch siano dovuti a qualche patch malfunzionante o mancante relativa all'alimentazione.. Ad ogni modo ho ovviamente poi provato a riavviare in modalità batteria+alimentatore con cuffie staccate ma quando sono poi andato ad attaccarle l'audio continuava ad uscire dall'altoparlante..

Share this post


Link to post
Share on other sites

Ricontrollando bene il thread dove ho preso il kext AppleHDA, ho notato che per attivarlo non si faceva menzione dell'injector che uso io piuttosto di un metodo a scelta tra patch del DSDT, aggiunta di testo su Clover o installazione del kext Enabler. carbo, dici che magari un differente metodo di attivazione del kext HDA possa eliminare questi bug?

Share this post


Link to post
Share on other sites

Aggiornamento: Ho installato questo kext di supporto, DummyHDA, al kext AppleHDA. Ora lo switch sembra funzionare con l'alimentatore inserito al boot, sia che la batteria sia collegata che non. Viceversa gli auricolari non si attivano se il boot viene fatto con la batteria connessa e l'alimentatore staccato. Il problema però è che se ho l'alimentatore attaccato e lo stacco il sistema impiega diversi minuti a notificare l'entrata in modalità batteria, e allo stesso modo se sono in modalità batteria impiego diversi minuti ad essere informato dell'entrata in modalità alimentatore. In ambedue i casi la notifica, segnalata anche dall'aumento o diminuzione di luminosità a seconda che l'alimentatore venisse attaccato o staccato, era precedentemente istantaneo.

 

Boh, sono sempre più portato a pensare che i problemi di switch audio siano per qualche strano motivo dettati della gestione energetica..  :worried_anim:

 

Edit: Niente, dopo qualche riavvio di prova con o senza batteria per capire se il problema si stava risolvendo, il Yosemite pare aver corretto i problemi di gestione energetica e lo switch batteria/alimentatore avviene come prima in maniera automatica mentre quello altoparlanti/auricolari è tornato ad essere del tutto anarchico (a volte funziona correttamente, altre funzionano solo gli altoparlanti, con la batteria, con l'alimentatore+batteria, senza batteria, etc..). Mi piacerebbe proprio sapere il perché di tutto ciò..  :(

DummyHDA.kext.zip

Share this post


Link to post
Share on other sites

Nel frattempo che esce fuori un colpo di genio per l'audio, mi sono ributtato su webcam e USB e credo di aver risolto. Il problema però è che fuori un problema via se ne presenta un altro. Per far comparire la webcam su resoconto di sistema è bastato cancellare dalla partizione EFI il kext GenericUSBXHCI, e voilà ecco che pure l'hard disk esterno ora compare subito al primo colpo non appena lo attacco ad una qualsivoglia porta USB. Purtroppo però come detto, per la serie morto un Papa se ne fa un altro, ecco che l'eliminazione di questo kext ha comportato un malfunzionamento nello sleep. Il computer non entra per niente in standby e rimane acceso, con l'aggravante che lo schermo diventa nero, si blocca tutto e tocca riavviare il PC. Ciò con attaccato un dispositivo USB (io sono costretto ad usare una WIFI USB quindi praticamente almeno un dispositivo USB al PC l'ho sempre attaccato). Se invece non vi sono dispositivi USB attaccati il computer spegne lo schermo ed è possibile rientrare nel sistema operativo previo login, ma di fatto non va in ibernazione. Possibile che tocchi applicare una patch nel DSDT?

 

Aggiungo poi che la webcam funziona, in FaceTime mi vedo ma non riesco a fare il login (proprio come in iMessage) mentre PhotoBoot pare non dare problemi.

Share this post


Link to post
Share on other sites

Ho provato ad editare il DSDT ma non me lo fa salvare come ACPI Machine Language Library perché ritornano 4 errori ed onestamente non so come correggerli..

Share this post


Link to post
Share on other sites

Guarda, trovi tutto nel file postato nel post di apertura del thread. C'è anche il file config.plist, se vuoi dargli un'occhiata. Io l'ho spulciato più e più volte e mi sembrava a posto, ma magari c'è qualche stringa con qualche valore errato.. Sai 4 occhi sono meglio di due.  ;)

Share this post


Link to post
Share on other sites

Niente.. Output audio ora neanche individuato (icona grigia), sleep identico a prima (non va in ibernazione e schermo nero con riavvio necessario) ed in più ora con batteria attaccata viene anche data l'icona di batteria staccata..

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jdorz
      Hello all,

      I have successfully gotten my Hackintosh working 99 percent. The remaining issue that I am running into is that my system will randomly kernel panic upon a user issued shutdown or reboot WHEN I have either a usb sound card or usb headset plugged into any of my USB ports (both 2.0 and 3.0). If I remove the headset, it will power down with no issues. Does anyone have any suggestions?

      My system is as follows:
      MacOS 10.14 Mojave
      Gigabyte H370 HD3
      8400 i5 Coffee Lake
      Radeon RX 580 sound card

      I have the internal audio disabled. I have also attached my config.plist file.

      I have the following Kexts installed:

      FakePCIID_XHCIMux.kext
      USBInjectAll.kext
      FakeSMC.kext
      WhateverGreen.kext
      IntelMausiEthernet.kext
      XHCI-300-series-injector.kext

      Lilu.kext


      Thank you.
      config.plist
    • By fusion71au
      This is a brief guide on how to create a vanilla El Capitan (also same process for Sierra) OS X Installer USB with an updated prelinked kernel containing FakeSMC.

      It is tailored for those users who want to understand the “nuts and bolts” of how to create an installer and also to help brush up on their terminal skills (rather than have one made for them with the numerous automated “tools” available or even Apple’s createinstallmedia) :
       
       
      Specifically, it is also a “Proof of Concept” which shows that installation is possible without even having to rely on boot loader kext injection.

      Prerequisites
      Existing Yosemite installation (or Mavericks - see post#4 for steps 7,8) “Install OS X El Capitan.app" downloaded to the Applications folder Pacifist FakeSMC.kext - Slice or Kozlek branch Bootloader - Clover or Chameleon 8GB or larger USB drive (16GB recommended), formatted HFS+ (MBR or GUID) named “Installer”  
      Procedure
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Open OS X terminal and type the following lines, followed by <Enter> after each line.
          The image restore and file copying may take a while to complete, and at the end of the process, the Installer volume is renamed to “OS X Base System"....
       
      sudo -s hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg asr restore -source /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg  -target /Volumes/Installer -erase -format HFS+ -noprompt -noverify rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages cp -av /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation cp -av /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg /Volumes/OS\ X\ Install\ ESD/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System diskutil unmount /Volumes/OS\ X\ Install\ ESD exit 3.  Right click on the “OS X Base System” Volume and click “Get Info”
       

      4.  Click on the lock icon and untick “Ignore ownership on this volume”
       

      5.  Extract/Copy the El Capitan Kernels folder into /System/Library/ of the USB with Pacifist.  NB It is found in the "Essentials.pkg" in /System/Installation/Packages
       

      6.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel —> OG.prelinkedkernel
       

      7.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of the installer USB using Finder.
       

      8.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel…..
       
      sudo -s chmod -R 755 /Volumes/OS\ X\ Base\ System/Library/Extensions chown -R 0:0 /Volumes/OS\ X\ Base\ System/Library/Extensions touch /Volumes/OS\ X\ Base\ System/System/Library/Extensions kextcache -u /Volumes/OS\ X\ Base\ System exit Any errors should be noted but the output below is normal e.g.


      9. Install your Bootloader targeting the OS X Base System volume
       
       
       
       
      10.  Boot your system with the USB without injected kexts into the OS X Installer GUI....
       
       
       
       
       
      Post Install
      The original prelinked kernel in a fresh install of El Capitan will also lack FakeSMC ie it will only be linked to Apple signed kexts.  In order to boot into El Capitan the first time around without boot loader kext injection, the PLK needs to be rebuilt for the El Capitan volume like we did for the installer:
       
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel for the El Capitan volume —> OG.prelinkedkernel
      3.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of El Capitan using Finder
      4.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel.  In this example, the El Capitan volume is named "El_Capitan" - change if you have named it something else...
      sudo -s chmod -R 755 /Volumes/El_Capitan/Library/Extensions chown -R 0:0 /Volumes/El_Capitan/Library/Extensions touch /Volumes/El_Capitan/System/Library/Extensions kextcache -u /Volumes/El_Capitan exit 5. Install your Bootloader targeting the El Capitan volume.  This step is only necessary if you are installing El Capitan on a new drive without existing boot loader (not required if installing on a disk with existing boot loader beside Yosemite).
      6. Reboot your system without injected kexts into El Capitan!
       
       
      Other links
      The All-In-One Guide to Vanilla OS X for beginners
       
      Updates for Sierra and High Sierra   Custom Prelinkedkernel Generator Tool I have made a custom prelinkedkernel generator "PLK.tool" for Sierra + El Capitan.  Instructions:   1.  Download and extract the attached BaseSystem_PLK.tool.zip into your ~/Downloads folder.   2.  Copy any extra kexts necessary for booting your hack to ~/Downloads/BaseSystem/ExtraKexts (e.g. FakeSMC, VoodooPS2Controller), making sure SIP is disabled. 3.  Copy BaseSystem.dmg to ~/Downloads/BaseSystem  4.  Open terminal and run the following commands... cd ~/Downloads/BaseSystem chmod +x PLK.tool ./PLK.tool ---> supply your admin password ---> will place your new custom prelinkedkernel on the desktop.       macOS High Sierra bypass Firmware and MBR checks in post#13.
      BaseSystem_PLK.tool_ElCap.zip
      BaseSystem_PLK.tool_Sierra.zip
      BaseSystem_PLK.tool_Mojave.zip (need to run in Mojave to avoid dependency errors)
       
    • By unixb0y
      Bluetooth + AirDrop + Apple Watch "Auto Unlock" + Continuity / Handoff
      BCM20702 / TP-Link T9E (AC1900)
       
      I have a little update on getting BCM20702 running in Mojave:
       
      Without kext files, nothing worked "OOB" with my USB dongle. So I got "BrcmFirmwareStore" and "BrcmPatchRAM2" from RehabMan.
      I tried putting the kext files in /L/E , didn't work so I tried /S/L/E. * While that didn't work at first, I then tried to refresh the kext cache; the files didn't show up in kextstat.
      I used this command:
      sudo kextcache -invalidate / which told me 2 error messages: BrcmFirmwareStore and BrcmPatchRAM2 had the wrong permissions. This is fixed like so:
      sudo chown -R 0:0 /System/Library/Extensions/BrcmPatchRAM2.kext/ sudo chmod -R 755 /System/Library/Extensions/BrcmPatchRAM2.kext/ sudo chown -R 0:0 /System/Library/Extensions/BrcmFirmwareRepo.kext/ sudo chmod -R 755 /System/Library/Extensions/BrcmFirmwareRepo.kext/ Reboot and be happy! 
      Both the actual Bluetooth entry in System Preferences, that was missing before as well as an entry in System Report > Bluetooth finally appeared!
      I have a TP-Link Archer T9E WiFi card and now in conjunction, AirDrop does work like a charm! 
      Cheers, Dave 
       
      * EDIT:
      RehabMan replied to me on GitHub and it's not recommended to use /S/L/E and you should let that folder remain reserved for Apple original kext files. So I tried putting the files (with the correct permissions) back into /Library/Extensions and Bluetooth and AirDrop both still work fine!
      So I would recommend to put the files either into EFI/EFI/CLOVER/kexts/Other or - like me - into /Library/Extensions and after (or before) copying the two kext files, set the permissions like shown above for both files with chown and chmod.
       
      EDIT2: 
      I totally forgot to mention that even unlock via Apple Watch works! I assumed it would not work, until the "iMac" itself saw my Watch and kindly asked if I wanted to activate it  I immediately turned the feature on and it's working like a charm!
      What also perfectly works is Handoff. It's a feature that I never found really useful, especially between iOS and Mac, however when I have a Safari window open on my iPhone, the Hackintosh shows me the handoff Safari icon in the App switcher as well as in the dock (only tested Safari for now) and it behaves just like on my MacBook Pro!
      Universal Clipboard is also working as well as SMS / MMS.
      I couldn't test "Cellular Calls" and the "Continuity Camera" as I don't have a second phone and it's quite late here right now for calling someone on the telephone and I don't have any iOS 12 devices either. The "Instant Hotspot" did not work, but I think that anybody going the TP-Link T9E + BCM20702 way is building a PC that is permanently attached to WLAN or even LAN (Ethernet), so that's not an issue. I think laptop Hackintoshers should just use a MacBook WiFi card as they probably already have the connector etc. etc. (no adapter or Motherboard-dependent solutions needed).
    • By warty
      On 8/20/2018 at 5:22PM, TessereKt said:
       
      On 8/21/2018 at 7:34AM, insanelyDeepak said:
       
      @insanelyDeepak, I would like to try cloverHDA, but I need help understanding how to use it.
       
      I have an Asus laptop that uses Realtek ALC295.
       
      My questions with regard to using cloverHDA:
      1.  I am running High Sierra (10.13.6). Is cloverHDA directly compatible? If not, can it easily be made compatible with adjustments I can apply?
       
      2.  What needs to be done with the original AppleHDA.kext that is already present in /S/L/E? Should it be left alone? Should it be removed? If it is removed, does the AppleHDA.kext that comes with cloverHDA, for example /Vanilla AppleHDA/Mac OS Sierra 10.12.6/AppleHDA.kext, need to be installed in its place?
       
      3.  In the 21 aug 18 reply to TessereKt, you mentioned "there is ALCPluxfix must install this." I noticed that there is a directory for alc_fix in one ALC295 directory (the ALC295_v2 Asus UX430UA directory) but not in the other ALC 295 directory that is provided (the ALC295/3254 directory). In which situation(s) is ALCPlugFix required?
       
      4.  My pathmaps are somewhat different from those in the cloverHDA.kext. Is there an easy way for me to customize the kext? For example, if I just switch the values in the xml files, will that be enough? Or does the whole thing then need to be recompiled?
       
      needed pathmaps:
      33-2
      23-3
      7-36-18
      9-34-19
       
      (My highest priority for the moment is getting headphone working, which is 33-2, and I might even be able to use the 33-3 that is already included. But I would like to eventually get all of them working.)
       
       
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides also to you some customization features and a better management of the hall macOS isntall media creation process
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process
        - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)
        - You can use any drive or partition you want that can be erased and is at least 7 GB of size
        - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery, and you can use TINU to install macOS too.
        - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method in the terminal, with also some extra optiona features
        - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code
        - Does not requires to do anything of special first, just open the program
        - No need to go in disk utility first, TINU can format your drive for you
        - Uses recent and more modern APIs and SDKs and Swift 3 language
        - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)
        - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update
        - Advanced section, to customize your macOS install media
        - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)
        - Clover EFI folder installer
       
        Features that are planned for some future versions:
        - Integrated EFI partition mounter tool (TINU can already mount EFI partitions from version 2.0, but a dedicated section which allows to mount every EFI partition in the system will be added)
        - Install clover and configure clover
        - Install kexts inside the kexts folder of clover
        - Clover drivers customization
        - Use custom dsdt in clover
        - integrated pre-made clover config templates database from a remote and open repository
        - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage device in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   Latest stable TINU release:   Download the app:                                https://github.com/ITzTravelInTime/TINU/releases   View the source code:                            https://github.com/ITzTravelInTime/TINU/       Frequently asked questions about TINU:  https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, TINU does only uses the installer creation method from apple, which has been changed by appleitself, causing this problem for hackintosh users some times, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also present TINU in the adavnced settings, starting from the version 2.0 of the app. I leave also some screenshots as well
       
       
       
       
       
       
       
       

×