Jump to content
Subby

[HELP!?] Sony VAIO VPCF1 Nvidia GT 425m (HDMI only no LCD)

101 posts in this topic

Recommended Posts

Hi All,

 

i don't post here often but hope someone could help me?! i have spent a week or so trying to get this laptop's 1080p LCD working!

 

Thus far i have Everything working via the HDMI out (Sound, Airport, Camera, boot shutdown) on the latest Yosemite. 10.10.5

 

i can boot to the laptop LCD via "nv_disable=1 boot flag but the experience is painful at best (low resolution, jumpy display and mouse movements)

 

the laptop will only boot with 'GraphicsEnabler=Yes'

 

its a single Nvidia card in this laptop (no intel Graphics) 

 

i currently have no dsdt on this boot and have next to no experience on how to use it!

 

i have used 'MaciASL_ML' to make a 'System DSDT' file from my laptop (attached) and i have made a ioreg (also attached) 

 

i have also got my EDID for the LCD display from Windows

 

00  FF  FF  FF  FF  FF  FF  00  36  7F
25  00  00  00  00  00  2D  0C  01  04
90  24  14  00  EA  A8  E0  99  57  4B
92  25  1C  50  54  00  00  00  01  01
01  01  01  01  01  01  01  01  01  01
01  01  01  01  40  38  80  B4  70  38
40  40  3C  3C  55  00  68  C8  10  00
00  18  40  38  80  80  71  38  AA  40
80  80  88  00  68  C8  10  00  00  18
00  00  00  FC  00  4E  76  69  64  69
61  20  44  65  66  61  75  6C  00  00
00  FC  00  74  20  46  6C  61  74  20
50  61  6E  65  6C  00  00  1F
 
 
i tried a few ways of injecting this with no success! the only success i see with my setup seems to be dsdt based
 
so i look to you! this community!  to see if you can help a novice who can not afford a real Mac!
 
any extra info you need to help me i am more than wiling to do my very best to provide!
 
i can boot in to Windows 10 with my other hard drive or download a live linux distro if needed!
 
thanks in advance for any help you can give me! (i have also attached my 'org.chameleon.Boot.plist' from my extra folder (i can install Clover if needed!? i already have it on a external usb drive, but not sure if it needs to be installed to the system drive to fully work for injecting?)
 
thanks again!!
 
Subz

ioregSaved.txt

System DSDT.zip

org.chameleon.Boot.plist.zip

Share this post


Link to post
Share on other sites
Advertisement

Try this.

Hi & thank you so much for your time!

 

unfortunately this dose not work on the laptop LCD or HDMI with GraphicsEnabler=Yes or =No 

 

i have attached my smbios.plist (not sure if helps,)

 

on -v boot i see much different things happening (like its finding HDMI audio in the boot process) could the voodoo kexts i use for audio be a problem?

 

if i boot with GraphicsEnabler=No i can get in to it via 'share screen' from my old Desktop Hackingtosh (with GraphicsEnabler=Yes) i can not connect to it from desktop mac

 

i also have voodoo battery kext & a kext for my wifi card? (i'm guessing these would not effect display?)

 

as you would expect nv_disable=1 will still boot to laptop lcd with crappy resolution, 

 

thank you again for your time and efforts!!

 

anything else i can do to help?

 

Subz

smbios.plist.zip

Share this post


Link to post
Share on other sites

Attach boot log and IOReg copy.

Use this (File > Save a Copy As)

 

 

Thank you again!

 

attached is the requested file!

 

 

Subz

 

EDIT: this was done via screen share booting with the dsdt you uploaded before & GraphicsEnabler=No bootflag (so none of the screens worked) if you want me to boot to the HDMI working boot (no dsdt) and run again let me know! :)

Subz MacBook.zip

Share this post


Link to post
Share on other sites

Remove VoodooHDA and try with DSDT again, use GraphicsEnabler=Yes with HDMI plugged

Attach boot log too

Share this post


Link to post
Share on other sites

Remove VoodooHDA and try with DSDT again, use GraphicsEnabler=Yes with HDMI plugged

Attach boot log too

 

 

Thanks Again!

 

removed kext, booted with IGPEnabler=No GraphicsEnabler=Yes HDMI port working i re ran the file you sent me before and saved like i did before (hope this was correct?)

 

 

thank you again for your time & help!!!

 

Subz

Subz MacBook no voodooHDA.zip

Share this post


Link to post
Share on other sites

IOReg not reflect that, copy DSDT into your Extra folder.

 

 

Sorry i was to blame! it was not in there!

 

it seems with GraphicsEnabler=Yes and the dsdt i can not get in to the laptop (screen share or hdmi) is it worth doing with bootflag nv_disable=1 ? i am guessing not?

 

EDIT: IGPEnabler=No or Yes makes no difference

Share this post


Link to post
Share on other sites

IGPEnabler is for Integrated Graphics.

You must inject nvidia graphic only.

 

 

Thanks Again for your help!

 

i have now removed IGPEnabler from my org.chameleon.Boot.pllst (as i now know i don't need it)

 

I could not gain access to my laptop in Yosemite with GraphicsEnabler=Yes & the dsdt you attached intill i removed smbios.plist, (no screens work, but i could screen share, HDMI screen is attached to the laptop)

 

this is with GraphicsEnabler=Yes and your dsdt (i hope this is right!!)

 

Subz

Subz MacBook no smbios or voodoohda.zip

Share this post


Link to post
Share on other sites

Use MacBookPro6,1 smbios

EDIT: use generate P/C states and DropOEM

 

Thanks again!!

 

 

i have now installed this and booted with GraphicsEnabler=Yes & the dsdt you attached,

 

no laptop lcd or hdmi working after boot but i can get in via screen share,

 

attached is bootlog and ioreg

 

does this one help?

 

Subz

Use MacBookPro6,1 smbios

EDIT: use generate P/C states and DropOEM

 

sorry, how/where can i do this?

 

Subz

sorry i'm such a novice and do not know how to 'use generate P/C states and DropOEM'

 

any hints at all would be most grateful!! 

 

Subz

Subz MacBook 2'nd try.zip

Share this post


Link to post
Share on other sites

Use the options that allow to use HDMI display and attach IOReg.

 

 

would that not be the one in post #7 (that one booted to the hdmi screen?)

 

with this smbios 6.1 i no longer seem to be able to boot to hdmi!

 

if i restore my old smbios i think its 3.1? then i can (with GraphicsEnabler=Yes)

 

i have attached the smbios and ioreg

 

hope this helps in some way?

 

Subz

Subz MacBook smb3.1.zip

smbios.plist.zip

Share this post


Link to post
Share on other sites

Try this

 

 

booting with the 3.1 smbios (the one that works with no dsdt) i get no screens and can not connect from my desktop with screen share

 

booting with the 6.1 smbios i also get no screens! but can get in via screen share

 

i have attached ioreg incase its of use 

 

another thank you!! :)

 

Subz

Subz MacBook new dsdt.zip

Share this post


Link to post
Share on other sites

Try to stay on MBP6,1 (if possible)

 

 

 

smbios 6.1 has same result as last dsdt,

 

no screens but i can get in via screen share? (Subz MacBook dsdt3.zip  )

 

with smbios 3.1 and this latest dsdt i can get to the hdmi port!!

 

not sure if this will help! i know you said try to stick with 6.1 (Subz MacBook hdmi + dsdt.zip)

 

thank you again for your time!

 

Subz

Subz MacBook dsdt3.zip

Subz MacBook hdmi + dsdt.zip

Share this post


Link to post
Share on other sites

Try to find out a smbios that match better with your hardware, use the first DSDT and check if HDMI output works with another smbios, that would be a good start.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×