Jump to content
  1. akid1

    akid1

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By macinsane
      Mojave (and maybe High Sierra 10.13.6) on Asrock H370M-ITX/ac and getting RX560 or RX580 to work with Intel graphics for full hardware acceleration
       
      Components used:
       
      Core i7 8700, UHD 630
      Gigabyte Radeon RX560
      Wifi/BT BCM943602BAED (DW1830) M.2
      Sapphire Nitro RX 580
      Samsung PM961 NVMe SSD
       
      *This guide requires you to know the basics, meaning how to create a macOS install drive, installing and using Clover. There are great beginners guides out there! As always you need at least FakeSMC to boot, every other kext I’ve used is mentioned in the guide. For Mojave beta you need to be enlisted with your Apple-ID in Apple’s beta programme. What is described here may work for High Sierra 10.13.6, but I doubt it to be reliable. Even in early beta status (PB3) Mojave runs much more stable and smoother than High Sierra ever did for me.* 
       
      *UPDATE Mojave final*
      For the final release of Mojave you can use my attached Clover folder as a reference. If you don't have a Radeon RX 580 installed or you prefer WhatEverGreen just use the DSDT_no_graphics.aml and rename it to DSDT.aml. You need to have updated to BIOS V3.00 to use it.  
       
      *UPDATE*
      I've updated to BIOS Revision 3.00 which seems to work fine in contrast to 1.50. Already compiled a new DSDT and uploaded it alongside a new config.plist. You can use both if you like. If you don't use a RX 580 you need to edit the PEG0-PEGP section in the DSDT to adjust it to your graphics hardware. With this DSDT and config in place you'll only need FakeSMC, IntelMausiEthernet, USBinjectall plus XHCI-300-Injector, Lilu plus AppleALC for Sound. You can add Shiki for iTunes DRM playback if you like, I've uploaded the latest version as well. Avoid Whatevergreen at this time.
       
      UEFI-BIOS settings:
       
      The board comes with BIOS version 1.20, there is an update 1.50 on the Asrock website. Usually it is good to stay updated but in this case I’ll recommend to stay on 1.20, because the 1.50 version seems to be unstable and I had restarts upon wake and things like that I couldn’t get fixed even with dsdt patches. So I just downgraded to 1.20 which runs fine.
      Settings needed: Just the usual. Disable fast boot and security boot (everything Windows-related), disable vt-d and enable XHCI hand-off. Activate multi monitor support and set VRAM to 64MB to activate the Intel IGPU. From what I’ve read most people recommend 128MB but I find the 64MB setting to be more reliable, getting artifacts with settings below or above 64MB. 128MB may be needed for 4k support, though. *Update* BIOS V 3.00 with Mojave final release works fine with 128MB. As for nVidia users: You may have to disable the Intel graphics. I’m using an AMD card and that is the brand to go these days since Apple decided to work with AMD
       
      Clover and power management:
       
      I recommend upgrading to 4586. It seems that Aptiomemoryfix is now working with H370 chipsets. I stayed on OsxAptiomemoryfix2 together with Emuvariable and it works. Feel free to experiment. *Update* Now using OsxAptioV3.  
      For power management with your CoffeeLake cpu you can just tick plugin type within Clover or compile a ssdt with Pikeralphas script. Mojave reports my cpu correctly as Core i7 since PB3, before that it is just “Unknown” but that is just cosmetic. 
       
      Graphics:
       
      *UPDATE*
      Whatevergreen 1.2.3 now supports Displayport on Nitro RX580. Still recommend DSDT or SSDT port activation instead as it runs more reliable and faster than WhatEverGreen.
       
      *UPDATE*
      I updated to PB4/DP5 and switched to a Sapphire Nitro RX 580. You don't need to spoof Kabylake anymore, SMBIOS 18,x now works and can use my attached DSDT_RX580 for your convenience! You'll need it for displayport to work as primary display or else you get black screen on boot and can use only HDMI. Problems are the same as written below in the graphics section. If you need iTunes you absolutely need to keep a copy of the latest Shiki that is available, because it is discontinued. The newest WhatEverGreen-Fix (1.2.0/1.2.1) does not work! If you want to use Final Cut and don't need iTunes just stay away from Shiki or Whatevergreen. 
       
       
      This is the worst part. Getting the Radeon to run correctly alongside the Intel graphics took me weeks to figure out. 
       
      While RX570 and 580 run out of the box in most cases, the RX560 models often do not or at least not correctly. Apple even banned them from eGPU use. For my approach you cannot use “Whatevergreen.kext”, it simply didn’t work for me the way I needed it. Instead I added some fixes to my DSDT to set the correct number of ports used (DP, HDMI, DVI) and tell macOS to use the correct frambuffer. For those who are not into dsdt editing I added my DSDT, look at the “PEGP” section how it is done. This works for the RX560 using the “Acre” framebuffer, you can replace it with “Radeon”, that works too. Other cards need a different framebuffer and a different number of ports. You can do it!   BTW: Do not buy this Gigabytecard!!! It has some weird VBIOS on it, which caused me nightmares before I got the card to work! Buy a Sapphire card instead, they are used by Apple too.   
       
      To get full hardware acceleration for encoding videos you have to have the Intel graphics enabled alongside your AMD card. Problem is, you cannot have it running simply as a second graphics card but you’ll need to “hide” it, means telling macOS that it doesn’t have any display connectors. Otherwise you’ll have screen artifacts or in the worst case just constant crashes. This can be done by adding a certain ig-platform-id in Clover. If you use 59120003 the Intel graphics will not show up in system profiler but it is there. You can check it with iStats or HWMonitor or look if the Kaby Lake graphics kexts are loaded.  This ID makes the CoffeeLake UHD 630 to be recognized as a Kaby Lake gpu that has no display ports, is just used as a helper card.
       
      You’ll need it as a helper card for video encoding. That is what Intel graphics are used for in Macs, to support video encoding on the hardware side. You can check if hardware encoding is supposedly enabled by using MacX Video Converter Pro and VDADecoderChecker. If both say “yes” and “fully supported” this is a good start. But despite the widespread belief this doesn’t mean everything is set correctly! You now have to find out, how to get both cards working together. This is the moment where you have to choose between work and fun: Are you using FinalCut Pro for video editing or are you planning to use iTunes for entertainment? Up until this day (Mojave PB3 PB4/DP5, High Sierra 10.13.6) you cannot have both working correctly! I’ll show you how it is done both ways. 
       
      The best settings for Final Cut:
       
      Use the DSDT I’ve added with the respective AMD settings for the RX560 or modify them for your graphics card.
       
      Use SMBIOS for iMac17,1 (14,2 does work but picture over DP port is ugly, iMac 18,1/2/3 do not work *Since Mojave PB4 they do work at least for RX580*) in Clover.
       
      Have AppleIntelKBLGraphicsFramebufferInjector_3e9x.kextin your Clover/kexts/Other folder.
       
      Until Mojave PB2 (may work on High Sierra 10.13.6):
       
      Fake-ID 3E928086 plus ig-platform-id 59120003
       
      These are the correct setting when installing Mojave (usually you will start with PB1 as the full installer).
       
      For Mojave PB3 and higher:
       
      Fake-ID 59128086 plus ig-platform-id 59120003
       
      After upgrading to PB3 you will get a black screen with 3E92 fake id because PB3 introduces Coffee Lake kexts and macOS will use these kexts instead but that doesn’t work with our ig-platform-id. So you can download the update to PB3 but before installing it you’ll need to change the fake-id to a usual Kaby Lake id. While this didn’t work in High Sierra and the first two Mojave betas (meaning you didn’t get full hardware encoding) it is now magically working with PB3. It is safe to remove AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext after upgrading to PB3.
       
      For Mojave PB4 and higher (including final release):
      Only add ig-platform-id 3E920003 and inject Intel = Yes in Clover, no need for spoofing a fake id anymore. Now iMac18,3 works best with AMD. Intel only users should use iMac18,1 instead.
       
      The best setting for iTunes and why it is the worst for Final Cut:
      Just do the same thing as for FinalCut, put Shiki.kext into your Clover/kexts/other folder and add -shikigva boot argument. You can use -shikigva=1 or 2 or 12 it will work either way. Now you can watch movies with iTunes, yay! But it has some sideeffects. You cannot use this setting when seriously editing with Final Cut.
       
      While this works by tricking macOS to use the IntelGraphics to play protected video content, it doesn’t seem to be the way real Macs are doing this. As soon as you open FinalCut you will notice (check this with iStats or HWMonitor) that the Intel graphics is not or only barely utilized under certain circumstances depending on your material. Instead cpu usage skyrockets, indicating that slow software rendering is used instead of hardware encoding through Intel graphics. To make it worse the Radeon still “thinks” there is an Intel graphics helping so it does not run at highest potential. 
       
      Wifi and Bluetooth
       
      *UPDATE*
      With Mojave PB4/DP5 Bluetooth stopped working with Rehabman's kext, my MagicMouse simply isn't connecting anymore. I decided to finally remove the card because handoff isn't working anyway these days with M.2 or NGFF bluetooth on High Sierra or Mojave (tried several ones "the internet" claims they would work oob but they do not ;)). That is what I wanted Bluetooth for. If you need Wifi I recommend you go with a cheap Wifi-only card, you don't need to pay 30 or 40 $ for dual cards that won't work the way they were intended to work. If you are on a micro ATX board and can have a graphics card plus PCIe Wifi/BT-card that actually connects to a physical USB port on you're board then you may be lucky enough to have handoff working as expected. I'm having a wifi repeater laying around with an ethernet port in case I may need wifi someday on my hack. 
       
      I swapped the Intel Wifi card that was coming with the mainboard plugged into the onboard M.2 port with a compatible Dell card. The DW1830 or BCM943602BAED. The wifi part runs half way out of the box, but if you want the card to appear as Apple AirportExtreme and set the country code according to your country you need to put FakePCIID_Broadcom_WiFi.kext into Clover/kexts/other and add some Clover kext-to-patches by PMHeart. 
       
      Name: com.apple.driver.AirPort.BrcmNIC
      Find: 75166644 3BA3581A 0000750C 4183FE04 7406
      Replace: 66906644 3BA3581A 00006690 4183FE04 6690
      Comment: AirPortBrcmNIC - PCIe in 10.13.x
       
      Name: com.apple.driver.AirPort.BrcmNIC
      Find: 4183FCFF 7435488D 55D0
      Replace: 66C70644 45EB348D 55D0    (*this is for DE country code, change for your need)
      Comment: BCM4352-Country Code 
       
      Bluetooth will work thanks to Rehabman’s kexts. You’ll need BrcmPatchRAM2.kext and BrcmFirmwareData.kext OR BrcmFirmwareRepo.kext. The Data.kext can be injected through Clover, just throw it into the kexts/other folder, the Repo.kext has to be installed in /Library/Extensions on your mac drive, it won’t work with Clover. I had issues with the Data.kext, Bluetooth was gone on every second or third reboot. The Repo.kext is more reliable, haven’t had any issues yet. I really don’t like the kexts to be installed in my system but I guess I have to live with it for the time being.
       
      Oh, handoff and continuity don’t work, doesn’t matter that system profiler shows them as enabled. At least it works in one way: the mac can handoff Safari pages to my iPhone, but not the other way around. Documents opened on my phone show up in the dock, but they are not loaded. 
      This issue is around since at least High Sierra and from what I’ve read Rehabman is not going to fix this, because he founds this features not worth it. I have to disagree, these are very convenient and valuable features if you work with desktop, laptop and tablet in different situations, I miss this capability very much!    
       
      Audio
       
      Audio works with Lilu.kext plus AppleALC.kext and you need to inject Layout ID=1 in Clover if you don't use a patched DSDT. For Mojave use the boot setting -lilubetaall to force the kexts to load. If you like to have DP or HDMI audio add a HDAU device to your dsdt (see mine for reference). There's an audio patch already added in my DSDT, so you don't need to use the Clover patch.
       
      Credits:
      Credits go to this great community! I hope I mentioned everyone in this guide whose insights made this hack possible. If I have forgotten someone please let me know!
       
       
       
       
      CLOVER_Mojave_Final.zip
    • By macinsane
      Powerful budget Hackintosh for the living room
       
      Components used:
       
      MSI B250I Pro Mini-ITX
      Pentium G4600
      Arctic Freezer 33 semi passive CPU cooler
      ASUS Geforce GT1030
      8 GB GSkill DDR4-2133 RAM
      Samsung 256GB PCIe SSD
      GMYLE Bluetooth USB
      Silverstone ITX Case
      PICO Mini ATX 120W
       
      My plan was to build a Hackintosh with the best price-performance-ratio to be used as media player in the living room hooked to the TV. For that use it should be silent, fanless at best. So I decided to go for the Pentium G4600 which offers nearly the same performance as the I3-7100 for a much lower price and the MSI B250I Pro Mini ITX board, the cheapest one with M.2 slots for PCIe and Wifi. The Arctic Freezer 33 is my favourite choice as CPU cooler and I’m using it for all my builds. The fan literally never spins up during usual daily usage.
       
      For graphics card the fanless GT1030 is the obvious choice as it delivers the best performance with the lowest possible power consumption. Speaking of power: As the Arctic Freezer is too huge for a standard ATX power supply to fit in an ITX case I go for a PICO Mini ATX adapter that allows up to 120 watts on 16 volts, so a common laptop power supply can be used and of course it runs noiseless as wished.  
       
      Everything works like a real mac, there are no power management, sleep or wake issues. You can even use your Bluetooth keyboard or mouse to wake it and it will sleep well again. It is not necessary to disable USB power via DSDT. For this build I don’t even bother to compile one. This hasn’t happened for years J
       
      Of course the installation needs preparation because the Pentium CPU isn’t supported out of the box. You need to configure your UEFI right and get your config.plist for Clover in order before you can start, otherwise macOS will simply kernel panic. Telling it the other way: there is no post installation action required
       
      And for those who are planning to use the Intel HD630 instead of a dedicated graphics card: You can’t. It sounds promising at first to have a macOS supported Intel HD on this chip but it seems as if Intel has just branded it this way and in reality using a different architecture. The best you can achieve is to get into desktop by spoofing a Skylake ID but you won’t get hardware acceleration this way.   
       
      *For this guide I assume that you already know how to prepare a macOS install drive, how to install Clover bootloader and configure it, mounting your EFI partition and so on. You know: the basic skills. If you don’t you’ll find beginners guides for these tasks on the forum.*
       
      *CREDITS: Go to all people involved in the hackintosh community. For this guide I searched and tested for days, finding all the bits needed to complete the installation. If you think one or two of the presented solutions here is based on one of your own unique ideas please feel free to tell me and I will add your name here at once of course. Many thanks to all of you!*
       
      Clover version used: 4392
       
      Installed OS: 10.13.3
       
      UEFI Configuration
       
      \Advanced\Integrated Peripherals\
                  SATA Mode AHCI MODE
       
      \Advanced\USB Configuration
      XHCI-Handoff ENABLED
       
      \Advanced\Integrated Graphics Configuration\
                  Initiate Graphics Adapter PEG
                  IGD Multi Monitor DISABLED
       
      \Advanced\Windows OS Configuration
                  Everything DISABLED
       
      \Advanced\Wake Up Event Setup
                  Everything DISABLED
                  or at least:
                  Resume By USB Device ENABLED if you like
       
      \Overclocking\CPU Features
                  Intel VT-d Tech DISABLED     
                  C1E Support ENABLED
                  (very important, needed to prevent kernel panics on boot)
       
      Clover Configuration
       
      Just use Clover Configurator for convenient editing of your config.plist. For successful boot at least FakeCPUID must be added and KernelXCPM be ticked.
       
      ACPI
       
      Change HDAS to HDEF
      Change HECI to IMEI
      Change SAT0 to SATA
      Change GFX0 to IGPU
       
      Fix Shutdown TRUE
       
      Devices
       
      Audio Inject 1 (if you use AppleALC)
       
      Kernel and Kext Patches
       
      FakeCPUID 0x0306A0
      KernelXCPM True
      Apple RTC True
       
      Kernel to Patch
       
      Find b9a00100 000f32 Replace b9a00100 0031c0 to disable AVX
      (This is needed because the Pentium lacks AVX support. Without it apps like Safari and AppStore are likely to crash.)
       
      SmBIOS
       
      iMac18,2
       
      Kexts and SSDT
       
      /EFI/CLOVER/ACPI/patched
       
      Toleda's SSDT-HDMI-NVIDIA-PEG0.aml 
      Download at GitHub.
      (needed for HDMI/DVI audio with AppleALC (on non GT1030 cards) and fixes a wake up issues that could lead to black screen)  
       
      /EFI/CLOVER/drivers64UEFI
       
      Remove any Osxaptiofix or Memoryfix installed by Clover and use OsxAptioFix2Drv-free2000.efi instead. Solves the occasional “Does printf work?” completely.
       
      /EFI/CLOVER/kexts/Other
       
      FakeSMC.kext
      Lilu.kext
      FakePCIID.kext
      NvidiaGraphicsFixup.kext
      Shiki.kext
      RealtekRTL8111.kext
      USBInjectAll.kext
      XHCI-200-series-injector.kext
       
      For audio use AppleALC.kext or VoodooHDA.kext (never both!) and AppleHDADisabler.kext
      Only VoodooHDA enables HDMI, DP or DVI audio on GT1030. Other cards may work with AppleALC (tested with GT710 and DVI audio works).
       
      Nvidia webdrivers Issues
       
      Don’t use the designated webdrivers for 10.13.3! They give you extremely poor OpenCL performance what leads to choppy video playback. Instead use NVDAWebPatcher to patch the webdrivers for 10.13.2 and install them instead. I’m not kidding the 10.13.3 drivers are unusable, this step is mandatory.
    • By iosxnoobpro
      I've never been so happy and proud after all the hard work / hustles / frustration / failures.. i finally got everything working (holy grail)..

      Specs:
      Intel 4790k @ 4.7 Win10/El Capitan
      Asus Maximus VII Impact z97 m-itx
      Asus Gtx 960 Strix 4gb
      Asus VC239H
      Dell Monitor
      HyperX Fury 8gbx2 1866mhz running @2133mhz OSX / 2400mhz Windows 10
      Seasonic p660 80+ Platinum
      Seagate 1tb Barracuda - Storage 
      Samsung 850 Evo 250gb - Windows 10
      Avexir V1 120gb - OSX El Capitan
      Phanteks Enthoo Evolv ITX
      Cryorig R1 Ultimate - Cooler
      Cryorig XT140 - Exhaust Fan
      Thermaltake Riing14 RGB - Intake


       
       
      For more Photos
      https://pcpartpicker.com/b/7MjcCJ

       
×