Jump to content
chatdeau

HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

1,460 posts in this topic

Recommended Posts

Advertisement

so ok but you didn't follow my instruction i sad use another seprate SSD and install again mojave on it just update it to the latest software update and then download catalina from app stor . and try to install on the same ssd drive if the installation is successful then you will need the new usb to boot the system

first of all you have to update mojave and it will let you to upgrade from mojave to cat

Share this post


Link to post
Share on other sites

You're right. I'll do a fresh install tomorrow. Trouble if I don't have an SSD?

i think i need a bios update as well (3.54)

Edited by hirion

Share this post


Link to post
Share on other sites

as you wish  you can use HDD but it,s make really any joy because they  are slow 

Edited by Rockey12

Share this post


Link to post
Share on other sites

Soon there will be SSD too..but you need a host card as well. For now, I'm glad if it goes like this

Should the BIOS be 3.61? Many people complain

Edited by hirion

Share this post


Link to post
Share on other sites

but if you update to the new bios you will need another dsdt file  but donnot use clover for it usr linux  live cd or  use  DSDTEditor  for windows

Share this post


Link to post
Share on other sites

Who can export from live Linux right? I've already done one

Continue tomorrow..Thank you very much for your patience!

Edited by hirion

Share this post


Link to post
Share on other sites
8 hours ago, hirion said:

HHMMM:whistle:It is possible? It didn't work for long ..:cry:

Screenshot 2020-01-14 at 2.25.43.png

Hi hirion, what do you mean. It is possible? It didn't work for long , by the way if you ask me about macOS Catalina i would say i don.t like it i am still big fan of Mac OS X mavericks my Favorite OS X operating system

 

why i chose this method to install Catalina because it is easy to do and painless

if i understand correctly what you mean i cant say nothing about it how long apple let the people  to upgrade from Mojave to Catalina. but for now you can enjoy the hack.

Share this post


Link to post
Share on other sites

Hi Rockey12!

My favourite OS X system was Snow Leopard, but what was its advantage (it was fast and stable) doesn't work with the new hardwares.

As for the hack, I didn't enjoy it for long. The steps I took to install - maybe you can tell me what I did wrong:

1. I made an 10.14.6 USB installer, I installed it to a separate HDD, but I didn't make it bootable with Clover, the boot remained on the USB. I didn't format the whole HDD to APFS, the Mojave is in a Clover Container

2. I went to Software update, it instantly offered to update to Catalina and I did

3. After installation it restarted, and I booted from the Mojave USB installer. I shut the system a few times but I could always boot it from the USB

4. It seemed stable so I tried to make the HDD bootable with Clover. I got an error message "install failed".

5. I put in another HDD (the one I use for master, it has Mojave on it) and tried to make a Catalina boot with it with the same EFI I use on the master HDD and the installer USB.

6. Istallation was successful. Then I took out the master HDD and I tried to start Catalina. Apple logo appeared then appeared the access denied sigh (circle, a line accross it)

7. I put back the master HDD, and deleted all the Clover folders from Catalina HDD, but I can't boot it since then, the access denied symbol appears at once. That't why my joy didn't last too long...

Share this post


Link to post
Share on other sites

i don,t really no what is wrong or where the fault is but i did the same way the only thing i did was MacPro6,1 SMBios that's all

i don't want to waste your time  if u want another try to create complete catalina usb installer

Edited by Rockey12

Share this post


Link to post
Share on other sites
8 minutes ago, Rockey12 said:

i don,t really no what is wrong or where the fault is but i did the same way the only thing i did was MacPro6,1 SMBios that's all

i don't want to waste your time  if u want another try to create complete catalina usb installer 

I was surprised that it was working as iMac 14,2 SMBios. Is it very difficult to make a USB installer for Catalina? (I don't want to use up all the space here in this topic, so if you want, we could continue in private - if there is a PM option).

Share this post


Link to post
Share on other sites

Does this have to look like this? (Connected to external usb the Catalina HDD)

Screenshot 2020-01-14 at 22.06.59.png

Edited by hirion

Share this post


Link to post
Share on other sites

I reinstalled with Mac Pro 6.1 SMbios. It seems to work. Can you help me set up the sound card? ALC 262 If I remember correctly. Thanks!

Edited by hirion

Share this post


Link to post
Share on other sites

yes I can help okay copy all of them to clover kext folder 

 

use these Arguments   in your config.Plist  -lilubetaall -alcbeta

layout id 28 in DSDT  

AppleALC-1.4.5-RELEASE.zip

Screenshot 2020-01-15 at 02.42.32.png

Screenshot 2020-01-15 at 02.43.37.png

Edited by Rockey12

Share this post


Link to post
Share on other sites

Thanks!:guitar:I've copied it to the Clover / Kext folder and use it like that.

 

Edited by hirion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Tushark2
      Hello,
      1st my laptop spec. 
      CPU - 2.53 GHz Intel Core i3 380m
      RAM - 6 GB 1333 MHz DDR3
      GPU -  1st gen Intel HD Graphics 288 MB
      Laptop - Dell Vostro 3500 series
      BT/WIFI - AzureWave BCM94352HMB
       
      I installed Olarila Mojave 10.14.6 and managed to install 1st gen intel HD graphics but it was bit laggy bcos this gnu doest support metal and its a old machine, so I decided to move to Olarila High Sierra.
      I installed it with most of things working fine expect some issues, for that I want to make SSDT and DSDT to make it run without glitches.
       
      I am atteching my sendme.zip , can some take a look to my current settings and suggest me some changes  
      (Olarila down from few days for me )
       
      Send me MacBook-Pro.zip
    • By _ivan_palmisano_
      Ho provato tutti i modi ma sono arrivato alla conclusione che ha bisogno di una patch DSDT.
      Ciao, ho recentemente un hackintosh nel mio laptop e devo risolvere l'attacco video HDMI che non ha eseguito quando collego il mio laptop alla TV.
      le foto con queste informazioni sono state fatte con un programma quando che avrei vinto 10 nell'altra foto l'informazione di hackintosh.
      Acer Aspire 5741g Modello High Sierra System!
      Caratteristiche:
      CPU: Intel Core I3 350M 2.27Ghz Arrandale 32nm Tecnologia
      Ram: 6: 00GB
      Grafica: Monitor Pnp generico (1366x768 Ghz) 1024mb Nvidia GeForce GT 320M (Acer Incorporated)
      Archiviazione: 465 GB Sata
      Driver Optiocal: Optiarc DVD RW- AS-7585H
      Audio: dispositivo audio ad alta degradazione
      Qualcuno può aiutarmi!?! E 'la terza volta che faccio questo post in questo gruppo visto che sono nuovo nel mondo hackintosh preferisco se qualcuno è capace a risolvere il mio problema che lo faccia in remoto così non faccio sbagli.
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By rguibi
      Hello

      I have a laptop HP EliteBook 840 G2 - Core i5 5300U - 2.3 GHz and graphic card intel HD5500 and installed a SIERRA , but the definition of the graphics card is not installed
    • By Donw35
      Catalina update 10.15.2 without issues, make sure you update your kexts before hand.
      Catalina update 10.15.1 without issue although you may have to make sure clover boots from the right partition.
      HP 840 G2, working with OS X 10.15 Catalina, for this to work you will need the SSDT-ECUSBX.aml and place that  EFI/CLOVER/ACPI/Patched. 
      Make sure you remove Remove all patches about renaming acpi of EC or H_EC, revert all ACPI renaming in ACPI DSDT.
       
      My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts and set the config.plist
       
      Not working
      SD Card reader
      Finger Print device
       
      Working
      Video - screen looks better in OS X then it does in Windows 10
      Display port
      VGA port
      WiFi and BlueTooth working OOO using the below hack
      Battery status with Rehabman's DSDT patch
      Brightness controls
      Sounds - using VoodooHDA
      * Microphone - cannot turn it off or mute
      Keyboard backlight - controlled though BIOS anyways
      touchpad - using VoodooPS2Controller
      USB3 - this laptop has two on board only and I haven't test them using the docking station
      USB3.1 C
      Ethernet - using IntelMausiEthernet
      Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.
      Web Cam, works but I covered it up.
       
       

       
      SSDT-ECUSBX.aml
      CLOVER.zip
×