Jump to content
chatdeau

HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

1,494 posts in this topic

Recommended Posts

put All The Kexts into EFI/CLOVER directory for macOS 10.13.2 in 10.13.2directory. Have fun!

How to install MacOS Sierra 10.12.3 on HP Z620 Workstation.

download macOS Sierra Installer (go to App Store to download).

create a USB Installer.

 to create a bootable USB. However, we have to use kexts from CustoMac Essential package and put these kexts to /Volumes/EFI/EFI/CLOVER/kexts/Other/ directory (mount your EFI partition first!)

 

Here the Tricks

Note: I put my /Volumes/EFI/EFI/CLOVER directory and all kexts we need in the repo.

 

  • Install the lastest CLOVER (e.g., v2k4)
  • We have to use flag npci=0x2000 all the time. (I also use dart=1)
  • Z620 crashes randomly when booting, we can fix that with flag cpus=1. However, this makes our PC slow (only 1 CPU!!), therefore, we fix this problem by installing VoodooTSCSync.kext at /System/Library/Extensions . Remember to fix permission. E.g.
    chmod -R 755 /System/Library/Extensions/* && chown -R root:wheel /System/Library/Extensions/* && kextcache -system-caches.
  • We got problem with USB ports (therefore, cannot install from USB). We fix it by:
    • First, Use Clover Configurator V4.39.1 app to mount EFI and patch ACPI (Look at "List of Patches" in Acpi menu and apply All Of Them)
    • Install USBInjectAll.kext to inject all USB ports!
  • HP Z620 crashes with many versions of FakeSMC and NullCPUPowerManagement.kext, so please use those

 

http://sixflow.net/osx86/index.php?mid=System&document_srl=83674&cpage=1#comment

untitled folder.zip

Share this post


Link to post
Share on other sites
Advertisement

 Unfortunately I can not get to the installer of 10.13.3

Clover 4415

HP Z620 Bios 3.91

CPU E5-2680

Bios settings as a guide

drivers64 and kext (other and 10.13 folder) with the kext you gave me.

I tried to boot with -v npci=0x2000 and debug=0x100 to try to understand what the problem is.

 

 

 

Tips?

 

I think i need this patch 

 

http://www.insanelymac.com/forum/topic/326200-new-possibilities-for-x79-appleacpiplatform-panic/page-3

 

EDIT:

 

 

I added my EFI folder and the origin folder generated by Clover F4

 

 

 

Tips?put All The Kexts into EFI/CLOVER directory for macOS 10.13.2 in 10.13.2directory. Have fun!

How to install MacOS Sierra 10.12.3 on HP Z620 Workstation.

download macOS Sierra Installer (go to App Store to download).

create a USB Installer.

 to create a bootable USB. However, we have to use kexts from CustoMac Essential package and put these kexts to /Volumes/EFI/EFI/CLOVER/kexts/Other/ directory (mount your EFI partition first!)

 

Here the Tricks

Note: I put my /Volumes/EFI/EFI/CLOVER directory and all kexts we need in the repo.

 

  • Install the lastest CLOVER (e.g., v2k4)
  • We have to use flag npci=0x2000 all the time. (I also use dart=1)
  • Z620 crashes randomly when booting, we can fix that with flag cpus=1. However, this makes our PC slow (only 1 CPU!!), therefore, we fix this problem by installing VoodooTSCSync.kext at /System/Library/Extensions . Remember to fix permission. E.g.
    chmod -R 755 /System/Library/Extensions/* && chown -R root:wheel /System/Library/Extensions/* && kextcache -system-caches.
  • We got problem with USB ports (therefore, cannot install from USB). We fix it by:
    • First, Use Clover Configurator V4.39.1 app to mount EFI and patch ACPI (Look at "List of Patches" in Acpi menu and apply All Of Them)
    • Install USBInjectAll.kext to inject all USB ports!
  • HP Z620 crashes with many versions of FakeSMC and NullCPUPowerManagement.kext, so please use those

 

http://sixflow.net/osx86/index.php?mid=System&document_srl=83674&cpage=1#comment

EFI.zip

origin.zip

Share this post


Link to post
Share on other sites

I just followed some Rehabman guides to install MaciASL, Patchmatic etc.

 

I have tried Clover DSDT patch...

 

 

I'm trying but I do not have enough knowledge to succeed

 

 

I am reading the file DSTD.dsl and looking for the values ​​that modify in the guide (SCK0, CPUSCK0) but I can not find them with MaciASL, probably the extracted data are not similar.

 

 

sorry my friend  but you didn't patch your dsdt how can you expect to install any thing   

your clover ACPI patched folder is empty there is no dsdt or any ssdt  

 

 

http://www.insanelymac.com/forum/topic/326200-new-possibilities-for-x79-appleacpiplatform-panic/?p=2489834

Share this post


Link to post
Share on other sites

Rockey12,

 

Thank you, I believe there is positive progress !.

 

I attached photos of the KP, could it depend on the CPU E5-2680 v1 ??

 

Archivio.zip

 

 

use this config.Plist as a reference this one is from z420

 

ssdt from z420 as a reference

 

Share this post


Link to post
Share on other sites

so please don't use this ssdt in your clover folder patch your own ssdt 

 

celect all the patches in config.plist and let the clover to patch  dsdt and ssdt for you  dureanig the clover start press F5

Share this post


Link to post
Share on other sites

Excuse me, I feel very stupid to ask.

Ok for the config.plist part and the patches.

Patch my SSDT what do you mean?

With the SSDT.aml you attached me what do I do?

 

so please don't use this ssdt in your clover folder patch your own ssdt 

 

celect all the patches in config.plist and let the clover to patch  dsdt and ssdt for you  dureanig the clover start press F5

Share this post


Link to post
Share on other sites

I solved with a user who contacted me via PM.

 

@Rockey12 I have read of your workstation with bricked bios, have you tried to restore it with the Boot Block Recovery mode (E15 jumper + USB with bios .bin?

 

Excuse me, I feel very stupid to ask.

Ok for the config.plist part and the patches.

Patch my SSDT what do you mean?

With the SSDT.aml you attached me what do I do?

Share this post


Link to post
Share on other sites

I am wondering if anyone has an HP Z420 with Native sound working?

 

I have moved up from a z400 with native audio working with patched DSDT + Patched Apple HDA and Codeccommander. 

Since both the z400 and Z420 both use realtek ALC262, I used the same DSDT/HDEF patch on my patched Z420 DSDT + Clover Inject Layout 28 + AppleALC 1.2.3 without success. 

Audio is of course working with VoodooHDA but I can not get Native Audio working.

Everything else working great include native power + speed stepping, LAN, and USB2 ports(not 3).

 

 

Current config: HP Z420, QuadCore Xeon E5-1620, Nvidia Quadro K2000, 48gb Ram, 256 Samsung SSD, Clover Bootloader.

Edited by apav

Share this post


Link to post
Share on other sites
10 hours ago, jaymack said:

I would like to patch the DSDT as I also have an HP Z400 with Realtek ALC262. Can you share the patch?

Sure, see attached.

 

HDEF:DSDT.dsl

Share this post


Link to post
Share on other sites
On 1.4.2018 at 3:02 AM, apav said:

Since both the z400 and Z420 both use realtek ALC262, I used the same DSDT/HDEF patch on my patched Z420 DSDT + Clover Inject Layout 28 + AppleALC 1.2.3 without success. 

AppleALC.kext needs Lilu.kext
AppleALC alone is not working

https://github.com/vit9696/AppleALC/releases

https://github.com/vit9696/Lilu/releases

Share this post


Link to post
Share on other sites
On 4/9/2018 at 1:12 AM, MacPeet said:

AppleALC.kext needs Lilu.kext
AppleALC alone is not working

https://github.com/vit9696/AppleALC/releases

https://github.com/vit9696/Lilu/releases

Yes, I was using AppleALC + LILU + I tried to patch my DSDT using previous Z400 HDEF patch but wasn't working for me. MaLd0n was able to correctly add DSDT HDEF patch and I now have native sound on my Z420.

Thanks.

Share this post


Link to post
Share on other sites

Hi

I would like to ask if someone work with AMD r580 GPU because I would like to upgrade to this card for after effects

My workstation is

HP Z800 2 x 3,32 GHz 6-Core Intel Xeon | 48gb | GTX titan 6gb | Sierra 10.12.6

All works fine

Edited by post6522

Share this post


Link to post
Share on other sites

Radeon Pro WX 7100  is the best choice

Here's the detailed post. It's kind of long because this happened over the course of a few days of debugging/tinkering.

I'm using:

  • Clover v2.4k r4380
  • Kexts:
    • AppleALC
    • FakeSMC
    • Lilu
    • RealtekRTL8111
    • USBInjectAll
    • WhateverGreen
    • patched AMD kexts (details below)
  • Boot Options:
    • dart=0
    • Inject ATI=False

Story:

I was having a ton of problems with High Sierra. Initially, I tried to do an in-place update from Sierra and that didn't work, I'm not sure what exactly happened. I decided to do a clean High Sierra install.

 

I was able to get through the installation process up to where you're prompted for username, etc. I saw the Apple logo and the loading bar get about half way, then a flash on the screen, then the screen turned black, the backlight on the screen was still and and I didn't get any "no signal" messages so it seemed like it booted up fine, just no video. I tried reinstalling a few times to see if it was something that went wrong during install and I kept getting the same results.

 

Eventually, I tried booting into safe mode (-x) and was then able to complete the installation. After the installation completed, everytime I tried booting normally into the OS it would go to the same black screen that occurred during installation. Booting into safe mode, however, seemed to work fine but without video acceleration.

 

First, I attempted to use the framebuffer patching guide. I gave up on it because I was never able to find a framebuffer in the AMD9500Controller.kext that had the same number of ports (4 display ports) as the WX 7100.

 

I was able to get this video card to work previously in Sierra by patching some of the kexts with the WX 7100's device id. I wasn't sure which kexts to add the device id to in High Sierra.

 

In safe mode, I dumped the currently loaded kexts and made note of all the AMD kexts that were loaded (kextstat -l | grep AMD). Here is a list of the loaded kexts:

 

96    2 0xffffff7f817b1000 0x1f8000   0x1f8000   com.apple.kext.AMDSupport (1.6.0) 441E3318-2B41-3EC8-95CA-7A098B2801F5 <94 93 11 10 7 5 4 3 1>
104    0 0xffffff7f819a9000 0x64000    0x64000    com.apple.kext.AMD9500Controller (1.6.0) 74FE706C-076A-3302-9D0D-12846730C210 <96 94 93 11 10 5 4 3 1>
112    0 0xffffff7f83a29000 0x28000    0x28000    com.apple.kext.AMDFramebuffer (1.6.0) 74616066-E134-31AD-AEE8-40BB1420567B <96 93 11 10 7 5 4 3 1>

 

I also enabled remote login while in safe mode so that I could ssh into the machine. I booted normally into the machine and was met with another black screen. From another computer, I ssh'ed into the machine and performed the same kextstat -l | grep AMD to see which kexts had loaded. Here is the output:

 

106    2 0xffffff7f82603000 0x1db000   0x1db000   com.apple.kext.AMDSupport (1.6.0) 441E3318-2B41-3EC8-95CA-7A098B2801F5 <105 99 12 11 7 5 4 3 1>
112    0 0xffffff7f82834000 0x64000    0x64000    com.apple.kext.AMD9500Controller (1.6.0) 74FE706C-076A-3302-9D0D-12846730C210 <106 105 99 12 11 5 4 3 1>
134    0 0xffffff7f82c55000 0x84f000   0x84f000   com.apple.kext.AMDRadeonX4250 (1.6.0) BE3FD082-A557-3556-B357-EDD2DFC63E7A <133 124 99 12 7 5 4 3 1>
137    0 0xffffff7f834b2000 0x28000    0x28000    com.apple.kext.AMDFramebuffer (1.6.0) 74616066-E134-31AD-AEE8-40BB1420567B <106 99 12 11 7 5 4 3 1>

 

The first thing I did was try removing the AMDRadeonX4250.kext, the only different kext that was loaded during normal mode versus safe mode. After removing this, the computer could boot in normal mode with video output but still without video acceleration.

 

After this, I remembered that the WX 7100 is very similar to the RX 480/580 (device id 0x67DF1002). So, I found every instance of 0x67DF1002 that appeared in the AMD kexts (grep -R 0x67DF1002 /System/Library/Extensions/AMD*). Here's a list of the kexts that contain the RX 480/580 device id:

 

/System/Library/Extensions/AMD9500Controller.kext/Contents/Info.plist
/System/Library/Extensions/AMD9520Controller.kext/Contents/Info.plist
/System/Library/Extensions/AMDRadeonX4000.kext/Contents/Info.plist
/System/Library/Extensions/AMDRadeonX4000HWServices.kext/Contents/Info.plist
/System/Library/Extensions/AMDRadeonX4200.kext/Contents/Info.plist
/System/Library/Extensions/AMDRadeonX4250.kext/Contents/Info.plist

 

So, I editted each of these kexts to include 0x67C41002. Rebuilt the kext cache (sudo kextcache -i /). Then, booted up in normal mode and was greeted with full video acceleration.

 

This probably could have been accomplished by spoofing the RX 480/580 device id, but I learned a lot through this process and thought I'd share my experience with all of you.

Share this post


Link to post
Share on other sites

Hello hackintoshers. I know this thread is getting long and old, but I am about to try my first hackintosh. Has anyone installed MacOS Sierra 10.12.6 with Clover on a HP Z440 workstation (Xeon E5-1620 v4, Intel C612 chipset, Realtek HD ALC221 audio)? I am using a Sapphire Pulse Radeon RX 580 8GB. Windows 10 Pro is running now.

What kexts do I need? From countless threads and tutorials I have come up with this list:

AppleALC.kext

AppleIntelE1000e.kext

AtherosE2200Ethernet.kext

CoreDisplayFixup.kext

EFICheckDisabler.kext

FakeSMC.kext

IntelGraphicsFixup.kext

Lilu.kext

NullCPUPowerManagement.kext

RealtekRTL8111.kext

Shiki.kext

USBInjectAll.kext

VoodooHDA.kext

VoodooPS2Controller.kext

WhateverGreen.kext

XHCI-x99-injector.kext

 

Others I have seen:

XHCI-x99-injector.kext

AHCIPortInjector_v1.0.0.kext

IOAHCIBlockStorageInjector_v1.0.0.kext

NvidiaGraphicsFixup.kext

 

But I think some of these may be for laptops.

Is it a problem to install unnecessary kexts? Or the more, the merrier? Do I need to edit a DSDT? Or does Clover Configurator or 'that beasty thing' do this for me?

 

When I get it running, can I upgrade to High Sierra 10.13.4 from the App Store without a care, or does some of the above need to change? Would I be better off creating my USB installer for High Sierra to begin with?

What problems should I expect?

Edited by Jon_K

Share this post


Link to post
Share on other sites

Can someone help me with installing high sierra on a HP Workstation Z640. I have never done this before so I'm really confused about what needs to happen. I created a bootable usb installer. I boot up to the "Clover Boot Manager" and when I click "install macOS high sierra" the apple logo comes up but that's it; no loading bar and it's just stuck there. the screen is also offset so the apple logo is closer to the bottom right of the screen(I don't know if that's important). when I use verbose mode setting it gives me this

 

. I take it that means barely anything has happened.

 

I also decided to try the bootable usb on my laptop( ASUS G750jx - nvidia gtx 770M - intel corei7 4700HQ). In this case it doesn't even show the apple logo. It simply shows the computers default startup logo( Replublic Of Gamers Logo) but curiously also offsets the screen when its showing this logo. it then proceeds to startup up to my normal windows log in screen.

 

  I however did not use [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] installer to make the bootable disk I used the os terminal with the command by following this guide http://hackintosher.com/guides/make-macos-flash-drive-installer/

 

I am following this guide https://hackintosher.com/guides/macos-high-sierra-hackintosh-install-clover-walkthrough/ and now I'm stuck in that apple logo. 

 

 

IMG_4357.JPG

Share this post


Link to post
Share on other sites
On 5/8/2018 at 2:21 AM, post6522 said:

 

2034877618_ScreenShot2018-05-08at15_13_06.thumb.png.98d9ae3e5af86db8ebd21ae82bb01074.png1585420939_ScreenShot2018-05-08at15_13_19.thumb.jpg.877a814c9e8409956d2637f5ce6c404c.jpg

 

Hi 

I would like to ask how I can change slot of my GPU from ethernet to pci

Thanks A lot

 

R U comfortable modifying your DSDT directly ?

 

 

Share this post


Link to post
Share on other sites

Mojave runs on Z400, apart from the graphics acceleration for nvidia cards.
Must wait for webdriver compatible.imageproxy.php?img=&key=c17464ef1b1b51c7

img.png

Edited by kif.007

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By Donw35
      09192020 - Big Sur Beta 7 update, no issues.
      09042020 - Big Sur Beta 6 update, no issues.
       
      I have moved on with this and do not use my HP G2 for Hackintosh, its mainly used for Kali Linux for Packet analysis these days, with that said I am using the HP 840 G3 for Hackintosh. I transitioned to OpenCore and Big Sur for this laptop but feel free to continue to ask questions. 
       
      My G3 has the BCM84360CS2 mod, I got the module from eBay for $10 and the adapter for $10 off amazon.
       
      Big Sur Beta 5 is working using the below EFI folder. OpenCore 6.1.0 and latest kexts
       
      Method: USB Big Sur installation
      Create an Big Sur Beta5 or Catalina USB installer (google is your friend here, plenty of tutorials there) Mount the EFI partition of your USB installer using Clover Configurator Copy the EFI file attached here. Boot your laptop using F9 and choose the USB installer and follow the prompts  
       
       
      Catalina and old method in the Spoiler
       
       
      Credits go to Jake Lo for creating this EFI file. I did make some changes to his, this one is Open Core 6.1.0 and latest Lilu.kext and WhatEverGreen.kext
      HP_840_G3_BSB5.zip
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.6 Clover (UEFI) r5122 Lilu.kext 1.4.7 WhateverGreen.kext 1.4.2 AppleALC.kext 1.5.2 IntelMausi.kext 1.0.3 (acidanthera version, not IntelMausiEthernet) NVMeFix.kext 1.0.3 EFIChecikDisabler.kext 0.5  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 1.2.zip
    • By MaLd0n
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 
       
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Original DSDT have 167,880 lines and 762kb
       
      DSDT ORIGINAL.aml.zip138.01 kB · 8 downloads
       
      -Patched DSDT have 30,912 lines and 111kb
       
      DSDT PATCHED.aml.zip27.01 kB · 17 downloads
       
      --Hardware--
      Asus ROG RAMPAGE VI EXTREME OMEGA

      Processor  Intel i9-10980XE

      GPU Radeon RX 5700 XT

      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -XSPI -EC -PNLF -ARPT -GFX0 -NVME  
      --Screenshots-



















       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145 Model with Intel Core i5-1035G1 IceLake / Intel HD Graphics ICL
      -Update bios/uefi to last version 
       
      *For now we have 2 problems. Wake from sleep and some bugs in trackpad*
       
      --Bios/UEFI config--
      Go to Security tab and disable Secure boot
       
      -IceLake Premade installation Folder (easy way installation)
      https://tinyurl.com/y3tl6xlx
       
      --Clover and OpenCore Folders--
      Just paste EFI folder inside EFI partition
      -OpenCore
      https://tinyurl.com/y3c4rjkr
      -Clover
      https://tinyurl.com/y4496nq8
       
      --Enable Trackpad Dragging Option--
      Go to System Preferences/Accessibility/PointerControl/Trackpad Options and "Enable dragging"

      -Bluetooth Broadcom
       
      BrcmBluetoothInjector.zip2.46 MB · 4 downloads
       
      -OcQuirks.efi for Clover (Just replace Drivers folder)
       
      drivers.zip74.57 kB · 4 downloads
       
      --DSDT Patches--

      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 12 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -FULL RENAMED DEVICES   --IGPU Patch-- (All credits to Austere.J) Discussion about that HERE
       
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key>             <dict>                 <key>AAPL,ig-platform-id</key>                 <data>AABSig==</data>                 <key>device-id</key>                 <data>UooAAA==</data>                 <key>framebuffer-fbmem</key>                 <data>AACQAA==</data>                 <key>framebuffer-patch-enable</key>                 <data>AQAAAA==</data>                 <key>framebuffer-stolenmem</key>                 <data>AAAwAQ==</data>                 <key>framebuffer-unifiedmem</key>                 <data>AAAAgA==</data>                 <key>hda-gfx</key>                 <string>onboard-1</string>                 <key>igfxfw</key>                 <data>AgAAAA==</data>             </dict>  
      --USB Fix-- https://tinyurl.com/y4mqfahz
       
      -ScreenShots

       


























      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Acidanthera Team, Olarila Facebook Community, Hackintosh Facebook Community and many others!     We're all here to have fun and learn from each other!
×